أصلح خطأ Generator عند تشغيل Adobe Photoshop

تاريخ آخر تحديث 29 أكتوبر 2026

تعرّف على كيفية إصلاح خطأ Generator في Adobe Photoshop من خلال التحقق من إعدادات الأمان، وإزالة الإضافات المتعارضة، ومراجعة السجلات.

Generator هو تطبيق Node.js يتولى إدارة الاتصال بين Photoshop وإضافات Generator. يوفر منطق إنشاء الأصول لـ التصدير كـ وأصول الصورة.

عند تشغيل Photoshop أو تحديد ملف > تصدير > التصدير كـ، يظهر مربع حوار يوضح: "توجد مشكلة في Generator. Please quit Photoshop and try again. إذا استمرت المشكلة، فأزل أي إضافات من جهات خارجية أو حاول إعادة تثبيت Photoshop."

جرِّب الحلول التالية بالترتيب.

برنامج الأمان يحظر Generator

قد يحظر برنامج الأمان أو مكافحة الفيروسات الاتصال من Generator على المنفذ 8010 أو يمنع تشغيل عملية node.

افتح إعدادات الأمان أو مكافحة الفيروسات.

أضف Photoshop إلى قائمة التطبيقات المسموح بها.

تأكد من أن المنفذ 8010 مفتوح لـ Generator.

أضف node.exe إلى قائمة التطبيقات المسموح بها في C:\Program Files\Adobe\Adobe Photoshop <version>\node.exe على Windows.

على macOS، اسمح بتشغيل عملية node في /Applications/Adobe Photoshop <version>/Adobe Photoshop <version>.app/Contents/MacOS/node.

على Windows، اسمح لـ Photoshop بالوصول إلى المجلدات الخاضعة للتحكم.

أعد تشغيل Photoshop، ثم حدد ملف > تصدير > التصدير كـ لاختبار Generator.

إضافة من جهة خارجية تتعارض مع Generator

قد تكون الإضافات من جهات خارجية الموجودة في مجلد Generator الخاص بـ Photoshop غير متوافقة مع إصدارك الحالي أو تتعارض مع إضافة أصول الصورة الافتراضية.

Windows: C:\Program Files\Adobe\Adobe Photoshop <version>\Plug-ins\Generator

macOS: /Applications/Adobe Photoshop <version>/Plug-ins/Generator

أنشئ مجلدًا مؤقتًا على سطح المكتب باسم إضافات Generator المعطلة.

انقل مجلدات الإضافات من جهات خارجية إلى المجلد المؤقت. اترك إضافة Image Assets الافتراضية في مجلد Generator.

ابدأ تشغيل Photoshop وحدد ملف > تصدير > التصدير كـ.

إذا اختفى الخطأ، فأضف الإضافات مرة أخرى واحدة تلو الأخرى، وأعد تشغيل Photoshop بعد كل إضافة إلى أن يظهر الخطأ مجددًا.

اترك المكوّن الإضافي الافتراضي Image Assets في مجلد Generator.انقل فقط المكوّنات الإضافية التي قمت بتثبيتها بشكل منفصل.

يفشل Generator في البدء، ولا تحتاج إليه

إذا كنت لا تستخدم Export As أو Image Assets، فأوقف Generator كحل مؤقت.

ابدأ بتشغيل Photoshop.

في Windows، حدد Edit > Preferences > Plug-ins.في macOS، حدد Photoshop > Settings > Plug-ins.

قم بإلغاء تحديد Enable Generator.

حدد OK، ثم أعد تشغيل Photoshop.

يؤدي تحديد File > Export > Export As إلى تشغيل Generator مرة أخرى. إذا كنت بحاجة إلى Export As، فعالج خطأ Generator بدلاً من ترك Generator متوقفًا.

تعرض سجلات Generator أخطاء بدء التشغيل

يمكن أن تحتوي سجلات Generator على معلومات حول المكوّنات الإضافية التي يفشل تحميلها أو مشكلات النظام التي تمنع Generator من البدء.

في Windows، انتقل إلى C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop <version>\Logs\Generator.

في macOS، انتقل إلى /Users/<username>/Library/Logs/Adobe/Adobe Photoshop <version>/Generator.

افتح أحدث سجل لـ Generator وابحث عن رسائل الخطأ.

إذا لم يكن مجلد Generator موجودًا، فتحقق من أن لديك إذن الكتابة على المجلد الأصلي.

إذا كنت بحاجة إلى مساعدة إضافية، فاستخدم Adobe Log Collector Tool لجمع سجلات التشخيص.

يتم إخفاء مجلدات AppData في Windows ومجلدات Library في macOS بشكل افتراضي. يمكن أن تساعدك تعليمات إظهار الملفات والمجلدات المخفية في Windows في تحديد مكان سجلات Windows.

تحدث أخطاء Generator على Apple Silicon

إذا استمر فشل Generator على جهاز Mac يعمل بمعالج Apple Silicon، فقد يساعدك تشغيل Photoshop باستخدام Rosetta في تحديد ما إذا كانت مشكلة التوافق مع الوضع الأصلي هي سبب المشكلة.

قم بإنهاء Photoshop.

في Finder، افتح Applications وابحث عن Adobe Photoshop.

انقر بالضغط على مفتاح Control فوق Adobe Photoshop، ثم حدد Get Info.

حدد Open باستخدام Rosetta، ثم ابدأ تشغيل Photoshop واختبر Generator.

إذا استمر ظهور الخطأ، فقدّم سجلات Generator عند التواصل مع دعم Adobe للحصول على المساعدة.بالنسبة لمشكلات Export As غير المرتبطة بـ Generator، استخدم إرشادات استكشاف الأخطاء وإصلاحها لعمليات التصدير والحفظ.