Obtenga más información sobre cómo limpiar el código en Dreamweaver, comprobar la compatibilidad con navegadores, valide los documentos XML y creación de páginas compatibles con XHTML.

Limpieza del código

Se pueden eliminar automáticamente etiquetas vacías, combinar etiquetas font anidadas y, en general, mejorar el código HTML o XHTML desordenado o ilegible.

Para obtener información sobre cómo limpiar HTML generado a partir de un documento de Microsoft Word, consulte Cómo abrir y editar documentos existentes.

  1. En un documento abierto, Seleccione Herramientas > Limpiar HTML.

  2. En el cuadro de diálogo que aparece, seleccione las opciones deseadas y haga clic en Aceptar.

    Nota:

    Según el tamaño del documento y el número de opciones seleccionadas, la operación de limpieza puede tardar varios segundos en realizarse.

    Eliminar Etiquetas contenedoras vacías

    Elimina las etiquetas que carecen de contenido. Por ejemplo, las etiquetas <b></b> y <font color="#FF0000"></font> están vacías, pero la etiqueta <b> en <b>texto</b> no lo está.

    Eliminar Etiquetas anidadas repetidas

    Elimina todas las repeticiones de una etiqueta. Por ejemplo, en el código <b>Esto es lo que <b>realmente</b> quería decir</b>, las etiquetas b que delimitan la palabra realmente son redundantes y se eliminarían.

    Eliminar Comentarios HTML ajenos a Dreamweaver

    Elimina todos los comentarios que Dreamweaver no haya insertado. Por ejemplo, <!‑‑begin body text--> se eliminaría, pero no <!‑‑TemplateBeginEditable name="doctitle”‑‑>, ya que se trata de un comentario de Dreamweaver que marca el comienzo de una región editable en la plantilla.

    Eliminar Formato especial de Dreamweaver

    Elimina comentarios que Dreamweaver añade al código para permitir que los documentos se actualicen automáticamente cuando se actualizan las plantillas y los elementos de biblioteca. Si selecciona esta opción al limpiar el código en un documento creado a partir de una plantilla, el documento se separará de la plantilla. Para más información, consulte Separación de un documento de una plantilla.

    Eliminar Etiqueta(s) específica(s)

    Elimina las etiquetas especificadas en el cuadro de texto contiguo. Utilice esta opción para eliminar etiquetas personalizadas insertadas por otros editores visuales y otras etiquetas que no desea que aparezcan en el sitio (por ejemplo, blink). Separe las distintas etiquetas mediante comas (por ejemplo, font,blink).

    Combinar etiquetas de <font> anidadas cuando sea posible

    Consolida dos o más etiquetas font cuando controlan el mismo rango de texto. Por ejemplo, <font size="7"><font color="#FF0000">rojo grande</font></font> se cambiaría a <font size="7" color="#FF0000">rojo grande</font>.

    Mostrar registro al terminar

    Muestra un cuadro de alerta con detalles acerca de los cambios realizados en el documento inmediatamente después de concluir la limpieza.

Verificación de que las etiquetas y llaves están equilibradas

Puede realizar una comprobación para asegurarse de que las etiquetas, paréntesis (()), llaves ({ }) y corchetes ([ ]) de la página estén equilibrados. Equilibrados significa que todos los paréntesis, etiquetas, llaves y corchetes de apertura tienen uno de cierre, y viceversa.

Comprobación de que las etiquetas están equilibradas

  1. Abra el documento en la Vista de código.
  2. Sitúe el punto de inserción en el código anidado que desea comprobar.
  3. Seleccione Edición > Seleccionar etiqueta padre.

    Se resaltarán las etiquetas de apertura y cierre (y su contenido) en el código. Si elige Edición > Seleccionar etiqueta padre, y las etiquetas están equilibradas, Dreamweaver seleccionará las etiquetas html y /html más externas.

Comprobación de que los paréntesis, llaves y corchetes estén equilibrados

  1. Abra el documento en la Vista de código.
  2. Sitúe el punto de inserción en el código que desea comprobar.
  3. Seleccione Editar > Código > Equilibrar llaves.

    Se seleccionará todo el código comprendido entre los paréntesis, llaves y corchetes. Si se vuelve a elegir Editar > Código > Equilibrar llaves, se seleccionará todo el código comprendido dentro de los paréntesis, llaves y corchetes que encierran la nueva selección.

Comprobación de la compatibilidad con los navegadores

La función Comprobar compatibilidad con navegadores (BCC) le ayuda a ubicar combinaciones de código HTML y CSS que pueden provocar problemas en determinados navegadores. Esta función también comprueba el código de los documentos para cualquier propiedad o valor CSS que no sea compatible con los navegadores de destino.

Validación de documentos XML

Puede establecer las preferencias del validador, los problemas específicos que debe comprobar el validador y los tipos de errores de los que debe informar el Validador.

  1. Siga uno de estos procedimientos:
    • Para un archivo XML o XHTML, seleccione Archivo > Validar > Como XML.

    • La ficha Validación del panel Resultados mostrará el mensaje “No se han encontrado errores ni advertencias” o una lista de los errores de sintaxis encontrados.

  2. Haga doble clic sobre un mensaje de error para seleccionar el error en el documento.
  3. Para guardar el informe como un archivo XML, haga clic en el botón Guardar informe.
  4. Para ver el informe en su navegador principal (así podrá imprimir el informe), haga clic en el botón Examinar informe.

Validación de documentos con el validador de W3C

Dreamweaver le ayuda a crear páginas web compatibles con estándares gracias a su compatibilidad incorporada con el validador de W3C. El validador de W3C valida el cumplimiento de los estándares HTML, XHTML o XML en los documentos HTML y XML. Puede validar documentos abiertos y archivos publicados en un servidor en vivo.

Utilice el informe que se genera tras la validación para corregir los errores existentes en el archivo.

Nota:

En las preferencias de Dreamweaver, puede especificar el analizador sintáctico que desea utilizar para validar sus documentos. Esta especificación se utiliza como configuración alternativa para los casos en los que no se pueda detectar el tipo de documento (DOCTYPE) automáticamente.

Validación de un documento abierto

  1. Para abrir el panel Validación, seleccione Ventana > Resultados > Validación. Este panel muestra los resultados de la validación.

  2. Seleccione Archivo > Validar > Documento actual (W3C).

Validación de un documento en vivo

Para documentos en vivo, Dreamweaver valida el código recibido por el navegador. Este código se muestra al hacer clic con el botón derecho del ratón en el navegador y elegir la opción para ver el código fuente. La validación de documentos en vivo es especialmente útil cuando se validan páginas dinámicas con PHP, JSP, etc.

La opción Validar documento en vivo solo se activa cuando la URL de la página que se está validando comienza por http.

  1. Para abrir el panel Validación, seleccione Ventana > Resultados > Validación. Este panel muestra los resultados de la validación.

  2. Haga clic en Vista en vivo.

  3. Seleccione Archivo > Validar > Validar documento en vivo (W3C).

En el caso de los documentos en vivo, cuando se hace doble clic en un error en el panel de validación W3C, se abre una ventana independiente. La ventana muestra el código generado por el navegador y resalta la línea que contiene el error.

Personalización de la configuración de validación

  1. Para abrir el panel Validación, seleccione Ventana > Resultados > Validación.

  2. En el panel Validación W3C, haga clic en el icono de Validación W3C (reproducción). Seleccione Configuración.

  3. Seleccione un DOCTYPE para la validación si no se ha especificado un DOCTYPE explícitamente para el documento.

  4. Si no desea que se muestren errores y advertencias, borre las opciones.

  5. Haga clic en Administrar si desea eliminar las advertencias o errores que haya ocultado mediante el panel Validación W3C. Cuando quite los errores y advertencias, estos no aparecerán al seleccionar Mostrar todo en el panel Validación W3C.

  6. Seleccione No mostrar el cuadro de diálogo de notificación del validador de W3C si no desea que el cuadro de diálogo de notificación del validador de W3C se muestre al comenzar la validación.

Trabajo con informes de validación

Tras la validación, los informes de validación se muestran en el panel Validación W3C.

  • Para obtener más información sobre el error o advertencia, seleccione el error/advertencia en el panel Validación W3C. Haga clic en Más información.

  • Para guardar el informe como un archivo XML, haga clic en Guardar informe.

  • Para ver el informe completo en HTML, haga clic en Examinar informe. El informe HTML proporciona la lista completa de los errores y advertencias junto con un resumen.

  • Para saltar a la ubicación del código que contiene el error, seleccione el error en el panel Validación W3C. Haga clic en el botón Opciones y seleccione Ir a línea.

  • Para ocultar los errores y las advertencias, seleccione el error o la advertencia en cuestión. Haga clic en el botón Opciones y seleccione Ocultar error.

  • Para ver todos los errores y advertencias, incluidos los errores ocultos, haga clic en el botón Opciones. Seleccione Mostrar todo. Los errores y advertencias ocultos que haya eliminado en el cuadro de diálogo Preferencias no se incluirán.

  • Para borrar todos los resultados del panel Validación W3C, haga clic en el botón Opciones. Seleccione Borrar resultados.

Configuración de las preferencias del validador

Además del validador estándar de W3C, Dreamweaver es compatible con validadores de código externos que instale como extensiones. Cuando instale una extensión de validador externo, Dreamweaver enumerará sus preferencias en la categoría Validador de W3C del cuadro de diálogo Preferencias.

  1. Seleccione Edición > Preferencias (Windows) o Dreamweaver > Preferencias (Macintosh).
  2. Seleccione Validador de W3C en la lista Categoría de la izquierda.

  3. Seleccione las bibliotecas de etiquetas que desea utilizar para la validación.

    No puede seleccionar varias versiones de la misma biblioteca de etiquetas y del mismo idioma. Por ejemplo, si selecciona HTML 4.01, no podrá seleccionar también HTML 5. Seleccione la versión más antigua con la que desee realizar la validación. Por ejemplo, si un documento contiene código HTML 4.01 válido, el código HTML 5 también será válido.

  4. Seleccione las opciones de visualización para los tipos de errores y advertencias que desea que se incluyan en el informe del validador.
  5. Haga clic en Aplicar para aplicar los cambios y, a continuación, haga clic en Cerrar para cerrar el cuadro de diálogo Preferencias.

Creación de páginas compatibles con XHTML

Cuando crea una página, puede hacer que sea compatible con XHTML. También puede hacer que un documento HTML existente sea compatible con XHTML.

Creación de documentos compatibles con XHTML

  1. Seleccione Archivo > Nuevo.
  2. Seleccione la categoría y el tipo de página que vaya a crear.
  3. Seleccione una de las definiciones de tipo de documento XHTML (DTD) en el menú emergente DocType que aparece a la derecha del cuadro de diálogo y haga clic en Crear.

    Por ejemplo, puede hacer que un documento HTML sea compatible con XHTML seleccionando XHTML 1.0 de transición o XHTML 1.0 estricto en el menú emergente.

    Nota:

    No todas las clases de documentos pueden hacerse compatibles con XHTML.

Creación de documentos compatibles con XHTML de forma predeterminada

  1. Seleccione Edición > Preferencias o Dreamweaver > Preferencias (Mac OS X) y elija la categoría Nuevo documento.
  2. Seleccione un documento predeterminado, elija una de las definiciones de tipo de documento XHTML en el menú emergente Tipo de documento predeterminado (DTD) y haga clic en Aceptar.

    Por ejemplo, puede hacer que un documento HTML sea compatible con XHTML seleccionando XHTML 1.0 de transición o XHTML 1.0 estricto en el menú emergente.

Creación de un documento compatible con XHTML a partir de un documento HTML

  1. Abra un documento y siga uno de estos procedimientos:

    • En el caso de los documentos sin marcos, seleccione Archivo > Convertir y, a continuación, seleccione una de las definiciones de tipo de documento XHTML.

      Por ejemplo, puede hacer que un documento HTML sea compatible con XHTML seleccionando XHTML 1.0 de transición o XHTML 1.0 estricto en el menú emergente.

    • En el caso de los documentos con marcos, seleccione un marco y, después, seleccione Archivo > Convertir. A continuación, seleccione una de las definiciones de tipo de documento XHTML.

  2. Para convertir todo el documento, repita este paso con todos los marcos y con el documento de conjunto de marcos.

Nota:

No se puede convertir una instancia (copia) de una plantilla, ya que debe estar en el mismo lenguaje que la plantilla en que se basa. Por ejemplo, un documento basado en una plantilla XHTML siempre estará en XHTML, y un documento basado en una plantilla HTML no compatible con XHTML siempre será HTML y no se podrá convertir a XHTML ni a ningún otro lenguaje.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea