Existen cuatro maneras principales de mejorar el rendimiento de Photoshop:

  • Optimizar la configuración del hardware
  • Especificar las preferencias de rendimiento
  • Utilizar buenos hábitos de trabajo en Photoshop
  • Tomar ciertas medidas para acelerar el sistema operativo

Para obtener los mejores resultados, adopte un enfoque general a la hora de optimizar el rendimiento de Photoshop. Lea todas las sugerencias ofrecidas y considere cuáles deberían aplicarse según la configuración de su ordenador, los tipos de archivos utilizados y su flujo de trabajo. Cada circunstancia es exclusiva y requiere una combinación de técnicas diferente para conseguir el mejor rendimiento en Photoshop.

Optimizar la configuración del hardware

Utilice un procesador lo suficientemente rápido

La velocidad de la unidad central de procesamiento del ordenador, o CPU, limita la velocidad de procesamiento de Photoshop. Photoshop CS4 requiere un procesador Intel multinúcleo o PowerPC G5 (Mac OS) o un procesador con una velocidad mínima de 1,8 GHz (Windows). Photoshop CS5, CS6 y CC requieren un procesador Intel multinúcleo (Mac OS) o un procesador con una velocidad mínima de 2 GHz (Windows).

Photoshop por lo general se ejecuta más rápido con más núcleos de procesador, si bien algunas funciones pueden aprovechar mejor los núcleos adicionales que otras. Existe una ley de rendimientos decrecientes con varios núcleos: cuantos más núcleos use, menos obtendrá de cada núcleo adicional. Por lo tanto, Photoshop no se ejecuta cuatro veces más rápido en un equipo con 16 núcleos de procesador que en un equipo con cuatro núcleos. Para la mayoría de los usuarios, la mejora de rendimiento que proporciona un equipo con más de 6 núcleos no justifica el aumento del coste.

Photoshop CS6, CC y CC 2014 también utilizan el procesador gráfico (GPU) más que en versiones anteriores para mejorar el rendimiento de más funciones. Este incremento del uso de la GPU puede causar problemas de rendimiento cuando se ejecutan Photoshop CS6 y versiones posteriores en un entorno virtual. Los equipos virtuales no pueden acceder a la GPU.

Maximice el uso de la memoria RAM

Photoshop utiliza memoria de acceso aleatorio (RAM) para procesar las imágenes. Si Photoshop no dispone de memoria suficiente, usa espacio del disco duro, también denominado disco de memoria virtual, para procesar la información. Acceder a la información en memoria es más rápido que acceder a la información en el disco duro. Por lo tanto, Photoshop es más rápido cuando puede procesar toda o la mayor parte de la información de la imagen en la memoria RAM. Si es posible, asigne suficiente RAM a Photoshop para que pueda manejar el archivo de imagen de mayor tamaño con el que se vaya a trabajar.

¿A cuánta RAM puede acceder Photoshop?

Versión de Photoshop Versión de sistema operativo Cantidad máxima de RAM que Photoshop puede usar
CS4, CS5 y versiones posteriores, de 32 bits Windows 32 bits 1,7 GB
CS4, CS5 y versiones posteriores, de 32 bits Windows 64 bits 3,2 GB
CS4, CS5 y versiones posteriores, de 64 bits* Windows 64 bits Tanta memoria RAM como pueda contener su ordenador
CS4, 32 bits Mac OS 3 GB
CS5, 32 bits Mac OS 2,1 GB
CS5 y versiones posteriores, de 64 bits Mac OS Tanta memoria RAM como pueda contener su ordenador

* La versión de 64 bits de Photoshop no es oficialmente compatible con Windows XP de 64 bits, pero debería poder ejecutarse.

Para obtener más información sobre el rendimiento y sobre Photoshop de 64 bits, consulte Ventajas y limitaciones de los sistemas operativos de 64 bits | Photoshop CS4, CS5, CS6, CC, CS6, CC.

Para obtener instrucciones sobre la asignación de RAM a Photoshop, consulte Uso de la memoria.

Utilice un disco duro grande y rápido para trabajar con imágenes de gran tamaño

Photoshop lee y escribe información de la imagen en el disco cuando no hay suficiente RAM para contener todos. Compruebe el indicador de eficiencia como se describe a continuación para determinar si un disco duro más rápido o un disco en estado sólido mejorarían el rendimiento. Si el número de eficiencia está por encima de 95%, adquirir un disco de memoria virtual más rápido es poco rentable.

Para mejorar el rendimiento de Photoshop, utilice un disco con una velocidad de transferencia de datos rápida. Por ejemplo, puede usar un disco duro interno o un disco externo conectado a través de una interfaz rápida como Thunderbolt, FireWire 800, eSATA o USB3. Los servidores de red (disco duro accesible a través de una red) tienen un índice de transferencia de datos más lento.

Photoshop de CS4 a CS6 requieren al menos 1 GB de espacio libre en el disco duro (Windows) o 2 GB de espacio libre en el disco duro (Mac OS). Photoshop CC requiere al menos 2.5 GB (Windows) o 3.2 GB (Mac OS). La instalación requiere espacio adicional, y Adobe recomienda más espacio en disco duro para la memoria virtual y espacio en disco de memoria virtual.

Las matrices RAID 0 rápidas son excelentes como discos de memoria virtual, especialmente si la matriz se utiliza de forma exclusiva para el disco de memoria virtual. Asegúrese también de que la matriz se desfragmenta de forma regular y no es el volumen de arranque. 

Discos de estado sólido

Instalar Photoshop en un disco de estado sólido (SSD) permite que Photoshop se inicie con rapidez, probablemente en menos de un segundo. Pero la mayor rapidez de inicio es la única ventaja de tiempo que se consigue. Es la única vez en la que se leen muchos datos del disco SSD.

Para sacar el máximo partido de un SSD, utilícelo como disco de memoria virtual. El uso de este disco como disco de memoria virtual le ofrece importantes mejoras de rendimiento si tiene imágenes que no se ajustan completamente en la memoria RAM. Por ejemplo, intercambiar segmentos entre RAM y SSD es mucho más rápido que intercambiar segmentos entre RAM y disco duro.

Si su SSD no tiene mucho espacio libre (el archivo de memoria virtual supera la capacidad del SSD), añada un disco duro secundario o terciario. (Añádalo después de la unidad de estado sólido (SSD). Asegúrese de que estos discos estén seleccionados como discos de memoria virtual en el panel Rendimiento de Preferencias.

Además, el rendimiento de los distintos discos SSD varía en gran medida, mucho más que el de los discos duros. Si se usa una unidad antigua más lenta, no se obtienen muchas mejoras con respecto a un disco duro.

Nota: añadir RAM para mejorar el rendimiento es más rentable que adquirir un SSD. Si el dinero no es importante, ha instalado toda la memoria RAM posible en el equipo, ejecuta Photoshop CS5 como aplicación de 64 bits, y todavía quiere mejorar el rendimiento, considere utilizar un disco de estado sólido como disco de memoria virtual.

Como se mencionó anteriormente, un SSD no mejora el rendimiento si el indicador de eficiencia ya es muy alto. Cuanto más bajo sea el indicador de eficiencia, mayor será la mejora que ofrece el SSD.

Establecimiento de las preferencias de rendimiento

Las preferencias de rendimiento seleccionadas tienen un gran impacto en el rendimiento de Photoshop. Para establecer las preferencias de rendimiento, elija Photoshop > Preferencias > Rendimiento (Mac OS) o Edición > Preferencias > Rendimiento (Windows). A continuación, especifique las opciones deseadas en cada una de las áreas siguientes:

Uso de la memoria

Cuanta más RAM disponible haya para Photoshop, más rápido podrá la aplicación procesar la información. El área Uso de la memoria del cuadro de diálogo Preferencias de rendimiento indica la cantidad de RAM disponible para Photoshop. También muestra el rango ideal para el sistema.

Nota: la memoria RAM disponible no es la cantidad de RAM total. Photoshop resta RAM necesaria para el sistema operativo. 

Por defecto, Photoshop utiliza el 70% de la memoria RAM disponible. Puede asignar más o menos memoria RAM a Photoshop, cambiando el valor en el cuadro Permitir que Photoshop use. O bien, arrastre el regulador de Uso de la memoria. Reinicie Photoshop para que los cambios surtan efecto.

La asignación de memoria RAM predeterminada de 70% ofrece un buen rendimiento para la mayoría de usuarios que ejecutan la versión de 32 bits de Photoshop. Para averiguar la asignación de memoria RAM ideal para su sistema, cámbiela en incrementos de 5% y observe el rendimiento de Photoshop en el indicador de estado Eficiencia. Consulte Observe el indicador de eficiencia.

Si ejecuta la versión de 64 bits de Photoshop y se producen errores de falta de RAM o de memoria, aumente la asignación de RAM. Si no se están ejecutando otras aplicaciones, puede aumentar la asignación de memoria RAM en 100% para mejorar el rendimiento de Photoshop.

Si ejecuta la versión de 32 bits de Photoshop, pueden producirse errores de falta de RAM si la asignación de RAM se establece en 100%. Si obtiene errores de falta de RAM, reduzca la asignación de memoria RAM en 85-90% y vuelva a probar. Si siguen los problemas, vaya reduciendo la asignación de RAM en incrementos de 5% y vuelva a probar hasta que deje de producirse el error, o use la versión de 64 bits de Photoshop si puede.

Discos de memoria virtual

Configure el disco de memoria virtual en un disco duro desfragmentado que disponga de mucho espacio libre y que cuente con velocidades de lectura/escritura altas (consulte Desfragmente el disco duro). Si tiene más de un disco duro, puede especificar más discos de memoria virtual. Photoshop admite un espacio máximo de 64 exabytes para los discos de memoria virtual, en un máximo de cuatro volúmenes. (Un exabyte equivale a 1.000 millones de gigabytes).

Si el disco de inicio es un disco duro (a diferencia de un disco de estado sólido), intente utilizar un disco duro diferente para el disco de memoria virtual principal. Si el disco de inicio es un SSD, seleccionar un disco diferente para el disco de memoria virtual principal no representará ninguna ventaja. Si utiliza el disco SSD como disco de inicio del sistema y como disco principal de memoria virtual obtendrá unos buenos resultados. Y probablemente sea mejor que emplear otro disco duro independiente para la memoria virtual. Consulte Asignación de discos de memoria virtual en la ayuda de Photoshop para obtener más información.

Preferencias de historia y caché

Niveles de caché

Photoshop usa el almacenamiento de imágenes en caché para redibujar más rápidamente las imágenes de alta resolución. Con el almacenamiento de imágenes en caché, Photoshop emplea versiones de baja resolución de las imágenes para actualizarlas rápidamente en pantalla a medida que se trabaja. La opción Niveles de caché permite hacer que Photoshop guarde entre uno y ocho niveles de datos de imagen en caché. Cuantos más niveles de caché tenga, más tardará Photoshop en abrir el archivo, aunque responderá mejor mientras trabaja. Cuantos menos niveles de caché tenga, menos tardará la imagen en cargarse, aunque Photoshop se ralentizará. 

El valor predeterminado de Niveles de caché es 4. Sin embargo, este valor se puede cambiar en función de los tipos de archivos con los que trabaje y la cantidad de memoria RAM de que disponga.

Si utiliza archivos relativamente pequeños (de alrededor de 1 megapíxel o 1280 x 1024 píxeles) y muchas capas (más de 50), establezca la caché en 1 o 2. Si establece Niveles de caché en 1, se deshabilitará el almacenamiento de imágenes en caché, de forma que solamente se guardará en caché la imagen presente en pantalla en cada momento.

Nota: algunas características de Photoshop no producen el resultado de calidad más alta si Niveles de caché se configura en 1.

Si utiliza archivos con dimensiones en píxeles más grandes (por ejemplo, de 50 megapíxeles o más), establezca Niveles de caché en un valor superior a 4. La definición de un nivel de caché superior mejora el rendimiento, ya que acelera las operaciones de redibujado.

El tamaño de segmento de caché es la cantidad de datos (segmentos) con la que Photoshop funciona en un momento dado. Photoshop procesa cada segmento de datos y, a continuación, lo redibuja. Photoshop es más eficiente cuando funciona con segmentos mayores, pero cuanto mayor sea el tamaño del segmento, más tiempo se requerirá para volver a dibujarlo. Los segmentos más grandes aceleran las operaciones complejas, como por ejemplo los filtros de enfoque. Sin embargo, los cambios pequeños, como por ejemplo los trazos de pincel, responden mejor cuando Photoshop usa segmentos más pequeños.

En Photoshop CS4, puede cambiar el tamaño de los segmentos de caché con el plugin opcional Azulejos más grandes. Consulte Plugin Azulejos más grandes (Photoshop CS4).

En Photoshop CS5 y CS6, puede elegir el tamaño de los segmentos en Preferencias de rendimiento, en el menú emergente Tamaño de segmentos de caché. Si tiene un procesador Intel "Core", elija 128 K o 1024 K. Si su procesador es un Intel Pentium 4 o AMD, Photoshop será más eficiente si utiliza 132 K o 1032 K.

En Photoshop CS5 y CS6, la sección Historia y caché de Preferencias de rendimiento también tiene tres ajustes preestablecidos de caché: Altos y finos, Por defecto y Grande y plano. Estas opciones establecen el nivel de caché y el tamaño de los segmentos según el tipo de documento que se esté editando y la cantidad de memoria RAM instalada en el equipo.

  • Altos y finos Son mejores para editar imágenes con menores dimensiones en píxeles y que tengan muchas capas (de decenas a cientos).
  • Grande y plano Es mejor para editar imágenes con grandes dimensiones en píxeles (de decenas a cientos de megabytes) y pocas capas.
  • Por defecto Para las imágenes intermedias.

Estados de historia

Cada estado de historia o instantánea de una operación que afecta a toda la imagen aumenta la cantidad de espacio en disco de memoria virtual que necesita el archivo. Photoshop crea una copia del archivo original. De este modo, si se aplica un desenfoque gaussiano a una imagen de 500 KB y se crea una instantánea de la edición en el panel Historia, Photoshop requiere 1 MB de espacio en disco de memoria virtual para la imagen. Si se aplica un ajuste de niveles, un filtro de ruido y una máscara de enfoque a una imagen de 5 MB y se guarda una instantánea de historia de cada estado, la imagen necesita 15 MB de espacio en disco de memoria virtual.

Cada estado de historia o de la instantánea en el panel Historia aumenta la cantidad de espacio en el disco de memoria virtual que utiliza Photoshop. Cuanto más píxeles cambie una operación, más espacio de memoria virtual consumirá el estado de historia correspondiente. Un estado de historia correspondiente a un pequeño trazo de pintura o una operación no destructiva, como crear o modificar una capa de ajuste, consume poco espacio de memoria virtual. Un estado de historia correspondiente a aplicar un filtro a toda la imagen consume mucho más espacio de memoria virtual.

Puede ahorrar espacio de disco de memoria virtual y mejorar el rendimiento limitando o reduciendo el número de estados que Photoshop puede guardar en el panel Historia. Photoshop puede guardar hasta 1.000 estados de historia; de forma predeterminada, permite guardar 20. Para reducir este número, haga clic en el menú emergente Estados de historia en el área Historia y caché del cuadro de diálogo Preferencias de rendimiento y arrastre a un valor más bajo.

Plugin Azulejos más grandes (Photoshop CS4)

El plugin Azulejos más grandes, que está ubicado en la carpeta Plugins opcionales en el DVD de la aplicación, está deshabilitado de forma predeterminada. Para activarlo, cópielo en la carpeta Extensiones, dentro de la carpeta Plugins de Photoshop CS4, y quite la tilde (~) del nombre de archivo. Habilite únicamente el plugin si dispone de más de 1 GB de RAM.

Al activar el plugin, éste aumenta el tamaño del mosaico de la imagen en Photoshop. Photoshop redibuja más datos al mismo tiempo, ya que cada azulejo es mayor y todos ellos se dibujan, completos, de uno en uno. Se necesita menos tiempo para redibujar un número menor de azulejos de mayor tamaño que un número mayor de azulejos más pequeños. Puede que parezca que los azulejos más grandes se redibujan más lentamente, y en realidad puede tardarse más en ver los resultados en pantalla si se están realizando pequeños ajustes constantemente. Sin embargo, el tiempo total que se necesita para calcular y dibujar la imagen final es menor. Las actualizaciones de pantalla mientras se pinta también pueden ser menos suaves si está instalado el plugin Azulejos más grandes.

Si pasa la mayor parte del tiempo pintando o ajustando rápidamente los controles de filtros y paneles y Photoshop redibuja correctamente, no active el plugin Azulejos más grandes. Sin embargo, si está más tiempo observando las barras de avance en la pantalla, Azulejos más grandes puede mejorar el rendimiento.

Ajustes de GPU

Photoshop CS4 y versiones posteriores utilizan la GPU de la tarjeta gráfica del ordenador para que la pantalla se redibuje más rápidamente. Para que Photoshop acceda a la GPU, la tarjeta gráfica requiere una GPU que admita OpenGL. También requiere 128 MB de VRAM (RAM de vídeo) como mínimo y un controlador compatible con OpenGL 2.0 y Shader Model 3.0.

Photoshop CS6 requiere 256 MB de VRAM. Photoshop 13.1 no puede mostrar las funciones 3D si tiene menos de 512 MB de VRAM en su tarjeta de vídeo. Photoshop CC requiere 512 MB de VRAM. 

La mejor manera de optimizar la aceleración de GPU es mantener el controlador de la tarjeta gráfica actualizado. Para obtener más información sobre la aceleración de GPU e instrucciones para actualizar controladores de tarjeta gráfica, consulte Preguntas frecuentes sobre la GPU de Photoshop CCPreguntas frecuentes sobre la GPU de Photoshop CS6 o Compatibilidad con GPU y OpenGL | Photoshop CS4, CS5. Para obtener instrucciones sobre la especificación de ajustes de GPU en el cuadro de diálogo Preferencias de rendimiento, consulte Preguntas frecuentes de la GPU de Photoshop CC Preguntas frecuentes de la GPU de Photoshop CS6 o Funciones y preferencias de la GPU y de OpenGL | Photoshop y Bridge | CS4, CS5.

OpenCL

OpenCL es una tecnología que permite al uso de las aplicaciones el procesador del adaptador de vídeo, la GPU. Varias funciones utilizan OpenCL en Photoshop CC, por lo que deben ser más rápidas. Asegúrese de que OpenCL esté activado para ejecutar estas funciones en su mayor velocidad.

Para activar OpenCL, elija Edición > Preferencias > rendimiento (Windows) o Photoshop > Preferencias > rendimiento (Mac OS). Haga clic en Ajustes avanzados y seleccione Usar OpenCL.

Las funciones con OpenCL activado son:

  • Panorámica de vídeo
  • Efectos de desenfoque (campo, iris, y desenfoque de inclinación)

Guardar en el fondo y guardar automáticamente información de recuperación

La opción Guardar en el fondo está activada de manera predeterminada. Si está activada, Photoshop le permite continuar trabajando mientras se ejecutan los comandos Guardar y Guardar como en lugar de tener que esperar hasta que se haya completado la operación. Si desea ver el progreso de una operación de almacenamiento en el fondo, puede seleccionar Guardar progreso en el menú emergente Estado. Las operaciones de almacenamiento realizadas en el fondo (es decir, con la opción activada) tardan más. Sin embargo, no tendrá que esperar a que termine para seguir trabajando.

En la mayoría de los casos, las operaciones de almacenamiento en el fondo no afectan significativamente el rendimiento o la capacidad de respuesta de las operaciones normales de Photoshop. Sin embargo, si está editando un archivo que es mucho más grande que el RAM disponible, la operación de almacenamiento puede afectar al rendimiento o la capacidad de respuesta hasta que el proceso haya terminado.

La opción Guardar automáticamente la información de recuperación se activa solo si la opción Guardar en el fondo está activada. Si está activada, se guarda la información de recuperación de cada archivo abierto en el intervalo especificado. Esta información de recuperación se almacena en el fondo, en una ubicación oculta. El archivo original nunca se modifica. El archivo original solo se modifica si ejecuta los comandos Guardar o Guardar como. Si Photoshop o el sistema se bloquea, la información de recuperación aparecerá la próxima vez que inicie Photoshop.

Si selecciona un valor más bajo para el intervalo de recuperación, obtendrá una mayor protección contra los bloqueos. En la mayoría de los casos, guardar la información de recuperación no afecta al rendimiento o la capacidad de respuesta de Photoshop. Sin embargo, el rendimiento se puede ver afectado dependiendo de las operaciones que esté ejecutando y del tamaño y el número de archivos abiertos. Lo más probable es que este problema ocurra si los archivos que va a modificar son más grandes que el RAM disponible.

Posibles problemas:

Si Photoshop parece ralentizarse de manera intermitente, seleccione Guardar progreso en el menú emergente en la parte inferior izquierda de la ventana de la imagen. Si observa problemas de rendimiento mientras la barra de Guardar progreso se mueve, aumente el valor de la opción Guardar automáticamente la información de recuperación. O desactive la opción.

La información de recuperación se guarda en la misma ubicación que los archivos de memoria virtual de Photoshop. Aumenta la cantidad de espacio que utiliza Photoshop en los discos de memoria virtual especificados en la opción Discos de memoria virtual en el panel Rendimiento de Preferencias. Si habitualmente trabaja con muchos archivos grandes abiertos, la cantidad de espacio puede ser significativo. Si obtiene errores de falta de espacio en disco al ejecutar comandos distintos de Guardar, añada espacio al disco de memoria virtual. O bien, desactive la opción Guardar automáticamente información de recuperación.

Consejos para aumentar el rendimiento de Photoshop

Trabaje dentro de las limitaciones de tamaño de archivo

Cuanto más grande sea el archivo con el que trabaja, más probabilidades habrá de que se produzcan problemas de rendimiento. 

Photoshop admite un tamaño de archivo máximo de 300.000 x 300.000 píxeles, excepto en el caso de los archivos con formato PDF, que se ven limitados a 30.000 x 30.000 píxeles y 200 x 200 pulgadas.

Capacidad de tamaño de los archivos para Photoshop:

  • Archivos PSD: 2 GB
  • Archivos TIFF: 4 GB (Photoshop CS6 admite archivos TIFF de más de 4 GB)

Nota: la mayoría de las aplicaciones no pueden trabajar con archivos TIFF más grandes de 2 GB.

  • Archivos PSB: 4 exabytes (4096 petabytes o 4 millones de terabytes)
  • Archivos PDF: 10 GB (el tamaño máximo de las páginas está restringido a 200 pulgadas)

Consulte también Tamaño de archivo en la ayuda de Photoshop CS5.

Photoshop CS6 admite profundidades de bits impares, además de profundidades de bits pares.

Observe el indicador de eficiencia

Observe el indicador de eficiencia mientras trabaja en Photoshop. Este parámetro le indica si Photoshop ha utilizado toda la memoria RAM disponible y empieza a usar el disco de memoria virtual, que reduce el rendimiento. Haga clic en el menú emergente en la parte inferior de la ventana de la imagen y elija Eficiencia. (También puede ver el estado de eficiencia en el panel Información. Consulte Trabajo con el panel Información en la ayuda de Photoshop CS5). Si el valor de Eficiencia es inferior al 100 %, Photoshop está utilizando el disco de memoria virtual. Por lo tanto, funcionará más lentamente. Si la eficiencia es inferior a entre 90% y 95%, asigne más memoria RAM a Photoshop en las preferencias de rendimiento (consulte Uso de la memoria) o añada más memoria RAM al sistema.

Indicador de eficiencia

Cierre las ventanas de documento innecesarias

Las ventanas de documento consumen más memoria RAM en Photoshop CS4 que en las versiones anteriores. Si se abren demasiadas imágenes en Photoshop, puede que aparezca un error de falta de RAM o que Photoshop se ejecute lentamente. Si esto sucede, cierre algunas ventanas de documento.

Reduzca el número de ajustes preestablecidos cargados de motivos y puntas de pincel

Para reducir la cantidad de espacio de memoria virtual que utiliza Photoshop, minimice el número de motivos y puntas de pincel cargados. Guarde los ajustes preestablecidos que no necesite en ese momento en un archivo de ajustes preestablecidos. O elimínelos si los ha cargado de un archivo de ajustes preestablecidos.

Para ver los ajustes preestablecidos cargados de motivos o pinceles, seleccione Edición > Gestor de ajustes preestablecidos. A continuación, seleccione Tipo de ajuste preestablecido > Motivos o Tipo de ajuste preestablecido > Pinceles. Para guardar los ajustes preestablecidos de motivos o pinceles que no se estén usando, selecciónelos en el Gestor de ajustes preestablecidos. A continuación, haga clic en Guardar conjunto y asígneles un nombre. Haga clic en Eliminar para eliminarlos de los ajustes preestablecidos cargados. Si los necesita más adelante, puede volver a cargarlos desde el Gestor de ajustes preestablecidos o los distintos menús emergentes de motivos y pinceles.

Minimice o desactive las miniaturas de vista previa

Cada vez que modifica el documento, Photoshop actualiza todas las miniaturas visibles en los paneles Capas y canales. Esta actualización puede afectar a la capacidad de respuesta cuando esté trabajando con capas que se pinten, muevan o se empujen rápidamente. Cuanto más miniaturas visibles haya, mayor será este efecto.

Para minimizar o deshabilitar las miniaturas de vista previa en estos paneles, haga clic en el panel Canales, Capas o Trazados y elija Opciones de panel. En el área Tamaño de miniatura, seleccione un tamaño de miniatura más pequeño o elija Ninguno. A continuación, haga clic en OK.

Configure Maximizar la compatibilidad de archivos PSD y PSB en Preguntar

La función Maximizar la compatibilidad de archivos PSD y PSB adjunta una copia alisada de la imagen cuando se guarda. Estos datos adicionales garantizan que los archivos PSD y PSB puedan abrirse en versiones anteriores de Photoshop, Photoshop Lightroom y aplicaciones de otros fabricantes que admitan archivos PSD. También le permite abrir previsualizaciones QuickLook en los diálogos Finder y Abrir en Mac OS. Para archivos grandes y con capas que solo contengan algunas capas, el aumento de tamaño puede ser significativo. Guardar la información de compatibilidad también es un proceso más lento con los documentos grandes.

Para guardar documentos más rápidamente utilizando más espacio en el disco:

  1. Para documentos PSD y PSB de 16 bits y 32 bits, active Desactivar la compresión de archivos PSD y PSB en el panel Administración de archivos del diálogo Preferencias.

  2. Para archivos TIFF, no seleccione Compresión ZIP para el documento ni para las capas en el diálogo Opciones TIFF.

Consulte Maximización de la compatibilidad al guardar los archivos en la ayuda de Photoshop CS5 para obtener más información.

Trabaje en modo de imagen de 8 bits

Photoshop puede realizar muchas operaciones en imágenes de 16 y 32 bits. Sin embargo, estas imágenes requieren más memoria, espacio de memoria virtual, y tiempo para procesarse que las imágenes de 8 bits. Para convertir la imagen a 8 bits por canal, elija Imagen > Modo > 8 Bits/canal. Consulte Profundidad de bits en la ayuda de Photoshop para obtener más información.

Nota: la conversión a 8 bits por canal elimina datos de la imagen. Guarde una copia de la imagen original de 16 o 32 bits antes de convertir a 8 bits por canal.

RAW de cámara puede abrir imágenes con 8 o 16 bits por canal. Para cambiar esta configuración, abra el cuadro de diálogo RAW de cámara abriendo un archivo RAW. Haga clic en el texto azul subrayado debajo de la imagen de vista previa y, a continuación, seleccione 8 bits/canal o 16 bits/canal en el menú emergente Profundidad.

Desactive la previsualización de fuentes WYSIWYG

Desactivar la lista de previsualización de fuentes WYSIWYG aumenta la velocidad de procesamiento de las fuentes en Photoshop. En Photoshop CS4 y CS5, elija Photoshop > Preferencias > Tipo (Mac OS) o Edición > Preferencias > Tipo (Windows). Anule la selección de Tamaño de previsualización de fuentes y haga clic en OK. En Photoshop CS6 y CC, seleccione Tipo > Tamaño de vista previa de fuentes > Ninguno.

Consulte Solucionar problemas de fuentes | Photoshop CS5 para obtener más ayuda con las fuentes.

Reduzca la resolución de imagen

Cuanto mayor sea la resolución, más memoria y espacio en disco necesitará Photoshop para mostrar, procesar e imprimir una imagen. Una resolución de imagen superior no proporciona necesariamente mayor calidad de imagen. Pero puede implicar una reducción del rendimiento en Photoshop, el uso del espacio adicional en el disco de memoria virtual, y una impresión más lenta. La resolución óptima para sus imágenes depende de la forma en que las imágenes se muestren o se impriman. Suele ser útil realizar todo el procesamiento de la imagen con la resolución original. Y, a continuación, cuando empiece a optimizar la imagen para un medio de salida determinado, reducir el tamaño y la resolución de la imagen a unos parámetros adecuados para ese medio. (Guardar una copia del original en resolución completa).

Para las imágenes presentadas en pantalla o por correo electrónico, piense en términos de dimensiones en píxeles totales. Muchas imágenes web no tienen más de 700 píxeles de ancho. Las imágenes son cada vez más grandes, pero hoy en día las más grandes de uso común son de 2560 X 1600 píxeles, o unos cuatro megapíxeles.

Para reducir el tamaño de una imagen en Photoshop, elija Imagen > Tamaño de imagen. En el cuadro de diálogo Tamaño de imagen, asegúrese de que tanto la opción Restringir proporciones como la opción Volver a muestrear cuadros de imagen estén seleccionadas. Introduzca un nuevo valor para la anchura o la altura en píxeles. (Si introduce un valor para uno de los parámetros, cambiará también el otro parámetro porque la opción Restringir proporciones fija la relación entre ambos).

Para las imágenes impresas, aumentar la resolución más allá de unos 360 ppp aportará solo beneficios insignificantes en la mayoría de los casos. Si efectúa muchas impresiones, merece la pena experimentar para encontrar una resolución que le ofrezca los resultados que busca.

Para reducir la resolución de una imagen en Photoshop, elija Imagen > Tamaño de imagen. En el cuadro de diálogo Tamaño de imagen, seleccione Volver a muestrear la imagen. Cambie los valores de Tamaño del documento para reflejar el tamaño físico en el que desea imprimir el documento. A continuación, reduzca el valor de resolución y haga clic en Aceptar. Si el valor de resolución es menor que el valor que tenía pensado, en lugar de mayor (en otras palabras, si pretende aumentar la resolución del documento en lugar de reducirla), consulte otra documentación sobre impresión de imágenes para obtener información sobre cómo imprimir imágenes de baja resolución.

Si va a aumentar la resolución de la imagen para imprimir en lugar de reducirla, realice este aumento de resolución como uno de los últimos pasos antes de imprimir la imagen. De esta manera, no será necesario procesar toda esta información adicional en las fases anteriores.

Para obtener más información, consulte Redimensionar, remuestrear y recortar imágenes | Photoshop, así como Preparando para imprimir desde Photoshop y Novedades y cómo imprimir en Photoshop.

Purgue Deshacer, el portapapeles y los estados de historia

Deshacer, el portapapeles y los estados de historia contienen datos de imagen. Para liberar memoria RAM, seleccione Edición > Purgar y, a continuación, Deshacer, Portapapeles, Historias o Todo. 

Nota: el comando Purgar no se puede deshacer.

El contenido del portapapeles suele ser voluminoso si ha estado copiado y pegado datos en documentos grandes. Y no son nada útiles cuando la operación de pegado ha terminado. Las opciones Deshacer y Estados de historia, sin embargo, suelen contener datos útiles para corregir errores anteriores. Purgar Historial y Deshacer proporciona más RAM inmediatamente. Sin embargo, de todas formas los historiales que no se utilizan se mueven automáticamente de la memoria RAM al disco de memoria virtual mientras trabaja. Por lo tanto, purgar Historial y Deshacer sólo resulta útil en determinadas circunstancias.

La Galería de filtros permite probar uno o más filtros sobre una imagen antes de aplicar los efectos, con lo que puede ahorrar bastante tiempo. Consulte Descripción general de la Galería de filtros en la ayuda de Photoshop para obtener más información.

Arrastrar entre archivos

Arrastrar y soltar capas o archivos es más efectivo que copiarlos y pegarlos. Al arrastrar se evita el portapapeles y se transfieren los datos directamente. Copiar y pegar tiene la posibilidad de involucrar una transferencia mayor de datos y es un método mucho menos eficaz.

Use las capas con sentido común

Las capas son fundamentales para trabajar con Photoshop, pero también hacen que aumente el tamaño de los archivos y se prolongue el tiempo necesario para las operaciones de redibujado. Photoshop recompone cada capa después de cada modificación realizada en la imagen. Una vez que haya finalizado las modificaciones de las capas, acóplelas (fusiónelas) para reducir el tamaño de un archivo. Seleccione las capas en el panel Capas, haga clic con el botón derecho (Windows) o mantenga pulsada la tecla Control y haga clic (Mac OS) y elija Combinar capas. (Asegúrese de eliminar las capas vacías del archivo, ya que aumentan su tamaño. Seleccione las capas vacías en el panel Capas, haga clic con el botón derecho del ratón [Windows] o mantenga pulsada la tecla Control y haga clic [Mac OS] y elija Eliminar capa). Para acoplar todas las capas de un archivo, seleccione Capa > Acoplar imagen.

Nota: recuerde que Photoshop no le permite separar las capas tras haberlas combinado. Puede elegir Edición > Deshacer o utilizar el panel Historia para volver a un estado anterior.

Si no cambia con frecuencia algunas de las capas, piense en la posibilidad de convertir las capas o los conjuntos de capas en objetos inteligentes, lo cual ahorra espacio en disco y mejora el rendimiento. Seleccione las capas o los conjuntos de capas en el panel Capas, haga clic con el botón derecho (Windows) o mantenga pulsada la tecla Control y haga clic (Mac OS) y elija Convertir en objeto inteligente.

Guarde los archivos TIFF sin capas

Photoshop puede guardar capas en los archivos TIFF. Sin embargo, los archivos TIFF con capas son mayores que los archivos TIFF acoplados y consumen más recursos al procesarse e imprimirse. Si trabaja con un archivo TIFF con capas, guarde el archivo con capas original como un archivo de Adobe Photoshop (.psd). A continuación, cuando esté listo para guardar el archivo en formato TIFF, elija Archivo > Guardar como. En el cuadro de diálogo Guardar como, elija Formato > TIFF, seleccione Guardar como copia, anule la selección de Capas y haga clic en Guardar.

Para obtener velocidad adicional cuando exporte archivos TIFF, no elija la compresión ZIP. Sin embargo, la compresión ZIP produce archivos TIFF de pequeñas dimensiones.

No exporte al portapapeles

La opción Exportar portapapeles hace que Photoshop tenga el contenido del portapapeles disponible para otros programas. Si copia grandes cantidades de datos en Photoshop, pero no los pega en otras aplicaciones, ahorre tiempo desactivando la opción Exportar portapapeles.

  1. Elija Photoshop > Preferencias > General (Mac OS) o Edición > Preferencias > General (Windows).
  2. Anule la selección de Exportar portapapeles.
  3. Haga clic en OK.

Optimización del sistema operativo para Photoshop

Cierre las aplicaciones y los elementos de inicio innecesarios

Las aplicaciones abiertas y los elementos de inicio disminuyen la cantidad de memoria disponible para Photoshop. Cierre las aplicaciones, los elementos de inicio y las extensiones que no necesite y, a continuación, ponga más memoria a disponibilidad de Photoshop. Consulte los temas siguientes en los documentos de solución de problemas de Adobe sobre sistemas operativos:

 A continuación, consulte Uso de la memoria para obtener instrucciones sobre cómo asignar más memoria RAM a Photoshop.

Desactivar App Nap (Mac)

Ejecute el Liberador de espacio en disco (Windows)

Cuando trabaja con una aplicación, se almacena temporalmente una copia del archivo de datos en el disco duro. Muchas aplicaciones crean archivos .tmp y los eliminan cuando sale de la aplicación. Los errores de sistema y los bloqueos, sin embargo, podrían impedir que una aplicación eliminase tales archivos, por lo que ocuparían espacio en disco y podrían producir problemas. De vez en cuando, ejecute el programa Liberador de espacio en disco para eliminar los archivos temporales y cualquier otro archivo que no se utilice.

  1. Siga uno de estos procedimientos:

    • En Windows XP: seleccione Inicio > Todos los programas > Accesorios > Herramientas del sistema > Liberador de espacio en disco.
    • En Windows Vista/Windows 7/8: seleccione Inicio, escriba Liberador de espacio en disco en el cuadro de texto de búsqueda y seleccione Liberador de espacio en disco en la lista de programas.
  2. Elija una unidad para que se limpie, si corresponde.
  3. Seleccione los archivos temporales y cualquier otro archivo que desee eliminar.
  4. Haga clic en Aceptar.

Desfragmente el disco duro

Al añadir, eliminar y mover archivos en un disco duro, su espacio disponible ya no es un solo bloque contiguo. Si el sistema no tiene suficiente espacio contiguo, guarda fragmentos de un archivo en diferentes ubicaciones del disco duro. Photoshop tarda más tiempo en leer o escribir un archivo fragmentado que uno guardado en una ubicación contigua.

Para obtener instrucciones sobre cómo desfragmentar discos duros en Windows, consulte estos temas de ayuda de Microsoft:

  • (Windows XP) "El mantenimiento de un PC equipado con Windows XP". Siga las instrucciones de "Desfragmentador de disco".
  • (Windows 7 y Vista) ”Mejorar el rendimiento mediante la desfragmentación del disco duro”
  • (Windows) 8 “Optimizar el disco duro”

En Mac OS, utilice una utilidad de discos, como el Desfragmentador de discos, Symantec Norton Utilities o Micromat Drive 10. La fragmentación no suele ser un problema en Mac OS, a menos que normalmente trabaje con la unidad casi llena. Para obtener más información, consulte Desfragmentación del disco duro y comprobación de errores.

Nota: las matrices RAID no se fragmentan. Es más probable que la fragmentación se convierta en un problema si usa un solo disco para todo. También puede ser un problema si los archivos permanentes y el disco de memoria virtual de Photoshop comparten un mismo volumen, especialmente si no hay mucho espacio libre. En este caso, desfragmentar el disco puede suponer una diferencia significativa.

Los discos de estado sólido no requieren desfragmentación porque su rendimiento no se degrada significativamente con niveles normales de fragmentación.

Instale las últimas actualizaciones del sistema operativo

Las actualizaciones del sistema operativo Windows o Mac OS X mejoran su rendimiento y la compatibilidad con las aplicaciones. 

Obtenga Service Packs y otras actualizaciones de Windows del sitio Web de Microsoft. Para obtener asistencia técnica para instalar Service Packs y otras actualizaciones, póngase en contacto con el Servicio de soporte técnico de Microsoft.

Para obtener actualizaciones de Mac OS X, elija Actualización de software en el menú Apple. Para obtener soporte técnico para instalar actualizaciones, póngase en contacto con el servicio de soporte técnico de Apple.

Importante: Antes de instalar una actualización del sistema, compruebe los requisitos del sistema para el software de Adobe para asegurar la compatibilidad. (Compruebe también cualquier software o hardware de terceros que utilice con el software de Adobe). Si la actualización no aparece en la lista, póngase en contacto con Adobe o con el fabricante del software o hardware de terceros.

Especifique una memoria virtual fija (Windows)

La memoria virtual permite que el sistema use espacio del disco duro para guardar información que normalmente se guarda en la memoria. Se tarda más en acceder a la información guardada en un disco duro que en acceder a la información en la memoria. Por lo tanto, usar una parte del disco duro como memoria virtual puede disminuir el rendimiento. Además, Photoshop no puede usar el espacio del disco duro que emplea el sistema como memoria virtual para sus archivos de disco de memoria virtual. (Utiliza el disco de memoria virtual para almacenar información de las imágenes mientras se trabaja).

Especificar una configuración de memoria virtual fija ayuda a impedir que los archivos del disco de memoria virtual de Photoshop compitan por espacio con la memoria virtual del sistema, especialmente si establece la configuración de la memoria virtual en una unidad distinta del disco de memoria virtual principal. Para ambos tipos de memoria virtual, asegúrese de usar una unidad con suficiente espacio libre y espacio contiguo para obtener un mejor rendimiento. Asimismo, conserve el archivo de paginación en un disco duro desfragmentado vacío e independiente.

Como siempre, el consejo de utilizar discos separados para la memoria virtual y los discos virtuales no hace referencia a los discos de estado sólido. Si utiliza un SSD, puede ser útil colocar los archivos más utilizados en un SSD. Al colocarlos en el mismo SSD, se producirán pocas o ninguna pérdida.

Para cambiar la memoria virtual en Windows XP, cierre todas las aplicaciones y, a continuación, haga lo siguiente:

  1. Elija Inicio > Configuración > Panel de control y haga doble clic en Sistema.
  2. Haga clic en la ficha Opciones avanzadas y a continuación, seleccione Configuración en el área Rendimiento.
  3. Haga clic en la ficha Avanzadas y, en el área Memoria virtual, haga clic en Cambiar.
  4. En la lista Unidad, seleccione una unidad de disco duro cuyo espacio sea 1,5 veces superior a la cantidad de memoria RAM instalada en el ordenador. Por ejemplo, si el ordenador tiene 2 GB de RAM, seleccione una unidad de disco duro que al menos disponga de 4 GB de espacio libre.
  5. En el área Tamaño del archivo de paginación para la unidad seleccionada, seleccione Tamaño personalizado y, en el cuadro Tamaño inicial, escriba un valor que duplique la cantidad de memoria RAM instalada en el ordenador.
  6. En el cuadro Tamaño máximo, escriba un valor que cuadruplique la cantidad de memoria RAM instalada en el ordenador.
  7. Haga clic en Establecer y después en Aceptar.  
  8. Haga clic para cerrar el applet del Panel de control de Sistema.
  9. En el cuadro de diálogo Cambio de configuración del sistema, haga clic en Sí para reiniciar Windows.

Para cambiar la memoria virtual en Windows 7 y Vista, cierre todas las aplicaciones y, a continuación, haga lo siguiente:

  1. Seleccione Inicio > Panel de control y haga doble clic en Sistema.
  2. Seleccione la Configuración avanzada del sistema de la lista Tareas.
  3. Seleccione la ficha Opciones avanzadas del área Rendimiento.
  4. Seleccione la ficha Opciones avanzadas y haga clic en Cambiar.
  5. Anule la selección de Administrar automáticamente el tamaño del archivo de paginación para todas las unidades.
  6. Haga clic en cada letra de disco duro para que se muestre el espacio disponible correspondiente a esa unidad. Seleccione una unidad de disco duro cuya capacidad triplique la cantidad de memoria RAM instalada en el ordenador y que no contenga un disco de memoria virtual.
  7. Seleccione Tamaño personalizado y escriba en el cuadro Tamaño inicial la cantidad de memoria RAM física con que cuente, más 300 MB. Escriba en el cuadro Tamaño máximo el triple de la cantidad de memoria RAM instalada en el ordenador. 
  8. Haga clic en Establecer y luego en Aceptar. Siga haciendo clic en Aceptar y salga de todos los cuadros de diálogo.
  9. Reinicie el ordenador. Si tiene alguna aplicación abierta, seleccione Reiniciar más adelante, cierre las aplicaciones y seguidamente, reinicie Windows. De lo contrario, haga clic en Reiniciar ahora.

Para cambiar la memoria virtual en Windows 8, cierre todas las aplicaciones y, a continuación, haga lo siguiente:

  1. Haga clic en Inicio > Paneles de control. Si no hay botón de inicio, seleccione el icono de carpetas y busque el panel de control en el equipo.
  2. Seleccione Sistema y seguridad > Sistema.
  3. Siga los pasos para Windows 7 y Vista especificados anteriormente desde el paso 3.

Para obtener más información, consulte estos temas de ayuda de Microsoft:

  • (Windows XP) "Para cambiar el tamaño del archivo de paginación de la memoria virtual"
  • (Windows Vista, Windows 7 y Windows 8) “Cambiar el tamaño de la memoria virtual”

Consulte también el extracto sobre memoria virtual de Real World Photoshop CS5 for Photographers (Peachpit Press), de Conrad Chavez.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea