Certificatul pachetului Mac a expirat

Certificatul utilizat pentru a semna pachetele de instalare sau actualizare Acrobat sau Reader pentru Mac a expirat pe 21 februarie 2017. Din cauza acestui certificat expirat, macOS a început să semnalizeze multe dintre corecțiile și utilitarele de instalare Acrobat sau Reader drept nesemnate sau expirate.

Următoarele corecții și utilitare de instalare complete sunt afectate:

  • Pachete Acrobat DC Continuous anterioare 15.016.20041
  • Pachete Acrobat Reader DC Continuous anterioare 15.016.20039
  • Pachete Acrobat DC 2015 anterioare 15.006.30173
  • Pachete Acrobat Reader DC 2015 anterioare 15.006.30172
  • Pachete Acrobat și Reader XI anterioare 11.0.17

Dacă încercați să instalați vreunul din pachetele afectate, va apărea următorul mesaj de avertizare:

Certificat expirat pentru pachetul de instalare

Dacă încercați să instalați aceste pachete folosind linia de comandă, sistemul de operare Mac blochează instalarea, care nu reușește.

Soluție: descărcați cea mai recentă versiune sau corecție

Utilitare de instalare complete

Cele mai recente utilitare de instalare complete nu sunt afectate de această problemă. Dacă aveți un pachet complet de instalare Acrobat/Reader care afișează o avertizare, descărcați cea mai recentă versiune.

Pachetele de instalare din această locație au fost reîmprospătate și nu ar trebui să aveți probleme la instalarea din cele mai recente pachete. 

Corecții

Cele mai recente corecții pentru toate pistele nu au această problemă. Adobe vă recomandă să instalați cele mai recente actualizări:

Rețineți că, pentru toate aceste pachete, nu veți vedea nicio avertizare și ele pot fi instalate fără probleme. Dar, dacă preluați în mod explicit lanțul de certificate utilizat pentru a semna pachetul, făcând clic pe pictograma „lacăt”, acesta va arăta că certificatul a expirat, după cum se arată aici:

Mesaj de eroare pentru certificat expirat

Cu toate acestea, semnătura pachetului este validă, iar sistemul de operare nu blochează instalarea în niciun fel, lucru pe care-l puteți verifica folosind comanda pkgutil:

pkgutil --check-signature <calea la fișierul pkg>

Este arătat mai jos un exemplu de ieșire la terminal pentru pachetul 11.0.19 Acrobat, enunțând că pachetul este semnat de un certificat autorizat de sistemul de operare: 

Comanda pkgutil

Această lucrare este oferită sub licență Atribuire-Necomercial-FărăModificări 3.0 Ne-adaptată Creative Commons  Postările pe Twitter™ şi Facebook nu sunt acoperite de condiţiile de licenţiere Creative Commons.

Prevederi legale   |   Politică de confidențialitate online