影像或文件最佳化之後,便可以匯出 (或儲存,視原始檔類型而定)。

您可以使用 GIF、JPEG 或其他圖像檔案格式,將文件匯出 (或儲存) 為單一影像。您也可以將整份文件匯出為 HTML 檔案,以及將選取的分割或指定的區域匯出為關聯的影像檔案。除此之外,您還可以將 Fireworks 的狀態和圖層以個別影像檔案匯出。

以下是決定 Fireworks 匯出檔案預設位置的因素 (依影響性排列):

  1. 文件的目前匯出偏好設定 (這是之前匯出文件並儲存成 PNG 時定義的)

  2. 目前匯出/儲存位置 (亦即離開「儲存檔案」、「另存新檔」或「匯出」對話方塊中的預設位置後到達的位置)

  3. 目前檔案的位置

  4. 新文件或影像儲存在作業系統中的預設位置

    相對的,Fireworks 儲存文件的預設位置取決於不同的條件組合。如需詳細資訊,請參閱「儲存 Fireworks 檔案」。

匯出頁面為影像檔案

  1. 選取「檔案 > 匯出」。

  2. 為匯出的檔案選擇匯出位置。

  3. 請執行下列步驟之一:

    • 從「匯出」彈出式選單選取「只有影像」,並選取或取消選取「只有目前頁面」核取方塊。頁面會匯出為「最佳化」面板上設定的影像格式。

    • 選取「匯出」彈出式選單中的「頁面至檔案」,並選取「匯出為」彈出式選單中的「影像」。頁面會匯出為「最佳化」面板上設定的影像格式

    • 選取「匯出」彈出式選單中的「頁面至檔案」,並選取「匯出為」彈出式選單中的「Fireworks PNG」。每個頁面都會匯出為能與舊版的 Fireworks 8 相容的個別 PNG 檔案。

    註解:

    如果您要以選取格式匯出所有頁面,請選取所有頁面,然後最佳化設定。

匯出單一影像

如果是在處理從 Fireworks 開啟的現有影像,即可將之儲存而不需要匯出。如需詳細資訊,請參閱「以其他格式儲存文件」。

註解:

若只要匯出文件中的特定影像,您必須先分割文件,然後只匯出您要的分割。

  1. 在「最佳化」面板中,選取檔案格式並設定格式專屬的選項。

  2. 選取「檔案 > 匯出」。

  3. 選取匯出影像檔案的目標位置。

    一般而言,網頁圖像的最佳位置就是在您的本機網站內的資料夾。

  4. 輸入沒有副檔名的檔案名稱。匯出時會依據檔案類型增加副檔名。

  5. 從「匯出」彈出式選單中,選取「只有影像」。

  6. 按一下「儲存檔案」。

匯出分割的文件

依照預設,當您匯出分割的 Fireworks 文件時,會匯出 HTML 檔案和相關的影像。匯出的 HTML 檔案可以在瀏覽器中加以檢視,或是匯入至其他應用程式進一步進行編輯。

匯出前,請確定您在「HTML 設定」對話方塊中選取適當的 HTML 樣式。請參閱「設定 HTML 匯出選項」。

匯出所有分割

  1. 選取「檔案 > 匯出」。

  2. 瀏覽到硬碟上您要匯出到的資料夾。

  3. 從「匯出」彈出式選單中,選取「HTML 和影像」。

  4. 在「檔案名稱」方塊 (Windows) 或「另存新檔」(Mac OS) 方塊中輸入檔名。

  5. 從「HTML」彈出式選單中,選取「匯出 HTML 檔案」。

  6. 從「分割」彈出式選單中,選取「匯出分割」。

  7. (選擇性) 選取「將影像放入子資料夾」。

  8. 按一下「儲存檔案」。

匯出選取的分割

  1. 按住 Shift 並按一下以選取多個分割。

  2. 選取「檔案 > 匯出」。

  3. 選取要儲存匯出檔案的位置,例如本機網站內的資料夾。

  4. 從「匯出」彈出式選單中,選取「HTML 和影像」。

  5. 輸入沒有副檔名的檔案名稱。匯出時會依據檔案類型增加副檔名。

    如果您要匯出多個分割,Fireworks 會使用您輸入的名稱做為所有匯出圖像的基本名稱,但不包括已經使用「圖層」面板或「屬性」檢視窗自訂名稱的圖像。

  6. 從「分割」彈出式選單中,選取「匯出分割」。

  7. 若要只匯出您在匯出前選取的分割,請選擇「只有選取的分割」並確認沒有選取「包含不含分割的區域」選項。

  8. 按一下「儲存檔案」。

更新分割

如果您已經匯出分割的文件,之後又更改了 Fireworks 中的原始文件,那麼您可以只更新更改的影像或分割。為了能輕易找出取代的分割,請自行為分割命名。

  1. 隱藏分割並編輯下方的區域。

  2. 再次顯示分割。

  3. 以滑鼠右鍵按一下 (Windows) 或按住 Control 並按一下 (Mac OS) 分割,然後選取「匯出選取的分割」。

  4. 選取與使用相同基本名稱的原始分割相同的資料夾,然後按一下「儲存檔案」。

  5. 當系統詢問您是否要取代現有檔案時,請按一下「確定」。

    註解:

    請避免將分割的大小調整為大於 Fireworks 中其原始的匯出大小,否則在分割更新時,便會在 HTML 文件中產生無法預期的效果。

匯出動畫

在您建立和最佳化動畫之後,就可以開始匯出。您可以將動畫匯出為下列任何檔案類型:

GIF 動畫

這些動畫提供剪輯圖案及卡通式圖像的最佳效果。

Flash SWF 或 Fireworks PNG (不需要匯出)

將動畫匯出為 SWF 檔案,以匯入至 Flash。或者您可以略過匯出步驟,將 Fireworks PNG 來源檔案直接匯入至 Flash。利用這種直接的方法,您可以匯入動畫的所有圖層和狀態,然後在 Flash 中進一步編輯。請參閱「與 Flash 搭配使用」。

多個檔案

當相同物件在不同圖層中有多個元件時,匯出動畫狀態或圖層為多個檔案就非常有用。例如,如果圖像中公司名稱的每個字母都以動畫處理,就可以將這個橫幅廣告匯出為多個檔案。請參閱「匯出狀態或圖層為多個檔案」。

如果您的文件包含不只一個動畫,您可以插入分割以使用不同的動畫設定 (例如重複和狀態延遲) 匯出每個動畫。

匯出 GIF 動畫

  1. 選擇「選取 > 取消選取」以取消選取所有的分割和物件,並在「最佳化」面板中選取「GIF 動畫」作為檔案格式。

  2. 選取「檔案 > 匯出」。

  3. 輸入檔案的名稱並選取目標。

  4. 按一下「儲存檔案」。

使用不同動畫設定匯出多個 GIF 動畫

  1. 按住 Shift 並按一下這些動畫,將它們全部選取。

  2. 選取「編輯 > 插入 > 矩型分割」或「多邊形分割」。

  3. 在訊息方塊中,按一下「多重」。

  4. 個別選取每個分割,然後使用「狀態」面板替每個分割設定不同的動畫設定。

  5. 選取要使之成為動畫的所有分割,然後在「最佳化」面板中選取「GIF 動畫」做為檔案格式。

  6. 以滑鼠右鍵按一下 (Windows) 或按住 Control 並按一下 (Mac OS) 每個分割,然後選取「匯出選取的分割」個別匯出每個分割。在「匯出」對話方塊中,輸入每個檔案的名稱,選取目標,並按一下「儲存」。

匯出狀態或圖層為多個檔案

Fireworks 可以將文件中的每個圖層或狀態匯出為個別的影像檔案,而且使用「最佳化」面板中指定的最佳化設定。圖層或狀態的名稱決定了每個匯出檔案的檔案名稱。這個匯出方法有時也用來匯出動畫。

  1. 選取「檔案 > 匯出」。

  2. 輸入檔名並選取目標資料夾。

  3. 在「匯出」彈出式選單中,選取一個選項:

    狀態至檔案

    會將狀態匯出為多個檔案。

    圖層至檔案

    會將圖層匯出為多個檔案。

    注意: 此操作會匯出目前狀態上的所有圖層

  4. 若要自動裁切每個匯出的影像,以只包含每個狀態上的物件,請選取「修剪影像」。若要包含整個畫布 (包括物件以外的空白區域),請取消選取這個選項。

  5. 按一下「儲存檔案」。

匯出文件的某個區域

  1. 從「工具」面板選取「匯出區域」工具

  2. 拖曳定義要匯出的文件部分的圈選區域。

    註解:

    您可以在拖曳時調整圈選區域的位置。在按住滑鼠按鈕的同時,按住鍵盤上的空格鍵,就可以將圈選範圍拖曳至畫布上的另一個位置。放開空格鍵,便可繼續繪製圈選區域。

    放開滑鼠按鈕後,匯出區域會保持選取狀態。

  3. 必要的話,請調整匯出區域:

    • 若要依比例調整匯出區域的圈選區域大小,請按住 Shift 並拖曳控點。

    • 若要從中心調整圈選區域的大小,請按住 Alt (Windows) 或 Option (Mac OS) 並拖曳控點。

    • 若要強制等比例並從中心調整大小,請按住 Alt 和 Shift (Windows) 或 Option 和 Shift (Mac OS) 並拖曳控點。

  4. 在匯出區域的圈選區域內 按兩下以移至「影像預覽」。

  5. 調整「影像預覽」中的設定,並按一下「匯出」。

  6. 輸入檔名並選取目標資料夾。

  7. 在「匯出」彈出式選單中,選取「只有影像」。

  8. 按一下「儲存檔案」。

    註解:

    若要取消而不匯出,請在匯出圈選區域外按兩下、按 Esc,或是選取另一個 工具。

匯出 HTML

除非另有指定,否則當您匯出分割的 Fireworks 文件時,實際匯出的會是 HTML 檔案及其影像。若要定義 Fireworks 匯出 HTML 的方式,可以使用「HTML 設定」對話方塊。

Fireworks 產生多數網頁瀏覽器和 HTML 編輯器可讀取的純粹 HTML。依照預設,匯出會指定 UTF-8 編碼。

匯出 Fireworks HTML 的方式有很多種:

  • 匯出 HTML 檔案,稍後在 HTML 編輯器中開啟,進行編輯。

  • 將 Fireworks 檔案中的每個頁面分別匯出到不同的 HTML 檔案。

  • 複製 HTML 程式碼到 Fireworks 中的剪貼簿,然後將該程式碼直接貼入現有的 HTML 文件中。

  • 匯出 HTML 檔案,在 HTML 編輯器中開啟它,從檔案中手動複製程式碼的部分,然後將該程式碼貼入另一個 HTML 文件。

  • 將 HTML 匯出為「階層式樣式表」(CSS) 圖層和 XHTML。

  • 使用「更新 HTML」命令來更改您之前建立的 HTML 檔案。

    Fireworks 讓您能使用 Generic、Dreamweaver、Microsoft® FrontPage® 和 Adobe GoLive® 等格式匯出 HTML。

    注意: Adobe Dreamweaver 與 Fireworks 緊密地整合在一起。Fireworks 控制匯出 HTML 到 Dreamweaver 中的方式,與控制匯出到 HTML 編輯器中的方式不同。如果您要將 Fireworks HTML 匯出到 Dreamweaver,請參閱「與 Dreamweaver 搭配使用」。

    將 Fireworks HTML 放入其他應用程式的匯出方法最適合於團體環境工作時使用。這個方法會將工作流程分段,所以某個人於某種應用程式中執行工作,另一個人可以在稍後使用另一種應用程式接手。

在匯出的 HTML 中包含註解

Fireworks HTML 註解的開頭是 <!-- ,結尾則是 --> 。在這兩個標記間的內容不會解譯為 HTML 或 JavaScript 程式碼。

  1. 在匯出之前,請選取「HTML 設定」對話方塊「一般」索引標籤上的「包含 HTML 註解」選項。

匯出的結果

當您從 Fireworks 匯出或複製 HTML 時,將會產生下列內容:

  • 當文件包含互動元素時,重組分割影像和任何 JavaScript 程式碼的必要 HTML 程式碼。Fireworks HTML 包含到匯出影像的連結並且將網頁背景顏色設定為畫布顏色。

  • 一個或多個影像檔案,視文件的分割數目和按鈕的狀態數目而定。

  • 必要的話,會出現名為 spacer.gif 的檔案。Spacer.gif 是透明、1x1 像素的 GIF,是 Fireworks 用來修正當您於 HTML 表格中重組分割影像時產生的間距問題。您可以選擇 Fireworks 是否要匯出間距。

  • 如果您匯出任何彈出式選單,則會匯出下列檔案:mm_css_menu.js,以及含有 CSS 彈出式選單程式碼的 .css 檔案。如果您的彈出式選單包含子選單,也會同時匯出 arrows.gif 檔。

  • 如果您匯出或複製 HTML 到 Dreamweaver,會建立備註檔案以協助 Fireworks 和 Dreamweaver 整合。這些檔案的副檔名為 .mno。

匯出 Fireworks HTML

  1. 選取「檔案 > 匯出」。

  2. 瀏覽到硬碟上您要匯出到的資料夾。

  3. 從「匯出」彈出式選單中,選取「HTML 和影像」。

  4. 按一下「選項」按鈕,並從「HTML 設定」對話方塊「一般」索引標籤上的「HTML 樣式」彈出式選單中,選取您的 HTML 編輯器。如果沒有列出您的 HTML 編輯器,請選取「一般」。

    註解:

    選取您的 HTML 編輯器做為 HTML 樣式是很重要的,這樣互動式的元件如按鈕和變換影像功能就可以在匯入您的 HTML 編輯器時正確運作。

  5. 按一下「確定」。

  6. 從「HTML」彈出式選單中,選取「匯出 HTML 檔案」。

  7. 如果文件包含分割,請從「分割」彈出式選單中選取「匯出分割」。

  8. 若要將影像儲存在個別的資料夾,請選取「將影像放入子資料夾」。您可以選取特定的資料夾或使用 Fireworks 預設的 Images 資料夾。

  9. 如果您要匯出多重頁面的 Fireworks 文件,請取消選取「只有目前頁面」核取方塊,即可將所有頁面匯出到不同的 HTML 文件。

  10. 按一下「儲存檔案」。

    匯出後,您就會在硬碟上看到 Fireworks 匯出的檔案。影像和 HTML 檔案會在「匯出」對話方塊所指定的位置產生。

複製 HTML 程式碼到剪貼簿

複製 HTML 程式碼到 Fireworks 中的剪貼簿有兩種方式。使用「複製 HTML 程式碼」命令,或在「匯出」對話方塊中選取「複製至剪貼簿」做為選項。稍後您可以在想要的 HTML 編輯器中將這個 HTML 貼入文件中。

在決定如何將 Fireworks HTML 放入其他應用程式時,請考慮複製 HTML 程式碼到剪貼簿的下列缺點:

  • 不能將影像儲存到子資料夾。這些影像必須留在複製的 HTML 檔案所在的相同資料夾,只有將 HTML 複製到 Dreamweaver 時不受這個限制。

  • Fireworks 彈出式選單中使用的任何連結或路徑都會對應到您的硬碟,只有複製到 Dreamweaver 的 HTML 是例外。

  • 如果您使用 Dreamweaver 或 Microsoft FrontPage 以外的 HTML 編輯器,與按鈕、行為和變換影像關聯的 JavaScript 程式碼都會複製,但可能無法正常運作。

    如果遇到這樣的問題,請不要將 HTML 複製到剪貼簿,而改用「匯出 HTML 檔案」選項。

    注意: 在您複製 HTML 程式碼前,請確定您已經從「HTML 設定」對話方塊中的「一般」索引標籤選取了適當的 HTML 樣式且選擇「包含 HTML 註解」

使用「複製 HTML 程式碼」選項複製 Fireworks HTML

  1. 選取「編輯 > 複製 HTML 程式碼」。

  2. 依照精靈的指示。當提示出現時,請指定資料夾做為匯出影像的目標。這個資料夾必須是您的 HTML 檔案所在的位置。

    註解:

    如果您想要將 HTML 程式碼貼入 Dreamweaver,要在哪裡匯出影像並不重要,只要它們位於與您將要貼入程式碼之 HTML 檔案相同的 Dreamweaver 網站即可。

使用「匯出」對話方塊複製 Fireworks HTML

  1. 選取「檔案 > 匯出」。

  2. 在「匯出」對話方塊中指定要做為匯出影像目標的資料夾。這個資料夾必須是您的 HTML 檔案所在的位置。

    註解:

    如果您想要將 HTML 程式碼貼入 Dreamweaver,要在哪裡匯出影像並不重要,只要它們位於與您將要貼入程式碼之 HTML 檔案相同的 Dreamweaver 網站即可。

  3. 從「匯出」彈出式選單中,選取「HTML 和影像」。

  4. 從「HTML」彈出式選單中,選取「複製至剪貼簿」。

  5. 如果文件包含分割,請從「分割」彈出式選單中選取「匯出分割」。

  6. 按一下「選項」按鈕,從「HTML 設定」對話方塊中選取您的 HTML 編輯器,並按一下「確定」。

  7. 按一下「儲存檔案」。

將從 Fireworks 複製的 HTML 貼入 HTML 文件

  1. 在您的 HTML 編輯器中開啟現有的 HTML 文件或建立新文件。將這個文件儲存在與您匯出影像的相同位置。

    註解:

    如果您使用的是 Dreamweaver,就不一定要將 HTML 儲存在與您匯出影像的相同位置。只要您從 Fireworks 匯出影像到 Dreamweaver 網站,並將這個 HTML 檔案儲存到該網站內的某個位置,Dreamweaver 就會找出到關聯影像的路徑。

  2. 檢視 HTML 程式碼,並將插入點放置在介於 <BODY> 標記之間的位置。

    註解:

    從 Fireworks 複製的 HTML 程式碼不會包含開頭或結尾的 <HTML> <BODY> 標記。

  3. 貼上 HTML 程式碼。

    可能的話,在您複製到剪貼簿時,請將這些影像匯出到它們最終會駐留在網站上的位置。Fireworks 使用文件關聯式的 URL,因此如果 HTML 或影像移動,URL 連結就會中斷。

從匯出的 Fireworks 檔案複製程式碼並貼入另一個 HTML 文件

  1. 開啟您在 HTML 編輯器中匯出的 Fireworks HTML 檔案。

  2. 反白標示必要的程式碼並將其複製到剪貼簿。

  3. 開啟現有的 HTML 文件或建立新的文件。

  4. 將程式碼貼入新的 HTML 檔案。您不需要複製 <HTML> <BODY> 標記,因為目標 HTML 文件中應該已經包含這些標記。

    如果您已經在 Fireworks 中的「HTML 設定」對話方塊中選擇了「包含 HTML 註解」,請依照註解中的指示複製並貼入程式碼到適當的位置。

  5. 如果您的 Fireworks 文件中包含互動元素,請複製 JavaScript 程式碼。

    JavaScript 程式碼由 <SCRIPT> 標記所包圍,並位於文件的 <HEAD> 區段中。除非您的目標文件已經有 <SCRIPT> 區段,請複製並貼上整個 <SCRIPT> 區段。在此情況下,您應該只將 <SCRIPT> 區段的內容複製並貼上到現有的 <SCRIPT> 區段,但注意不要覆寫現有區段中的內容。也請確認在您貼上程式碼後, <SCRIPT> 區段中沒有包含重複的 JavaScript 函數。

更新匯出的 HTML

更新可以讓您更改先前匯出的 Fireworks HTML 文件,並且在您只想要更新文件的某一部分時非常有用。

註解:

「更新 HTML」在 Dreamweaver 文件中的作用與在其他 HTML 文件中的作用不同。如需詳細資訊,請參閱「與 Dreamweaver 搭配使用」。

更新 時,您可以選擇只取代更改的影像或覆寫所有程式碼和影像。如果您選擇只取代更改的影像,那麼您在 Fireworks 外對 HTML 檔案所做的更改都會保留。

註解:

若要對文件配置做大幅的更改,請在 Fireworks 中進行更改並重新匯出這個 HTML 檔案。

  1. 選取「檔案 > 更新 HTML」。

  2. 選取要更新的檔案。

  3. 按一下「開啟」。

  4. 請執行下列步驟之一:

    • 如果找不到 Fireworks 產生的 HTML,請按一下「確定」,在文件結尾插入新的 HTML。

    • 如果找到由 Fireworks 產生的 HTML,請選取下列一項並按一下「確定」:

      更新影像和 HTML

      會取代之前的 Fireworks HTML

      只更新影像

      只會覆寫影像

  5. 如果出現「選取影像資料夾」對話方塊,請選取資料夾並按一下「開啟」。

匯出 CSS 圖層

CSS 圖層能夠互相上下重疊。在 Fireworks 中,一般的 HTML 輸出是無法重疊的。

  1. 選取「檔案 > 匯出」。

  2. 輸入檔名並選取目標資料夾。

  3. 從「匯出」彈出式選單中,選取「CSS 和影像」。

    • 若要僅匯出目前狀態,請選取「僅目前狀態」。

    • 若要僅匯出目前頁面,請選取「僅目前頁面」。

    • 若要選擇影像的資料夾,請選取「將影像放入子資料夾」。

  4. 按一下「選項」以設定 HTML 頁面屬性。

  5. 按一下「瀏覽」以指定背景影像並設定背景影像的拼貼方式:

    • 選取「無重複」,僅顯示一次影像。

    • 選取「重複」,以水平和垂直排列方式重複 (並排) 顯示背景影像。

    • 選取「水平重複」,以水平排列方式顯示影像。

    • 選取「垂直重複」選項,以垂直排列方式顯示影像。

  6. 選取頁面在瀏覽器上的對齊方式:靠左、置中或靠右。

  7. 按一下「確定」,然後按一下「儲存」。

匯出 XHTML

XHTML 就是 HTML (目前格式化和顯示網頁的標準) 和 XML (延伸式標記語言) 的組合。XHTML 為向下相容 (也就是說,目前大多的網頁瀏覽器都可以檢視 XHTML),而且它也可以用任何可以顯示 XML 內容的裝置讀取,例如 PDA、行動電話和其他掌上裝置等。

Fireworks 也可以匯出 XHTML。請參閱「從 HTML 檔案建立 Fireworks PNG 檔案」。

如需有關 XHTML 的詳細資訊,請參閱「全球資訊網協會」(W3C) 的 XHTML 規格,網址為 www.w3.org

  1. 選取「檔案 > HTML 設定」,從「一般」索引標籤上的「HTML 樣式」彈出式選單中選取「XHTML」樣式,然後按一下「確定」。

  2. 使用任何可以匯出或複製 HTML 的方法來匯出您的文件。請參閱「匯出 HTML」。

    註解:

    Fireworks 在匯出為 XHTML 時使用 UTF-8 編碼。

使用和不使用 UTF-8 編碼匯出檔案

UTF-8 (代表 Universal Character Set Transformation Format-8) 是文字編碼的方式,用以讓網頁瀏覽器在相同 HTML 網頁上顯示不同的字元集 (例如,中文文字和英文文字)。依預設值會開啟 UTF-8 編碼。

Fireworks 也可以匯入使用 UTF-8 編碼的文件。請參閱「從 HTML 檔案建立 Fireworks PNG 檔案」。

不使用 UTF-8 編碼匯出文件

  1. 選取「檔案 > HTML 設定」。

  2. 在「文件描述」索引標籤上,清除「UTF-8 編碼」核取方塊並按一下「確定」。

  3. 使用任何可以匯出或複製 HTML 的方法來匯出文件。

設定 HTML 匯出選項

「HTML 設定」對話方塊可用來定義 Fireworks 匯出 HTML 的方式。在「文件描述」索引標籤中所做的修改只會影響目前的文件。「一般」和「表格」設定是整體的偏好設定,並會影響所有的新文件。

  1. 請執行下列步驟之一:

    • 選取「檔案 > HTML 設定」。

    • 按一下「匯出」對話方塊中的「選項」按鈕。

  2. 在「一般」索引標籤中,選取您所偏好的選項。

    HTML 樣式

    選取匯出 HTML 的樣式。

    任何 HTML 編輯器都可以使用 Generic HTML。然而,如果您的文件中包含行為或其他互動式內容,請選取您的特定編輯器 (如果出現在清單上)。

    若要使用 XHTML 標準來匯出文件,請從彈出式選單中選取適當的 XHTML 樣式。

    副檔名

    從彈出式選單選取檔案副檔名,或輸入新的副檔名。

    包含 HTML 註解

    選取此項,以包含有關在 HTML 中的哪個位置複製和貼上的註解。如果您的文件包含互動的元素,如按鈕、行為或變換影像,建議使用這個選項。

    小寫檔案名稱

    選取此項,讓 HTML 檔案和關聯影像檔案的名稱在匯出時成為小寫。

    注意: 如果在「副檔名」彈出式選單中已經選取大寫副檔名,這個選項並不會將 HTML 檔案的副檔名變成小寫

    彈出式選單使用 CSS

    選取此項,以對彈出式選單程式碼使用 CSS 而非 JavaScript。您可以使用 Dreamweaver 對選單編製索引,以及更新程式碼內的連結。

    將 CSS 寫入外部檔案

    選取此項,以將 CSS 程式碼寫入外部 .css 檔案 (該檔匯出至與 HTML 檔案相同的位置)。.css 檔案的名稱必須符合 HTML 檔案的名稱 (檔案副檔名除外)。選擇這個選項也會對與 HTML 檔案相同的位置,匯出名為 mm_css_menu.js 的檔案。

    注意: 只有在選擇「彈出式選單使用 CSS」選項時,才能使用這個選項

    檔案建立器 (Mac OS)

    從彈出式選單中選取相關的應用程式。當您按兩下硬碟上的匯出 HTML 檔案時,它會自動在選取的應用程式中開啟。

  3. 在「表格」索引標籤中,選取 HTML 表格的設定。如需詳細資訊,請參閱「定義 HTML 表格匯出的方式」。

  4. 在「文件描述」索引標籤中,從下列選項中選取:

    分割檔案名稱

    在彈出式選單中選取自動命名分割的公式。您可以使用預設設定或自行選擇選項。

    注意: 如果您為任何前三個選單選取「無」,Fireworks 會匯出彼此覆寫的分割檔,因此所得到的結果是單一的匯出圖像,以及一個會在每個儲存格中顯示此圖像的表格。

    預設 Alt 標籤

    輸入從網頁下載影像或影像下載失敗時,要出現在影像所在位置的文字。在某些瀏覽器中,當指標經過影像上方時,替代文字會顯示為工具提示。這對有視覺障礙的網頁使用者而言,也是一項輔助功能。

    匯出多重導覽列 HTML 頁面 (在無影格組時使用)

    在匯出將數個網頁連結在一起的導覽列時,請選取此項。Fireworks 會匯出導覽列中每個按鈕代表的其他網頁。

    包含沒有分割物件的區域

    選取以包含分割未涵蓋的畫布區域。

    UTF-8 編碼

    依預設值會開啟。讓您的匯出文件能顯示多個字元集的字元。若要關閉這個選項,請取消選取核取方塊。

  5. 若要將這些設定儲存為整體的預設設定,請按一下「設為預設值」.

匯出 Adobe PDF 檔案

當您要列印 Fireworks 設計或送給人檢閱時,請匯出至 Adobe PDF。檢閱者可以在 Adobe Reader® 或 Adobe Reader® 中新增註解以及對其他人註解的回應。如需有關設定 PDF 檢閱的詳細資訊,請參閱 Acrobat 說明。

匯出的 PDF 檔案會保留所有頁面和超文字連結,讓檢閱者在瀏覽時就像在瀏覽網頁一樣。不過和 HTML 原型不同的是,Adobe PDF 提供的安全設定會防止檢閱者編輯或複製您的設計。

  1. 選取「檔案 > 匯出」。

  2. 從「匯出」彈出式選單中,選擇「Adobe PDF」。

  3. 選擇要匯出的頁面,然後選取「匯出後檢視 PDF」以自動在 Adobe Reader 或 Acrobat 中開啟 PDF。

  4. 若要自訂 PDF,請按一下「選項」,然後調整下列設定:

    「相容性」

    決定哪些 Adobe PDF 應用程式可以開啟匯出的檔案。

    壓縮

    會決定影像壓縮的類型,縮小檔案大小。在一般情況下, JPEG 和 JPEG2000 壓縮比較適用於包含色彩漸變的影像,例如相片。如果是具有大範圍純色、單色的圖片,ZIP 是較佳的選擇。

    品質

    提供 JPEG 或 JPEG2000 壓縮的影像品質設定。選取「高」品質會產生良好影像品質的大型檔案大小。

    轉換為灰階

    將所有影像轉換成灰階,縮小檔案大小。

    啟動文字選擇

    讓檢閱者從匯出的檔案中複製文字。取消選取這個選項會大幅降低檔案大小。

    出血值

    會決定影像在每個頁面上的空白邊框像素寬度。例如,值 20 會以 20 個像素的邊框圍住每個影像。

    使用密碼開啟文件

    必須使用「開啟密碼」才能開啟匯出的檔案。

    使用密碼限制工作

    必須使用「保護密碼」才能執行這些選取的功能:列印、編輯、複製和注釋。

  5. 請按一下「確定」關閉「選項」對話方塊。

  6. 請指定檔名和位置,然後按一下「儲存」。

    註解:

    如果 Fireworks 文件中的頁面有透明畫布,則套用任何透明度的物件會在您匯出至 PDF 時失去透明特性。若要避免這種情況,請在匯出至 PDF 之前,將畫布設定為非透明背景。

影片

使用 Fireworks 將客戶證明建立為 PDF 或 HTML 檔案 (00:05:32)

瞭解如何使用 Fireworks 匯出選單來準備用於客戶核准或團隊審查的 PDF 或 HTML 文件。

Tom Green 編著

在 Adobe Acrobat 或 Adobe Reader中檢視匯出的 PDF檔案時,請使用以下設定:

  1. 在 Adobe Acrobat 或 Adobe Reader 中,選取「編輯 > 偏好設定」。

  2. 在面板左側選取「頁面顯示」。

  3. 將「自訂解析度」設定為 72 像素/英寸 (PPI)。

  4. 將「縮放」值設定為 100%。

匯出 FXG 檔案

FXG 是 Flash Catalyst、Fireworks、Illustrator 和 Photoshop 支援的檔案格式。使用 FXG 匯出將含有向量與點陣圖影像的檔案匯出時,會建立名為 <filename.assets> 的不同資料夾。資料夾包含與檔案相關的點陣圖影像。

如果您刪除資料夾中任何相關的檔案,匯入操作將會失敗。

註解:

FXG 中沒有一致對應標籤的元素、濾鏡、混合模式、漸層及遮色片會匯出為點陣圖圖像。

  1. 選取「檔案 > 匯出」,瀏覽至您要儲存檔案的位置。

  2. 輸入 FXG 檔案的檔案名稱。

  3. 在「匯出」對話框中,從「匯出」選單選取「FXG 和影像」。

  4. 按一下「儲存檔案」。

註解:

在 Flash Catalyst 中開啟匯出的 FXG 檔案時,擴充超出 Fireworks 中畫布的物件會完整地顯示。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策