本文為您提供 Adobe Flash Professional CS6 新功能的概觀。

支援 Adobe AIR 3.4 (僅限 Flash Professional CS6 Update 12.0.2)

透過 Flash Professional CS6 Update 12.0.2 的作用,Flash Professional 延伸支援 AIR 3.4 和 Flash Player 11.4。此外,這個更新還可讓 Flash Professional 運用 AIR 3.4 所公開的功能,加強 iOS 裝置的應用程式開發工作流程。

Toolkit for CreateJS 1.2

Toolkit for CreateJS 1.2 發行版本延伸支援將按鈕轉換為 HTML5。此外,更新還包括數個 JSX 相關錯誤的修正。其他如忽略多個空白關鍵影格等問題,也已在這個更新中獲得解決。

您可以從 Adobe Extension Manager CS6 下載並安裝 Toolkit for CreateJS 1.2。如需有關 Toolkit 的詳細資訊,請參閱使用 Flash Professional Toolkit for CreateJS

適用於 AIR 的行動裝置模擬

新的行動裝置內容模擬器可讓您模擬硬體按鍵、加速計、多點觸控和地理位置。

選擇適用於 AIR 遠端除錯的網路介面

當您將 AIR 應用程式發佈至 Android 或 iOS 裝置時,可以選擇要用於遠端除錯的網路介面。Flash Pro 會將選取網路介面的 IP 位址封裝至除錯模式行動裝置應用程式。然後,應用程式就會自動連接至主機 IP,以便在啟動目標行動裝置時啟動除錯工作階段。若要存取設定,請選擇「檔案 > 發佈設定」,然後選取「AIR 設定」對話方塊中的「部署」索引標籤。如需詳細資訊,請參閱封裝 AIR for iOS 的應用程式Adobe AIR for Desktop 的發佈功能文章。

 

Toolkit for CreateJS

Adobe Flash Professional Toolkit for CreateJS 是適用於 Flash Professional CS6 的擴充功能,可讓設計人員和動畫人員使用開放原始碼 CreateJS JavaScript 元件庫建立適用於 HTML5 專案的資源。此擴充功能支援 Flash Professional 中大多數的核心動畫和圖例功能,其中包括向量、點陣圖、傳統補間動畫、聲音、移動導引線、動畫遮色片和 JavaScript 時間軸指令碼。只要按一下,Toolkit for CreateJS 就會以可在瀏覽器中預覽的 JavaScript 形式匯出舞台和元件庫中的內容,協助您立即開始建置表達性 HTML5 內容。

Toolkit for CreateJS 是為了協助 Flash Pro 使用者轉換到 HTML5 而設計。它會使元件庫中的元件與「舞台」上的內容完全變成格式化的 JavaScript,讓可以使用 JavaScript 與 CreateJS API (ActionScript 3 使用者會感到熟悉) 增加互動性的開發人員容易瞭解、編輯並輕鬆地重複使用。此外,Toolkit for CreateJS 也會發佈簡單的 HTML 網頁,以供使用者快速預覽資源。如需詳細資訊,請參閱本文

匯出 Sprite 工作表

現在,在元件庫或「舞台」上選取元件就能匯出 Sprite 工作表。Sprite 工作表是一個圖像影像檔案,其中包含選取元件中使用的所有圖像元素。檔案中的元素是以並排格式排列。您也可以在選取元件庫中的元件時,包含元件庫中的點陣圖。若要建立 Sprite 工作表,請執行下列步驟:

  1. 選取元件庫或「舞台」上的元件。
  2. 以滑鼠右鍵按一下並選擇「匯出 Sprite 工作表」。

高效率 SWF 壓縮

對於以 Flash Player 11 或更新版本為目標的 SWF,有個新的壓縮演算法 LZMA 可供使用。新壓縮的效率比以往高達 40%,特別適用於包含許多 ActionScript 或向量圖形的檔案。

  1. 選擇「檔案 > 發佈設定」。
  2. 在對話方塊的「進階」區段中,選取「壓縮影片」選項並從選單中選擇 LZMA。

直接模式發佈

「直接」是新的可用視窗模式,可讓硬體加速內容使用 Stage3D (Stage3D 需要 Flash Player 11 或更新版本)。

  1. 選擇「檔案 > 發佈設定」。
  2. 選取「HTML 包裝函式」。
  3. 選取「視窗模式」選單中的「直接」。

如需詳細資訊,請參閱這篇文章

支援 AIR 外掛程式的直接顯示模式

這個功能為 AIR 應用程式帶來對 StageVideo/Stage3D 的 Flash Player「直接」模式顯示支援。新的 renderMode=direct 設定可以用在 AIR 應用程式的應用程式描述器檔案中。桌上型電腦版 AIR、AIR for iOS 和 AIR for Android 都可以設定「直接」模式。

透過 Wi-Fi 除錯 iOS

現在,您可以透過 Wi-Fi,在 iOS 上除錯 AIR 應用程式,其中包括中斷點、跳入和跳離、變數監控程式和追蹤。

如需有關除錯 AIR 應用程式的詳細資訊,請參閱 AIR Debug Launcher

支援 AIR 的固定執行階段

AIR 的「發佈設定」對話方塊現在具有可將 AIR 執行階段嵌入應用程式套件的選項
套件. 內嵌執行階段的應用程式可以在任何桌上型電腦、Android 或 iOS 裝置上執行,而不需安裝共享 AIR 執行階段。

Adobe 建議:

請檢視適用於行動裝置桌上型電腦之 Adobe AIR 固定執行階段支援的影片。

AIR 的原生擴充功能

您可以將原生擴充功能併入您在 Flash Pro 中開發的 AIR 應用程式。透過使用原生擴充功能,您的應用程式可以存取目標平台的所有功能,即使執行階段本身沒有內建對功能的支援亦然。

從 Flash Pro 中取得最新 Flash Player

現在,您可以從 Flash Pro 中的「說明」選單,直接前往 Adobe.com 的 Flash Player 下載頁面。

匯出 PNG 連續圖畫

使用者這個功能可以產生影像檔案,供 Flash Pro 或其他應用程式用來產生內容。例如,PNG 連續圖畫通常用在遊戲應用程式中。這個功能可讓您從元件庫項目匯出一連串的 PNG 檔案,或是匯出「舞台」上的個別影片片段、圖像元件和按鈕。

  1. 選取元件庫或「舞台」上的單一影片片段、按鈕或圖像元件。
  2. 以滑鼠右鍵按一下選項以顯示快顯選單。
  3. 選擇「匯出 PNG 連續圖畫」。
  4. 在系統的「儲存」對話方塊中,選擇輸出的位置。按一下「確定」。
  5. 在「匯出 PNG」對話方塊中設定您的選項。按一下「匯出」匯出 PNG 連續圖畫。

關鍵字:Flash CS6 的新功能、Flash Professional CS6 新功能、Flash CS6 新功能、Flash Professional CS6 的新功能

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策