Adobe Flash Player 的可用安全性更新

發佈日期: 2017 年 1 月 10 日

弱點識別碼: APSB17-02

優先順序: 請參閱下表

CVE 編號: CVE-2017-2925、CVE-2017-2926、CVE-2017-2927、CVE-2017-2928、CVE-2017-2930、CVE-2017-2931、CVE-2017-2932、CVE-2017-2933、CVE-2017-2934、CVE-2017-2935、CVE-2017-2936、CVE-2017-2937、CVE-2017-2938

平台: Windows、Macintosh、Linux 及 Chrome OS

摘要

Adobe 已發佈適用於 Windows、Macintosh、Linux 及 ChromeOS 的 Adobe Flash Player 安全性更新。這些更新可解決重大弱點,防止其可能允許攻擊者控制受的影響系統。

受影響的版本

產品 受影響的版本 平台
Adobe Flash Player 桌面執行階段 24.0.0.186 和舊版
Windows、Macintosh 和 Linux
適用於 Google Chrome 的 Adobe Flash Player 24.0.0.186 和舊版 Windows、Macintosh、Linux 及 Chrome OS
適用於 Microsoft Edge 和 Internet Explorer 11 的 Adobe Flash Player 24.0.0.186 和舊版 Windows 10 和 8.1
  • 若要確認您的系統所安裝的 Adobe Flash Player 版本,請進入關於 Flash Player 頁面,或是在 Flash Player 中執行的內容上按一下滑鼠右鍵,然後從選單選擇「關於 Adobe (或 Macromedia) Flash Player」。如果您使用多種瀏覽器,請對安裝在系統中的每個瀏覽器均進行檢查。

解決方法

Adobe 依照下列優先順序分級將這些更新分類,並建議使用者將其安裝更新至最新版本:
產品 更新版本 平台 優先順序分級 上市情況
Adobe Flash Player 桌面執行階段
24.0.0.194 Windows 與 Macintosh
1 Flash Player 下載中心
Flash Player 散發
適用於 Google Chrome 的 Adobe Flash Player 24.0.0.194 Windows、Macintosh、Linux 及 Chrome OS 1 Google Chrome 發行版本
Microsoft Edge 和 Internet Explorer 11 適用的 Adobe Flash Player 24.0.0.194 Windows 10 和 8.1 1 Microsoft 安全性公告
Linux 適用的 Adobe Flash Player 24.0.0.194 Linux 3 Flash Player 下載中心
  • Adobe 建議 Windows、Macintosh 和 Linux 的 Adobe Flash Player Desktop Runtime 使用者透過產品本身的更新機制 [1],或前往 Adobe Flash Player 下載中心,將產品更新至 24.0.0.194。
  • 與 Google Chrome 一同安裝的 Adobe Flash Player 將會自動更新為最新的 Google Chrome 版本,其中包含 Windows、Macintosh、Linux 及 Chrome OS 的 Adobe Flash Player 24.0.0.194。
  • 與 Microsoft Edge 及 Internet Explorer 11 一同安裝的 Adobe Flash Player (適用於 Windows 10 和 8.1) 將自動更新為最新版本,其中將包含 Adobe Flash Player 24.0.0.194。 
  • 請前往 Flash Player 說明頁面,取得安裝 Flash Player 的協助。

[1] Windows 專用 Flash Player 11.2.x 或更高版本使用者,或是 Macintosh 專用 Flash Player 11.3.x 或更高版本使用者,若有選取「允許 Adobe 安裝更新」選項,將會自動收到更新。並未啟用「允許 Adobe 安裝更新」選項的使用者,可在提示時透過產品內的更新機制安裝更新。

弱點詳細資料

  • 這些更新可解決可能導致資訊洩漏的略過安全性限制弱點 (CVE-2017-2938)。
  • 這些更新可解決可能導致程式碼執行的釋放後繼續使用 (use-after-free) 弱點 (CVE-2017-2932、CVE-2017-2936、CVE-2017-2937)。
  • 這些更新可解決可能導致程式碼執行的堆積緩衝區溢位弱點 (CVE-2017-2927、CVE-2017-2933、CVE-2017-2934、CVE-2017-2935)。
  • 這些更新可解決可能導致程式碼執行的記憶體損毀弱點 (CVE-2017-2925、CVE-2017-2926、CVE-2017-2928、CVE-2017-2930、CVE-2017-2931)。

鳴謝

Adobe 在此感謝以下個人和組織提報相關問題並與 Adobe 合作協助保護我們的客戶:
  • Microsoft Vulnerability Research 的 Nicolas Joly (CVE-2017-2936、CVE-2017-2937)
  • Google Project Zero 的 Mateusz Jurczyk and Natalie Silvanovich (CVE-2017-2931、CVE-2017-2932、CVE-2017-2933、CVE-2017-2934、CVE-2017-2935)
  • 與 Chromium Vulnerability Rewards Program 計劃合作的 Khalil Zhani (CVE-2017-2928)
  • Tencent PC Manager 的 willJ (CVE-2017-2925)
  • COSIG 的 Francis Provencher (CVE-2017-2930)
  • Google Project Zero 的 Jann Horn (CVE-2017-2938)
  • Fortinet 旗下 FortiGuard Labs 中與 Chromium Vulnerability Rewards Program 計劃合作的 Kai Lu (CVE-2017-2926、CVE-2017-2927)