Troubleshooting instructions to resolve issue with saving cloud documents in XD.

Issue

You may encounter the following issues or errors when working with Cloud Documents in Adobe XD:

  • Unable to create or save a cloud document, open a document that has been shared with you, or share a document with another user.
  • The home screen shows an empty list of recent documents, or a Something went wrong message appears.
  • A dialog with Cloud documents is not available or error code 50, 3623, or 3624 is displayed.

Root cause

Creative Cloud Sync requires an update or is not running correctly.

Solution

Update Creative Cloud Sync by following the steps:

Check for any pending updates

  1. Quit Adobe XD. 

  2. Open Adobe Creative Cloud desktop app.

    On Windows: 

    • Open your Start menu.
    • Click Adobe Creative Cloud to launch. 
    Launch Adobe Creative Cloud
    Launch Adobe Creative Cloud

    On macOS:

    • In Applications, go to Adobe Creative Cloud folder.

    • Launch Adobe Creative Cloud.
    Launch Adobe Creative Cloud in macOS
    Launch Adobe Creative Cloud in macOS
  3. Click Proceed to execute any pending updates.

    Click Proceed to execute pending updates
    Click Proceed to execute pending updates
  4. When update has completed, verify that Creative Cloud Sync version is 4.1.0.29 or later.

    • Go to Preferences > Creative Cloud > Files
    Click preferences in CC
    Click preferences in CC
    Click File in CC
    Click File in CC
    • If update was completed but version does not indicate the required version:

      1. Click the profile image and select Sign out.

      2. Click the three dots next to Profile image > Quit.

      3. Relaunch Adobe Creative Cloud application.

      4. Sign back in using your Adobe ID.

      5. Verify Creative Cloud Sync version.

  5. Verify that Adobe Creative Cloud preferences are enabled:

    1. Click the three dots next to profile image.

    2. Select Preferences.

    3. In General tab, ensure that you keep this option: Always keep Creative Cloud desktop up to date checked. 
    Keep CC app up to date
    Keep CC app up to date
  6. Relaunch XD or go to next step to update Creative Cloud. 

  7. Execute Creative Cloud Update.

    • Restart your machine and launch Adobe Creative Cloud desktop.

    • If update banner is still not available:
      • Click the three dots next to Profile image
      • Select Check for App Updates.
      • Wait for the update to complete.
    Check for app updates
    Check for app updates

Advanced troubleshooting

If you are still having issues and you have Administrator access to your machine, the following steps may address the issue:

  1. Sign out of the Creative Cloud within the apps preferences.

  2. Quit the Creative Cloud desktop app from the apps preferences.

  3. Using Activity Monitor (macOS) or Task Manager (Windows), ensure that the following two processes are closed: CoreSync and Adobe Desktop Service.

  4. Navigate to the following path:

    • On Windows:

      • C:\Program Files (x86)\Adobe\Adobe Sync

    • On macOS:

      • /Applications/Utilities/Adobe Sync

  5. Rename the following folder CoreSync to CoreSync-OLD.

  6. Restart your machine and follow above steps to update Adobe Creative Cloud desktop app.

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