User Guide Cancel

ColdFusion Builder workbench

  1. ColdFusion User Guide
  2. Introduction to ColdFusion
    1. About Adobe ColdFusion
    2. Download Adobe ColdFusion
    3. What's new in ColdFusion (2021 release)
    4. ColdFusion (2021 release) Release Notes
    5. Deprecated Features
    6. REST enhancements in ColdFusion (2018 release)
    7. Server Auto-Lockdown
    8. Asynchronous programming
    9. Docker images for ColdFusion
  3. Adobe ColdFusion (2021 release)
    1. Install ColdFusion- Zip Installer
    2. Install ColdFusion- GUI Installer
    3. ColdFusion Licensing and Activation
    4. ColdFusion Package Manager
    5. CFSetup configuration tool
    6. SAML in ColdFusion
    7. ColdFusion and Amazon S3
    8. ColdFusion and DynamoDB
    9. ColdFusion and Amazon SQS
    10. ColdFusion and Amazon SNS
    11. ColdFusion and MongoDB
    12. ColdFusion and Azure Blob
    13. ColdFusion and Azure Service Bus
    14. New and updated language enancements
    15. Multi-cloud storage services
    16. Multi-cloud RDS databases
    17. ColdFusion and Azure Cosmos DB
  4. Install ColdFusion
    1. ColdFusion server profiles
    2. Prepare to install ColdFusion
    3. Install the server configuration
    4. Install the JEE configuration
    5. Install ColdFusion Express
    6. Install integrated technologies
    7. Configure your system
    8. Troubleshoot installation issues
    9. Install ColdFusion silently
    10. Install Adobe ColdFusion (2016 release) hotfix
    11. ColdFusion (2018 release) - Install JEE configuration
  5. Use ColdFusion
    1. Command Line Interface (CLI)
    2. External session storage
    3. Generate Swagger documents
    4. Language enhancements
    5. NTLM support
    6. New and changed functions/tags in Adobe ColdFusion (2016 release)
    7. PDF enhancements
    8. Security enhancements in ColdFusion (2016 release)
  6. Performance Monitoring Toolset
    1. Auto-discovery of ColdFusion nodes and clusters
    2. Code profiler in ColdFusion Performance Monitoring Toolset
    3. Configure ColdFusion Performance Monitoring Toolset settings
    4. Install ColdFusion Performance Monitoring Toolset
    5. Overview of ColdFusion Performance Monitoring Toolset
    6. View cluster and node metrics
    7. View data source metrics
    8. View external services
    9. View incoming services
    10. View list of sites and busy connections
    11. View topology of sites
    12. Datastore Health Monitoring
    13. Performance Monitoring Toolset Update 1
    14. Secure Performance Monitoring Toolset with HTTPS/SSL
    15. Performance Monitoring Toolset deployment guide
  7. Use ColdFusion Builder
    1. About ColdFusion Builder
    2. System requirements | ColdFusion Builder
    3. Install ColdFusion Builder
    4. Edit code in ColdFusion Builder
    5. Manage servers in ColdFusion Builder
    6. Manage projects in ColdFusion Builder
    7. What’s new in Adobe ColdFusion Builder (2018 release)
    8. Frequently Asked Questions (FAQ) | Adobe ColdFusion Builder (2018 release)
    9. Debug applications in ColdFusion Builder
    10. ColdFusion Builder workbench
    11. ColdFusion Builder extensions
    12. Debugging Perspective in ColdFusion Builder
    13. Build mobile applications using ColdFusion Builder
    14. Bundled ColdFusion Server
    15. Debug mobile applications in ColdFusion Builder
    16. Use extensions in ColdFusion Builder
  8. Coldfusion API Manager
    1. Overview of Adobe ColdFusion API Manager
    2. Features in ColdFusion API Manager
    3. Get started with ColdFusion API Manager
    4. Install ColdFusion API Manager
    5. Authentication types
    6. Create and publish APIs
    7. Administrator
    8. Subscriber
    9. Throttling and rate limiting
    10. Notifications
    11. Connectors
    12. Set up cluster support
    13. Integrate ColdFusion and API Manager
    14. Metrics and Logging in API Manager
    15. Generate Swagger documents
    16. Configure SSL
    17. Known issues in this release
    18. Policies in ColdFusion API Manager
    19. Create a Redis cluster
    20. Multitenancy in API Manager
    21. Docker images for ColdFusion API Manager
  9. Configure and administer ColdFusion
    1. Administer ColdFusion
    2. Use the ColdFusion administrator
    3. Data Source Management for ColdFusion
    4. Connect to web servers
    5. Deploy ColdFusion applications
    6. Administer ColdFusion security
    7. Basic Troubleshooting and FAQs
    8. Work with Server Manager
    9. Use multiple server instances
    10. WebSocket Enhancements (ColdFusion 11)
    11. Security Enhancements (ColdFusion 11)
    12. Work with Server Monitor
    13. ColdFusion Administrator API Reference
  10. CFML Reference
    1. Introduction to CFML Reference
      1. New functions in ColdFusion (2018 release)
      2. New and changed functions/tags in Adobe ColdFusion (2016 release)
      3. Script supported tags and functions
      4. New and changed tags/functions in ColdFusion 11
    2. Reserved words and variables
      1. Reserved words and variables
      2. Reserved words
      3. Scope-specific built-in variables
      4. Custom tag variables
      5. ColdFusion tag-specific variables
      6. CGI environment (CGI Scope) variables
    3. ColdFusion tags
      1. ColdFusion tags
      2. Tags in ColdFusion 10
      3. Tag summary
      4. Tags by function
      5. Tag changes since ColdFusion 5
      6. Tags a-b
      7. Tags c
      8. Tags d-e
      9. Tags f
      10. Tags g-h
      11. Tags i
      12. Tags j-l
      13. Tags m-o
      14. Tags p-q
      15. Tags r-s
      16. Tags t
      17. Tags u-z
    4. ColdFusion functions
      1. ColdFusion functions
      2. New functions in ColdFusion 10
      3. ColdFusion functions by category
      4. Function changes since ColdFusion 5
      5. Functions a-b
      6. Functions c-d
      7. Functions e-g
      8. Functions h-im
      9. Functions in-k
      10. Functions l
      11. Functions m-r
      12. Functions s
      13. Functions t-z
      14. BooleanFormat
    5. Ajax JavaScript functions
      1. Ajax JavaScript functions
      2. Function summary Ajax
      3. ColdFusion.Ajax.submitForm
      4. ColdFusion.Autosuggest.getAutosuggestObject
      5. ColdFusion.Layout.enableSourceBind
      6. ColdFusion.MessageBox.getMessageBoxObject
      7. ColdFusion.ProgressBar.getProgressBarObject
      8. ColdFusion.MessageBox.isMessageBoxDefined
      9. JavaScriptFunctionsinColdFusion9Update1
    6. ColdFusion ActionScript functions
      1. ColdFusion ActionScript functions
      2. CF.http
      3. CF.query
    7. ColdFusion mobile functions
      1. ColdFusion Mobile Functions
      2. Accelerometer Functions
      3. Camera Functions
      4. Connection Functions
      5. Contact Functions
      6. Event Functions
      7. File System Functions
      8. Geolocation Functions
      9. Media and Capture Functions
      10. Notification Functions
      11. Splash Screen Functions
      12. Storage Functions
    8. Application.cfc reference
      1. Application.CFC reference
      2. Application variables
      3. Method summary
      4. onAbort
      5. onApplicationEnd
      6. onApplicationStart
      7. onMissingTemplate
      8. onCFCRequest
      9. onError
      10. onRequestEnd
      11. onRequest
      12. onRequestStart
      13. onServerStart
      14. onSessionEnd
      15. onSessionStart
    9. Script functions implemented as CFCs
      1. Script Functions Implemented as CFCs
      2. Accessing the functions
      3. Function summary
      4. ftp
      5. http
      6. mail
      7. pdf
      8. query
      9. Script functions implemented as CFCs in ColdFusion 9 Update 1
      10. storedproc
    10. ColdFusion Flash Form style reference
      1. Styles valid for all controls
      2. Styles for cfform
      3. Styles for cfformgroup with horizontal or vertical type attributes
      4. Styles for box-style cfformgroup elements
      5. Styles for cfformgroup with accordion type attribute
      6. Styles for cfformgroup with tabnavigator type attribute
      7. Styles for cfformitem with hrule or vrule type attributes
      8. Styles for cfinput with radio, checkbox, button, image, or submit type attributes
      9. Styles for cftextarea tag and cfinput with text, password, or hidden type attributes
      10. Styles for cfselect with size attribute value of 1
      11. Styles for cfselect with size attribute value greater than 1
      12. Styles for cfcalendar tag and cfinput with dateField type attribute
      13. Styles for the cfgrid tag
      14. Styles for the cftree tag
      15. ColdFusion Flash Form Style Reference
    11. ColdFusion event gateway reference
      1. ColdFusion Event Gateway reference
      2. addEvent
      3. CFEvent
      4. CFEventclass
      5. Constructor
      6. Gateway development interfaces and classes
      7. getStatus
      8. setCFCPath
      9. setCFCMethod
      10. getOriginatorID
      11. getLogger
      12. getBuddyList
      13. getBuddyInfo
      14. IM gateway message sending commands
      15. IM Gateway GatewayHelper class methods
      16. onIncomingMessage
      17. onIMServerMessage
      18. onBuddyStatus
      19. onAddBuddyResponse
      20. onAddBuddyRequest
      21. IM Gateway CFC incoming message methods
      22. IM gateway methods and commands
      23. CFML CFEvent structure
      24. warn
      25. info
      26. setOriginatorID
      27. data command
      28. submit Multi command
      29. submit command
      30. setGatewayType
      31. setGatewayID
      32. setData
      33. setCFCListeners
      34. outgoingMessage
      35. getStatusTimeStamp
      36. numberOfMessagesReceived
      37. numberOfMessagesSent
      38. removeBuddy
      39. removeDeny
      40. removePermit
      41. setNickName
      42. setPermitMode
      43. setStatus
      44. SMS Gateway CFEvent structure and commands
      45. SMS Gateway incoming message CFEvent structure
      46. getStatusAsString
      47. getProtocolName
      48. getPermitMode
      49. getPermitList
      50. getNickName
      51. getName
      52. getDenyList
      53. getCustomAwayMessage
      54. getQueueSize
      55. getMaxQueueSize
      56. getHelper
      57. getGatewayType
      58. getGatewayServices
      59. getGatewayID_1
      60. getGatewayID
      61. getData
      62. getCFCTimeout
      63. setCFCTimeout
      64. getCFCPath
      65. getCFCMethod
      66. GatewayServices class
      67. Gateway interface
      68. GatewayHelper interface
      69. addPermit
      70. addDeny
      71. addBuddy
      72. error
      73. debug
      74. Logger class
      75. stop
      76. start
      77. CFML event gateway SendGatewayMessage data parameter
      78. restart
      79. fatal
      80. SMS gateway message sending commands
    12. ColdFusion C++ CFX Reference
      1. C++ class overview
      2. Deprecated class methods
      3. CCFXException class
      4. CCFXQuery class
      5. CCFXRequest class
      6. CCFXStringSet class
      7. ColdFusion C++ CFX Reference
    13. ColdFusion Java CFX reference
      1. ColdFusion Java CFX reference
      2. Class libraries overview
      3. Custom tag interface
      4. Query interface
      5. Request interface
      6. Response interface
      7. Debugging classes reference
    14. WDDX JavaScript Objects
      1. WDDX JavaScript objects
      2. JavaScript object overview
      3. WddxRecordset object
      4. WddxSerializer object
  11. Develop ColdFusion applications
    1. Introducing ColdFusion
      1. Introducing ColdFusion
      2. About ColdFusion
      3. About Internet applications and web application servers
      4. About JEE and the ColdFusion architecture
    2. Changes in ColdFusion
      1. Changes in ColdFusion
      2. Replacement of JRun with Tomcat
      3. Security enhancements
      4. ColdFusion WebSocket
      5. Enhanced Java integration
      6. ColdFusion ORM search for indexing and search
      7. Solr enhancements
      8. Scheduler enhancements
      9. Integration with Microsoft Exchange Server 2010
      10. RESTful Web Services in ColdFusion
      11. Lazy loading across client and server in ColdFusion
      12. Web service enhancements
      13. Displaying geolocation
      14. Client-side charting
      15. Caching enhancements
      16. Server update using ColdFusion Administrator
      17. Secure Profile for ColdFusion Administrator
    3. Introduction to application development
      1. Introduction to application development using ColdFusion
      2. Using the Developing ColdFusion Applications guide
      3. About Adobe ColdFusion documentation for Developers
    4. The CFML programming language
      1. The CFML programming language
      2. Elements of CFML
      3. ColdFusion variables
      4. Expressions and number signs
      5. Arrays and structures
      6. Extend ColdFusion pages with CFML scripting
      7. Regular expressions in functions
      8. ColdFusion language enhancements
      9. Built-in functions as first class citizen
      10. Data types- Developing guide
    5. Building blocks of ColdFusion applications
      1. Building blocks of ColdFusion applications
      2. Create ColdFusion elements
      3. Write and call user-defined functions
      4. Build and use ColdFusion Components
      5. Create and use custom CFML tags
      6. Build custom CFXAPI tags
      7. Use the member functions
      8. Object Oriented Programming in ColdFusion
    6. Develop CFML applications
      1. Develop CFML applications
      2. Design and optimize a ColdFusion application
      3. Handle errors
      4. Use persistent data and locking
      5. Use ColdFusion threads
      6. Secure applications
      7. Client-side CFML (for mobile development)
      8. Use the ColdFusion debugger
      9. Debugging and Troubleshooting Applications
      10. Develop globalized applications
      11. REST enhancements in ColdFusion
      12. Authentication through OAuth
      13. Social enhancements
    7. Develop mobile applications
      1. Mobile application development
      2. Build mobile applications
      3. Debug mobile applications
      4. Inspect mobile applications
      5. Package mobile applications
      6. Troubleshoot mobile applications
      7. Device detection
      8. Client-side CFML
      9. Mobile Templates
      10. Code samples to build a mobile application
    8. Access and use data
      1. Access and use data
      2. Introduction to Databases and SQL
      3. Access and retrieve data
      4. Update database
      5. Use Query of Queries
      6. Manage LDAP directories
      7. Solr search support
    9. ColdFusion ORM
      1. ColdFusion ORM
      2. Introducing ColdFusion ORM
      3. ORM architecture
      4. Configure ORM
      5. Define ORM mapping
      6. Work with objects
      7. ORM session management
      8. Transaction and concurrency
      9. Use HQL queries
      10. Autogenerate database schema
      11. Support for multiple data sources for ORM
      12. ColdFusion ORM search
    10. ColdFusion and HTML5
      1. ColdFusion and HTML 5
      2. Use ColdFusion Web Sockets
      3. Media Player enhancements
      4. Client-side charting
      5. Display geolocation data
    11. Flex and AIR integration in ColdFusion
      1. Flex and AIR integration in ColdFusion
      2. Use the Flash Remoting Service
      3. Use Flash Remoting Update
      4. Offline AIR application support
      5. Proxy ActionScript classes for ColdFusion services
      6. Use LiveCycle Data Services ES assembler
      7. Use server-side ActionScript
    12. Request and present information
      1. Request and present information
      2. Retrieve and format data
      3. Build dynamic forms with cfform tags
      4. Validate data
      5. Create forms in Flash
      6. Create skinnable XML forms
      7. Use Ajax data and development features
      8. Use Ajax User Interface components and features
    13. Office file interoperability
      1. Office file interoperability
      2. Using cfdocument
      3. Using cfpresentation
      4. Using cfspreadsheet
      5. Supported Office conversion formats
      6. SharePoint integration
    14. ColdFusion portlets
      1. ColdFusion portlets
      2. Run a ColdFusion portlet on a JBoss portal server
      3. Run a ColdFusion portlet on a WebSphere portal server
      4. Common methods used in portlet.cfc
      5. ColdFusion portlet components
      6. Support for JSR-286
    15. Work with documents, charts, and reports
      1. Work with documents, charts, and reports
      2. Manipulate PDF forms in ColdFusion
      3. Assemble PDF documents
      4. Create and manipulate ColdFusion images
      5. Create charts and graphs
      6. Create reports and documents for printing
      7. Create reports with Report Builder
      8. Create slide presentations
    16. Use web elements and external objects
      1. Use web elements and external objects
      2. Use XML and WDDX
      3. Use web services
      4. Use ColdFusion web services
      5. Integrate JEE and Java elements in CFML applications
      6. Use Microsoft .NET assemblies
      7. Integrate COM and CORBA objects in CFML applications
    17. Use external resources
      1. Send and receive e-mail
      2. Interact with Microsoft Exchange servers
      3. Interact with remote servers
      4. Manage files on the server
      5. Use event gateways
      6. Create custom event gateways
      7. Use the ColdFusion extensions for Eclipse
      8. Use the data services messaging event gateway
      9. Use the data management event gateway
      10. Use the FMS event gateway
      11. Use the instant messaging event gateways
      12. Use the SMS event gateway

 

ColdFusion Builder is an Eclipse-based development environment that allows you to develop Adobe ColdFusion applications and run them on ColdFusion servers. You use it to develop ColdFusion applications using coding and debugging tools.

About the workbench

The ColdFusion Builder workbench is a full-featured environment for developing Adobe ColdFusion applications. Much of the basic functionality of the ColdFusion Builder IDE comes from Eclipse. The ColdFusion Builder plug-ins add features and functionality for creating ColdFusion applications. The plug-ins also provide tools for modifying the IDE user interface and supply some core functionality to support application building.

Workbench The workbench is the ColdFusion Builder development environment.

The workbench contains three primary elements: perspectives, editors, and views. You use all three in various combinations at various points in the application development process. The workbench contains all the tools you use to develop applications.

Perspective A perspective is a group of views, editors, menus, and toolbars in the workbench. Essentially it is a special work environment that helps you accomplish a specific type of task. For example, ColdFusion Builder contains two perspectives. You use the ColdFusion Builder Development perspective to develop applications and the ColdFusion Debugging perspective to debug them.

For more information about perspectives, see About ColdFusion Builder perspectives.

Editor An editor allows you to edit various types of files. The editors available to you vary according to the number and types of Eclipse plug-ins installed. ColdFusion Builder contains editors for writing CFML, HTML, JavaScript, and Cascading Style Sheets (CSS) code. For more information about code editing in ColdFusion Builder, see ColdFusion Builder editors and Code Editing in ColdFusion Builder.

Views A view typically supports an editor. For example, when you edit CFML, the Outline view and Snippet view are also displayed in the ColdFusion Builder Development perspective. These views support the development of ColdFusion applications and are therefore displayed when a CFML file is opened for editing.

Some views support the core functionality of the workbench itself. For example, the File Explorer view allows you to manage files and folders within the workbench. The RDS Dataview and RDS Fileview display data sources, files, and directories on both remote and local servers.

The term view is synonymous with the term panel as it is used in Adobe Dreamweaver® and other Adobe development tools.

For more information about the views in the ColdFusion Builder Development perspective, see ColdFusion Builder Development perspective.

For more information about the views in the ColdFusion Debugging perspective, see ColdFusion Debugging perspective.

Workspace Not to be confused with workbench, a workspace is a defined area of the file system. The workspace contains the resources (files and folders) that make up your application projects. A workspace can contain multiple projects. You can work with only one workspace at a time; however, you can select a different workspace each time you start ColdFusion Builder. For more information, see Managing Projects.

Resource The general term resource applies to the files and folders in the projects in a workspace. For more information, see Add ColdFusion pages, interfaces, and components and Add other files.

Project All the resources that make up your applications are contained within projects. You cannot build an application in ColdFusion Builder without first creating a project. For more information, see Managing Projects.

Workbench menus and toolbars

You access workbench commands through the menu bar, right-click context menus, toolbars, and keyboard shortcuts.

Workbench menus

The ColdFusion Builder workbench contains the following main menus:

File menu

The File menu lets you create, save, close, print, import, and export workbench resources and exit the workbench.

Menu command Description
New Creates a resource. Before you create a ColdFusion component, interface, or page, ensure that you have created a project to store these resources.
Open File Open a file for editing. You can also open files that are not in the workspace.
Close Closes the active editor. You are prompted to save changes before the file closes.
Close All Closes all open editors. You are prompted to save changes before the files close.
Save Saves the content of the active editor
Save As Lets you save the contents of the active editor in a different filename and location
Save All Saves the contents of all open editors.
Revert Replaces the contents of the active editor with the previously saved contents.
Move Moves the currently selected resources to a different project
Rename Lets you change the name of the selected resource
Refresh Refreshes the resource with the contents in the file system
Convert Line Delimiters To

Lets you convert line delimiters to the operating system applicable to your development or deployment platform:

  • Windows (default)
  • Unix
  • MacOS 9
Print Prints the contents of the active editor
Switch Workspace Opens the Workspace Launcher that lets you switch to a different workspace. When you switch to a different workspace, the workbench is restarted.
Restart Restarts ColdFusion Builder
Import
Lets you import resources to the workbench using the Import wizard
Export Lets you export resources from the workbench using the Export wizard
Properties Displays the properties dialog box for the selected resource. The Properties For dialog box provides information about the path to the resource and the date of the last modification on the resource. It also provides information if the project's resources have inherited their encoding and line delimiters or if they are set to a particular value.
Recent File List A list of the most recently accessed files in the  workbench . You can open these files from the File menu by clicking the filename. You can control the number of files that must appear in this list using the Preferences dialog box.
Exit Closes the open resources and exits the workbench

The Navigate menu lets you locate and navigate through resources in your workbench.

Menu command Description
Go Into Lets you navigate within hierarchies of resources such that the selected resource is at the root. That is, when you select a folder within a project and select Go Into, only the selected folder (and artifacts within the folder) appear in the Navigation view. This command is useful in navigating through large-sized projects with complex hierarchies.
Go To Lets you jump to a specific resource or display the hierarchy that appeared before the current display. For example, select the Go Into command for a resource, and then select Go To > Back. The Back command displays the same hierarchy from which you activated the Go Into command.
Open Declaration Opens declaration for selected code element.
Quick Outline Displays a quick view of the Outline view. A hierarchical view of the code structure of the page appears in a pop-up menu.
Open Resource Lets you select a resource in the workspace and open it in an editor using the Open Resource dialog box
Show In Lets you find and select the currently selected resource in another view. If an editor is active, these commands are used to select the resource that is currently being edited in another view.
Next
Lets you navigate to the next item in a list or table in the active view
Previous Lets you navigate to the previous item in a list or table in the active view
Last Edit Location Lets you jump to the last edit position in the active editor
Go To Line Lets you jump to a specific line in the active editor
Back Lets you move editor focus to a previously opened file.
Forward Lets you return editor focus from the previous file.

Project menu

The Project menu lets you manage projects in the workbench.

Menu command

Description

Open Project

Opens the currently selected project. The selected project must be closed for this command to be available.

Close Project

Closes the currently open project]

Properties

Displays the project properties dialog box

Window menu

The Window menu lets you display, hide, and manage the various views, perspectives, and actions in the workbench.

Menu command Description
New Window Opens a new workbench window with the same perspective as the currently open perspective
New Editor Opens an editor that is of the same type as the currently active editor
Open Perspective Opens a new perspective in the workbench
Show View Lets you select the views to display in the workbench
Customize Perspective Lets you customize the currently selected perspective
Save Perspective As Lets you save the currently selected perspective, creating your own customized perspective.
Reset Perspective Lets you reset a customized perspective
Close Perspective Closes the currently open perspective
Close All Perspectives Closes all the open perspectives in the workbench
Navigation Contains shortcuts to navigate between the views, perspectives, and editors in the workbench
Preferences Lets you set you preferences for using the workbench. There are a number of preferences to configure the appearance of the workbench and the views and editors contained in the workbench.

Toolbars

Workbench toolbar

The workbench toolbar contains buttons for important and frequently used commands. These commands are also available from various ColdFusion Builder menus.

Workbench toolbar

The following buttons appear in the workbench toolbar (shown left to right):

Button/command Description
New Displays a pop-up menu that displays all the types of projects and documents you can create.
Save Saves the document that is open in the editor and currently selected
Print Prints the document that is open in the editor and currently selected
New ColdFusion Project Opens the wizard to create a ColdFusion project.
Open CFC Lists all the CFCs that are available for projects displayed in the Navigator view.
Debug Uses the project’s currently open file to begin a debugging session. You can also select other application files in the project from the attached pop-up menu.
Run Runs the project’s currently open file. You can also select other application files in the project from the attached pop-up menu.
External Tools Selects a custom launch configuration
Search Searches for text strings and filename patterns for files in the project
Next Annotation Allows you to select and move forward to code annotations
Previous  Annotation Allows you to select and move backward to code annotations
Last Edit Location Takes you to the code element that you last edited in the currently open file.
Back To Lets  you move editor focus to a previously opened file.
Forward To Lets you return editor focus from the previous file.

CFML Editor toolbar

The CFML Editor contains buttons that are user interface shortcuts to frequently used commands. These commands are also available from various ColdFusion Builder menus. Some buttons in the toolbar are shortcuts to frequently used code elements, and are context sensitive to the code that you enter in the CFML Editor.

CFML editor toolbar

Button/command Description
Open Tag Editor Opens the Tag Editor. For more information about using the Tag Editor, see Tag Editor.
Insert cfabort Inserts the  cfabort  tag. This command is context sensitive to the script code.
Insert cfdump Inserts the  cfdump  tag. This command is context sensitive to the script code.
Wrap in cfoutput Wraps the selected code within the  cfoutput  tag.This command is context sensitive to the script code that you enter in the CFML Editor.
Insert cfset Inserts the cfset tag.
Insert cfscript Block Inserts a cfscript code block.
Wrap in cftry/cfcatch Wraps the selected code within the cftry or cfcatch tag, depending on the code.This command is context sensitive to the script code.
Wrap in ## Wraps the selected code within "#" marks.
Wrap/Unwrap in cfcomment Comments or uncomments the selected code.
Wrap/Unwrap in /* */ Wraps or unwraps the selected code within ""/* */"" marks
Wrap in Single Quotes Wraps the selected code within single quotation marks.
Wrap in Double Quotes Wraps the selected within double quotation marks.
To Uppercase Changes the text in the selected code to uppercase
To Lowercase Changes the text in the selected code to lowercase.

About ColdFusion Builder perspectives

A perspective is a group of editors and views that support the completion of a task. ColdFusion Builder contains two perspectives: the ColdFusion Builder Development perspective and the ColdFusion Builder Debugging perspective.

Open and switch perspectives

When you open a file that is associated with a particular perspective, ColdFusion Builder automatically opens that perspective. That is, perspectives change automatically to support the task at hand. For example, when you create a ColdFusion project, the workbench displays the Development perspective. Similarly, when you start a debugging session, ColdFusion Builder switches to the Debugging perspective.

By default, perspectives open in the same window. To open a perspective in a new window, do the following:

  1. Select Window > Preferences

  2. In the tree view structure, select General > Perspectives.

  3. Under Open a New Perspective, select In The Same Window.

You can manually switch perspectives by doing one of the following:

  • Select Window > Open Perspective > Other from the main menu.
  • Use the perspective bar in the main workbench toolbar.

Eclipse provides many predefined perspectives. So, if you use the plug-in configuration of ColdFusion Builder, you sometimes have additional perspectives.

You can access the other Eclipse perspectives by doing one of the following:

  • Select Window > Open Perspective > Other from the main menu.
  • Click  in the perspective bar in the main workbench toolbar and select Other.

Set a default perspective

  1. Select Window > Preferences.

  2. In the tree view structure, select General > Perspectives.

  3. Under Available Perspectives, select the perspective that you want to set as the default, and click Make Default.

  4. Click OK.

The default perspective has the word "default" in parentheses after the perspective name.

ColdFusion Builder Development perspective

You use the ColdFusion Builder Development perspective to create, edit, configure, and run ColdFusion applications in ColdFusion Builder. In addition, you can configure and manage local or remote ColdFusion servers.

The ColdFusion Builder Development perspective includes these views:

Outline view

The Outline view displays a hierarchy of elements in the file that is currently open in the editor. For example, it displays the functions in a CFC file and the tags in an HTML file.

You use Outline view to inspect and navigate the structure of your CFML, HTML, JavaScript, and CSS pages. If a page contains multiple code elements, you can use the Outline view to see a hierarchical view of the code structure of the page.

You can sort the elements in Outline view alphabetically or in the order of their definition in the page. You can choose to view all the code elements or view only specific code elements.

  • The Outline view displays the structure of your CFML code. For example, each item in the Outline view can represent a CFML tag.
  • Double-click an element in  Outline  view to directly go to that element in the editor, instead of scrolling through the entire code. When you select an item in Outline view, that item is highlighted in the editor, which makes it easier to navigate your code.
  • Use the filter to search for a tag or element in the Outline view. Enter the name of the tag or element to search for in the Filter field. The matching strings are displayed in the Outline view.

To specify the CFML tags to be displayed in an Outline view, select ColdFusion > Editor  profiles  > Editor > Outline. Then select, add, or remove tags, as required.

RDS FileView and RDS DataView

To use Remote Data Services (RDS), enable RDS while installing the ColdFusion server. ColdFusion Builder provides views to access files and data sources on a remote server.

The RDS FileView displays the files and directories on both remote and local servers. The RDS DataView displays the data sources configured in a remote server.

When you add a ColdFusion server instance in ColdFusion Builder, it automatically becomes available in RDS FileView and RDS DataView.

Configure a remote server for RDS FileView

If you want to configure a remote server manually and then access its files and directories using RDS FileView, do the following:

  1. Click RDS FileView in the upper-right corner of the ColdFusion Builder perspective.

  2. Right-click in RDS FileView and select RDS Configuration.

  3. Click New.

  4. Specify remote server information such as the  host name , port number,  user name , and password.

  5. Select Prompt For Password.

  6. Click Test Connection to check that the RDS configuration is correct. Then, click OK.

  7. Select the remote server from RDS FileView.

  8. Specify the password for the remote server to view its files and directories.

Configure a remote server for RDS DataView

To configure a remote sever and access data sources from the remote server using RDS DataView:

  1. Click RDS DataView.

  2. Right-click in RDS DataView and select RDS Configuration.

  3. Click New.

  4. Specify the server information such as host name, port number, remote server  user name , and password.

  5. Select Prompt for Password.

  6. Click Test Connection to check that the RDS configuration is correct. Then, click OK.

  7. Expand the new server in RDS DataView to view data sources.

RDS Query viewer

The RDS Query viewer lets you create and run queries on a selected data source.

The RDS Query Viewer is available in the RDS DataView toolbar. To create and execute a query using the RDS Query viewer, do the following:

  1. Click   in RDS DataView to open RDS Query Viewer area.

  2. Type the query in the blank area. You can also build a query by dragging tables and columns from the RDS DataView view into the RDS Query Viewer.

  3. Select the server and data source from the drop-down list.

  4. Click Execute Query. The results of the query are displayed in the RDS Query Viewer area.

  1. RDS query viewer

Right-click a table in the RDS DataView view and select Show Table Contents. You can view all the records of the selected table in the RDS Query Viewer.

The Navigator view displays ColdFusion projects and other projects, and allows navigation through the project’s files and folders.

File view

The File view displays files and directories on the local computer where ColdFusion Builder is installed and allows you to create new files.

If you edit a file outside ColdFusion Builder, you can automatically refresh the file in ColdFusion Builder. To do so, select Window > Preferences > General > Workspace, and select Refresh Automatically.

The File view also lets you add FTP sites and browse files on the FTP server. ColdFusion projects can be associated with FTP connections so that you can easily upload, download, and synchronize files. For more information, see Deploy projects over FTP and Secure FTP connections.

Servers view

Displays the details of ColdFusion servers including server name, status, description, server type, server host, and port. You can use the Server view to perform these tasks:

  • Add and delete a ColdFusion server
  • Start and stop a server
  • Launch Server Monitor
  • Launch ColdFusion Server Administrator
  • Open server log

For more information, see Managing Servers.

Source view and Default Browser view

The Source view displays the source code for files. The Default Browser View displays the output in an HTML or CFML page.

Console view

The Console view displays the status of the ColdFusion server and any messages from the ColdFusion server.

TailView view

The TailView view displays the Server log and Workspace log, and lets you easily navigate through the logs. To automatically display the logs, RDS must be configured and enabled.

After selecting a server, you can open logs from the shortcut in the button bar of the Server Manager. Select the log to open it in the TailView view. By default, the TailView view opens the Exception log. When you are in Server view, you can open the Exception log by right-clicking and selecting Open Log.

To manually open the logs, right-click in the TailView view and select Add. Browse to and select a log file on your computer’s file system.

The Tailview view toolbar contains the following buttons (left to right) that let you manage multiple logs in different tabs.

TailView toolbar

Button/command Description
Move Left Moves the Server log or Workspace log to the left
Move Right Moves the Server log or Workspace log to the right
Adds Log Opens a log file on your computer’s file system
Starts Watching Log File Starts watching on a log file
Stops Watching Log File Stop watching on a log file
Reloads The Log File Reloads a log file
Clears Log File In Display
Removes the log file displayed in the TailView view, without deleting it from the computer’s file system
Erases Log File On Disk Remove a log file from the computer’s file system
Deletes Log Tab Removes a log file from the computer’s file system
Deletes All Log Tabs Removes all the log tabs from the TailView view
Scroll Lock Prevents the Console view from scrolling.
Color Settings Sets color preferences for displaying the log file in the TailView view

Services Browser view

The Services Browser view lists the servers added in the Server Manager and lets you browse through ColdFusion components (CFCs), web services and their methods.

Browse ColdFusion components

The Services Browser view lists the following components:

  • Components that the ColdFusion component browser lists. The ColdFusion component browser is located at cf_root/ wwwroot /CFIDE/ componentutils /componentdoc.cfm
  • Components that are located in any directories specified in the ColdFusion Administrator Mappings page
  • Components that are located in any directories specified in the ColdFusion Administrator Custom Tag  paths  page

The Services Browser view toolbar contains the following buttons (left to right) that let you filter methods in CFCs based on the access type - remote, public, package, and private.

Services browser toolbar

Button/command

Description

Show System CFCs

A toggle button that shows or hides system CFCs. System CFCs are stored within the server web root.

Show Remote

A toggle button that shows or hides methods with the access type - remote

Show Public

A toggle button that shows or hides methods with the access type - public

Show Package

A toggle button that shows or hides methods with the access type - package

Show Private

A toggle button that shows or hides methods with the access type - private

Manage web services

The Services Browser view lets you manage a list of web services by adding or deleting WSDL URLs from a list.

  • To view the list of web services, click   in the Services Browser view.
  • To add a web service to the list, click   , enter a valid WSDL URL, and click OK.
  • To delete a web service, select the web service, and click   .

When you are editing a ColdFusion file, you can use the Services Browser view to generate CFML code to run a web service or to create a web service object. Similarly, when you are editing an ActionScript file, you can use the Services Browser to generate ActionScript.To run or create a web service, do the following:

  1. Place your pointer where you want to insert the code.

  2. View the list of web services.

  3. Highlight a web service or a method in a web service, right-click, and select:

  • Insert CFObject to insert a web service.
  • Insert CreateObject to create a web service.

Extensions view

You use the Extensions view to perform the following tasks:

  • Install and uninstall extensions
  • Import and reload extensions

The Extensions view also displays details like the extension name and description of the installed extension.

The Extensions view toolbar contains the following buttons (left to right) that let you manage extensions in the Extensions view.

Extensions view toolbar

Button/command

Description

Install Extension From Archive File

Lets you select the Archive file to install and opens the Extension Install wizard to guide you through the installation.

Import Extension From Folder

Lets you select the folder that contains the extension files.

Uninstall Selected Extension

Uninstalls the selected extension.

View Details About Selected Extension

Displays details about the selected extension.

Snippets view

A code snippet is a piece of text that you can insert and reuse in your files, without having to type the text each time. You use the ColdFusion Snippet view to create and save code snippets, variables, and plain text. You can add code snippets to an existing or new document.

The Snippet view toolbar contains the following buttons (left to right) that let you manage code snippets in the Snippets view.

Code snippet toolbar

Button/command

Description

Refresh Snippet View

Refreshes the Snippet view

Insert The Selected Snippet

Inserts the selected snippet into the document

Create A New Snippet

Creates a code snippet

Edit The Selected Snippet

Lets you modify the selected code snippet

Delete The Selected Snippet

Deletes the selected code snippet

Create A New Snippet Package

Creates a snippet package to which you can add code snippets

Delete Selected Snippet Package

Deletes the selected snippet package only if it is empty. You cannot delete a snippet package that contains snippets.

Create a code snippet

  1. In the Code Snippet area, click  .

  2. In the New Snippet dialog box, specify the snippet name, and the start and end blocks of code.

  3. Click OK to create the code snippet.

Insert a code snippet

  1. Move the cursor to the desired insertion point.

  2. Select the code snippet from the Code Snippet area.

  3. Click   in the Code Snippet toolbar.

If you select code in the editor, and then insert a snippet, the snippet is wrapped between the start and end block of the selected code. If you insert a snippet without selecting code in the editor, the snippet is inserted at the current caret position. caret is the marker in the CFML editor that indicates where the next character appears.You can also edit or delete an existing code snippet or an entire code snippet package from the Code Snippet area.

Using trigger text to insert snippets

You can insert snippets in the CFML editor using trigger text. For example, you create a snippet and give it the trigger text "abc." To insert this snippet in the editor, you type abc and press Ctrl + J (Windows) or Command + J (Mac). The text abc is replaced with the associated snippet.

Specify the path to store snippets

Snippets are stored in a snippet’s directory as an XML file. By default, snippets are stored in the workspace/.metadata/snippets directory of your project workspace. To specify a different directory, do the following:

  1. From the Windows menu, select Preferences.

  2. In the tree view structure of the Preferences dialog box, select ColdFusion > Snippets.

  3. Specify the path to the directory in which to store snippets.

System-defined snippet variables

Snippet variables are case sensitive. The following system-defined variables are available.

Variable Description
$${DATE} The system date with the year as a four-digit number. For example, 12/01/2009
$${TIME} The system time using a 12-hour clock. For example, 03:15:05 PM
$${DATETIME} The system date and time. For example, 12/01/2009 15:15:05 PM
$${DAYOFWEEK} The full name of the day of the week. For example, Monday
$${CURRENTFILE} The filename of the currently open file. For example, application.cfm
$${CURRENTFOLDER} The fully qualified path of the currently open folder. For example, C:\workspace\myproject
$${CURRENTPATH} The fully qualified path of the currently open file. For example, C:\workspace\myproject\application.cfm
$${CURRENTPRJPATH} The project name of the currently open project. For example,  myproject
$${USERNAME} The name of the current user.
$${MONTHNUMBER} The month, from 01 through 12.
$${DAYOFMONTH} The day of the month from 01 through 31.
$${DAYOFWEEKNUMBER} The day of the week as a number, from 1 through 7. Sunday is considered as the start of  ther  week. So, for example, Monday is 2.
$${DATETIME24} The date and time using a 24-hour clock. For example, 12/01/2009 15:30:00
$${YEAR} The current year as a four-digit number. For example, 2009
$${YEAR2DIGIT} The current year as a two- didgit  number. For example, 09

For example, to insert the current date, use the following system-defined variable:

Date: $${DATE}

User-defined snippet variables

User-defined variables prompt you for the variable name and default value. For example, the following user-defined variable prompts you to enter the author’s name:

Author name: $${Author}

ColdFusion Debugging perspective

The ColdFusion Debugging perspective contains tools to debug your ColdFusion applications. There are different views that let you add breakpoints to your code, step into or over functions in your code, and examine and evaluate expressions. The editor works with the debugging tools to locate and highlight lines of code that need correction.

The ColdFusion Debugging perspective contains the following views:

Variables view

The Variables view toolbar contains the following buttons (left to right) that let you show the current variables, including the variable scope.

Variables view toolbar

Button/command

Description

Show Type Names

Displays the type of the variables

Show Logical Structure

This command is not supported in ColdFusion Builder

Collapse All

Collapses the information in the view to show only variable types

Debug Output Buffer view

The Debug Output Buffer contains two panes:

Browser Displays what appears in the browser during application execution. Specify the URL of the page that you want to debug.

Note:

When you click the Home button, the URL that you specified as the Home Page URL in the Preferences dialog box (Window > Preferences > ColdFusion > Debug Settings) appears. For more information on editing the Debugger settings, see Specify debugger settings in ColdFusion Builder.

Server Output Buffer Displays the Debugger output in two views - source view and HTML view.

The Server Output Buffer pane displays an output only when the Debugger is suspended at  breakpoint . The output that appears is only up to the suspended breakpoint.

Note:

The Server Output Buffer displays the output even for a page that is executed using an external browser.

Breakpoints view

The Breakpoints view toolbar contains the following buttons (left to right) that let you manage breakpoints during a debugging session.

Breakpoint view toolbar

Button/command Description
Remove Selected Breakpoints Removes the selected breakpoint
Remove All Breakpoints Removes all breakpoints
Show Breakpoints Supported by Selected Targets Displays the breakpoints that you are currently debugging
Go to File for Breakpoint Goes to the file in which the selected breakpoint is set
Skip All Breakpoints Ignores all breakpoints
Expand All Expands all the breakpoint information in the view
Collapse All Collapses all the breakpoint information in the view
Link with Debug View Highlights the selected breakpoint when the application stops execution in the Debug View
Add Java Exception Breakpoint Lets you specify which Java exception to throw when you reach the selected breakpoint
Menu Lets you specify the type of information to display in the Breakpoints view

Expressions view

The Expressions view lets you create expressions using variables and functions; you can inspect, evaluate, and watch these expressions. The Expressions view also lets you evaluate and watch variables that you selected in the Variables view.

The Expression view toolbar contains the following buttons (left to right) that let you create, evaluate, and watch expressions.

Expressions view toolbar

Button/command

Description

Show Type Names

Displays the type of the variables

Show Logical Structure

Displays the logical structure in the view

Collapse All

Collapses all expressions in the view

Create a New Watch Expression

Adds a watch expression

Remove Selected Expressions

Removes the selected variable or watch expression

Remove All Expressions

Removes all variables and watch expressions in the Expressions view

Outline view

The Outline view displays the current source file’s content in outline form. For more information, see Outline view.

Debug View

The Debug view keeps the results of each debug session. The Debug view shows the stack trace when the page execution is suspended at breakpoint or when stepping into or over code.

The Debug toolbar contains the following buttons (left to right):

Debug toolbar

Button/command Description
Resume Resumes a debugging session
Suspend Pauses a debugging session
Terminate Stops a debugging session
Disconnect Disconnects the debugger from the selected debug target when debugging remotely
Remove All Terminated Launches Clears all terminated debug targets from the display
Step Into Executes code line by line, including included code, UDFs, and CFCs
Step Over Executes code line by line, excluding included code, UDFs, and CFCs
Step Return Returns to the original page from which you entered the included code, UDF, or CFC
Drop to Frame This command is not supported in ColdFusion Builder.
Use Step Filters/Step Debug Ensures that all step functions apply step filters

Edit view

The Edit view displays the stacked source tabs, one tab for each source file that you have open.

Servers view

The Servers View lets you start, stop, and manage servers in ColdFusion Builder. You can also launch the ColdFusion Server Monitor and ColdFusion Server Administrator from the Servers View.

Servers view toolbar

The Servers view toolbar contains the following buttons (left to right) that let you manage servers.

Button/command

Description

Add Server

Adds a server

Start Server

Starts a server

Restart Server

Stops and starts a server

Pause Server

Pauses the server

Stop Server

Stops a server

Open Console/Shell

Opens a new console and displays a pop-up menu to select other servers

Open Log

Opens the server log in the TailView view

For more information about managing servers and using Servers view, see Using Servers View.

Console view

Console view displays the output from trace statements placed in your CFML code and also feedback, like status, warnings, and errors from the debugger itself.

The Console view toolbar contains the following buttons (left to right) that let you view and manage the trace statements in the Console view.

Console toolbar

Button/command

Description

Clear Console

Clears all content from the Console view

Scroll Lock

Prevents the Console view from scrolling

Pin Console

Prevents the console from refreshing its contents when another process is selected

Display Selected Console

Displays the selected console

Open Console

Opens a new console and displays a pop-up menu to select other console views

Problems view

As you enter code, the ColdFusion Builder compiler detects syntax and other compilation errors, and displays the errors in the Problems view. The Problems view shows errors only for CFML files that are open in ColdFusion Builder.

TailView view

The TailView view displays the server logs. For more information, see TailView view.

Add views to the workbench

The workbench contains views besides the views associated with ColdFusion Builder’s default development and debugging perspectives. These additional workbench views help you streamline the application development process.

  1. To add a view to the workbench, select Window > Show View > Other > General

These optional views are categorized by type and are associated with distinct workbench functionality or with specific Eclipse plug-ins.

Several workbench views, like the Tasks, Bookmarks, and Search views, are valuable aids as you develop your applications in ColdFusion Builder.

ColdFusion Builder editors

Editors are associated with resource types. As you open resources in the workbench, the appropriate editor is opened. The workbench is a document-centric (and project-centric) environment for developing applications.

Use the CFML editor to edit CFML files. For more information, see Code Editing in ColdFusion Builder.

Use the HTML editor to edit HTML code and the JavaScript editor to edit JavaScript code. The CSS editor lets you display and edit Cascading Style Sheets; you can then apply styles to the visual elements of your applications.

You can use the Link with Cursor feature to switch between the different editors based on the type of code you are editing. The editors provide many features, including code colorization, code assist, and Outline view, that help you navigate through your code and keep it valid.

As you enter CFML, HTML, JavaScript, and CSS code, hints are displayed to help you complete your code. This feature is called Code Assist. For more information, see Code Assist.

Customizing a perspective

You can configure the layout of your perspective; that is, you can configure the views and editors that are visible in the perspective. For example, you can configure the Tasks view to be visible in one perspective, and hidden in another perspective. You can also configure several other aspects of a perspective, such as the following:

  • File > New submenu items
  • Window > Perspective > Other submenu items
  • Window > Other Views submenu items
  • Action sets (buttons and options) that appear in the toolbar and in the main menu
Note:

Menu names differ slightly in the plug-in configuration of ColdFusion Builder.

Create a customized perspective

  1. Open the perspective to modify.

  2. Select Window > Customize Perspective.

  3. Select the Shortcuts tab or the Commands Groups Availability tab, depending on the items that you want to add or remove in your customized perspective.

  4. Use the check boxes to select the element that you want to be visible on menus and toolbars in the selected perspective.

  5. Click OK.

  6. Select Window > Save Perspective As.

  7. In the Save Perspective As dialog box, enter a name for the modified perspective and click OK.

Note:

When you save a modified perspective, ColdFusion Builder adds the name of the modified perspective to the Window > Open Perspective > Other menu.

Delete a customized perspective

You can only delete perspectives that you created. You cannot delete perspectives that are delivered with the workbench.

  1. In ColdFusion Builder, select Window > Preferences.

  2. In the Preferences dialog box, you see a tree-view structure on the left side.

  3. In the tree-view structure, select General > Perspectives.

  4. Under Available Perspectives, select the perspective that you want to delete.

  5. Click Delete, and then click Yes to confirm the delete action.

  6. Click OK.

Reset a customized perspective

After you have modified a perspective, you can restore it to its original layout.

  1. In ColdFusion Builder, select Window > Preferences.

  2. In the Preferences dialog box, you see a tree-view structure on the left side.

  3. In the tree-view structure, select General > Perspectives.

  4. Under Available Perspectives, select the modified perspective that you want to reset.

  5. Click Reset, and then click OK.

Adobe logo

Sign in to your account

[Feedback V2 Badge]