"Error 1321: El programa de instalación no tiene privilegios suficientes...." o "Error 1309: Error al intentar abrir..."| Instalar productos CS3 | Windows

Última actualización el 19 dic 2015

Problema

Cuando instalas productos de Adobe Creative Suite 3, aparece uno de los siguientes mensajes de error en el registro de instalación:

  • Error 1321: el instalador no tiene privilegios suficientes para modificar este archivo C:\Windows\system32\Macromed\Flash\FlashPlayerTrust\AcrobatConnect.cfg.
  • Error 1309: error al intentar abrir el archivo de origen C:\Windows\system32\Macromed\Flash\FlashPlayerTrust\AcrobatConnect.cfg. Código de error del sistema: 2

El ejemplo que aparece a continuación muestra cómo aparece el error en el registro de instalación:

Acción 11:21:48: InstallValidate. Validando instalación. Inicio de acción 11:21:48: InstallValidate.Error 1321.El programa de instalación no tiene privilegios suficientes para modificar el archivo C:\Windows\system32\Macromed\Flash\FlashPlayerTrust\AcrobatConnect.cfg. Acción finalizada 11:21:48: InstallValidate. Devuelve el valor 3.

Motivo

El programa de instalación de Adobe Creative Suite 3 no pudo acceder al archivo o directorio identificado en el mensaje de error. La carpeta o archivo que causa el error se puede identificar en el registro de instalación de Adobe Creative Suite. Para obtener información adicional sobre cómo encontrar y leer el registro de instalación, consulta la sección "Registro de instalación de Adobe Creative Suite". Las soluciones que aparecen a continuación hacen referencia a las ubicaciones más comunes de los errores.

Solución

Actualizar los privilegios del usuario para archivos.

Importante: La ruta del archivo en los mensajes de error aparece inmediatamente después de "to modify the file" o "open the source file". La carpeta principal está inmediatamente antes del archivo mencionado en el error.En los mensajes de error anteriores, el directorio principal del error 1321 sería "FlashPlayerTrust".

Realizar los pasos que aparecen a continuación en la carpeta principal que contiene el archivo.En el ejemplo siguiente, la carpeta es FlashPlayerTrust. La ruta a la carpeta FlashPlayerTrust es C:\Windows\system32\Macromed\Flash\.

En Windows XP Professional

En el Explorador de Windows, navegar a C:\Windows\system32\Macromed\Flash\.
Hacer clic con el botón derecho en la carpeta FlashPlayerTrust y seleccionar Propiedades.

Importante: Si no puedes ver la carpeta FlashPlayerTrust, procede a la sección "Para mostrar archivos y carpetas ocultas" y continúa con el paso 3.
En la ventana Propiedades de FlashPlayerTrust, seleccione la pestaña Seguridad.

Importante: Si no ves esta opción, procede a la sección "Para deshabilitar el uso compartido simple de archivos" y continúa con el paso 4.
Seleccionar Administradores (1) en Nombres de grupos o usuarios.Si no está seleccionado Permitir para Control total en la lista Permisos, cambiar el nivel de control de acceso a Permitir control total (2).

Seleccionar SYSTEM (1) bajo Nombres de grupos o usuarios.Si no está seleccionado Permitir para Control total en la lista Permisos, cambiar el nivel de control de acceso a Permitir control total (2).

En la pestaña Seguridad (1), hacer clic en Opciones avanzadas (2).

Seleccionar Reemplazar entradas de permisos en todos los objetos secundarios con las entradas que se muestran aquí que se aplican a objetos secundarios (1) y hacer clic en Aceptar (2).

  • Si aparece un diálogo de seguridad, haga clic en Sí para continuar.
Haz clic en Aceptar para cerrar el cuadro de diálogo Propiedades de FlashPlayerTrust.
Instalar productos de Adobe Creative Suite 3.

En Windows XP Home

Apaga el ordenador.
Espera 5 segundos y vuelve a encender el ordenador.
Mantén presionada la tecla F8 en el momento en que aparezca el logotipo de Windows.

Nota: También puedes mantener presionada F8 unos momentos antes de que aparezca el logotipo de Windows. Si Modo seguro no aparece en las esquinas del escritorio, no te encuentras ejecutando en Modo seguro. Reinicia e intenta el proceso de nuevo.
Utilizando las teclas de dirección, seleccione Modo seguro con funciones de red y presione Entrar.
Continúa con la sección "Windows XP Professional".

Importante: Debe reiniciar el ordenador antes de continuar con el paso 9 Instalar productos de Adobe Creative Suite 3.

En Windows Vista

En el Explorador de Windows, navegue hasta C:\.
Haga clic con el botón derecho en FlashPlayerTrust y seleccione Propiedades.

Importante: Si no puedes ver la carpeta FlashPlayerTrust, continúa con la sección "Mostrar archivos y carpetas ocultas" y después continúa con el paso 3.
En la ventana Propiedades de FlashPlayerTrust, seleccionar la pestaña Seguridad (1).Haz clic en Opciones avanzadas (2).

En la ventana Propiedades de seguridad avanzadas de FlashPlayerTrust, seleccione la pestaña Propietario (1).Haz clic en Editar (2).

Seleccione el grupo Administradores (1) en Cambiar propietario a, seleccione Reemplazar propietario en subcontenedores y objetos (2) y haga clic en Aceptar (3).

  • Si aparece un cuadro de diálogo de Seguridad de Windows, haga clic en Sí para continuar.

Haz clic en Aceptar para cerrar la ventana Propiedades de seguridad avanzadas de FlashPlayerTrust.
Haga clic en Aceptar para cerrar el cuadro de diálogo Propiedades de FlashPlayerTrust.
Haz clic con el botón derecho en FlashPlayerTrust y selecciona Propiedades.
En la ventana Propiedades de FlashPlayerTrust, seleccione la pestaña Seguridad.Haga clic en Avanzado.
En la ventana Propiedades de seguridad avanzadas de FlashPlayerTrust, selecciona la pestaña Permisos (1).Haz clic en Editar (2).

Verifica que el valor de la columna Permisos para SYSTEM y Administradores indique Control total.
  • Si el valor no indica Control total.
Desmarque Incluir permisos heredables del objeto principal de este objeto y haga clic en Aplicar.

Nota: Es posible que aparezcan algunos cuadros de diálogo para confirmar dicha acción. Copie los permisos y acepte las advertencias de seguridad.
Haga clic en Editar.
Seleccione Control total y haga clic en Aceptar.
Seleccione Reemplazar todos los permisos heredables en todos los elementos descendientes por permisos heredables de este objeto (1). Haga clic en Aceptar (2).

Haga clic en Aceptar para cerrar la ventana Propiedades de seguridad avanzada de FlashPlayerTrust.
Haga clic en Aceptar para cerrar el cuadro de diálogo Propiedades de FlashPlayerTrust.
Instalar los productos de Adobe Creative Suite 3.

Línea de comandos

Este método se puede usar en todas las versiones de Windows, pero requiere el uso de la utilidad del símbolo del sistema.

Nota: Debe elevar el nivel de permisos para Windows Vista con UAC habilitado.

Iniciar el símbolo del sistema.
  • En Windows XP
    1. Seleccione Inicio > Ejecutar.
    2. Escriba cmd y haga clic en Aceptar.
  • En Windows Vista
    1. Seleccione Inicio > Programas > Accesorios.
    2. Haga clic con el botón derecho en Línea de comandos y seleccione Ejecutar como administrador.

Use los siguientes comandos, incluidas las comillas, y presione Intro al final de cada línea.

Importante: Asegúrese de introducir espacios entre /T, /E, /C y /G en la tercera línea.

c:

"C:\Windows\system32\Macromed\Flash\FlashPlayerTrust\"

cacls "C:\Windows\system32\Macromed\Flash\FlashPlayerTrust\" /T /E /C /G Administrators:F

cacls "C:\Windows\system32\Macromed\Flash\FlashPlayerTrust\" /T /E /C /G SYSTEM:F

exit


archivo de registro de instalación de Adobe Creative Suite

El archivo de registro del instalador de Adobe Creative Suite 3 contiene mensajes detallados sobre por qué no se pudo realizar la instalación (o se realizó correctamente). El archivo de registro te puede ayudar a diagnosticar el problema más rápido.Cada intento de instalación agregará información al archivo de registro de instalación anterior. Eliminar el registro de instalación actual y ejecutar la instalación de nuevo puede simplificar el proceso de solución de problemas. El archivo de registro se crea tanto en Windows como en Macintosh. Los mensajes de error contenidos diferirán en formato debido a las diferencias del sistema operativo.

Navegar hasta el archivo de registro de Adobe Creative Suite 3.

\Program Files\Common Files\Adobe\Installers folder.
Descomprimir el archivo de registro de Adobe Creative Suite 3.

Importante: El archivo de registro está archivado con una utilidad de compresión llamada gzip y requerirá una herramienta de descompresión como Winzip o WinRAR.

Nota sobre nombres de registro:
  • El archivo de registro para Creative Suite 3 Design Premium, por ejemplo, es: Adobe Creative Suite 3 Design Premium 1.0.log.gz
Buscar en el archivo o archivos de registro Error 1714 y Error 1704.
Registrar las rutas identificadas cerca del mensaje de error.

Importante: La ruta del archivo en los mensajes de error aparece inmediatamente después de "to modify the file" o " open the source file". La carpeta principal está inmediatamente antes del archivo referenciado en el error. En los mensajes de error anteriores, el directorio principal del error 1321 sería "FlashPlayerTrust".

Ejemplo de error del registro de instalación de Adobe Creative Suite 3:

Action 11:21:48: InstallValidate. Validating install Action start 11:21:48: InstallValidate. Error 1321.The Installer has insufficient privileges to modify the file C:\Windows\system32\Macromed\Flash\FlashPlayerTrust\AcrobatConnect.cfg. Action ended 11:21:48: InstallValidate. Devuelve el valor 3.

Habilitar y deshabilitar archivos y carpetas ocultas

En Windows XP

Para mostrar archivos y carpetas ocultas:

Seleccione Organizar > Opciones de carpeta y búsqueda.
En la ventana Opciones de carpeta, seleccione la pestaña Ver.
En Configuración avanzada, seleccione Mostrar archivos y carpetas ocultas.
Haga clic en Aceptar para cerrar la ventana Opciones de carpeta.

Para ocultar archivos y carpetas ocultas:

Seleccione Organizar > Opciones de carpeta y búsqueda.
En la ventana Opciones de carpeta, seleccione la pestaña Ver.
En Ajustes avanzados, seleccione No mostrar archivos y carpetas ocultas.
Haga clic en Aceptar para cerrar la ventana Opciones de carpeta.

En Windows Vista

Para mostrar archivos y carpetas ocultas:

Seleccione Organizar > Opciones de carpeta y búsqueda.
En la ventana Opciones de carpeta, seleccione la pestaña Ver.
En Ajustes avanzados, seleccione Mostrar archivos y carpetas ocultas.
Haga clic en Aceptar para cerrar la ventana Opciones de carpeta.

Para ocultar archivos y carpetas ocultas:

Seleccione Organizar > Opciones de carpeta y búsqueda.
En la ventana Opciones de carpeta, seleccione la pestaña Ver.
En Ajustes avanzados, seleccione No mostrar archivos y carpetas ocultas.
Haga clic en Aceptar para cerrar la ventana Opciones de carpeta.

Habilitar y deshabilitar el uso compartido simple de archivos

En Windows XP

Para deshabilitar el uso compartido simple de archivos:

Seleccione Inicio > Mi PC.
Seleccione Herramientas > Opciones de carpeta.
En la ventana Opciones de carpeta, seleccione la pestaña Ver.
En Ajustes avanzados, anule la selección de Usar uso compartido simple de archivos.
Haga clic en Aceptar para cerrar la ventana Opciones de carpeta.

Para activar el uso compartido sencillo de archivos:

Seleccionar Inicio > Mi PC.
Seleccionar Herramientas > Opciones de carpeta.
En la ventana Opciones de carpeta, seleccione la pestaña Vista.
En Configuración avanzada, selecciona Usar compartir archivos simple.
Haz clic en Aceptar para cerrar la ventana Opciones de carpeta.