Select a layer

Any change you make to an image only affects the active layer. If you don’t see the desired results when you manipulate an image, make sure that the correct layer is selected.

  • Do one of the following:
    • In the Layers panel, select a layer’s thumbnail or name.

    • To select more than one layer, hold down Ctrl (Command in Mac OS) and click each layer.

Show or hide a layer

In the Layers panel, the eye icon, in the leftmost column next to a layer means that the layer is visible. A line across the eye symbol indicates that the layer is not visible.

  1. Choose Window > Layers if the Layers panel is not already open.
  2. Do one of the following:
    • To hide a layer, click the eye icon. When a line appears across the eye icon, the layer is not visible. Click in the eye column again to show the layer.

    • Drag through the eye column to show or hide more than one layer.

    • To display just one layer, Alt-click (Option-click in Mac OS) the eye icon for that layer. Alt-click (Option-click in Mac OS) in the eye column again to show all the layers.

Resize or hide layer thumbnails

  1. Choose Panel Options from the Layers panel flyout menu.
  2. Select a new size, or select None to hide the thumbnails. Then click OK.

Lock or unlock a layer

You can fully or partially lock layers to protect their contents. When a layer is locked, a lock icon appears to the right of the layer name, and the layer cannot be edited or deleted. Except for the Background layer, you can move locked layers to different locations in the stacking order of the Layers panel.

  • Select the layer in the Layers panel, and do one of the following:
    • Click the Lock all pixels icon in the Layers panel, to lock all layer properties. Click the icon again to unlock them.

    • Click the Lock Transparency icon in the Layers panel, to lock the transparent areas of the layer, so that no painting occurs in them. Click the icon again to unlock.

    Note:

    For type and shape layers, transparency is locked by default and cannot be unlocked without first simplifying the layer.

Rename a layer

Note:

As you add layers to an image, rename layers according to their content. Use descriptive layer names so that you can easily identify layers in the Layers panel.

Note:

You can’t rename the Background layer unless you change it into a normal layer.

Do one of the following:

  • Double-click the layer’s name in the Layers panel, and enter a new name.
  • Right-click the layer and choose Rename Layer from the context menu.

Simplify a layer

You simplify a smart object, frame layer, type layer, shape layer, solid color layer, gradient layer, or pattern fill layer (or a layer group imported from Photoshop) by converting it into an image layer. You need to simplify these layers before you can apply filters to them or edit them with the painting tools. However, you can no longer use the type‑ and shape-editing options on simplified layers.

  1. Select a type layer, shape layer, fill layer, or a Photoshop layer group in the Layers panel.
  2. Simplify the layer or imported layer group:
    • If you selected a shape layer, click Simplify in the Tools Options bar.

    • If you selected a type, shape, or fill layer, or a Photoshop layer group, choose Simplify Layer from either the Layer menu, or from the Layers panel flyout menu.

Delete a layer

Deleting layers that you no longer need reduces the size of your image file.

  1. Select the layer in the Layers panel.
  2. Do one of the following:
    • Click the Delete Layer icon in the Layers panel, and click Yes in the delete confirmation dialog box. To bypass this dialog box, press Alt (Option in Mac OS) as you click the Delete icon.

    • Choose Delete Layer from either the Layer menu or the Layers panel More menu, and click Yes.

Sample color from all visible layers

By default, when you work with certain tools, the color you apply is sampled only from the active layer. With this default behavior, you can smudge or sample in a single layer even when other layers are visible, and you can sample from one layer and paint in another one.

If you want to paint using sampled data from all visible layers, do the following:

  1. Select the Color Picker tool, Magic Wand tool, Paint Bucket tool, Smudge tool, Blur tool, Sharpen tool, or Clone Stamp tool.
  2. In the Tool Options bar, select All Layers.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy