Undo, redo, or cancel actions

Many operations in both the Elements Organizer and Photoshop Elements can be undone or redone. For example, you can restore all or part of an image to its last saved version. Low amounts of available memory limit your ability to use these options.

  1. To undo or redo an operation, Choose Edit > Undo or choose Edit > Redo.
  2. To cancel an operation, hold down the Esc key until the operation in progress has stopped.

Using the History panel while editing

The History panel (F10 or Window > History) lets you jump to any recent state of the image created during the current work session. Each time you apply a change to pixels in an image, the new state of that image is added to the History panel.

For example, if you select, paint, and rotate part of an image, each of those states is listed separately in the panel. You can then select any of the states, and the image reverts to how it looked when that change was first applied. You can then work from that state.

Actions, such as zooming and scrolling, do not affect pixels in the image and do not appear in the  History panel. Nor do program-wide changes, such as changes to panels, color settings, and preferences.

History panel
A. Original state B. State C. Selected state 

Note the following guidelines when using the History panel:

  • By default, the History panel lists 50 previous states. Older states are automatically deleted to free more memory for Photoshop Elements. You can set the number of states in the application settings (Preferences > Performance > History States). The maximum number of states is 1000.

  • The original state of the photo is always displayed at the top of the History panel. You can always revert an image to its original state by clicking this top state. Clicking the original state is also handy for comparing before and after versions of your editing.

  • When you close and reopen the document, all states from the last working session are cleared from the panel.

  • States are added to the bottom of the list. That is, the oldest state is at the top of the list, the most recent one is at the bottom.

  • Each state is listed with the name of the tool or command used to change the image.

  • Selecting a state dims the subsequent states (steps that were performed after the selected step). This way you can easily see which changes will be discarded if you continue working from the selected state.

  • Selecting a state and then changing the image eliminates all states that came after it. Likewise, deleting a state deletes that state and all states (edits) after it.

Revert to a previous state of an image

In Quick and Expert modes, do any of the following:

  • Click the name of the state in the History panel.
  • Click the Undo or Redo buttons in the taskbar.
  • Choose Undo or Redo from the History panel menu or the Edit menu.

To set the keyboard command for Step Forward and Step Backward, choose Edit > Preferences > General  in Windows (Photoshop Elements > Preferences > General in Mac), and choose from the Step Back/Fwd menu.

Delete one or more states from the Undo History panel

Do one of the following:

  • To delete a state, click the name of the state, and choose Delete from the History panel menu. States following the one you selected are also deleted.
  • To delete the list of states from the History panel, without changing the image, choose Clear History from the panel menu or choose Edit > Clear > Clear History. Clearing is useful for freeing up memory, especially if you get an alert that Photoshop Elements is low on memory.

Note: Clearing the History panel cannot be undone.

Clear memory used by the clipboard and the History panel

You can delete items copied to the clipboard or states in the Undo History panel to free up memory.

In Expert mode, do one of the following:

  • To clear memory used by the clipboard, choose Edit > Clear > Clipboard Contents.
  • To clear memory used by the Undo History panel, choose Edit > Clear > Clear History or choose Clear History from the History panel flyout menu.
  • To clear the memory used in both the clipboard and the History panel simultaneously, choose Edit > Clear > All.

Note: Clearing the History panel or clipboard cannot be undone.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy