Last updated on
Apr 27, 2021
Users get a "Server Error" when clicking Send tab in Adobe Sign account.
Cause
Sever Errors are most often caused by the local internet browser configuration.
Resolution
To resolve these errors, do the following:
- Try to clear cache and cookies of the current browser and restart it.
- Use an alternate browser.
- Try opening a private/incognito mode of the browser to initiate a new default session.