Unable to see shared agreement on Manage page.

Issue

A user has shared the account with other user but still not all the documents are visible to the second user on the Manage page.

Cause

It occurs when the other user is a part of the transaction as a signer, which sharer has generated, and the document is still with the previous signer.
Since, the document has not reached the other user yet for signature, it is not visible.

Resolution

The other user has to wait until the document is routed.

Since it happens for legacy, sharing user can also opt for Advanced sharing instead to view the agreements of other users. For advance sharing, refer to Advanced Account Sharing.

Additional information

To enable Advance Sharing, contact Acrobat Sign Support.

Adobe, Inc.

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