Clique duas vezes dentro do painel Projeto ou use Arquivo > Importar > Arquivo para navegar e importar o arquivo SVG.
Saiba como importar arquivos SVG como camadas de forma nativas e editáveis, prontas para serem animadas sem necessidade de conversão.
A versão mais recente do After Effects permite importar o arquivo como gravação ou composição.
Arraste e solte o arquivo SVG importado no painel Linha do tempo.
Selecione a camada para usar a seção Conteúdo da camada no painel Propriedades, a fim de visualizar a estrutura do SVG.
Você também pode selecionar a seta ao lado da camada para desenrolá-la e expandir a seção Conteúdo. Você verá todos os elementos individuais e suas propriedades, como Caminho, Preenchimento e Transformação.
Você pode usar essas propriedades para animar como qualquer outra camada de forma. Por exemplo:
- Anime o Caminho para criar efeitos de transformação
- Altere a cor do preenchimento ao longo do tempo para transições dinâmicas
- Use as propriedades de Transformação para dimensionar, girar ou mover elementos independentemente
Se as camadas tiverem preenchimentos e traçados gradientes, você pode usar as propriedades de Escala e Rotação para animar o gradiente.
As importações de SVG no After Effects oferecem controle flexível e melhor sobre como os arquivos SVG são importados em seu projeto. Na versão mais recente, ao importar um arquivo SVG, você pode optar por importá-lo como uma gravação ou composição.
|
Importar como gravação |
Importar como composição |
|---|---|
|
Importa o SVG como uma única camada vetorial continuamente rasterizável. |
Importa o SVG como uma composição feita de camadas de forma editáveis. |
|
Mantém conexão com o arquivo SVG externo. |
Cada elemento é convertido em sua própria forma editável. |
|
Ideal para gráficos vetoriais de camada única quando você não precisa dividir a arte em partes. |
Ideal para editar caminhos, formas e detalhes no nível da camada quando você precisa animar elementos individuais. |
Você pode controlar qual abordagem de Importação é usada por padrão ao importar arquivos SVG definindo a opção Arrastar Vários Itens de Arquivo Como nas preferências de Importação.
- macOS: After Effects > Configurações > Importar > Arrastar vários itens de arquivo como
- Windows: Editar > Preferências > Importação > Arrastar vários itens de arquivo como
Clique duas vezes dentro do painel Projeto ou use Arquivo > Importar > Arquivo para navegar e importar o arquivo SVG.
Use o menu suspenso Importar Como na caixa de diálogo Importar arquivo para selecionar uma das seguintes:
- Gravação
- Composição - Manter tamanhos de camada
Escolher Gravação importa o arquivo como uma única camada nivelada sem acesso a elementos individuais, tornando-o adequado para uso estático ou quando nenhuma animação é necessária. Selecionar Composição – Manter tamanhos da camada cria uma nova composição onde cada camada de origem é importada separadamente, dimensionada para seu conteúdo real, tornando os pontos de ancoragem mais limpos e as transformações mais fáceis para animação.
macOS
Windows
Selecione as seguintes opções, se aplicável:
- Criar composição: cria uma nova composição usando configurações padrão e coloca automaticamente o SVG importado, seja como gravação ou como composição com camadas de forma, na linha do tempo, evitando que você crie manualmente uma composição e arraste o arquivo SVG para ela.
- Sequência de gráficos vetoriais escaláveis: importa vários arquivos SVG numerados e os trata como uma sequência de imagem vetorial quadro a quadro.
Use a seção Conteúdo da camada no painel Propriedades ou a seção Conteúdo da camada na linha do tempo para visualizar e trabalhar com elementos individuais e suas propriedades, caso tenha importado o arquivo SVG como uma composição. Se importado como gravação, ele se comporta como uma camada normal e pode ser ajustado usando as propriedades padrão de Transformação.
Assim como nos arquivos do Illustrator, se o arquivo vetorial for importado como material de filmagem, você pode selecionar a camada na linha do tempo, clicar com o botão direito do mouse e selecionar Criar > Criar formas e texto a partir da camada vetorial para convertê-la em camadas editáveis, permitindo que você anime caminhos, traços e preenchimentos individualmente.Na versão Beta mais recente do After Effects, o texto no arquivo de origem é convertido para camadas de texto editáveis que preservam fonte, tamanho, preenchimento, posição, estilos, traçados e configurações de fonte variável.
Quando você importa um SVG como gravação, o After Effects mantém um link ativo com o arquivo original, então qualquer alteração feita no SVG fora do aplicativo é atualizada automaticamente dentro do projeto.
Uso de novos recursos beta
Texto editável de arquivos do Illustrator agora está disponível para teste e comentários. Experimente agora no After Effects (beta).
Na versão beta mais recente do After Effects, quando uma camada do Illustrator é importada como gravação, qualquer texto no arquivo de origem é convertido em sua própria camada de texto editável, em vez de ser achatado em contornos de forma. Isso significa que fonte, tamanho, preenchimento, posição, estilos (como negrito e itálico), traçados e configurações de fonte variável são preservados, para que você possa continuar editando o texto diretamente no After Effects em vez de recriá-lo do zero ou voltar ao Illustrator para fazer alterações.
Selecione Arquivo > Importar > Arquivo e, em seguida, o arquivo do Illustrator que você deseja importar.
Na caixa de diálogo Importar Arquivo, certifique-se de que a opção Importar como esteja definida como Gravação ao selecionar o arquivo a ser importado.
Na caixa de diálogo de importação, confirme que Tipo de importação esteja definido como Gravação e selecione as Opções de camada com base no que deseja importar do arquivo do Illustrator.
Arraste o arquivo importado para o painel Linha do tempo.
Clique com o botão direito do mouse na camada do Illustrator e selecione Criar > Criar formas e texto a partir da camada vetorial, ou use Camada > Criar > Criar formas e texto a partir da camada vetorial.
O texto é convertido em uma camada de texto editável que corresponde fielmente à fonte, tamanho, preenchimento e posição do arquivo original. Você pode então editar e ajustar o texto diretamente no After Effects.
Texto somente com traçado ainda é convertido como caminhos em vez de uma camada de texto editável.
O conteúdo vetorial que não seja texto continua sendo convertido em camadas de forma, como antes, e, se o arquivo do Illustrator contiver ambos, você terá uma mistura de camadas de texto e de forma.
Participe da conversa em nossa comunidade After Effects (Beta) sobre suporte para texto editável de arquivos do Illustrator.
O conteúdo SVG na área de transferência agora pode ser colado no After Effects usando Editar > Colar. O conteúdo é importado como camadas de forma nativas e editáveis prontas para animar, sem necessidade de etapa intermediária de importação.
Copiar conteúdo do Illustrator
Abra sua arte no Adobe Illustrator.
Confirme se a preferência Incluir código SVG está selecionada.
- macOS: Selecione Illustrator > Configurações > Manuseio da área de transferência e selecione Incluir código SVG.
- Windows: Selecione Editar > Preferências > Manuseio da área de transferência e selecione Incluir código SVG.
Selecione a ilustração que deseja aplicar.
Converta qualquer texto SVG em curvas antes de copiar, pois o texto SVG não é compatível ao colar.
Selecione Editar > Copiar.
Alterne para o After Effects e faça uma das seguintes ações, dependendo do estado do projeto:
- Se nenhum projeto estiver aberto, selecione Editar > Colar para criar um novo projeto com uma composição contendo o conteúdo SVG como uma camada de forma.
- Se um projeto estiver aberto, mas nenhuma composição estiver selecionada, selecione Editar > Colar para criar uma nova composição no projeto atual contendo o conteúdo colado.
Se uma composição estiver selecionada no After Effects, selecione Editar > Colar para adicionar o conteúdo SVG como uma nova camada de forma nessa composição.
Colar svg de outros aplicativos
O conteúdo SVG copiado de qualquer aplicativo que grava SVG na área de transferência do sistema pode ser colado usando o mesmo fluxo de trabalho Editar > Colar. O suporte depende de o aplicativo de origem colocar dados SVG válidos na área de transferência.
Crie animações 3D impressionantes no After Effects
Anime personagens e ilustrações, adicione movimento ao texto e muito mais.