Observação:

Você não pode exportar arquivos para os formatos FLV e F4V nas versões de junho de 2014 e posterior do After Effects CC. Utilize o After Effect CC (junho de 2013) ou abaixo para exportar arquivos nos formatos FLV e F4V.

É possível renderizar e exportar filmes do After Effects como filmes que podem ser reproduzidos no Adobe Flash Player. Os arquivos SWF reproduzem nativamente no Flash Player, enquanto um arquivo FLV ou F4V deve ser incluído em (ou ser vinculado) um arquivo SWF para reprodução no Flash Player. Você também pode exportar composições para o Flash Professional como arquivos XFL.

Este vídeo da série After Effects CS5: Learn By Video fornece uma visão geral da exportação de vários formatos para o Flash Professional e o Flash Player e demonstra o uso e os problemas comuns com cada um deles.

XFL

Os arquivos XFL são representações de composições que podem ser abertas no Adobe Flash CS4 Professional ou posterior. Os arquivos XFL são basicamente o XML equivalente aos arquivos FLA.

SWF

Os arquivos SWF são pequenos arquivos que podem ser reproduzidos no Flash Player. Eles são geralmente usados para enviar gráficos vetoriais animados (como cartoons), áudio e outros tipos de dados pela Internet. Os arquivos SWF também permitem interação com o visualizador, como um clique para seguir um link da Web, controlar a animação ou fornecem informações a um aplicativo de Internet avançado (RIA). Os arquivos SWF são o resultado gerado pelos arquivos FLA.

FLV e F4V

Os arquivos FLV e F4V contêm apenas vídeo (rasterizado) baseado em pixel e não gráficos vetoriais, e eles não são interativos. Os arquivos FLA podem conter e referir a arquivos FLV e F4V, que então serão incorporados ou vinculados em arquivos SWF reproduzidos no Flash Player.

Exportar uma composição como um arquivo XFL para o Flash Professional

É possível exportar uma composição do After Effects para o formato XFL para alterações adicionais e usar no Adobe Flash CS4 ou posterior. Por exemplo, você pode usar o ActionScript no Flash Professional para adicionar animação interativa a cada uma das camadas de uma composição do After Effects.

Ao exportar uma composição como um arquivo XFL, o After Effects tenta exportar camadas individuais e quadros-chave, preservando as informações para uso diretamente no Flash Professional. Se o After Effects não pode exportar um elemento de uma composição como dados não renderizados em um arquivo XFL, o elemento é ignorado ou renderizado de um item PNG ou FLV, dependendo se desejar ignorar recursos sem suporte.

Sobre arquivos XFL

Os arquivos XFL são basicamente o XML equivalente aos arquivos FLA. Um arquivo XFL é uma pasta de arquivo compactada que contém a pasta de biblioteca e um documento XML (DOMDocument.xml) que descreve o arquivo FLA. A pasta de biblioteca contem os ativos conhecidos como arquivo XML. Quando você abre um arquivo XFL no Flash Professional, ele extrai estes itens do arquivo XFL e os usa para criar um documento FLA. Salve o documento Flash Professional como um arquivo FLA novo; não altere o arquivo XFL com o Flash Professional.

Observação:

Se desejar examinar ou editar manualmente o conteúdo de um arquivo XFL, é possível abrir o arquivo compactado exatamente como qualquer outro arquivo .zip. Alterar a extensão de arquivo para .zip não é necessário, mas pode gerar a extração dos arquivos para este exame manual mais conveniente.

Este vídeo da série After Effects CS5: Learn By Video demonstra a exportação para XFL.

Exportar uma composição para o formato XFL

  1. Para exportar uma composição selecionada como um arquivo XFL, escolha Arquivo > Exportar > Adobe Flash Professional (XFL).

  2. Na caixa de diálogo Configurações do Adobe Flash Professional (XFL), escolha o que o After Effects fará com camadas com recursos sem suporte:

    Ignorar

    As camadas com recursos sem suporte não são incluídas na saída XFL.

    Rasterizar para

    As camadas com recursos sem suporte são rasterizadas. Isso significa que as camadas serão renderizadas em um formato de bitmap (um arquivo FLV ou uma sequência de imagens PNG). Os vetores não são preservados. Isso preserva a aparência da camada quando o arquivo XFL é usado no Flash Professional. Ao rasterizar uma sequência de PNG, os quadros adjacentes idênticos são rasterizados somente uma vez, para um único arquivo PNG que é referenciado várias vezes.

  3. (Opcional) Clique no botão Opções de formato e modifique as configurações usadas para criar sequências PNG ou arquivos FLV.

    Se você clicar no botão Opções de formato quando FLV quando estiver selecionado no menu Formato, a caixa de diálogo de configurações de exportação é aberta. Embora seja possível modificar itens como taxa de bits, em geral não é necessário alterar muitas configurações nessa caixa de diálogo. As alterações feitas nessa caixa de diálogo mantêm-se e são usadas para operações subsequentes de exportação, por isso tenha cautela sobre o que é alterado.

    Se você fez alterações nas opções de formato que gostaria de desfazer, clique no botão Redefinir para padrão na caixa de diálogo Configurações do Adobe Flash Professional (XFL).

  4. Na caixa de diálogo Exportar como Adobe Flash Professional (XFL), escolha um local para os arquivos de saída.

Quando a composição está sendo processada, uma caixa de diálogo mostra o progresso da operação de exportação.

Quando o After Effects cria um arquivo XFL, também salva um relatório ([XFLfile_name] report.html) para a mesma pasta que o arquivo XFL. O relatório exibe as seguintes informações:

  • se as camadas com recursos sem suporte são rasterizadas ou foram ignoradas

  • se cada item de origem foi rasterizado (“renderizado”) ou foi transmitido integralmente (“vinculado”)

  • se cada camada foi rasterizada (“renderizada”) ou foi convertida em um objeto Flash nativo

Trabalhar no Flash Professional com um documento FLA criado a partir de um arquivo XFL

O painel Biblioteca no Flash Professional é semelhante ao painel Projeto no After Effects. Quando o Flash Professional cria um documento FLA de um arquivo XFL, cria símbolos, pastas e videoclipes e os organiza no painel Biblioteca. Cada item no painel Biblioteca tem um nome único -mesmo que se baseie em itens com nomes idênticos no After Effects – para que esses itens possam ser manipulados pelo ActionScript. Esse requisito de nomeação única faz com que o After Effects adicione caracteres e números de sublinhado a vários nomes quando cria o arquivo XFL.

Quando o Flash Professional cria um documento FLA de um arquivo XFL que inclui arquivos FLV, os arquivos FLV são incorporados à linha de tempo no Flash. Geralmente, um modo mais eficiente de criar um documento FLA é mover arquivos de vídeo para um local externo referenciado pelo arquivo SWF para transmitir vídeo. É possível desincorporar arquivos FLV como apropriado no Flash Professional, excluindo o vídeo e importando-o novamente usando o componente FLVPlayback.

Observação:

No After Effects, a linha de tempo da composição começa no Quadro 0. No Flash Professional, a linha de tempo começa no Quadro 1. Essa diferença faz com que a linha de tempo da composição do After Effects e a linha de tempo do Flash correspondente parecem estar deslocadas uma da outra por um quadro.

No After Effects, uma composição pode ter taxas de proporção de pixels diferentes de 1,0 (pixels quadrados). O Flash Professional suporta apenas uma taxa de proporção de pixels de 1.0. Quando uma composição for exportada para o formato XFL, o documento FLA é um documento de pixels quadrado com um número diferente de pixels para que a aparência do documento no Flash Professional corresponda à aparência da composição no After Effects. Os valores de escala no arquivo XFL preservam a aparência das camadas.

Como os recursos e os dados são preservados ao exportar uma composição para o formato XFL

Quando uma composição é exportada como um arquivo XFL, o After Effects passa por fases múltiplas, tentando em cada estágio exportar a quantidade de informações máxima de camadas e dos arquivos de origem.

Se a composição usa arquivos PNG, JPEG e FLV como fontes para suas camadas, os arquivos de origem são inclusos em XFL saída (passado completa) a menos que as camadas usem recursos que forçam o After Effects a transcodificar os arquivos de origem ou para rasterizar as camadas para exportar para XFL.

Observação:

A transcodificação é a conversão de um arquivo de origem de um formato para outro formato, como GIF para PNG. A rasterização é a conversão de uma camada em uma imagem de bitmap, incorporando todas as informações do modelo (como vetores e quadros-chave) em uma imagem nivelada, baseada em pixel em cada quadro.  

Estágio 1: Os arquivos de origem são transmitidos com inalterações, se possível.

Para que o arquivo de origem de uma camada seja passado para o arquivo XFL, a camada deve atender a esses requisitos:

  • A camada tem um item de gravação de origem, e esse item de gravação usa uma sequência de PNG ou arquivo JPEG ou FLV como sua origem. (A camada não é uma camada de texto, camada de câmera, camada de luz ou camada de forma.)

  • A taxa de quadros do item de gravação de origem corresponde à taxa de quadros da composição.

  • A origem da camada não está aparada.

  • A camada não estende antes do primeiro quadro ou o último quadro do espaço de trabalho da composição.

  • A camada não tem propriedades além de Posição, Ponto de ancoragem, Opacidade, Escala e Rotação. Como os efeitos adicionam propriedades às camadas, esse requisito também significa que ela não tem nenhum efeito aplicado.

  • A camada não tem desfoque de movimento, mesclagem de quadros ou remapeamento de tempo aplicado.

  • A camada não tem um fosco de controle.

  • Não há camadas de ajuste acima da camada.

  • As camadas acima não usam modos de mesclagem diferentes do Normal.

  • A camada não tem a opção Preservar Transparência definida, nem nenhuma camada acima dela.

  • A camada não é uma camada 3D.

Estágio 2: Os arquivos de origem restantes são convertidos em sequências PNG ou arquivos FLV, se possível.

Se a único motivo de um arquivo de origem de uma camada não poder ser transmitido para o arquivo XFL é que não usa uma sequência de PNG, sequência JPEG, ou FLV como sua origem, então a origem de um camada é transcodificada ou rasterizada em uma sequência de PNG ou arquivo FLV, que seja incluída no arquivo XFL. Em esse caso, os quadros-chave Posição, Opacidade, Escala e Rotação são preservados e convertidos em quadros-chave na saída XFL. Se várias camadas usam a mesma origem no After Effects e atendem todos os requisitos de passagem listados acima, também compartilharão de uma origem comum no documento criado no Flash Professional. As pré-composições podem ser rasterizadas como itens de origem.

O arquivo XFL criado a partir de uma composição preserva as informações de animação das camadas na composição. Os quadros-chave nas propriedades Posição, Opacidade, Escala e Rotação são convertidos em quadros-chave no Flash Professional, com um quadro-chave por quadro para cada propriedade animada. Apenas os quadros-chave Somente posição 2D (x e y) Rotação 2D (z) são convertidos.

No After Effects, a propriedade Ponto de ancoragem pode ser animado, mas o ponto de transformação no Flash Professional não pode ser animado. No Flash Professional, o ponto de transformação está localizado no canto superior esquerdo do símbolo. As animações de quadros-chave das propriedades de transformação (incluindo Ponto de ancoragem) no After Effects são convertidos em animações com base no centro de transformação no arquivo exportado XFL.

Estágio 3: As camadas restantes são rasterizadas como camadas individuais, se possível.

Se uma camada não atende aos requisitos para o arquivo de origem ser transmitido, transcodificado, ou rasterizado como um item de origem, a própria camada deve ser rasterizada como uma camada. Rasterizar uma camada significa que todas as informações do quadro-chave serão perdidas – todas as informações contidas nos próprios quadros da imagem rasterizada.

Para ser rasterizada como uma camada individual, uma camada deve atender a esses requisitos:

  • A camada baseia-se em um item de gravação de vídeo (incluindo um sólido) ou é uma camada de forma ou camada de texto. (A camada não é uma camada da câmera, camada de luz ou camada apenas de áudio.)

  • Não há camadas de ajuste acima da camada.

  • As camadas acima não usam modos de mesclagem diferentes do Normal.

  • A camada não tem um fosco de controle.

  • A camada não tem a opção Preservar Transparência definida, nem nenhuma camada acima dela.

  • A camada não é uma camada 3D.

Estágio 4: As restantes camadas serão renderizadas e rasterizadas em conjunto em compartimentos.

Se uma camada não atende aos requisitos de rasterização de uma camada individual, então será renderizada e rasterizada em conjunto com outras camadas em um grupo (compartimento). Os compartimentos de camadas que são rasterizados em conjunto são geralmente camadas 3D, camadas compostas em conjunto com modos de mesclagem, foscos de controle e camadas afetadas por uma camada de ajuste.

Limitações de exportação de uma composição para o formato XFL

Quando o Flash Professional abre um arquivo XFL, ele deve carregar todos os recursos para a memória. O After Effects o avisa quando você exportar uma composição para a qual dos ativos consumirão mais de 580 MB. Similarmente, o After Effects o avisa se o tempo que um arquivo XFL leva para abrir no Flash Professional é muito longo porque o número de quadros em uma sequência de PNG é maior que 1.050. Ainda é possível exportar uma composição para o formato XFL se exceder os limites, mas talvez não seja possível abrir o arquivo XFL com o Flash Professional.

Observação:

Para evitar os tempos de carregamento longos e relacionados a sequências com um grande número de arquivos PNG, considere pré-renderizar camadas com base em sequências PNG para o formato FLV.

O After Effects se baseia na versão incorporada do Adobe Media Encoder para criar arquivos FLV. O Adobe Media Encoder não pode criar arquivos FLV com dimensões de pixel maiores que 1920x1080.

Ao exportar uma composição para o formato XFL de um projeto de 32 bpc, a renderização de cores com valores abaixo de 0 e acima de 1 não produz os resultados que preservam a aparência da composição no After Effects. Você só deve trabalhar em um projeto de 8 bpc ou 16 bcp ao criar uma composição que você pretende exportar o Flash Professional no formato XFL.

O áudio não é exportado para o arquivo XFL.

Renderizar e exportar uma composição como um arquivo SWF

Os arquivos SWF são pequenos arquivos que podem ser reproduzidos no Flash Player. Eles são geralmente usados para enviar gráficos vetoriais animados (como cartoons), áudio e outros tipos de dados pela Internet. Os arquivos SWF também permitem interação com o visualizador, como um clique para seguir um link da Web, controlar a animação ou fornecem informações a um aplicativo de Internet avançado (RIA). Os arquivos SWF são o resultado gerado pelos arquivos FLA.

Ao renderizar e exportar um filme para um arquivo SWF, o After Effects mantém gráficos vetoriais como objetos de vector sempre que possível. Contudo, as imagens rasterizadas, modos de mesclagem, desfoque de movimento, alguns efeitos e os conteúdos de composições aninhadas não podem ser representados como vetores no arquivo SWF e são rasterizados.

É possível ignorar esses itens não suportados para que o arquivo SWF inclua somente os recursos do After Effects que podem ser convertidos em elementos SWF nativos, ou é possível rasterizar os quadros que contêm recursos sem suporte e adicioná-los ao arquivo SWF como imagens compactadas de bitmap JPEG, o que pode reduzir a eficiência do arquivo SWF.

O áudio é codificado no formato MP3 e adicionado ao arquivo SWF como um fluxo de áudio.

Quando o After Effects cria um arquivo SWF, também salva um relatório ([SWFfile_name]R.htm) para a mesma pasta que o arquivo SWF. O relatório também contém um link para o arquivo SWF para que você possa visualizar a saída usando o plug-in Flash Player. Abra o relatório em um navegador para visualizar o arquivo SWF e exibir os itens na composição não são suportados.

O arquivo SWF exportado inclui cada item alterado em uma composição do After Effects uma vez e depois referencia-o para cada uso. Se uma camada é usada em vários quadros, cada uso refere-se ao mesmo objeto, mesmo se as propriedades de transformação da camada (como Posição) forem animadas. Contudo, se o conteúdo da camada mudar – por exemplo, se uma máscara na camada for animada ou se o item de gravação de origem da camada for vídeo – um novo objeto é criado para cada quadro no qual a camada é visível. Se várias camadas na composição compartilham o mesmo item da gravação de origem, a origem será adicionada uma vez e depois referenciada para cada camada adicional que compartilha a origem. Se a origem for um arquivo do Illustrator, um clipe de filme SWF é criado e referenciado. Os caracteres de texto são adicionados como vetores uma vez e depois referenciados em todos os quadros subsequentes, a menos que você escolha a opção Preenchimento sobre traçado no menu de opções Preenchimento e traçado; em esse caso, os caracteres são adicionados como vetores em cada quadro.

Observação:

Se o gerenciamento de cores estiver ativado para o projeto, as cores são convertidas do espaço de cores de trabalho do projeto para o espaço de cores sRGB IEC61966-2.1 para a saída. Este espaço de cores de saída é adequado para filmes exibidos em um navegador. (Consulte Gerenciamento de cores.)

  1. Selecione a composição que deseja exportar e escolha Arquivo > Exportar > Adobe Flash Player (SWF).
  2. Digite um nome de arquivo (se certifique que inclui a extensão .swf) e o local e depois clique em Salvar.
  3. Especifique as opções conforme necessário e clique em OK.

Chris Jackson fornece dicas sobre a renderização e a exportação de arquivos SWF do After Effects em um trecho do seu livro Flash + After Effects no site da Focal Press.

Configurações de exportação de SWF

Qualidade JPEG

Especifica a qualidade de imagens rasterizadas. Quanto melhor a qualidade, maior será o arquivo. (Se você selecionar Rasterizar para recursos sem suporte, a configuração de qualidade JPEG é usada para as imagens de bitmap compactadas JPEG exportadas para o arquivo SWF, incluindo as imagens bitmap geradas a partir dos quadros da composição ou arquivos do Adobe Illustrator.)

Recursos sem suporte

Especifica se deve rasterizar os recursos sem suporte pelo formato SWF. Escolha Ignorar para excluir recursos sem suporte, ou escolha Rasterizar para renderizar os quadros que contêm recursos sem suporte como imagens de bitmap compactadas JPEG e inclui-los no arquivo SWF. Caso escolha Rasterizar, o exportador SWF rasteriza os arquivos de origem para cada camada nas composições (exceto camadas que usam arquivos ou sólidos do Illustrator como a gravação de origem) e composições aninhadas com a opção Recolher transformações ativada.

Taxa de bits de áudio

A taxa de bits do áudio exportado. Escolha Automático para obter a menor taxa de bits disponível para as configurações Taxa de amostragem e canais. As taxa de bits mais altas aumentam o tamanho do arquivo. O áudio em um arquivo SWF está no formato MP3.

Executar em loop continuamente

Especifica que o arquivo SWF exportado executa repetição continuamente durante a reprodução. Se você planejar especificar uma repetição gravando código HTML no Flash Player, desmarque Executar em loop continuamente.

Impedir edição

Cria um arquivo SWF que não pode ser modificado por aplicativos como o Flash Professional.

Incluir nomes de objetos

Inclui camada, máscara e nomes de efeito no arquivo, para uso como entrada para programas ActionScript. Selecionar essa opção aumenta o tamanho do arquivo. Objetos rasterizados não são nomeados.

Cada máscara é exportada como um objeto SWF separado, cujo nome é o nome da camada e depois o nome da máscara. Se todas as máscaras usando o modo Diferença, todas as máscaras são exportadas como um objeto SWF e o nome é o nome da camada. Cada caractere de texto é exportado como um objeto SWF separado.

Nivelar arte do Illustrator

Divide todos os objetos sobrepostos em partes não sobrepostas. Ao selecionar essa opção, não é necessário converter o texto do Illustrator em contornos antes de exportar. (Essa opção oferece suporte a arquivos de origem do Illustrator 9.0 ou posterior.)

Nivelar arte do Illustrator tem vantagens e desvantagens. Ao nivelar arte do Illustrator, o texto é exportado para o formato SWF adequadamente, por isso não é necessário converter o texto em contornos. Os objetos sobrepostos são removidos, por isso as camadas compostas têm a mesma aparência no After Effects e no arquivo SWF. As extremidades finais, junções e grupos de transparência são exportados corretamente e a arte fica fora das marcas de corte, que não é visível no arquivo SWF, não é incluída. Contudo, os arquivos SWF não ficam necessariamente menores. Além disso, o processo de nivelamento pode inserir objetos sem suporte que são ignorados ou rasterizados e halos branco podem aparecer em torno dos objetos. O processo pode ser lento, ocupar muita memória e, possivelmente ineficaz para trabalho artístico complexo do Illustrator.

Incluir links da Web do Marcador de camada

Faz os marcadores de camada se comportarem como links da Web. A opção Incluir links da Web do Marcador de camada adiciona links da Web e uma ação Obter URL ao arquivo SWF com as informações dos marcadores de camada. Essa opção também adiciona um rótulo de quadro para cada quadro SWF que contém um marcador de camada. Você pode especificar como o navegador abre o link da Web com comandos padrão de destino (por exemplo, _blank). (Consulte Links da Web, links de capítulo, pontos de sinalização e marcadores.)

_blank

Carrega o link da Web em uma nova janela do navegador.

_parent

Carrega o link da Web no quadro pai do quadro no qual o arquivo atual está sendo reproduzido.

_self

Carrega o link da Web no quadro atual.

_top

Carrega o link da Web no quadro superior na janela atual.

_level0

Carrega outro arquivo SWF no nível 0. O arquivo atual é reproduzido no nível 0; outro arquivo carregado no nível 0 substituirá geralmente o arquivo atual. O URL deve referir outro arquivo SWF.

_level1

Carrega um arquivo SWF no nível 1 se o URL se referir a outro arquivo SWF.

Recursos suportados para exportação do formato SWF

Camadas

As camadas de texto After Effects são exportadas para o formato SWF como gráficos vetoriais. Os seguintes tipos de camada e opções de camada não são suportados: foscos de controle, camadas 3D, câmeras 3D, luzes 3D, camadas de ajuste, camadas de forma, Preservar transparência, Recolher transformações e desfoque de movimento. A opção de caracteres Preenchimento sobre traçado e a propriedade de animador Desfoque não são suportadas e somente o modo de mesclagem Normal é suportado. As composições aninhadas não são suportadas e rasterizadas.

Máscaras

Apenas as máscaras com o modo de máscara Adicionar ou modo de máscara Diferença são suportadas; as várias máscaras em uma camada devem usar o mesmo modo da máscara. Se Adicionar modo estiver especificado, a opacidade parcial e a opção Invertida também são suportadas. A Difusão da máscara não é suportada. O resultado de máscaras de sobreposição com o modo Adicionar e a opacidade parcial podem parecer diferentes no arquivo SWF que no After Effects. (Consulte Modos de máscara.)

Efeitos

Texto do caminho, Forma de onda de áudio e Espectro de áudio são suportados para saídas no formato SWF.

Todas as Texto do caminho são suportadas, exceto as seguintes: Composto sobre o original, Preenchimento sobre traçado e Diferença.

As linhas desenhadas pelos efeitos Espectro de áudio e Forma de onda de áudio são convertidas em vetores. Os seguintes recursos sem suporte são ignorados: Cor externa (apenas se Cor interna é usada), Suavização e Composto sobre o original. Além disso, apenas as linhas uniformemente finas são incluídas no arquivo SWF. Por exemplo, se você selecionar a opção Usar caminho polar no Espectro de áudio, as linhas ficarão mais espessas mais distantes do centro no After Effects, mas o arquivo SWF as linhas permanecem na mesma espessura.

As formas de onda podem aumentar o tamanho do arquivo SWF, por isso reduza o valor Amostras exibidas no efeito Forma de onda de áudio ou o valor Bandas de frequência no efeito Espectro de áudio, ou diminua a taxa de quadros para que o arquivo SWF seja menor.

Resolução

Os arquivos SWF são sempre criados em resolução total (tamanho de composição); as imagens de bitmap compactadas JPEG são renderizadas em resolução total.

Arquivos do Adobe Illustrator

Somente os caminhos traçados e caminhos preenchidos nos espaços de cores CMYK ou RGB são suportados.

As camadas com arquivos de origem do Illustrator são convertidas em itens SWF correspondentes se a camada não contiver máscaras ou tiver a opção Recolher transformações ativada. As camadas do Illustrator que contêm máscaras ou têm a opção Recolher transformações ativada são rasterizadas. O arquivo SWF mantém as marcas de corte do Illustrator. A arte-final fora das marcas de corte estão incluídas no arquivo SWF mesmo que não seja visível, aumentando assim o tamanho do arquivo.

O relatório de exportação de SWF lista informações de recursos sem suporte nos arquivos do Illustrator para o primeiro quadro em que o arquivo do Illustrator é visível. Os recursos sem suporte são ignorados ou rasterizados (dependendo se a opção Ignorar ou Rasterizar recursos está selecionada) em todos os quadros em que a gravação é visível.

Renderizar e exportar uma composição como um arquivo FLV ou F4V

Os arquivos FLV e F4V contêm apenas vídeo (rasterizado) baseado em pixel e não gráficos vetoriais, e eles não são interativos.

Os formatos FLV e F4V são formatos de contêiner, cada qual associado a um conjunto de formatos de vídeo e de áudio. Os arquivos FLV geralmente contêm dados de vídeo que são codificados usando o codec de vídeo On2 VP6 e dados de áudio codificados usando um codec de áudio MP3. Os arquivos F4V geralmente contêm dados de vídeo que são codificados usando codec de vídeo H.264 e codec de áudio AAC.

Observação:

O After Effects CS4 e anterior também fornecia a opção para codificar dados de vídeo em arquivos FLV usando o codec de vídeo Sorenson Spark.

É possível reproduzir um arquivo de contêiner FLV ou F4V de várias formas diferentes, incluindo:

  • Importe o arquivo para o aplicativo Flash Professional e publique o vídeo em um arquivo SWF.

  • Reproduza o filme no Adobe Media Player (AMP).

  • Visualize o filme usando o Adobe Bridge.

Observação:

Podem ser incluídos marcadores do After Effects como pontos de sinalização em um arquivo FLV ou arquivo F4V de saída. Para transferir quadros-chave ou valores de propriedade globais para o aplicativo Flash Professional do After Effects, execute o script Convert Selected Properties To Markers.jsx antes de renderizar e exportar um arquivo FLV ou F4V.

Você renderiza e exporta um filme para o formato de contêiner FLV ou F4V usando a fila de renderização, assim como faz com outros formatos. (Consulte Renderizar e exportar um filme usando a fila de renderização.)

Para incluir o canal alfa na saída FLV, use o codec On2 VP6 e selecione Codificar canal alfa na guia Vídeo da caixa de diálogo de configurações da exportação. O After Effects pré-multiplica os canais com preto quando codifica a transparência nos arquivos FLV. (Consulte Interpretação do canal alfa: pré-multiplicado ou simples.)

Ao renderizar e exportar uma composição para o formato F4V ou FLV de um projeto de 32 bpc, a renderização de cores com valores abaixo de 0 e acima de 1 não produz os resultados que preservam a aparência da composição no After Effects. Para evitar resultados inesperados, você pode trabalhar em um projeto de 8 bcp ou 16 bcp ao criar uma composição que você pretende renderizar e exportar para o formato F4V ou FLV. Como alternativa, você pode trabalhar em um projeto de 32 bpc, renderizar e exportar a composição para outro formato e depois converter o arquivo de saída para F4V ou FLV.

Recursos online sobre formatos FLV e F4V

Este vídeo da série After Effects CS5: Learn By Video demonstra a exportação para formatos FLV e F4V.

Jan Ozer fornece detalhes técnicos e dicas em “Encoding options for H.264 video” no site Adobe Developer Connection para codificar vídeo usando o codec de vídeo H.264.

Kush Amerasinghe fornece uma visão geral do H.264 e F4V em “H.264 for the rest of us” no site Adobe Developer Connection.

Roberto Reinhardt fornece informações sobre o vídeo do Flash Player em alguns capítulos de amostra do vídeo do livro Video with Adobe Flash CS4 Professional Studio Techniques no site da Peachpit. No capítulo “Compression primer”, ele descreve detalhadamente as vantagens e desvantagens dos codecs de vídeo On2VP6 e H.264.

Mais informações sobre os formatos FLV e F4V, incluindo a especificação F4V, estão disponíveis no site Developer Connection Adobe.

Fabio Sonnati fornece recomendações sobre configurações para filmes H.264 (F4V) para dispositivos móveis no site Adobe Developer Connection.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online