Di seguito potete trovare maggiori informazioni sui punti di interruzione. Scoprite come rissare e ridimensionare gli oggetti per un layout dinamico e per formattare il testo con punti di interruzione.

Nota:

Non verranno più aggiunte ulteriori funzioni ad Adobe Muse, e il supporto verrà sospeso a partire dal giovedì 26 marzo 2020. Per ulteriori informazioni e assistenza, consultate la pagina dedicata alla fine del ciclo di vita di Adobe Muse.

In un design dinamico, un singolo layout potrebbe non essere adatto a tutte le possibili dimensioni di schermo. È possibile che immagini, testo, widget e moduli vengano riposizionati per altri punti di interruzione. Le cornici degli elementi potrebbero non rientrare nella larghezza della pagina, alcuni oggetti potrebbero sovrapporsi e il testo potrebbe risultare meno leggibile. Immagini, testo, widget e moduli devono quindi essere riposizionati per altri punti di interruzione. È importante disporre gli oggetti e formattare il testo con molta cura, tenendo conto che verranno visualizzati su schermi diversi. 

Dopo aver progettato la pagina, potete usare il cursore di scorrimento per visualizzare un’anteprima del layout a varie dimensioni dello schermo. Se è necessario disporre gli oggetti in maniera diversa per una specifica larghezza della finestra del browser, aggiungete dei punti di interruzione.

Di seguito viene descritta la funzionalità dei punti di interruzione e spiegato come progettare un layout dinamico efficace in Adobe Muse.

Cosa sono i punti di interruzione?

I punti di interruzione di un layout dinamico rappresentano diverse larghezze del browser, in pixel. Utilizzando come riferimento i punti di interruzione, potete visualizzare la pagina che state creando con dimensioni di finestra del browser diverse e verificare cosa accade ai vari oggetti quando si cambia la larghezza del browser.

Aggiungere i punti di interruzione

Per impostazione predefinita, un nuovo sito in Adobe Muse contiene un punto di interruzione per computer desktop (larghezza: 960 pixel). Potete iniziare a progettare il layout da questa larghezza. Una volta completata la progettazione, potete visualizzare l’anteprima del layout con diverse larghezze utilizzando il cursore di scorrimento. In questo modo, potete visualizzare e registrare la larghezza in cui si verificano problemi di layout, come ad esempio una riga di testo divisa in due o immagini originariamente in fila visualizzate in verticale. Queste sono le larghezze in cui sono necessari ulteriori punti di interruzione. Dopo aver aggiunto i punti di interruzione necessari, potete regolare la progettazione in modo che gli oggetti vengano disposti in modo ordinato.

Per ogni punto di interruzione, Adobe Muse aggiunge alla pagina Web una dichiarazione di query corrispondente. Si tratta di un modulo CSS3 che consente il rendering dei contenuti per diverse dimensioni di schermo. La maggior parte dei browser più recenti sono in grado di interpretare le query che corrispondono a questi punti di interruzione. Quando gli utenti visualizzano la pagina Web su dispositivi diversi, i browser riconoscono e visualizzano la query più appropriata e il layout corrispondente.

  1. Trascinate il cursore della barra dei punti di interruzione fino a dove desiderate aggiungere il punto di interruzione.

  2. Fate clic su sulla barra dei punti di interruzione. Un nuovo punto di interruzione viene aggiunto alla barra e viene riportata la larghezza del browser corrispondente.

    Aggiungete altri punti di interruzione sulla barra dei punti di interruzione, per impostare specifiche larghezze del browser.

    Quando fate clic su un punto di interruzione, questo diventa attivo e colorato. Gli altri punti di interruzione sono visualizzati in grigio.

    Nota:

    potete inoltre aggiungere dei punti di interruzione inserendo elementi di libreria con punti di interruzione nella vista Progettazione. Aprite il pannello Libreria, selezionate l'oggetto che desiderate inserire, fate clic sul simbolo + accanto all'oggetto e trascinate l'oggetto in vista Progettazione.

Dove è meglio aggiungere i punti di interruzione?

Potete aggiungere i punti di interruzione sia alle pagine mastro che alle singole pagine. Se aggiungete i punti di interruzione a una singola pagina, i valori corrispondenti vengono applicati solo a quella specifica pagina.

Quando aggiungete i punti di interruzione su una pagina mastro, potete poi scegliere quali applicare alle singole pagine. I punti di interruzione della pagina mastro sono rappresentati da triangolini sulle singole pagine. È sufficiente fare clic sul segno più (+) per attivare i punto di interruzione corrispondenti sulle singole pagine.

Punti di interruzione della pagina mastro
Fate clic su + per aggiungere i punti di interruzione alla pagina mastro.

Considerate il seguente scenario. Mentre create il layout del sito, potete aggiungere i punti di interruzione specifici per smartphone. Se li aggiungete sulla pagina mastro, verranno riportati anche sulle singole pagine e all’occorrenza potrete aggiungerli a specifiche pagine con un singolo clic.

Nota:

quando applicate una pagina mastro diversa a una pagina singola, i punti di interruzione provenienti dalla pagina mastro precedente vengono sostituiti con quelli della nuova pagina mastro.

Modificare i punti di interruzione

  1. Nella barra dei punti di interruzione, trascinate il cursore di scorrimento fino al valore del punto di interruzione desiderato. Questo corrisponde alla nuova posizione del punto di interruzione.

  2. Per visualizzare o modificare il colore del punto di interruzione, fate clic su di esso con il pulsante destro del mouse e selezionate Proprietà punto di interruzione.

    In questa finestra di dialogo potete modificare anche il colore del punto di interruzione, nonché la larghezza, l’altezza e il margine della pagina.

    Proprietà dei punti di interruzione per visualizzare e modificare colore e margini del punto di interruzione
    Modificate il colore e i valori del punto di interruzione nella finestra di dialogo Proprietà punto di interruzione.

  3. Fate clic su OK per salvare le impostazioni.

Nota:

non è possibile modificare i punti di interruzione della pagina mastro da una pagina singola.

Eliminare i punti di interruzione

  1. Per eliminare un punto di interruzione, effettuate una delle seguenti operazioni:

    • Fate clic sulla X a sinistra del punto di interruzione attivo.
    • Fate clic con il pulsante destro del mouse sulla barra dei punti di interruzione e selezionate Elimina punto di interruzione.

    Quando eliminate un punto di interruzione, vengono eliminate anche le modifiche di layout corrispondenti e le impostazioni del testo.

    Eliminare i punti di interruzione
    Fate clic sul simbolo x per eliminare il punto di interruzione.

    Eliminare i punti di interruzione mediante clic con il pulsante destro del mouse
    Fate clic con il pulsante destro del mouse ed eliminate i punti di interruzione.

    Nota:

    non è possibile eliminare un punto di interruzione della pagina mastro da una pagina singola.

Passare da un punto di interruzione all’altro

Dal punto di interruzione corrente, è possibile passare a quello successivo o precedente. Effettuate le seguenti operazioni:

  • Windows:
    • Punto di interruzione precedente: premete Ctrl + Maiusc + 5
    • Punto di interruzione successivo: premete Ctrl + Maiusc + 6
  • Utenti Mac OS:
    • Punto di interruzione precedente: premete Comando + Maiusc + 5
    • Punto di interruzione successivo: premete Comando + Maiusc + 6

Operazioni con gli oggetti in un layout dinamico

Utilizzate le seguenti opzioni per assicurarvi che il layout sia corretto per tutti i punti di interruzione:

  • Mostrare/Nascondere gli oggetti: potete nascondere un oggetto per un punto di interruzione e scegliere invece di mostrarlo per un altro. Per ulteriori informazioni, consultate Mostrare o nascondere gli oggetti.
  • Posizionare gli oggetti diversamente in altri punti di interruzione: un oggetto può trovarsi in posizioni diverse nei vari punti di interruzione. Per ulteriori informazioni, consultate Posizionare gli oggetti nel Web design dinamico.
  • Bloccare gli oggetti nei siti dinamici: scegliete quali oggetti devono essere statici quali devono essere invece fluidi. Potete quindi fissare gli oggetti statici in modo che restino sempre nella stessa posizione, per tutti i punti di interruzione. Per ulteriori informazioni, consultate Bloccare gli oggetti nei siti dinamici.
  • Ridimensionare gli oggetti: potete ridimensionare un oggetto in modo diverso per ciascun punto di interruzione. Potete inoltre impostare un oggetto per il ridimensionamento automatico in base alla larghezza della pagina. Per ulteriori informazioni sul ridimensionamento degli oggetti, consultate Ridimensionare gli oggetti.
  • Formattare il testo per i diversi punti di interruzione: per rendere il testo chiaro e leggibile sui diversi schermi, potete specificare un formato diverso per ogni punto di interruzione. Per ulteriori informazioni, consultate Formattazione del testo nei layout dinamici.

Mostrare o nascondere gli oggetti

Considerate questo scenario: avete aggiunto un menu tradizionale per un sito destinato a essere visualizzato su computer desktop. Tuttavia, questo menu occupa troppo spazio sui display dei tablet. Per dispositivi tablet sono più indicati i menu di tipo sandwich o i pannelli a soffietto.

Con Adobe Muse, è semplice gestire tali situazioni durante la progettazione dei siti Web dinamici. Potete scegliere di visualizzare un menu tradizionale per la visualizzazione su computer desktop e un menu di tipo sandwich per i dispositivi tablet, come illustrato di seguito.

Mostrare o nascondere gli oggetti nel layout dinamico
Nella visualizzazione su computer desktop potete mostrare il menu tradizionale e nascondere quello di tipo sandwich.

Mostrare o nascondere gli oggetti nel layout dinamico
Nella visualizzazione su dispositivo mobile potete mostrare il menu di tipo sandwich e nascondere quello tradizionale.

Per mostrare o nascondere gli oggetti nel progetto Adobe Muse:

  1. Inserite tutti gli oggetti necessari, inclusi quelli che dovranno essere nascosti per alcuni punti di interruzione.

  2. Trascinate il cursore di scorrimento per passare alla vista di un determinato punto di interruzione.

  3. Fate clic con il pulsante destro del mouse sull’oggetto da nascondere e fate clic su Nascondi in punto di interruzione.

    L’oggetto viene nascosto nella visualizzazione dell’attuale punto di interruzione, ma resta visibile negli altri punti di interruzione. Se desiderate invece nascondere l’oggetto in tutti gli altri punti di interruzione, fate clic su Nascondi in altri punti di interruzione. Successivamente sarà possibile renderlo visibile per punti di interruzione specifici mediante il pannello Livelli.

    Nascondere gli oggetti in alcuni punti di interruzione
    Nascondere gli oggetti in alcuni punti di interruzione

    A questo punto, disponete gli oggetti visibili nella visualizzazione del punto di interruzione.

  4. Passate alla visualizzazione del punto di interruzione in cui desiderate mostrare l’oggetto precedentemente nascosto, trascinando il cursore di scorrimento.

  5. Fate clic sul pannello Livelli e individuate il livello su cui si trova l’oggetto da mostrare. Potrebbe essere necessario accedere a livelli secondari, fino a individuare quello dell’oggetto.

    Mostrare o nascondere gli oggetti tramite il pannello Livelli
    Utilizzare il pannello Livelli per nascondere o mostrare gli oggetti

  6. Fate clic sulla prima colonna corrispondente al livello dell’oggetto. Un piccolo punto nero indica che l’oggetto è ora visibile nella visualizzazione del punto di interruzione corrente.

    Fate clic per mostrare o nascondere gli oggetti
    Fate clic sulla prima colonna per mostrare o nascondere gli oggetti.

    Per mostrare l’oggetto per tutti i punti di interruzione, fate clic su di esso con il pulsante destro del mouse e scegliete Mostra in altri punti di interruzione.

Posizionare gli oggetti

Gli oggetti possono occupare posizioni diverse nei diversi punti di interruzione. Ad esempio, potete posizionare le immagini in orizzontale nella visualizzazione per computer desktop e in verticale nella visualizzazione per dispositivi mobili.

Adobe Muse ricorda la posizione degli oggetti e la visualizza di conseguenza in base alle dimensioni dello schermo.

Disporre gli oggetti per la visualizzazione da computer desktop
Disponete gli oggetti in orizzontale per la visualizzazione da computer desktop.

Disporre gli oggetti per la visualizzazione da dispositivo mobile
Disponete gli oggetti in verticale per la visualizzazione da dispositivo mobile.

Per spostare gli oggetti tra diversi punti di interruzione, effettuate le seguenti operazioni:

  1. Selezionate il punto di interruzione per il quale desiderate posizionare l’oggetto.

  2. Trascinate l’oggetto nella posizione desiderata.

    Nota:

    quando disponete gli oggetti, ricordate di controllare la distanza tra di essi e tra gli oggetti e il bordo del browser. Potrebbe essere necessario regolare la posizione degli oggetti o aggiungere altri punti di interruzione per risolvere eventuali problemi di design tra un punto di interruzione e un altro.

Spostamento di più oggetti come gruppo

Potete spostare un gruppo di oggetti insieme nel layout dinamico. Per spostare un gruppo di oggetti allineati in verticale, è sufficiente selezionare l’oggetto superiore. Nel margine sinistro in Adobe Muse compare la maniglia verticale.

Maniglia di spostamento verticale in Adobe Muse
Spostate un gruppo di oggetti allineati in verticale.

Quando fate clic su questa maniglia e la spostate verso l’alto o il basso, l’oggetto selezionato e tutti gli oggetti al di sotto di esso vengono spostati in gruppo.

Posizionare gli oggetti con punti di interruzione

Potete aggiungere un insieme di punti di interruzione inserendo un elemento di libreria con punti di interruzione in vista Progettazione. Aprite il pannello Libreria (Finestra > Libreria). Selezionate l'elemento da aggiungere alla pagina. Fate clic sul simbolo più accanto all'elemento e trascinatelo nella vista Progettazione.

Aggiungere punti di interruzione con elementi di libreria
Selezionate il simbolo + per posizionare gli oggetti con punti di interruzione

Notate un insieme di punti di interruzione che vengono aggiunti automaticamente alla pagina. Se avete già aggiunto dei punti di interruzione alla pagina e aggiungete un elemento di libreria con punti di interruzione, tutti i punti di interruzione vengono attivati nella pagina.

Potete utilizzare gli elementi di libreria con punti di interruzione per riprodurre rapidamente i punti di interruzione tra pagine diverse e persino tra file .muse diversi.

Fissare gli oggetti

In Adobe Muse, potete fissare determinati oggetti per renderli statici. Gli oggetti possono essere fissati rispetto alla pagina o al browser:

  • Fissare gli oggetti alla finestra del browser: potete fissare un oggetto al browser in modo da renderlo permanente anche quando si usa la barra di scorrimento del browser. Questo è utile, ad esempio, per fissare una barra di menu che dovrà restare sempre nella stessa posizione, anche quando il visitatore fa scorrere la pagina verso l’alto o il basso. Per ulteriori informazioni su come fissare gli oggetti alla finestra del browser, visitate questo collegamento.
  • Fissare gli oggetti alla pagina: è possibile fissare un oggetto in una pagina in modo che resti sempre nella stessa posizione rispetto alla pagina Web. Questo è utile, ad esempio, per fare sì che il logo dell’azienda resti sempre nell’angolo in alto a destra della pagina Web.

Di seguito viene descritto come fissare un oggetto in una pagina con layout dinamico.

Nota:

per determinare se fissare o meno un oggetto, utilizzate il cursore di scorrimento per visualizzare la pagina con diverse larghezze della finestra del browser. Se pensate che sia necessario fissare un oggetto sulla pagina, effettuate le seguenti operazioni:

  1. Selezionate l’oggetto da fissare.

  2. Per l’opzione Fissa, in alto, selezionate una delle caselle per fissare l’oggetto nella pagina.

    Utilizzare l’opzione Fissa nella pagina in un design dinamico
    Utilizzate il menu Fissa per fissare gli oggetti in un layout dinamico.

  3. Fissate gli oggetti in una pagina in uno dei modi seguenti:

    • Fissa a sinistra : selezionate questa casella per fissare un oggetto al lato sinistro della pagina Web. La distanza tra il bordo del browser e il bordo sinistro dell’oggetto rimane costante.
    • Fissa al centro : selezionate questa casella per fissare un oggetto al centro della pagina Web. La distanza tra i bordi sinistro e superiore dell’oggetto e il bordo del browser rimane costante.
    • Fissa a destra : selezionate questa casella per fissare un oggetto al lato destro della pagina Web. La distanza tra il bordo del browser e il bordo destro dell’oggetto rimane costante.

    Ad esempio, se un pulsante di tipo Pre-ordina ora deve apparire nell’angolo destro della pagina per tutti i punti di interruzione, selezionate il pulsante e fissatelo a destra, come illustrato.

    Fate clic sulla casella per fissare l’oggetto a destra.
    Fate clic sulla casella a destra per fissare l’oggetto a destra.

    Quando fissate un oggetto in una pagina, Adobe Muse visualizza delle linee punteggiate che vanno dall’oggetto alla posizione in cui è stato fissato. Nell’immagine seguente, osservate la linea punteggiata che si estende fino al bordo destro della pagina: indica che l’oggetto è stato fissato al lato destro della pagina.

    Indicatore di Fissa nella pagina
    Una linea punteggiata indica la posizione in cui l’oggetto è stato fissato alla pagina.

  4. Utilizzate il cursore di scorrimento per visualizzare il layout alle diverse larghezze di pagina. Verificate che il blocco degli oggetti non interferisca con il layout della pagina, quando si ridimensiona la finestra.

Ridimensionare gli oggetti

  1. Passate alla visualizzazione del punto di interruzione in cui desiderate ridimensionare l’oggetto.

  2. Fate clic con il pulsante destro del mouse sull’oggetto e scegliete Ridimensiona > <opzione di ridimensionamento>.

    Nota:

    l’opzione di ridimensionamento dipende dal tipo di oggetto. Ad esempio, in un layout fluido un’immagine può essere ridimensionata per larghezza e altezza, mentre una casella di testo può essere ridimensionata solo per larghezza.

    Gli oggetti non fluidi non dispongono dell’opzione Ridimensiona.

  3. Trascinate e ridimensionate l’oggetto per il punto di interruzione corrente.

    Ad esempio, nella prima immagine, l’immagine non rientra nella larghezza in corrispondenza del punto di interruzione per 768 pixel. Potete trascinare e ridimensionare l’immagine in modo che si adatti alla larghezza della pagina, come illustrato nella seconda immagine.

    L’immagine non rientra nella larghezza della pagina.
    L’immagine non rientra nella larghezza della pagina.

    Ridimensionate gli oggetti per diversi punti di interruzione.
    Trascinate e ridimensionate gli oggetti per diversi punti di interruzione.

  4. Visualizzate un’anteprima dell’effetto ottenuto in un browser. Ridimensionate la finestra del browser fino al punto di interruzione. Osservate come cambiano le dimensioni dell’oggetto non appena lo schermo raggiunge il valore del punto di interruzione.

Nota:

gli elementi all’interno di un Pulsante stato o di un altro contenitore di widget impostati come elementi fluidi verranno riposizionati e/o ridimensionati insieme al relativo contenitore.

Copiare dimensioni e posizione degli oggetti

Per copiare le dimensioni e la posizione di un oggetto tra punti di interruzione diversi, effettuate le seguenti operazioni:

  1. Fate clic con il pulsante destro del mouse sull’oggetto da copiare.

  2. Effettuate una delle seguenti operazioni:

    • Scegliete Copia dimensioni e posizione in > [valore del punto di interruzione], per applicare le dimensioni e la posizione dell’oggetto al punto di interruzione specificato.
    • Scegliete Copia dimensioni e posizione in > Tutti i punti di interruzione, per applicare le dimensioni e la posizione dell’oggetto a tutti i punti di interruzione.

Formattazione del testo nei layout dinamici

Nella progettazione di siti Web dinamici, è importante gestire il testo per finestre browser di varie dimensioni, in modo che sia sempre chiaro e leggibile. Il testo inserito nella visualizzazione di un punto di interruzione potrebbe andare a capo bruscamente per un altro punto di interruzione. Si possono anche verificare interruzioni di riga indesiderate quando passate da un punto di interruzione all’altro.

Adobe Muse consente di formattare il testo in modo diverso per i vari punti di interruzione. Ad esempio, è possibile impostare la dimensione font su 20 punti per i tablet e 15 punti per i dispositivi mobili.

Formattare il testo per la visualizzazione su computer desktop
Formattare il testo per la visualizzazione su computer desktop

Formattare il testo per la visualizzazione su dispositivi mobili
Formattare il testo per la visualizzazione su dispositivi mobili

Per formattare il testo nella progettazione di siti Web dinamici, Adobe Muse offre un’icona di formattazione del testo nel pannello in cui si trovano gli strumenti taglierina e selezione. Questa icona dispone di due opzioni per formattare il testo.

Scegliete Formatta testo tra punti di interruzione per formattare il testo per tutti i punti di interruzione della pagina. Con questa opzione, è sufficiente formattare il testo per la visualizzazione di un solo punto di interruzione e il contenuto viene formattato automaticamente anche per tutti gli altri.

Se invece dovete formattare il testo per un punto di interruzione specifico, scegliete Formatta testo su punto di interruzione corrente. Ad esempio, potete aumentare la dimensione del testo a 24 punti per il layout destinato ai dispositivi mobili.

La formattazione del testo viene memorizzata e visualizzata a seconda della larghezza della finestra del browser su cui l’utente aprirà il sito.

Formattare il testo nei layout dinamici

  1. Passate alla vista del punto di interruzione richiesto.

  2. Selezionate la casella di testo e trascinate per ridimensionarla. Mentre ridimensionate la casella di testo, il testo scorre in base alle nuove dimensioni.

    Nota:

    il bordo destro della casella di testo definisce la larghezza di scorrimento del testo quando si ridimensiona la casella.

  3. Per formattare il testo, selezionatelo e fate clic su una delle seguenti opzioni:

    • Formatta testo tra punti di interruzione per formattare il testo per tutti i punti di interruzione.
    • Formatta testo su punto di interruzione corrente per formattare il testo solo per il punto di interruzione corrente.

    Entrambe queste opzioni sono disponibili nel pannello a sinistra quando è selezionato lo strumento testo o taglierina.

    Formattare il testo per i punti di interruzione
    Formattare il testo nei design dinamici

    A. Formatta testo tra punti di interruzione B. Formatta testo su punto di interruzione corrente 

    Nota:

    l’opzione Formatta testo nei design dinamici modifica solo la formattazione del testo. Non è possibile modificare le parole o il contenuto del testo per ciascun punto di interruzione.

Copiare la formattazione del testo tra diversi punti di interruzione

Per copiare le dimensioni e la posizione del testo in punti di interruzione o larghezze di browser diversi, effettuate le seguenti operazioni:

  1. Selezionate il testo da copiare.

  2. Effettuate una delle seguenti operazioni:

    • Fate clic con il pulsante destro del mouse sul testo e scegliete Copia formattazione testo in > [valore del punto di interruzione], per applicare gli attributi correnti del testo al punto di interruzione specificato.
    • Fate clic con il pulsante destro del mouse sul testo e scegliete Copia formattazione testo in > Tutti i punti di interruzione, per applicare gli attributi correnti del testo a tutti gli altri punti di interruzione.

    Utilizzando il cursore di scorrimento, osservate un’anteprima del layout ai vari punti di interruzione. Se necessario, aggiungete altri punti di interruzione per ottimizzare il layout per finestre del browser di larghezze differenti.

Applicazione di effetti di scorrimento in un layout dinamico

Potete aggiungere degli effetti di scorrimento a un layout dinamico. Gli effetti di scorrimento sono supportati solo per i punti di interruzione fissi. I punti di interruzione fissi indicano che il layout è fisso a quella larghezza di pagina. Aggiungete un punto di interruzione fisso, selezionate l’oggetto a cui desiderate applicare gli effetti di scorrimento, quindi configurate le impostazioni degli effetti di scorrimento.

  1. Aprite la pagina Adobe Muse in cui desiderate aggiungere l’effetto di scorrimento. Ad esempio, potete aggiungere gli effetti di scorrimento alla sezione di navigazione e all’immagine di sfondo nell’intestazione.

  2. Quando aprite il layout dinamico, osservate i punti di interruzione nella pagina: sono fluidi, come indicato dall’icona con frecce in entrambe le direzioni.

    Punti di interruzione fluidi
    I punti di interruzione fluidi sono rappresentati da una doppia freccia

    A questo punto nel pannello Effetti di scorrimento potete osservare che l’opzione è disattivata.

    Effetti di scorrimento disattivati per i punti di interruzione fluidi
    Gli effetti di scorrimento sono disattivati per i punti di interruzione fluidi.

  3. Per attivare gli effetti di scorrimento è necessario aggiungere un punto di interruzione fisso. Per aggiungere un punto di interruzione fisso, fate clic sulla barra del punto di interruzione e quindi su Aggiungi un punto di interruzione. 

  4. Scegliete Larghezza fissa dal menu a discesa e fate clic su OK.

    Aggiungere un punto di interruzione a larghezza fissa
    Aggiungere un punto di interruzione a larghezza fissa

    Punti di interruzione fissi
    Punti di interruzione fissi con icona quadrata

    Il punto di interruzione fisso è rappresentato da un quadratino. Quando visualizzate la pagina in una finestra browser larga 1225 pixel e oltre, la pagina rimane fissa come visualizzata a 1225 pixel. In corrispondenza di questo punto di interruzione, il layout non è più fluido.

  5. Selezionate l’oggetto a cui desiderate applicare gli effetti di scorrimento, quindi configurate le impostazioni degli effetti di scorrimento.

    Applicare gli effetti di scorrimento agli oggetti selezionati
    Applicare gli effetti di scorrimento agli oggetti selezionati

    Nota:

    è possibile applicare gli effetti di scorrimento solo in corrispondenza di un punto di interruzione fisso, e non di punti di interruzione fluidi.

    Per informazioni su come aggiungere e usare gli effetti di scorrimento in Adobe Muse, consultate Applicazione di effetti di scorrimento di Adobe Muse.

Domande frequenti

Cosa sono i punti di interruzione ideali per la progettazione di un sito per computer desktop, tablet e smartphone?

Se dovete progettare un sito per un dispositivo specifico, potete aggiungere il punto di interruzione appropriato. Tuttavia, gli utenti potranno visualizzare il sito da qualsiasi dispositivo, con display di qualsiasi dimensioni. Pertanto, è consigliabile aggiungere i punti di interruzione solo in corrispondenza di problemi effettivi nel design. In questo modo il sito si presenterà correttamente su qualsiasi dispositivo.

Perché i punti di interruzione della pagina mastro non funzionano sulle singole pagine?

I punti di interruzione della pagina mastro sono visualizzati come triangoli bianchi sulle singole pagine. Per attivarli su specifiche pagine, fate clic sul triangolo bianco sulla barra del punto di interruzione e quindi fate clic sul segno più (+).

In alternativa, copiate un elemento della pagina mastro, passate alla pagina in cui desiderate applicare i punti di interruzione, selezionate Modifica > Incolla con punti di interruzione, quindi eliminate l’elemento copiato dall’area di lavoro. Così facendo viene eliminato solo l’elemento, mentre i punti di interruzione della pagina mastro restano sulla singola pagina.

Come si può evitare che le caselle di testo si sovrappongano nel layout dinamico?

Le caselle di testo non vengono ridimensionate e potrebbero quindi sovrapporsi se non sono impostate come “fluide”. Per rendere le caselle di testo fluide, fate clic con il pulsante destro del mouse su ognuna di esse e selezionate Ridimensiona > Larghezza dinamica.

Come si può eliminare eventuale spazio bianco o in eccesso dai siti dinamici?

La presenza di spazio bianco o in eccesso può essere dovuta a diverse ragioni, ad esempio a un piè di pagina fisso o un oggetto nascosto. Per informazioni su come risolvere questo problema, consultate questo articolo.

Come è possibile rimuovere l’area grigia che compare nell’anteprima del sito?

Quando nell’anteprima viene visualizzata un’area grigia, controllate che non vi siano oggetti esterni o nascosti al di fuori della pagina. Per selezionare tutti gli oggetti, fate clic su Visualizza > Mostra bordi cornice. Potete inoltre ridurre il livello di zoom e visualizzare dove si trovano tutti gli oggetti. Controllate che non vi sia un oggetto nascosto o esterno e, per risolvere il problema, portatelo all’interno del layout.

Come è possibile rendere fluidi o dinamici tutti i widget?

Al momento i widget di Adobe Muse non sono dinamici. Per informazioni sul comportamento dinamico dei singoli widget, consultate questa tabella.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online