Scoprite come organizzare e riutilizzare widget, modelli e altri elementi grafici con il pannello Libreria di Adobe Muse CC.

Nota:

Non verranno più aggiunte ulteriori funzioni ad Adobe Muse, e il supporto verrà sospeso a partire dal giovedì 26 marzo 2020. Per ulteriori informazioni e assistenza, consultate la pagina dedicata alla fine del ciclo di vita di Adobe Muse.

Il pannello Libreria di Muse offre un modo pratico per archiviare e gestire gli elementi di pagina comuni. Aggiungendo gli elementi alla Libreria potrete accedervi rapidamente per inserirli nelle pagine del sito. La Libreria può contenere molti tipi di elementi, ad esempio logo, immagini, campioni di colore, guide, widget personalizzati, HTML incorporato, nonché stili di paragrafo, carattere e grafica. Questo articolo spiega come utilizzare il pannello Libreria per semplificare il processo di progettazione.

Le estensioni di Creative Cloud consentono di scegliere da un’ampia gamma di elementi di design per arricchire i vostri progetti. Per scaricarle, consultate Estensioni Creative Cloud per Adobe Muse.

Accesso al pannello Libreria

Potete accedere al pannello Libreria dalla vista Progettazione. Scegliete Finestra > Libreria o fate clic sulla scheda Libreria nel set di pannelli ancorato per rendere attivo il pannello.

Aprite il pannello Libreria in Adobe Muse.
Aprite il pannello Libreria in Adobe Muse.

Nota:

fate clic sul collegamento per visitare Adobe Muse Exchange dove potrete trovare elementi libreria pronti da scaricare e utilizzare per la creazione di altri siti.

Gestire le cartelle nel pannello Libreria

Creare una nuova cartella

Per iniziare a usare il pannello Libreria, create una nuova cartella. Effettuate le seguenti operazioni:

  1. Fate clic sul pulsante Cartella Crea (icona di cartella) nella parte inferiore del pannello Libreria.
Fate clic sul pulsante Crea cartella per creare una nuova cartella vuota.
Fate clic sul pulsante Crea cartella per creare una nuova cartella vuota.

  1. Inserite un nome descrittivo nel campo accanto all’icona della cartella.

Le cartelle vengono elencate in ordine alfabetico nel pannello Libreria. Affinché elementi correlati restino insieme nell’elenco, scegliete dei nomi simili, che inizino con le stesse lettere.

In qualsiasi momento potete fare doppio clic su una cartella nella Libreria per rinominarla.

Inserite un nome descrittivo nel campo della cartella.
Inserite un nome descrittivo nel campo della cartella.

Dopo aver creato una cartella, potete aggiungere degli elementi alla Libreria.

Nota:

potete anche aggiungere un elemento libreria nel pannello Libreria senza prima creare la cartella. Tuttavia è più veloce creare una nuova cartella, denominarla e quindi aggiungere un oggetto anziché aggiungere il nuovo elemento e rinominare successivamente sia quest’ultimo che la sua cartella. A prescindere dal metodo scelto, è consigliabile assegnare sempre un nome descrittivo alle cartelle e agli elementi del pannello Libreria.

Se intendete aggiungere più elementi alla libreria, potete creare e denominare un set di cartelle vuote prima di iniziare ad aggiungere gli elementi.

Aggiungete delle cartelle per organizzare diversi elementi del sito Adobe Muse e facilitarne la ricerca.
Aggiungete delle cartelle per organizzare diversi elementi del sito e facilitarne la ricerca.

Aggiungere elementi di pagina alle cartelle

Per aggiungere degli elementi alla Libreria in modo da poter accedervi rapidamente e aggiungerli in altre pagine, selezionate un elemento sulla pagina. Se dovete selezionare più elementi, tenete premuto il tasto Maiusc oppure trascinate lo strumento selezione per selezionare gli elementi desiderati.

Aggiungete gli elementi alla Libreria con uno dei metodi seguenti:

Opzione 1:

  1. Fate clic con il pulsante destro del mouse sugli elementi selezionati, scegliete Aggiungi alla libreria e selezionate la cartella in cui salvare l’elemento libreria.
Scegliete Aggiungi alla libreria dal menu di scelta rapida di Adobe Muse.
Scegliete Aggiungi alla libreria dal menu di scelta rapida.

Gli elementi selezionati vengono aggiunti alla cartella e la relativa anteprima viene visualizzata nel pannello Libreria.

  1. Inserite un nome descrittivo per l’elemento nel relativo campo.
Inserite un nome descrittivo per il nuovo elemento memorizzato nella cartella.
Inserite un nome descrittivo per il nuovo elemento memorizzato nella cartella.

In alternativa, potete aggiungere gli elementi selezionati alla libreria seguendo questo flusso di lavoro:

Opzione 2:

  1. Con gli elementi selezionati, fate clic sul pulsante Aggiungi elementi selezionati (icona voltapagina) nell’angolo in basso a destra del pannello Libreria.
Fate clic sul pulsante Aggiungi elementi selezionati.
Fate clic sul pulsante Aggiungi elementi selezionati.

  1. Immettete il nome dell’elemento nel relativo campo.

Quando una cartella contiene almeno un elemento, potete fare clic sulla freccia rivolta verso il basso a sinistra del nome della cartella per espanderne o ridurne il contenuto.

Nei file di progetto più grandi, potete ridurre tutte le cartelle nel pannello Libreria in modo da rendere l’elenco di elementi più gestibile. Per aprire o chiudere tutte le cartelle nel pannello Libreria, tenete premuto il tasto Opzione (Mac OS) o Alt (Windows) e fate clic sulla freccia.

Rinominare e organizzare le cartelle

Come accennato in precedenza, in qualsiasi momento potete fare doppio clic su una cartella per rinominarla. Se dovete memorizzare gli elementi necessari per un particolare cliente o per una specifica sezione di un sito, sarà utile denominare tutte le cartelle nel pannello Libreria in modo che vengano elencate insieme.

Le cartelle sono elencate per nome in ordine alfabetico nel pannello Libreria di Adobe Muse.
Le cartelle sono elencate per nome in ordine alfabetico nel pannello Libreria.

È consigliabile assegnare un nome descrittivo alle cartelle e agli elementi della libreria; evitate di utilizzare il nome predefinito senza titolo assegnato da Muse. Utilizzando dei nomi descrittivi potrete facilmente individuare gli elementi desiderati scorrendo rapidamente l’elenco delle cartelle. Potrete inoltre cercare elementi di libreria specifici, come descritto nella sezione successiva.

Gestire le risorse nel pannello Libreria

Eseguire una ricerca nel pannello Libreria

Dopo avere aggiunto numerosi elementi al pannello Libreria, può diventare difficile ricordare in quale cartella si trova un particolare elemento. Potete sempre espandere ogni cartella per visualizzarne il contenuto, ma se la libreria è molto grande questo può richiedere del tempo.

Per effettuare una ricerca nel pannello Libreria, digitate nel campo Filtra per nome una parte del nome dell’elemento che vi interessa.

Tutti gli oggetti corrispondenti vengono visualizzati nell’elenco sottostante in cartelle espanse.

Per cercare un particolare elemento, immettetene il nome nel campo di ricerca.
Per cercare un particolare elemento, immettetene il nome nel campo di ricerca.

Al termine della ricerca, fate clic sul pulsante X per cancellare il campo e visualizzare nuovamente l’elenco completo degli elementi del pannello Libreria.

Importare risorse

Le risorse di libreria personalizzate possono essere condivise tra più utenti, per semplificare la collaborazione con altri utenti e standardizzare l’aspetto dei siti creati. I file libreria esportati di Muse vengono salvati con l’estensione di file .mulib.

Per importare un file libreria di Muse nel progetto corrente, fate doppio clic su un file .mulib. Muse viene avviato (se non è già aperto) e il contenuto del file libreria viene aggiunto al pannello Libreria.

In alternativa, effettuate le seguenti operazioni:

  1. Fate clic sul pulsante Importa libreria Muse nell’angolo in basso a sinistra del pannello Libreria.
  2. Nella finestra di dialogo Importa elementi libreria, individuate e selezionate un file .mulib sul desktop e fate clic su Apri.
Fate clic sul pulsante Importa libreria Muse e aprite un file .mulib di Adobe Muse.
Fate clic sul pulsante Importa libreria Muse e aprite un file .mulib.

Le cartelle importate vengono visualizzate nel pannello Libreria e sono pronte per essere usate con il file corrente.

Se desiderate importare gli elementi libreria in una modalità diversa dalla vista Progettazione, potete anche scegliere File > Apri sito e quindi individuare e selezionare uno o più file .mulib nella finestra di dialogo Apri.

Usare elementi di libreria nei progetti

Potete archiviare e gestire vari tipi di risorse, inclusi elementi grafici, immagini vettoriali, moduli, intestazioni, piè di pagina e così via. Potete usare questi elementi per i progetti in due modi:

Inserendo elementi di libreria

Selezionate l'elemento che volete usare nel progetto. Trascinate l'elemento di libreria nella vista Progettazione.

Inserendo elementi di libreria con punti di interruzione:

Se l'elemento di libreria include punti di interruzione, potete inserire gli elementi nel layout con i punti di interruzione. Per utilizzare gli elementi di libreria con i punti di interruzione, fate clic sul segno più accanto all'elemento. Trascinate e rilasciate l'elemento in vista Progettazione.

Aggiungere elementi di libreria con punti di interruzione in Adobe Muse
Aggiungere elementi di libreria con punti di interruzione

I punti di interruzione dell'elemento di libreria vengono aggiunti alla pagina. Questa funzione consente di aggiungere un insieme di punti di interruzione tra le pagine principali e secondarie, con un singolo clic. Potete inoltre mantenere i punti di interruzione tra progetti diversi di Adobe Muse.

Se sono presenti punti di interruzione in una pagina e aggiungete un elemento di libreria con punti di interruzione, tutti i punti di interruzione verranno inclusi nella pagina.

Esportare immagini e altre risorse

Dopo aver aggiunto dei contenuti al pannello Libreria, è possibile esportarli come un file autonomo da condividere con altri utenti o per facilitare il lavoro quando si utilizzano più computer.

È importante notare che i contenuti associati al sito Web (e non incorporati in esso) come ad esempio i file Adobe Edge Animate OAM, le clip video e altri contenuti collegati, non vengono inclusi nel file .mulib creato dall’esportazione degli elementi dal pannello Libreria.

Per esportare un file libreria di Muse contenente anche i file immagini, effettuate le seguenti operazioni:

  1. Nella vista Progettazione, create l’elemento o il set di elementi da aggiungere alla libreria. Potete includere rettangoli, testo e file di immagini.
  2. Prima di aggiungere gli elementi al pannello Libreria, aprite il pannello Risorse (Finestra > Risorse), fate clic con il pulsante destro del mouse sulle immagini da esportare e scegliete Incorpora collegamento.

Nota: se gli elementi libreria da esportare non contengono file di immagini, potete passare al punto 2.

  1. Selezionate gli elementi desiderati e aggiungeteli alla libreria.
  2. Fate clic sul pulsante Esporta nella parte inferiore del pannello Libreria.
Selezionate le cartelle o gli elementi da esportare e fate clic sul pulsante Esporta.
Selezionate le cartelle o gli elementi da esportare e fate clic sul pulsante Esporta.

Un file .mulib viene creato e salvato sul desktop (o nel percorso specificato). Inviate il file .mulib tramite e-mail o trasferimento di file a un altro utente o membro del team.

Quando il destinatario apre il file .mulib e aggiunge l’elemento libreria a una pagina, le immagini appaiono nel pannello Risorse come immagini incorporate.

Creare campioni personalizzati

Utilizzando il pannello Libreria potete salvare un elemento contenente tutti i colori utilizzati nel progetto di un sito. Potete anche selezionare un set personalizzato di guide e aggiungerlo al pannello Libreria. Questo risulta utile per assicurare coerenza nel progetto di un sito.

Effettuate le seguenti operazioni per importare un set di colori in un nuovo file .muse in modo da velocizzare il processo di progettazione.

  1. Aprite il file .muse contenente i colori da memorizzare. Con lo strumento rettangolo create una singola forma rettangolare, quindi tenete premuto Opzione/Alt e trascinate il rettangolo per duplicarlo più volte. Con lo strumento contagocce nel menu Riempimento, impostate il riempimento di ogni rettangolo su uno dei valori di colore principali del sito.
  2. Create una nuova cartella nel pannello Libreria in cui memorizzare i campioni di colore.
  3. Con lo strumento selezione, selezionate l’intero set di rettangoli. Fate clic con il pulsante destro del mouse sul gruppo di rettangoli selezionato e scegliete Aggiungi alla libreria oppure fate clic sul pulsante Aggiungi elementi selezionati nella parte inferiore del pannello Libreria. Inserite nel campo un nome descrittivo con cui identificare il set di campioni.
  4. Selezionate la cartella che contiene i campioni e fate clic sul pulsante Esporta nella parte inferiore del pannello Libreria per esportare un file libreria di Muse con il contenuto selezionato. Inviate il file .mulib a un membro del team come allegato e-mail o tramite trasferimento del file con un’unità USB.
  5. Chi riceve il file .mulib potrà quindi avviare Muse, creare un nuovo sito, aprire il pannello Libreria e fare clic sul pulsante Importa per importare nella sua libreria il file contenente i campioni. In alternativa, potrà scegliere File > Apri sito e aprire il file .mulib.
  6. Quindi, potrà trascinare l’elemento contenente i colori dal pannello Libreria a una pagina per aggiungere i campioni al pannello Campioni.
  7. A questo punto potrà aprire il pannello Campioni (Finestra > Campioni), fare clic con il pulsante destro del mouse sul pannello Campioni e, dal menu di scelta rapida, scegliere Elimina tutti gli elementi inutilizzati.
Dopo l’importazione, è possibile eliminare i campioni di colore inutilizzati in un nuovo sito Adobe Muse.
Dopo aver importato i campioni colore in un nuovo sito, è possibile scegliere l’opzione per eliminare tutti i colori non utilizzati nel pannello Campioni.

Dopo aver eliminato i campioni non usati nel pannello Campioni, è possibile eliminare l’elemento libreria dalla pagina.

Nota:

con la stessa procedura è possibile importare stili di paragrafo e carattere assegnati a un testo, aggiungendo una cornice di testo come elemento nel pannello Libreria.

Creare miniature personalizzate

Il riquadro di anteprima del pannello Libreria funge da indicatore visivo del contenuto selezionato. Facilita la selezione degli elementi nella libreria e la loro aggiunta alle pagine. Tuttavia, il pannello di anteprima è impostato per visualizzare i file che sono praticamente quadrati. Se aggiungete alla libreria un elemento o un set di elementi più lungo, la relativa miniatura viene ridimensionata in scala.

Creare miniature personalizzate in Adobe Muse
Creare miniature personalizzate in Adobe Muse

Se necessario, potete creare un’altra immagine miniatura da usare come anteprima per l’elemento libreria. Effettuate le seguenti operazioni:

  1. Nel Finder o in Esplora risorse individuate la seguente directory sul computer:
  • Mac: ~/Libreria/Preferenze/Adobe/AdobeMuseLibrary/
  • Windows: %AppData%/AdobeMuseLibrary/

Nota:

per accedere alla directory, in Mac OSX potete scegliere Vai > Vai a cartella. In Windows, copiate invece questo percorso e incollatelo nella barra degli URL.

  1. Individuare il nome della cartella che corrisponde alla cartella Libreria di Muse da aggiornare. In questo esempio, la cartella Libreria è denominata “nav - background”.
  2. Aprite la cartella per visualizzarne il contenuto. Contiene un file PNG.
  3. aprite il file PNG con un programma per la modifica di immagini come Photoshop o Fireworks. Modificate il file PNG come desiderato.
  4. Salvate il file PNG nel suo percorso corrente e uscite dal programma di modifica immagini.
  5. Tornate a Muse e selezionate l’elemento nella libreria. Il file PNG che avete modificato viene visualizzato nel riquadro di anteprima.
Il file PNG personalizzato visualizza una miniatura più facile da identificare a colpo d’occhio.
Il file PNG personalizzato visualizza una miniatura più facile da identificare a colpo d’occhio.

Per ulteriori informazioni su come utilizzare Adobe Muse, visitate la pagina dedicata all’aiuto e alle esercitazioni di Adobe Muse e il forum di supporto per Adobe Muse.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online