Le prestazioni di Photoshop vengono determinate da quattro fattori principali:

  • ottimizzazione della configurazione hardware
  • impostazione delle preferenze prestazioni
  • utilizzo di procedure ottimali in Photoshop
  • procedure per rendere più veloce il sistema operativo

Per ottenere i risultati migliori, tuttavia, vi consigliamo di adottare un approccio globale per l'ottimizzazione delle prestazioni di Photoshop. Leggete tutti i suggerimenti contenuti in questo documento e stabilite quali implementare in base alla vostra configurazione informatica, al tipo di file utilizzati e al flusso di lavoro prescelto. Per ottenere le prestazioni migliori in Photoshop, è necessario adottare una combinazione di tecniche che varia di volta in volta in base alle circostanze.

Ottimizzazione della configurazione hardware

Utilizzate un processore sufficientemente veloce

La velocità di elaborazione di Photoshop è limitata dalla velocità della CPU del computer. Per Photoshop CS4 è necessario PowerPC G5 o un processore multicore Intel (Mac OS), oppure un processore da 1,8 GHz o superiore (Windows). Per Photoshop CS5, CS6 e CC è necessario un processore multicore Intel (Mac OS) oppure un processore da 2 GHz o superiore (Windows).

Sebbene tutte le funzionalità di Photoshop vengano eseguite più velocemente nei sistemi con più processori core, per l'esecuzione di alcune di esse una potenza di elaborazione aggiuntiva risulta particolarmente vantaggiosa. Quando si utilizzano più processori core, esiste un punto oltre il quale all'aumento del numero dei core non corrisponde un uguale aumento delle prestazioni. Di conseguenza, l'elaborazione con Photoshop in un computer che utilizza 16 processori core non sarà quattro volte più veloce rispetto a un computer che ne utilizza quattro. La maggior parte degli utenti ritiene che l'ottimizzazione delle prestazioni ottenuta con un numero di core superiori a sei non giustifichi la spesa.

Photoshop CS6, CC e CC 2014, inoltre, fa un uso maggiore del processore grafico (GPU) rispetto alle versioni precedenti per ottimizzare le prestazioni di numerose funzionalità. L'utilizzo più intensivo della GPU può generare problemi di prestazioni quando Photoshop CS6 e versioni successive vengono eseguiti in un ambiente virtuale. Le macchine virtuali non possono accedere alla GPU.

Massimizzate l'uso della RAM

Photoshop utilizza la memoria ad accesso casuale (RAM) per l'elaborazione delle immagini. Se la memoria disponibile è insufficiente, per l'elaborazione delle informazioni viene utilizzato lo spazio sul disco rigido (detto anche disco di memoria virtuale). Poiché l'accesso alle informazioni nella memoria risulta più rapido di quello alle informazioni memorizzate sul disco rigido, Photoshop è più veloce quando è in grado di elaborare gran parte o la totalità delle informazioni delle immagini nella memoria RAM. Se possibile, allocate una quantità di RAM sufficiente all'elaborazione del vostro file di immagine più grande.

Quanta RAM può essere utilizzata da Photoshop?

Versione Photoshop Versione SO Quantità massima di RAM utilizzabile da Photoshop
CS4, CS5 e versioni successive, 32 bit Windows a 32 bit 1,7 GB
CS4, CS5 e versioni successive, 32 bit Windows a 64 bit 3,2 GB
CS4, CS5 e versioni successive, 64 bit* Windows a 64 bit Tutta la RAM installabile nel computer
CS4, 32 bit Mac OS 3 GB
CS5, 32 bit Mac OS 2,1 GB
CS5 e versioni successive, 64 bit Mac OS Tutta la RAM installabile nel computer

*Photoshop a 64 bit non è ufficialmente supportato in Windows XP a 64 bit, ma dovrebbe essere comunque eseguito.

Per ulteriori informazioni sulle prestazioni e Photoshop a 64 bit, consultate Vantaggi e limiti del sistema operativo a 64 bit | Photoshop CS4, CS5, CS6, CC, CS6, CC.

Per istruzioni su come assegnare RAM a Photoshop, consultate Uso memoria.

Utilizzate un disco rigido capiente e veloce per elaborare immagini di grandi dimensioni

Photoshop esegue la lettura e la scrittura delle informazioni sull'immagine su disco quando la RAM è insufficiente per contenerle tutte. Controllate l'indicatore di efficienza, come descritto di seguito, per valutare se, utilizzando un disco rigido o un disco a stato solido più veloci, le prestazioni ne trarrebbero beneficio. Se l'indicatore di efficienza è superiore al 95%, ha poco senso investire denaro in un disco di memoria virtuale più veloce.

Per migliorare le prestazioni di Photoshop, utilizzate un disco con un'elevata velocità di trasferimento dati, ad esempio un disco rigido interno o un disco esterno connesso tramite un'interfaccia veloce, come Thunderbolt, FireWire 800, eSATA o USB3. I server di rete (disco rigido accessibile tramite una rete) offrono una velocità di trasferimento dati più lenta.

Photoshop dalla versione CS4 a CS6 richiede almeno 1 GB di spazio libero su disco rigido (Windows) o 2 GB di spazio libero su disco rigido (Mac OS). Photoshop CC richiede almeno 2,5 GB (Windows) o 3,2 GB (Mac OS). È necessario ulteriore spazio libero per l'installazione, mentre è consigliata una quantità ancora maggiore di spazio su disco rigido per memoria virtuale e dischi di memoria virtuale.

Gli array RAID 0 veloci sono ottimi come dischi di memoria virtuale, in particolare se l'array è utilizzato esclusivamente per il disco di memoria virtuale. Verificate inoltre che l'array venga deframmentato di frequente e non costituisca il volume di avvio. 

Dischi a stato solido

L'installazione di Photoshop su un disco a stato solido (SSD) consente a Photoshop di avviarsi rapidamente, probabilmente in meno di un secondo. Tuttavia, questo avvio rapido costituisce l'unico caso di risparmio di tempo, trattandosi dell'unica operazione in cui viene letta una grande quantità di dati dal disco SSD.

Per ottenere il massimo dall'utilizzo di un disco SSD, utilizzatelo come disco di memoria virtuale. Questa modalità di utilizzo garantisce miglioramenti significativi nelle prestazioni se disponete di immagini che non rientrano interamente nella RAM. Ad esempio, lo scambio di porzioni tra RAM e SSD è molto più veloce dello scambio tra RAM e disco rigido.

Se la quantità di spazio libero sul disco SSD non è sufficiente per un eventuale aumento di volume nel file di memoria virtuale, aggiungete un secondo o terzo disco rigido (dopo il disco SSD). Assicuratevi che i dischi vengano selezionati come dischi di memoria virtuale nel pannello Prestazioni delle Preferenze.

Ancor più che con i dischi rigidi, le prestazioni dei dischi SSD variano notevolmente a seconda del modello. Se utilizzate un'unità meno recente e più lenta, il miglioramento potrebbe essere minimo rispetto a un disco rigido.

Nota: aggiungere RAM per migliorare le prestazioni è economicamente più conveniente che non acquistare un disco SSD. Se siete disposti a spendere di più, avete già installato la quantità massima di RAM supportata dal vostro computer, utilizzate Photoshop CS5 come applicazione a 64 bit e desiderate migliorare ulteriormente le prestazioni, prendete in considerazione l'utilizzo di un disco a stato solido come disco di memoria virtuale.

Come accennato prima, l'utilizzo di un disco SSD non migliora le prestazioni se l'indicatore di efficienza è già alto. Più basso sarà l'indicatore di efficienza, maggiori le prestazioni del disco SSD.

Impostazione delle preferenze Prestazioni

Le preferenze Prestazioni che specificate incidono fortemente sulle prestazioni di Photoshop. Per impostare le preferenze Prestazioni, selezionate Photoshop > Preferenze > Prestazioni (Mac OS) oppure Modifica > Preferenze > Prestazioni (Windows). Specificate ora le opzioni preferite in ciascuna delle aree seguenti:

Uso memoria

Aumentando la quantità di RAM disponibile per Photoshop, potete accelerare i tempi di elaborazione delle informazioni sulle immagini. L'area Uso memoria della finestra di dialogo delle Preferenze prestazioni indica quanta RAM è disponibile per Photoshop e mostra un intervallo ideale per il vostro sistema.

Nota: la RAM disponibile non è la RAM totale. Photoshop sottrae la RAM necessaria al sistema operativo. 

Per impostazione predefinita, Photoshop utilizza il 70% della RAM disponibile. Potete assegnare più o meno RAM a Photoshop modificando il valore nella casella Consenti a PS di usare, oppure trascinando il dispositivo di scorrimento Uso memoria. Riavviate Photoshop per rendere effettive le modifiche.

L'allocazione di RAM predefinita del 70% è adatta alla maggior parte degli utenti che utilizzano la versione a 32 bit di Photoshop. Per determinare l'allocazione di RAM adatta al vostro sistema, modificate il valore predefinito di incrementi del 5%, monitorando le prestazioni nell'indicatore di stato dell'efficienza. Consultate Monitorare l'indicatore dell'efficienza.

Se utilizzate la versione a 64 bit di Photoshop e si verificano errori a causa di RAM o memoria insufficiente, aumentate l'allocazione di RAM. Dopo aver chiuso tutte le altre applicazioni, potete aumentare l'allocazione di RAM fino al 100% per migliorare le prestazioni di Photoshop.

Se utilizzate la versione a 32 bit di Photoshop, potrebbero verificarsi errori a causa di RAM insufficiente se avete impostato l'allocazione di RAM su 100%. In questo caso, diminuite l'allocazione di RAM fino a 85% o 90% e ripetete il test. Se i problemi persistono, riducete l'allocazione di RAM in incrementi del 5%. Ripetete quindi il test fino a quando l'errore non si verifica più oppure, se possibile, passate alla versione a 64 bit di Photoshop.

Dischi memoria virtuale

Impostate il disco di memoria virtuale in un disco rigido deframmentato con molto spazio non utilizzato e velocità elevata di lettura/scrittura (consultate Deframmentazione del disco rigido). Se avete più di un disco rigido, specificate dischi di memoria virtuale aggiuntivi. Photoshop supporta dischi di memoria virtuale con dimensioni massime di 64 exabyte, distribuiti su un totale di quattro volumi (Un exabyte corrisponde a 1 miliardo di GB).

Se il disco di avvio è un disco rigido, anziché un disco a stato solido, provate a utilizzare un disco rigido diverso per il disco di memoria virtuale principale. Se il disco di avvio è un disco SSD, non c'è motivo di selezionare un disco diverso per il disco di memoria virtuale principale. L'utilizzo del disco SSD sia per il disco di avvio del sistema che per il volume virtuale principale garantisce ottime prestazioni. È probabilmente la soluzione migliore rispetto all'utilizzo di un disco rigido separato per la memoria virtuale. Per ulteriori informazioni, consultate Assegnazione dei dischi di memoria virtuale nell'Aiuto di Photoshop

Preferenze di cronologia e cache

Livelli cache

Photoshop utilizza la cache delle immagini per velocizzare l'aggiornamento dello schermo per le immagini in alta risoluzione. Grazie all'uso della cache, Photoshop è in grado di utilizzare versioni di immagini a bassa risoluzione per aggiornare rapidamente le immagini visualizzate sullo schermo. L'opzione Livelli cache di Photoshop consente di salvare da 1 a 8 livelli di dati di immagini memorizzati nella cache. Più alto è il numero di livelli di cache, più lenta risulta l'apertura dei file in Photoshop, ma più rapidi saranno i tempi di risposta del programma. Più basso è il numero di livelli di cache, più veloce sarà il caricamento delle immagini, ma Photoshop risulterà più lento. 

L'impostazione predefinita di Livelli cache è 4, ma potete modificarla a seconda del tipo di file con cui lavorate e della quantità di RAM presente nel computer.

Se utilizzate file di dimensioni relativamente contenute (circa 1 megapixel o 1280 x 1024 pixel) e numerosi livelli (più di 50), impostate i livelli di cache su 1 o 2. Impostando l'opzione Livelli cache su 1, potete disattivare la cache delle immagini; in questo caso, solo l'immagine della schermata corrente viene immessa nella cache.

Nota: alcune funzionalità in Photoshop non offrono la massima qualità se Livelli cache è impostato su 1.

Se utilizzate file di dimensioni maggiori (ad esempio, 50 megapixel o superiori), impostate Livelli cache su un livello superiore a 4. L'utilizzo di un livello di cache più alto migliora le prestazioni poiché riduce i tempi di aggiornamento dello schermo.

La dimensione della cache porzione è la quantità di dati (porzioni) elaborati nel corso di una sola operazione. Photoshop elabora ciascuna porzione di dati e poi la ridisegna. Le prestazioni di Photoshop risultano migliori con le porzioni più grandi, ma ridisegnare queste porzioni richiede più tempo. Le porzioni più grandi velocizzano operazioni complesse, ad esempio l'utilizzo dei filtri di contrasto; al contrario, modifiche di entità minore, come i tratti del pennello, risultano più rapide quando Photoshop utilizza porzioni più piccole. 

In Photoshop CS4, potete modificare le dimensioni delle porzioni di cache utilizzando il plug-in facoltativo Porzioni grandi (consultate Plug-in Porzioni grandi (Photoshop CS4).

In Photoshop CS5 e CS6, potete scegliere le dimensioni delle porzioni dal menu a comparsa Dimensione cache porzione nelle preferenze Prestazioni. Se disponete di un processore Intel "Core", scegliete 128 K o 1024 K. Se il processore è un Intel Pentium 4 o AMD, le prestazioni di Photoshop saranno migliori se si utilizzano le opzioni 132 K o 1032 K.

In Photoshop CS5 e CS6, la sezione Storia e cache delle preferenze Prestazioni offre inoltre tre valori predefiniti per la cache: Picc. molti liv., Predefinito e Gran. pochi liv. Queste opzioni vi consentono di impostare il livello di cache e le dimensioni delle porzioni in base al tipo di documento che state elaborando e alla quantità di RAM disponibile.

  • Picc. molti liv. Ideale per la modifica di immagini di piccole dimensioni con molti livelli (da alcune decine a centinaia).
  • Gran. pochi liv. Ideale per la modifica di immagini di grandi dimensioni (da parecchie decine a centinaia di megabyte) con pochi livelli.
  • Predefinito Da utilizzare per i casi intermedi.

Stati storia

Ogni stato storia o istantanea di un'operazione che interessa tutta l'immagine comporta l'aumento della quantità di spazio su disco di memoria virtuale utilizzata dal file. Photoshop crea una copia dell'originale. Ad esempio, se applicate una sfocatura Gaussian a un'immagine di 500 KB e create un'istantanea della modifica nel pannello Storia, Photoshop richiede 1 MB di spazio su disco di memoria virtuale per l'immagine. Se regolate i livelli e applicate un filtro disturbo e una maschera definizione dettagli a un'immagine di 5 MB, quindi salvate un'istantanea Storia per ciascuno stato, l'immagine richiede 15 MB di spazio su disco di memoria virtuale.

Ogni stato storia o istantanea nel pannello Storia comporta l'aumento della quantità di spazio su disco di memoria virtuale utilizzata da Photoshop.  Maggiore è il numero dei pixel modificati durante un'operazione, più spazio di memoria virtuale verrà consumato dallo stato storia corrispondente. Lo stato storia che riguarda un piccolo tratto di pennello o un'operazione non distruttiva, come la creazione o modifica di un livello di regolazione, consuma un esiguo spazio di memoria virtuale. Lo stato storia corrispondente all'applicazione di un filtro all'intera immagine consuma uno spazio di memoria virtuale molto più grande.

Potete risparmiare spazio sul disco di memoria virtuale e migliorare le prestazioni limitando o riducendo il numero di stati che Photoshop può salvare nel pannello Storia. Photoshop può salvare fino a 1000 stati storia; per impostazione predefinita, ne vengono salvati 20. Per ridurre il numero, fate clic sul menu a comparsa Stati storia nell'area Storia e cache della finestra di dialogo delle preferenze Prestazioni, quindi trascinate per selezionare un valore più basso.

Plug-in Porzioni grandi (Photoshop CS4)

Il plug-in Porzioni grandi, disponibile nella cartella dei plug-in facoltativi, a sua volta disponibile nel DVD dell'applicazione, è disattivato per impostazione predefinita. Per attivarlo, copiatelo in Estensioni, nella cartella dei plug-in di Photoshop CS4 e rimuovete il carattere ~ dal nome del file. Abilitate il plug-in solo se disponete di oltre un GB di RAM.

Quando abilitate il plug-in, aumentano le dimensioni della porzione di immagine in Photoshop. Photoshop rielabora contemporaneamente una maggiore quantità di dati poiché ciascuna porzione di immagine viene ingrandita ed è rielaborata e completata in una sola volta. Infatti, l'intervallo di tempo richiesto per l'elaborazione di una minore quantità di immagini più grandi è inferiore a quello richiesto per l'elaborazione di una maggiore quantità di immagini più piccole. Le porzioni più grandi sembrano rallentare l'aggiornamento, ed effettivamente, se introducete numerose piccole variazioni, potrebbe essere necessario più tempo per vedere i risultati sullo schermo. La durata totale delle operazioni di computo e di elaborazione dell'immagine finale, tuttavia, è più breve. Quando è installato il plug-in Porzioni grandi, possono risultare meno fluidi gli aggiornamenti della schermata durante le operazioni di disegno.

Se per la maggior parte del tempo disegnate o modificate rapidamente i controlli nei filtri e nei pannelli, e l'aggiornamento di Photoshop avviene in tempi rapidi, vi consigliamo di non abilitare Porzioni grandi. Se tuttavia dovete attendere a lungo prima che le operazioni desiderate vengano completate, abilitate Porzioni grandi per migliorare le prestazioni.

Impostazioni GPU

Photoshop CS4 e versioni successive sfruttano la GPU nella scheda video del computer per velocizzare le operazioni di aggiornamento dello schermo. Per consentire a Photoshop di accedere alla GPU, la scheda video deve disporre di GPU che supporti OpenGL. Richiede anche almeno 128 MB di VRAM (RAM video) e un driver che supporti OpenGL 2.0 e Shader Model 3.0.

Photoshop CS6 richiede 256 MB di VRAM. Photoshop 13.1 non può visualizzare funzionalità 3D se sono disponibili meno di 512 MB di VRAM sulla scheda video. Photoshop CC richiede 512 MB di VRAM. 

Il modo migliore per ottimizzare l'accelerazione GPU è mantenere aggiornato il driver della scheda video del computer. Per ulteriori informazioni sull'accelerazione GPU e istruzioni sul caricamento dei driver per la scheda video, consultate Domande frequenti su GPU per Photoshop CCDomande frequenti su GPU per Photoshop CS6 o GPU e supporto per Open GL | Photoshop CS4, CS5. Per istruzioni su come specificare le impostazioni GPU nella finestra di dialogo delle preferenze Prestazioni, consultate Domande frequenti su GPU per Photoshop CCDomande frequenti su GPU per Photoshop CS6 o Funzionalità e caratteristiche della GPU e di Open GL | Photoshop e Bridge | CS4, CS5.

OpenCL

OpenCL è una tecnologia che consente alle applicazione di utilizzare il processore presente nella scheda video, la GPU. Alcune funzionalità utilizzano OpenCL in Photoshop CC, quindi dovrebbero essere più rapide. Accertatevi che OpenCL sia attivato per l'esecuzione di tali funzionalità alla velocità maggiore possibile

Per aprire OpenCL, scegliete Modifica > Preferenze > Prestazioni (Windows) o Photoshop > Preferenze (Mac OS). Fate clic su Impostazioni avanzate, quindi selezionate Usa OpenCL.

Le funzionalità abilitate per OpenCL sono:

  • Panorama video
  • Galleria sfocatura (Diaframma, Campo e Scostamento inclinazione)

Salvataggio in background e Salvataggio automatico di informazioni di recupero

La preferenza Salva in background è attiva per impostazione predefinita. Se è attiva, consente di continuare a lavorare in Photoshop quando si sceglie un comando Salva o Salva con nome, anziché dover attendere il completamento dell’operazione. Per visualizzare l'avanzamento di una sessione di salvataggio in background, potete selezionare Avanzamento salvataggio nel menu a comparsa dello stato. Le sessioni di salvataggio in background (ovvero con la preferenza attivata) richiede più tempo. Tuttavia, non è necessario attendere il completamento della sessione di salvataggio per continuare a lavorare.

Nella maggior parte dei casi, il salvataggio in background non influenza in modo significativo le prestazioni o i tempi di risposta del normale funzionamento di Photoshop. Tuttavia, se il file che state elaborando è molto più grande rispetto alla RAM, i tempi di risposta e le prestazioni possono subire rallentamenti per tutta la durata della sessione di salvataggio.

La voce Salva automaticamente informazioni di recupero può essere attivata solo se la preferenza Salva in background è attiva. Se è attiva, le informazioni di recupero vengono salvate per ogni file aperto in base all'intervallo specificato e vengono salvate in background in una posizione nascosta. Il file originale non viene mai modificato. Il file originale viene modificato solo se esplicitamente richiesto tramite i comandi Salva o Salva con nome. Se Photoshop o il sistema si arrestano in modo anomalo, le informazioni recuperate si apriranno durante il successivo avvio di Photoshop.

Impostando un intervallo di recupero più breve, la protezione contro gli arresti anomali sarà maggiore. Nella maggior parte dei casi, il salvataggio delle informazioni di recupero non influisce sulle prestazioni o sui tempi di risposta di Photoshop. Tuttavia, a seconda delle operazioni eseguite e delle dimensioni e quantità di file aperti, il funzionamento può subire qualche rallentamento.  È più probabile che il problema si verifichi se le dimensioni dei file da modificare sono più grandi della RAM disponibile.

Problemi possibili:

Se avete l'impressione che Photoshop rallenti in modo intermittente, selezionate Avanzamento salvataggio nel menu a comparsa dello stato in basso a sinistra nella finestra dell'immagine. Se notate problemi di prestazioni mentre la barra di avanzamento salvataggio è in esecuzione, aumentate il valore della preferenza Salva automaticamente informazioni di recupero ogni. In alternativa, disattivate la preferenza.

Le informazioni di recupero vengono salvate nelle stesse posizioni dei file di memoria virtuale di Photoshop. In questo modo Photoshop ha a disposizione una maggiore quantità di spazio nei dischi di memoria virtuale specificati nella preferenza Dischi di memoria virtuale, nel riquadro Prestazioni delle preferenze. Se lavorate tenendo regolarmente aperti più file di grandi dimensioni, la quantità di spazio utilizzata può essere significativa. Se ricevete una segnalazione di errore a causa di esaurimento dello spazio su disco mentre eseguite un comando diverso dai comandi di salvataggio, aggiungete spazio sul disco di memoria virtuale. In alternativa, disattivate la preferenza Salva automaticamente informazioni di recupero.

Procedure ottimali per l'utilizzo di Photoshop

Rispettare i limiti di dimensioni del file

Maggiori sono le dimensioni del file che state utilizzando, più probabilità avrete di riscontrare problemi di prestazioni. 

Photoshop supporta file di dimensioni massime pari a 300.000 x 300.000 pixel, tranne che per i file PDF, il cui limite è 30.000 x 30.000 pixel e 200 x 200 pollici.

Capacità di dimensioni file per Photoshop:

  • File PDS: 2 GB
  • File TIFF: 4 GB (Photoshop CS6 supporta file TIFF superiori a 4 GB)

Nota: la maggior parte delle applicazioni non funziona con file TIFF di dimensioni superiori ai 2 GB.

  • File PSB: 4 exabyte (4096 petabyte o 4 milioni di terabyte)
  • File PDF: 10 GB (dimensioni massime delle pagine: 200 pollici)

Vedete anche Dimensioni file nell'Aiuto di Photoshop CS5.

Photoshop CS6 supporta le profondità di bit dispari oltre che le profondità di bit pari.

Monitorare l'indicatore dell'efficienza

Quando lavorate in Photoshop, monitorate l'indicatore dell'efficienza per stabilire quando Photoshop ha utilizzato tutta la RAM e inizia a usare il disco di memoria virtuale, rallentando così le prestazioni. Fate clic sul menu a comparsa nella parte inferiore della finestra dell'immagine e scegliete Efficienza. Potete anche controllare lo stato dell'efficienza nel pannello Info. Consultate Utilizzo del pannello Info nell'Aiuto di Photoshop CS5. Un valore di efficienza inferiore al 100% indica che Photoshop sta utilizzando il disco di memoria virtuale e risulta quindi rallentato. Se l'efficienza è inferiore a 90% - 95%, allocate una maggiore quantità di RAM a Photoshop nelle preferenze Prestazioni (consultate Uso memoria) o aggiungete ulteriore RAM al sistema.

Indicatore di stato dell'efficienza

Chiudere finestre di documenti non necessari

Le finestre dei documenti utilizzano più RAM in Photoshop CS4 rispetto alle versioni precedenti. Se sono aperte troppe immagini in Photoshop, potrebbe verificarsi un errore di esaurimento RAM oppure il funzionamento di Photoshop potrebbe risultare lento. Se si verifica questo errore, chiudete alcune finestre documento.

Ridurre al minimo i motivi e le punte dei pennelli nei predefiniti

Per ridurre la quantità di spazio utilizzata nella memoria virtuale, minimizzate il numero dei motivi e delle punte dei pennelli caricati. Salvate i predefiniti, al momento non richiesti, in un file di predefiniti. Oppure eliminateli se sono stati caricati da un file di predefiniti.

Per visualizzare i motivi o pennelli predefiniti attualmente caricati, selezionate Modifica > Gestione predefiniti. Quindi, scegliete Tipo predefinito > Motivi o Tipo predefinito > Pennelli. Per salvare i predefiniti di motivi o pennelli non in uso, selezionateli in Gestione predefiniti. Quindi, fate clic su Salva set e indicate un nome file. Fate clic sul pulsante Elimina per eliminarli dai predefiniti attualmente caricati. Per riutilizzarli in un secondo momento, potrete ricaricarli da Gestione predefiniti o dai numerosi menu a comparsa disponibili per i motivi e i pennelli.

Ridurre o disattivare le miniature di anteprima dei pannelli

Ogni volta che modificate il documento, Photoshop aggiorna tutte le miniature visibili nei pannelli Livelli e Canali. L'aggiornamento può influire sui tempi di risposta quando si utilizzano opzioni rapide di disegno, spostamento o sfioramento di livelli. Maggiore è il numero di miniature visibili, migliore sarà l'effetto.

Per ridurre o disattivare le miniature di anteprima in questi pannelli, fate clic sul menu delle opzioni dei pannelli Canali, Livelli o Tracciati e scegliete Opzioni pannello. Nell'area Dimensione miniatura, selezionate una dimensione inferiore per la miniatura o scegliete Nessuno, quindi fate clic su OK.

Impostazione dell'opzione Massimizza compatibilità per file PSD e PSB su Chiedi

L'opzione Massimizza compatibilità per file PSD e PSB allega una copia con un unico livello dell'immagine al file salvato. Grazie a questi dati supplementari, i file PSD e PSB possono essere aperti nelle versioni precedenti di Photoshop, in Photoshop Lightroom e in applicazioni di terzi che supportano file PSD.  Inoltre è possibile visualizzare le anteprime di QuickLook nel Finder e nella finestra di dialogo Apri in Mac OS. L'aumento delle dimensioni può influire in modo significativo sui file di grandi dimensioni che presentano solo alcuni livelli. Il salvataggio delle informazioni sulla compatibilità inoltre richiede tempi più lunghi per i documenti di grandi dimensioni.

Per salvare più velocemente i documenti risparmiando più spazio su disco, eseguite le seguenti operazioni:

  1. Per i documenti PSD e PSB a 16 e a 32 bit,  attivate l'opzione Disattiva compressione di file PSD e PSB nel pannello Gestione file della finestra di dialogo Preferenze.

  2. Per i file TIFF, non selezionate la compressione ZIP per il documento o i livelli correlati nella finestra di dialogo Opzioni TIFF.

Per ulteriori informazioni, consultate Massimizzazione della compatibilità durante il salvataggio dei file nell'Aiuto di Photoshop CS5.

Utilizzare il metodo immagine a 8 bit

Photoshop consente di effettuare numerose operazioni con le immagini a 16 e 32 bit. L'elaborazione di queste immagini richiede tuttavia una maggior quantità di memoria e spazio di memoria virtuale e tempi più lunghi rispetto alle immagini a 8 bit. Per convertire l'immagine in formato 8 bit per canale, selezionate Immagine > Metodo > 8 bit/canale. Per ulteriori informazioni, consultate Profondità bit nell'Aiuto di Photoshop.

Nota: la conversione a 8 bit/canale comporta l'eliminazione di alcuni dati dall'immagine. Prima di effettuare la conversione a 8 bit/canale, salvate una copia dell'immagine originale a 16 o 32 bit.

La funzionalità Camera Raw è in grado di aprire immagini in entrambi i formati 8 e 16 bit per canale. Per modificare questa impostazione, accedete alla finestra di dialogo Camera Raw aprendo un file raw. Fate clic sul testo blu sottolineato sotto l'anteprima immagini e selezionate 8 bit/canale  o 16 bit/canale dal menu a comparsa Profondità.

Disattivare l'anteprima dei caratteri WYSIWYG

La disattivazione dell'elenco delle anteprime dei font consente di ridurre i tempi di elaborazione dei font in Photoshop. In Photoshop CS4 e CS5, selezionate Photoshop > Preferenze > Tipo (Mac OS) o Modifica > Preferenze > Tipo (Windows). Deselezionate Dimensione anteprima carattere e fate clic su OK. In Photoshop CS6 e CC, selezionate Tipo > Dimensione anteprima carattere > Nessuno.

Per ulteriori informazioni sui caratteri, consultate Risoluzione dei problemi relativi ai caratteri | Photoshop CS5.

Ridurre la risoluzione dell'immagine

Più alta è la risoluzione, maggiore è la quantità di memoria e di spazio su disco richiesta da Photoshop per visualizzare, elaborare e stampare un'immagine. Una risoluzione dell'immagine più alta non è necessariamente sinonimo di maggiore qualità dell'immagine, ma può comportare un rallentamento delle prestazioni di Photoshop e del processo di stampa e l'utilizzo di ulteriore spazio sul disco di memoria virtuale. La risoluzione ottimale delle immagini dipende dal modo in cui vengono visualizzate o stampate. Si consiglia di eseguire le operazioni di elaborazione più impegnative per lo più sull'immagine in risoluzione originale. Al momento di ottimizzare l'immagine per un particolare supporto di output, potrete ridurre le dimensioni e la risoluzione in un formato idoneo per quel supporto. (Salvate una copia dell'immagine in risoluzione originale.)

Per le immagini da presentare sullo schermo o da inviare tramite e-mail, è opportuno ragionare in pixel. La larghezza massima più comune delle immagini per il web è 700 pixel. Vengono prodotti display sempre più grandi, ma attualmente le dimensioni maggiori sono 2560 x 1600 pixel o circa quattro megapixel.

Per ridurre le dimensioni di un'immagine in Photoshop, selezionate Immagine > Dimensione immagine. Nella finestra di dialogo Dimensione immagine, accertatevi che entrambe le caselle Mantieni proporzioni e Ricampiona immagine siano selezionate. Immettete un nuovo valore di larghezza o altezza in pixel. (Specificando il valore di una dimensione, l'opzione Mantieni proporzioni corregge automaticamente il valore della seconda dimensione.)

Aumentare la risoluzione delle immagini stampate oltre 360 DPI, nella maggior parte dei casi comporta vantaggi insignificanti o nulli. Se producete un elevato numero di stampe, è consigliabile eseguire alcune prove per individuare la risoluzione ideale.

Per ridurre la risoluzione di un'immagine in Photoshop, scegliete Immagine > Dimensioni immagine. Nella finestra di dialogo Dimensione immagine, selezionate l'opzione Ricampiona immagine. Modificate i valori delle dimensioni del documento affinché rispecchino le dimensioni fisiche che intendete utilizzare per stampare il documento. Quindi, riducete il valore nel campo Risoluzione e fate clic su OK. Se il valore della risoluzione è inferiore anziché superiore al valore previsto (ovvero, nel caso in cui questa impostazione aumenti anziché ridurre la risoluzione), cercate nella documentazione le istruzioni per ottenere una stampa ottimale delle immagini a bassa risoluzione.

Se intendete aumentare, anziché ridurre, la risoluzione dell'immagine da stampare, eseguite questa operazione in coda, poco prima di stampare l'immagine. Questa modalità vi consente di non dover elaborare tutte queste informazioni supplementari nei primi passaggi.

Per ulteriori informazioni, consultate Opzioni avanzate di ridimensionamento, ricampionamento e ritaglio immagini | Photoshop, nonché Preparazione per stampare da Photoshop e Novità e Come stampare in Photoshop.

Svuotare la memoria di Annulla, Appunti e Storie

Le funzioni Annulla, Appunti e Storie contengono dati di immagini. Per liberare RAM, scegliete Modifica > Svuota memoria, quindi Annulla, Appunti, Storie o Tutto. 

Nota: non è possibile annullare l'operazione Svuota memoria.

Il contenuto degli Appunti spesso è voluminoso se i dati vengono copiati e incollati in documenti di grandi dimensioni. Inoltre, una volta terminata l'operazione, non si rivelano di grande utilità. Le opzioni Annulla e Storie spesso contengono dati utili per correggere errori eseguiti in precedenza. Lo svuotamento della memoria di Storie e Annulla consente di liberare immediatamente più RAM. Gli stati storia inutilizzati vengono tuttavia spostati automaticamente dalla RAM al disco di memoria virtuale mentre si lavora. Pertanto, lo svuotamento della memoria di Storie e Annulla è utile solo in circostanze limitate.

La Galleria filtri consente di provare uno o più filtri su un'immagine prima di applicarne gli effetti e di accelerare i tempi di tale operazione. Per ulteriori informazioni, consultate Panoramica della Galleria filtri nell'Aiuto di Photoshop.

Trascinare elementi da un file all'altro

Trascinare i livelli o i file è più efficace di copiarli e incollarli, poiché è possibile saltare il passaggio della copia negli Appunti, trasferendo i dati direttamente. Copiare e incollare può comportare il trasferimento di una maggiore quantità di dati, riducendo l'efficienza.

Utilizzare i livelli in modo opportuno

I livelli sono fondamentali per l'utilizzo di Photoshop, ma aumentano le dimensioni del file e allungano i tempi di aggiornamento. Dopo ogni modifica all'immagine, Photoshop ricompone ciascun livello. Dopo aver apportato modifiche ai livelli, potete unirli (incorporarli) in modo da ridurre le dimensioni del file. Selezionate i livelli nel pannello Livello, fate clic con il pulsante destro del mouse (Windows) o premete Control e fate clic (Mac OS), quindi scegliete Unisci livelli. (Rimuovete i livelli vuoti dal file poiché ne aumentano inutilmente le dimensioni. Per farlo, selezionate i livelli vuoti dal pannello Livelli, fate clic con il pulsante destro del mouse [Windows] o premete Control+clic [Mac OS], quindi scegliete Elimina livello.) Per unire tutti i livelli in un file, scegliete Livello > Unico livello.

Nota: è importante tenere presente che in Photoshop non è possibile separare livelli precedentemente uniti. Potete scegliere Modifica > Annulla o utilizzare il pannello Storia per tornare a uno stato non unito.

Se alcuni livelli non vengono modificati spesso, considerate la possibilità di convertire livelli o insiemi di livelli in oggetti avanzati, al fine di risparmiare spazio su disco e migliorare le prestazioni. Selezionate i livelli o l'insieme di livelli nel pannello Livello, fate clic con il pulsante destro del mouse (Windows) o premete Control e fate clic (Mac OS), quindi scegliete Converti in oggetto avanzato.

Salvare i file TIFF senza livelli

Photoshop è in grado di salvare i livelli nei file TIFF. Tuttavia, i file TIFF con livelli hanno dimensioni superiori a quelle dei file TIFF uniti e richiedono un maggiore impiego di risorse per l'elaborazione e la stampa. Se lavorate con un file TIFF con livelli, salvate il file originale con livelli come file Adobe Photoshop (.psd). In seguito, quando siete pronti a salvare il file in formato TIFF, scegliete File > Salva con nome. Nella finestra di dialogo Salva con nome, scegliete Formato > TIFF, selezionate Salva come copia, deselezionate Livelli e fate clic su Salva.

Per esportare più velocemente i file TIFF, non selezionate la compressione ZIP. La compressione ZIP consente tuttavia di ridurre al minimo le dimensioni dei file TIFF.

Non eseguire l'esportazione degli Appunti

L'opzione Esporta Appunti consente a Photoshop di rendere disponibile il contenuto degli Appunti agli altri programmi. Se copiate elevate quantità di dati in Photoshop, che tuttavia non intendete copiare in altre applicazioni, risparmierete tempo disattivando l'opzione Esporta Appunti.

  1. Scegliete Photoshop > Preferenze > Generali (Mac OS) oppure Modifica > Preferenze > Generali (Windows).
  2. Deselezionate Esporta Appunti.
  3. Fate clic su OK.

Ottimizzazione del sistema operativo per Photoshop

Chiudere applicazioni ed elementi di avvio non necessari

Eventuali altre applicazioni ed elementi di avvio aperti possono ridurre la quantità di memoria disponibile per Photoshop. Chiudete applicazioni, elementi di avvio ed estensioni non necessari per rendere disponibile più memoria per Photoshop. Consultate i seguenti argomenti nei documenti di supporto Adobe per la risoluzione dei problemi del sistema operativo:

 In seguito, consultate Uso memoria per istruzioni su come allocare RAM a Photoshop.

Disattivare App Nap (Mac)

Pulizia del disco (Windows)

Quando lavorate in un'applicazione, una copia del file di dati viene memorizzata temporaneamente nel disco rigido. Molte applicazioni creano file .tmp che vengono poi eliminati alla chiusura dell'applicazione. Arresti o errori di sistema, tuttavia, possono impedire a un'applicazione di eliminare tali file; questo provoca problemi e riduce lo spazio su disco. Di tanto in tanto, eseguite la pulizia del disco per rimuovere i file temporanei e altri file non in uso.

  1. Effettuate una delle operazioni seguenti:

    • In Windows XP, scegliete Start > Programmi > Accessori > Utilità di sistema > Pulitura disco.
    • In Windows Vista/Windows 7/8: selezionate Start, digitate Pulizia disco nella casella di testo per la ricerca, quindi scegliete Pulizia disco dall'elenco di programmi.
  2. Se necessario, scegliete l'unità da pulire.
  3. Selezionate i file temporanei ed eventuali altri file che volete eliminare.
  4. Fate clic su OK.

Deframmentazione del disco rigido

Quando si aggiungono, eliminano o spostano file su un disco rigido, lo spazio disponibile non è più costituito da un singolo blocco contiguo. Se il sistema non dispone di una quantità sufficiente di spazio libero contiguo nel disco rigido, salverà frammenti di file in diverse posizioni. È necessario più tempo per leggere o scrivere un file frammentato rispetto a un file salvato in una posizione contigua.

Per istruzioni su come deframmentare il disco rigido con Windows, consultate i seguenti argomenti della Guida in linea di Microsoft:

  • (Windows XP) "Migliorare le prestazioni con le attività di manutenzione". Seguite le istruzioni al "Punto 4: Deframmentare l'unità disco rigido".
  • (Windows 7 e Vista) "Deframmentare il disco rigido per migliorare le prestazioni"
  • (Windows 8) "Ottimizzare il disco rigido"

In Mac OS utilizzate un'utilità disco, ad esempio l'Utilità di deframmentazione dischi, Symantec Norton Utilities o Micromat Drive 10. La frammentazione è raramente un problema in Mac OS, a meno che non venga eseguita quando l'unità è quasi piena. Per ulteriori informazioni, consultate Deframmentazione del disco rigido e ricerca di errori.

Nota: negli array RAID non si verifica la frammentazione. La frammentazione può diventare un problema quando si utilizza un unico disco per tutte le operazioni, oppure quando uno stesso volume è condiviso da file permanenti e dal disco di memoria virtuale di Photoshop, in particolare se lo spazio libero è minimo. In questi casi, la deframmentazione del disco può comportare vantaggi significativi.

Non è necessario deframmentare i dischi a stato solido, in quanto le prestazioni non subiscono un degrado significativo con i livelli di frammentazione standard.

Installazione degli aggiornamenti disponibili per il sistema operativo

Gli aggiornamenti del sistema operativo Windows o Mac OS X possono migliorarne le prestazioni e la compatibilità con altre applicazioni. 

Scaricate i service pack di Windows e gli altri aggiornamenti dal sito Web di Microsoft. Per assistenza relativa all'installazione di service pack e altri aggiornamenti, contattate il supporto tecnico di Microsoft.

Per ottenere gli aggiornamenti per Mac OS X, scegliete Aggiornamento Software dal menu Apple. Per assistenza relativa all'installazione degli aggiornamenti, contattate il supporto tecnico Apple.

Importante: prima di installare un aggiornamento di sistema, controllate i requisiti di sistema per il software Adobe al fine di verificare la compatibilità. Verificate inoltre eventuale hardware o software di terze parti che utilizzate con il software Adobe. Se l'aggiornamento non è incluso nell'elenco, contattate Adobe o il produttore del software o hardware di terze parti.

Specificare una memoria virtuale fissa (Windows)

La memoria virtuale consente al sistema di utilizzare lo spazio su disco rigido per memorizzare informazioni normalmente archiviate nella memoria. L'accesso alle informazioni su disco rigido richiede più tempo rispetto all'accesso alle informazioni in memoria. Di conseguenza, l'utilizzo di una porzione del disco rigido come memoria virtuale può diminuire le prestazioni. Photoshop non è in grado di sfruttare lo spazio sul disco rigido utilizzato dal sistema per la memoria virtuale destinata ai file dei dischi di memoria virtuale, che viene usato per la memorizzazione delle informazioni sulle immagini durante il lavoro.

Se specificate una memoria virtuale fissa, i file di dischi di memoria virtuale di Photoshop evitano conflitti con la memoria virtuale per l'occupazione dello stesso spazio, in particolare se avete impostato un'unità diversa dal disco di memoria virtuale principale per la memoria virtuale. Per entrambi i tipi di memoria virtuale utilizzate un'unità con una quantità sufficiente di spazio libero contiguo al fine di ottimizzare le prestazioni. Inoltre, mantenete il file di paging su un disco rigido dedicato, deframmentato e vuoto.

Come consueto, il suggerimento di utilizzare dischi separati per la memoria virtuale e i dischi di memoria virtuale non è valido per i dischi a stato solido. È·vantaggioso caricare i file utilizzati più di frequente su un disco SSD, se a disposizione. Caricando tutti i file sullo stesso disco SSD, il funzionamento non verrà penalizzato o subirà solo insignificanti rallentamenti.

Per cambiare la memoria virtuale in Windows XP, chiudete tutte le applicazioni ed effettuate quanto segue:

  1. Scegliete Start > Impostazioni > Pannello di controllo e fate doppio clic su Sistema.
  2. Fate clic sulla scheda Avanzate, quindi selezionate Impostazioni nella sezione Prestazioni.
  3. Fate clic sulla scheda Avanzate, quindi su Cambia nella sezione Memoria virtuale.
  4. Dall'elenco delle unità, selezionate un disco rigido che dispone di 1,5 volte la quantità di RAM installata nel computer. Ad esempio, se il computer dispone di 2 GB di RAM, selezionate un disco rigido con almeno 3 GB di spazio libero.
  5. Nella sezione Dimensioni file di paging per l'unità selezionata, selezionate Dimensioni personalizzate; quindi inserite un valore corrispondente al doppio della quantità di RAM installata nel computer nella casella Dimensioni iniziali.
  6. Nella casella Dimensioni massime, inserite un valore pari a quattro volte la quantità di RAM installata nel computer.
  7. Fate clic su Imposta, quindi su OK.  
  8. Fate clic per chiudere l'Applet Pannello di controllo Sistema.
  9. Fate clic su Sì nella finestra di dialogo relativa alla modifica delle impostazioni di sistema per riavviare Windows.

Per cambiare la memoria virtuale in Windows 7 e Vista, chiudete tutte le applicazioni ed effettuate quanto segue:

  1. Scegliete Start > Pannello di controllo e fate doppio clic su Sistema.
  2. Scegliete Impostazioni di sistema avanzate dall'elenco Attività.
  3. Selezionate la scheda Avanzate, quindi fate clic su Impostazioni nella sezione Prestazioni.
  4. Selezionate la scheda Avanzate e fate clic su Cambia.
  5. Deselezionate Gestisci automaticamente dimensioni file di paging per tutte le unità.
  6. Fate clic su ciascuna lettera per visualizzare lo spazio disponibile nella relativa unità. Selezionate un disco rigido con una quantità di spazio libero disponibile pari ad almeno tre volte quella della RAM installata nel computer e non contenga un disco di memoria virtuale.
  7. Selezionate Dimensioni personalizzate, aggiungete 300 MB alla quantità di RAM fisica e digitate il valore ottenuto nella casella Dimensioni iniziali. Digitate un valore pari a tre volte la quantità di RAM installata nel computer nella casella Dimensioni massime. 
  8. Fate clic su Imposta, quindi su OK. Continuate a fare clic su OK per chiudere tutte le finestre di dialogo.
  9. Riavviate il computer. Se sono presenti applicazioni aperte, selezionate Riavvia in seguito, quindi chiudete tutte le applicazioni e riavviate Windows. In caso contrario, riavviate subito il computer.

Per cambiare la memoria virtuale in Windows 8, chiudete tutte le applicazioni ed effettuate quanto segue:

  1. Fate clic su Start > Pannelli di controllo. Se non è disponibile alcun pulsante Start, scegliete l'icona delle cartelle e navigate all'interno del computer per cercare il pannello di controllo.
  2. Scegliete Sistema e sicurezza > Sistema.
  3. Seguite i passaggi per Windows 7 e Vista sopra, partendo dal 3.

Per ulteriori informazioni, consultate i seguenti argomenti della Guida in linea di Microsoft:

  • (Windows XP) "Per modificare la dimensione del file di paging della memoria virtuale"
  • (Windows Vista, Windows 7 e Windows 8) "Come modificare la dimensione della memoria virtuale"

Vedete anche Virtual Memory, tratto da Real World Photoshop CS5 for Photographers (Peachpit Press), scritto da Conrad Chavez.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online