在优化了图形或文档后,您可以将其导出(或保存,视其源文件类型而定)。

可以将文档导出(或者,在某些情况下保存)为 GIF、JPEG 或其它图形文件格式的单个图像。还可以将整个文档导出为 HTML 文件及关联的图像文件,或者仅导出选定切片或指定区域。另外,也可以将 Fireworks 状态和层导出为单独的图像文件。

Fireworks 导出文件的默认位置按此顺序由以下因素确定:

  1. 文档的当前导出首选参数,该首选参数在您导出该文档并保存 PNG 时确定

  2. 当前导出/保存位置,在从“保存”、“另存为”或“导出”对话框中的默认位置浏览时确定

  3. 当前文件的位置

  4. 在操作系统中保存新文档或图像的默认位置

    与此相对的是,Fireworks 保存文档的默认位置由另一组条件确定。有关详细信息,请参阅保存 Fireworks 文件

将页面导出为图像文件

  1. 选择“文件”>“导出”。

  2. 选择导出文件的位置。

  3. 执行下列操作之一:

    • 从“导出”弹出菜单中选择“仅图像”,然后选中或取消选中“仅限当前页”复选框。页面会导出为“优化”面板上设置的图像格式。

    • 在“导出”弹出菜单中选择“页面到文件”,然后在“导出为”弹出菜单中选择“图像”。页面会导出为“优化”面板上设置的图像格式

    • 在“导出”弹出菜单中选择“页面到文件”,然后在“导出为”弹出菜单中选择“Fireworks PNG”。每个页面导出为向后与 Fireworks 8 兼容的单独 PNG 文件。

    注意:

    如果要以所选的格式导出所有页面,则选择所有页面,然后优化设置。

导出单个图像

如果要使用 Fireworks 中已打开的现有图像,则可以保存图像而不将其导出。有关详细信息,请参阅以其它格式保存文档

注意:

要只导出文档中的某些图像,必须首先将文档切片,然后只导出所需的切片。

  1. 在“优化”面板中,选择文件格式并设置格式特定的选项。

  2. 选择“文件”>“导出”。

  3. 选择要将图像文件导出到的位置。

    对于 Web 图形来说,最佳位置通常是本地网站内的一个文件夹。

  4. 输入无扩展名的文件名。扩展名会在导出过程中根据文件类型添加。

  5. 从“导出”弹出菜单中选择“仅图像”。

  6. 单击“保存”。

导出切片的文档

默认情况下,当导出包含切片的 Fireworks 文档时,将导出一个 HTML 文件及其相关图像。导出的 HTML 文件可以在 Web 浏览器中查看,也可以将其导入其它应用程序以供进一步编辑。

导出前,确保在“HTML 设置”对话框中选择了适当的 HTML 样式。请参阅设置 HTML 导出选项

导出所有切片

  1. 选择“文件”>“导出”。

  2. 导航到硬盘上要导出到的文件夹。

  3. 从“导出”弹出菜单中选择“HTML 和图像”。

  4. 在“文件名”(在 Windows 中)或“另存为”(在 Mac OS 中)框中键入文件名。

  5. 从“HTML”弹出菜单中选择“导出 HTML 文件”。

  6. 从“切片”弹出菜单中选择“导出切片”。

  7. (可选)选择“将图像放入子文件夹”。

  8. 单击“保存”。

导出所选切片

  1. 按住 Shift 并单击可选择多个切片。

  2. 选择“文件”>“导出”。

  3. 选择存储导出文件的位置,如本地网站内的文件夹。

  4. 从“导出”弹出菜单中选择“HTML 和图像”。

  5. 输入无扩展名的文件名。扩展名会在导出过程中根据文件类型添加。

    如果导出的是多个切片,则 Fireworks 使用所输入的名称作为所有导出图形的根名称,但不包括那些用“层”面板或“属性”检查器自定义命名的图形。

  6. 从“切片”弹出菜单中选择“导出切片”。

  7. 若要仅导出在导出之前选定的切片,请选择“仅已选切片”,并确保选中“包括无切片区域”选项。

  8. 单击“保存”。

更新切片

如果已经导出了切片文档,并且随后在 Fireworks 中对原始文档进行了更改,则可以只更新更改的图像或切片。要使查找替换切片变得容易,请自定义切片的名称。

  1. 隐藏切片并编辑其下的区域。

  2. 再次显示切片。

  3. 右键单击(在 Windows 中)或按住 Control 并单击(在 Mac OS 中)切片,然后选择“导出所选切片”。

  4. 选择与具有相同基本名称的原始切片相同的文件夹,然后单击“保存”。

  5. 当要求替换现有文件时,单击“确定”。

    注意:

    不要在 Fireworks 中调整切片大小使其超出原导出大小,否则在更新切片之后,HTML 文档中将出现意外的结果。

导出动画

完成动画的创建和优化后,就可以将其导出了。您可以将动画导出为以下任何文件类型:

GIF 动画

GIF 动画可以使剪贴画和卡通图形达到最佳效果。

Flash SWF 或 Fireworks PNG(无需导出)

将动画导出为 SWF 文件以便导入到 Flash。或者,通过将 Fireworks PNG 源文件直接导入到 Flash 跳过导出步骤。使用此直接方法,您可以导入动画的所有层和状态,然后在 Flash 中进一步编辑。请参阅与 Flash 一起使用

多个文件

在同一对象的不同层上有许多元件时,将动画状态或层导出为多个文件非常有用。例如,如果一个公司名称的每个字在图形中都是动态的,就可以将该名称的横幅广告作为多个文件导出。请参阅将状态或层导出为多个文件

如果文档中包含多个动画,则可以插入切片,以便用不同的动画设置(如循环和状态延迟)分别导出每个动画。

导出 GIF 动画

  1. 选择“选择”>“取消选择”以取消选择所有切片和对象,并在“优化”面板中选择“GIF 动画”作为文件格式。

  2. 选择“文件”>“导出”。

  3. 键入文件的名称,然后选择目标。

  4. 单击“保存”。

导出多个具有不同动画设置的 GIF 动画

  1. 按住 Shift 并单击动画将其全部选中。

  2. 选择“编辑”>“插入”>“矩形切片”或“多边形切片”。

  3. 在消息框中单击“多个”。

  4. 分别选择每个切片并使用“状态”面板为每个切片设置不同的动画设置。

  5. 选择要进行动画处理的所有切片,然后在“优化”面板中选择“GIF 动画”作为文件格式。

  6. 右键单击(在 Windows 中)或按住 Control 并单击(在 Mac OS 中)每个切片,然后选择“导出所选切片”分别导出每个切片。在“导出”对话框中为每个文件键入名称,选择目标并单击“保存”。

将状态或层导出为多个文件

Fireworks 可以用“优化”面板中指定的优化设置,将文档内的每个层或状态导出为单独的图像文件。层或状态的名称确定每个导出文件的文件名。该导出方法有时用于导出动画。

  1. 选择“文件”>“导出”。

  2. 键入文件名并选择目标文件夹。

  3. 在“导出”弹出菜单中选择一个选项:

    状态到文件

    将状态导出为多个文件。

    层到文件

    将层导出为多个文件。

    :这样将导出当前状态中的所有层。

  4. 若要自动裁剪每个导出的图像以使其只包括每个状态中的对象,请选择“修剪图像”。相反,若要包括整个画布(包括对象之外的空白区域),请取消选择此选项。

  5. 单击“保存”。

从文档导出区域

  1. 从“工具”面板中选择“导出区域”工具 

  2. 拖动一个选取框,定义要导出的文档的某个部分。

    注意:

    可以在拖动时调整选取框的位置。在按住鼠标按钮的同时,按住空格键,然后将选取框拖动到画布上的另一个位置。释放空格键继续绘制选取框。

    释放鼠标键时,导出区域保留为选中状态。

  3. 如有必要,调整导出区域的大小:

    • 若要按比例调整导出区域选取框的大小,请按住 Shift 并拖动手柄。

    • 若要从中心调整选取框的大小,请按住 Alt(在 Windows 中)或 Option(在 Mac OS 中)并拖动手柄。

    • 若要约束比例并从中心调整大小,请按住 Alt+Shift(在 Windows 中)或 Option+Shift(在 Mac OS 中)并拖动手柄。

  4. 在导出区域选取框内部双击以转到“图像预览”。

  5. 在“图像预览”中调整设置,然后单击“导出”。

  6. 键入文件名并选择目标文件夹。

  7. 在“导出”弹出菜单中,选择“仅图像”。

  8. 单击“保存”。

    注意:

    若要取消而不导出,请在导出区域选取框外双击、按 Esc 或选择其它工具。

导出 HTML

除非另有指定,否则在导出切片的 Fireworks 文档时,您会导出一个 HTML 文件及其图像。若要定义 Fireworks 导出 HTML 的方式,请使用“HTML 设置”对话框。

Fireworks 生成大多数 Web 浏览器和 HTML 编辑器都能够读取的纯 HTML。默认情况下,导出将指定 UTF-8 编码。

有多种方式导出 Fireworks HTML:

  • 导出 HTML 文件,以后可以在 HTML 编辑器中将其打开进行编辑。

  • 将 Fireworks 文件中的每页导出到单独的 HTML 文件。

  • 将 HTML 代码复制到 Fireworks 中的剪贴板,并将该代码直接粘贴到现有 HTML 文档中。

  • 导出 HTML 文件,在 HTML 编辑器中将其打开,手动从文件中复制代码的某些部分,然后将该代码粘贴到其它 HTML 文档中。

  • 将 HTML 导出为层叠样式表 (CSS) 层和 XHTML。

  • 使用“更新 HTML”命令对先前创建的 HTML 文件进行更改。

    Fireworks 可让您以“通用”、“Dreamweaver”、“Microsoft® FrontPage®”和“Adobe GoLive®”格式导出 HTML。

    :Adobe Dreamweaver 与 Fireworks 紧密集成。Fireworks 向 Dreamweaver 导出 HTML 的方式与向其它 HTML 编辑器导出 HTML 的方式不同。如果您要将 Fireworks HTML 导出到 Dreamweaver,请参阅与 Dreamweaver 一起使用

    如果您在团队环境中工作,则将 Fireworks HTML 导出到其它应用程序中的导出方法最为理想。此方法会将工作流程分割为多个部分,这样某人可以在一个应用程序中执行一项任务,而另一个人则可以稍后使用另一应用程序接着执行下面的任务。

在导出的 HTML 中包含注释

Fireworks HTML 注释以 <!-- 开始,以 --> 结束。这两个标记之间的任何内容都不被解释为 HTML 或 JavaScript 代码。

  1. 导出前,在“HTML 设置”对话框的“常规”选项卡上选择“包含 HTML 注释”选项。

导出的结果

在从 Fireworks 导出或复制 HTML 时,会生成以下内容:

  • 重新组合切片图像所必需的 HTML 代码,以及可能有的 JavaScript 代码(如果文档中包含交互元素)。Fireworks HTML 包含指向导出图像的链接并将网页背景色设为画布颜色。

  • 一个或多个图像文件,具体取决于文档中切片的数目以及按钮中包含的状态的数目。

  • 一个称为 spacer.gif 的文件(如有必要)。Spacer.gif 是一个透明的 1 x 1 像素的 GIF 图形,Fireworks 用它来解决切片图像在 HTML 表格中重新组合时产生的间距问题。可以选择 Fireworks 是否导出间隔符。

  • 如果您导出任何弹出菜单,则会导出以下文件:mm_css_menu.js 以及包含 CSS 弹出菜单代码的 .css 文件。如果弹出菜单包含子菜单,则还会导出一个称为 arrows.gif 的文件。

  • 如果将 HTML 导出或复制到 Dreamweaver,则会创建有助于 Fireworks 与 Dreamweaver 集成的注释文件。这些文件的扩展名为 .mno。

导出 Fireworks HTML

  1. 选择“文件”>“导出”。

  2. 导航到硬盘上要导出到的文件夹。

  3. 从“导出”弹出菜单中选择“HTML 和图像”。

  4. 单击“选项”按钮,并从“HTML 设置”对话框的“常规”选项卡上的“HTML 样式”弹出菜单中选择 HTML 编辑器。如果没有列出您需要的 HTML 编辑器,请选择“通用”。

    注意:

    必须选择 HTML 编辑器作为 HTML 样式,以便在导入到 HTML 编辑器中时,按钮和变换图像等交互元素能够正常工作。

  5. 单击“确定”。

  6. 从“HTML”弹出菜单中选择“导出 HTML 文件”。

  7. 如果文档中包含切片,则从“切片”弹出菜单中选择“导出切片”。

  8. 若要将图像存储在单独的文件夹中,请选择“将图像放入子文件夹”。您可以选择特定文件夹或使用 Fireworks 的默认图像文件夹。

  9. 如果要导出包含多个页面的 Fireworks 文档,请取消选中“仅限当前页”复选框以将所有页面导出到单独的 HTML 文档中。

  10. 单击“保存”。

    导出后,您将在硬盘上看到 Fireworks 导出的文件。在“导出”对话框中指定的位置将会生成图像和一个 HTML 文件。

将 HTML 代码复制剪贴板

可以使用两种方法之一在 Fireworks 中将 HTML 代码复制到剪贴板。使用“复制 HTML 代码”命令,或者在“导出”对话框中选择“复制到剪贴板”选项。稍后可以在首选的 HTML 编辑器中将该 HTML 粘贴到文档中。

在确定如何将 Fireworks HTML 放到其它应用程序中时,请考虑将 HTML 代码复制到剪贴板存在以下缺点:

  • 无法选择将图像保存到子文件夹中。图像必须与粘贴了复制的 HTML 代码的 HTML 文件放在同一文件夹中。复制到 Dreamweaver 的 HTML 除外。

  • Fireworks 弹出菜单中使用的任何链接或路径都将映射到硬盘中。复制到 Dreamweaver 的 HTML 除外。

  • 如果使用的 HTML 编辑器不是 Dreamweaver 或 Microsoft FrontPage,则与按钮、行为和变换图像相关联的 JavaScript 代码将被复制但可能无法正常工作。

    如果这些会带来问题,则使用“导出 HTML”选项而不是将 HTML 复制到剪贴板。

    :在复制 HTML 代码之前,请确保已选择了适当的 HTML 样式,并从“HTML 设置”对话框的“常规”选项卡中选中“包含 HTML 注释”。

使用“复制 HTML 代码”选项复制 Fireworks HTML

  1. 选择“编辑”>“复制 HTML 代码”。

  2. 按照向导提示操作。出现提示时,请指定一个文件夹作为导出图像的目标文件夹。该文件夹必须是 HTML 文件将要驻留的位置。

    注意:

    如果计划将 HTML 代码粘贴到 Dreamweaver,则无论将图像导出到哪儿,只要它们和将要粘贴代码的 HTML 文件属于同一个 Dreamweaver 站点即可。

使用“导出”对话框复制 Fireworks HTML

  1. 选择“文件”>“导出”。

  2. 在“导出”对话框中,为导出的图像指定一个目标文件夹。该文件夹必须是 HTML 文件将要驻留的同一位置。

    注意:

    如果计划将 HTML 代码粘贴到 Dreamweaver,则无论将图像导出到哪儿,只要它们和将要粘贴代码的 HTML 文件属于同一个 Dreamweaver 站点即可。

  3. 从“导出”弹出菜单中选择“HTML 和图像”。

  4. 从 HTML 弹出菜单中选择“复制到剪贴板”。

  5. 如果文档中包含切片,则从“切片”弹出菜单中选择“导出切片”。

  6. 单击“选项”按钮,从“HTML 设置”对话框中选择 HTML 编辑器,然后单击“确定”。

  7. 单击“保存”。

将从 Fireworks 复制的 HTML 粘贴到 HTML 文档

  1. 在 HTML 编辑器中,打开现有的 HTML 文档或创建新文档。将文档保存在图像导出到的相同位置。

    注意:

    如果使用 Dreamweaver,则没有必要将 HTML 文件与导出的图像保存在同一位置。只要是将图像从 Fireworks 导出到 Dreamweaver 站点并将 HTML 文件保存在该站点内的某个位置,Dreamweaver 就会解析相关图像的路径。

  2. 查看 HTML 代码,并将插入点放在 <BODY> 标签之间。

    注意:

    从 Fireworks 复制的 HTML 代码不包括开始或结束 <HTML><BODY> 标签。

  3. 粘贴 HTML 代码。

    如有可能,当复制到剪贴板时,请将图像导出到它们将在网站上驻留的位置。Fireworks 使用与文档相关的 URL,因此,如果 HTML 或图像被移动,URL 链接就会断开。

从导出的 Fireworks 文件中复制代码并粘贴到其它 HTML 文档

  1. 在 HTML 编辑器中打开导出的 Fireworks HTML 文件。

  2. 高亮显示必要的代码并复制到剪贴板。

  3. 打开现有的 HTML 文档或创建新文档。

  4. 将代码粘贴到新 HTML 文件。您不必复制 <HTML><BODY> 标签,因为目标 HTML 文档中应该已包含这些标签。

    在 Fireworks 中,如果从“HTML 设置”对话框中选择了“包含 HTML 注释”,请按照注释中的说明来复制代码并将其粘贴到适当的位置。

  5. 如果您的 Fireworks 文档包含交互元素,请复制 JavaScript 代码。

    JavaScript 代码包括在 <SCRIPT> 标签之间,且位于文档的 <HEAD> 部分。复制并粘贴整个 <SCRIPT> 部分,除非目标文档中已经有 <SCRIPT> 部分。在这种情况下,应该只将 <SCRIPT> 部分的内容复制并粘贴到现有的 <SCRIPT> 部分,注意不要覆盖现有部分的内容。同时,请确保粘贴代码后在 <SCRIPT> 部分中没有重复的 JavaScript 函数。

更新导出的 HTML

更新使您可以对以前导出的 Fireworks HTML 文档进行更改,如果只想更新文档的某个部分,则此功能非常有用。

注意:

对于 Dreamweaver 文档和其它 HTML 文档,“更新 HTML”的工作方式各不相同。有关详细信息,请参阅与 Dreamweaver 一起使用

更新时,可以选择只替换更改过的图像,或者覆盖所有的代码和图像。如果选择只替换更改过的图像,则在 Fireworks 外部对 HTML 文件所做的任何更改都将保留。

注意:

如果要对文档布局作大量更改,则在 Fireworks 中进行更改并重新导出 HTML 文件。

  1. 选择“文件”>“更新 HTML”。

  2. 选择要更新的文件。

  3. 单击“打开”。

  4. 执行下列操作之一:

    • 如果没有找到 Fireworks 生成的 HTML,单击“确定”在文档结尾处插入新的 HTML。

    • 如果找到了 Fireworks 生成的 HTML,请选择下列操作之一并单击“确定”:

      替换图像及其 HTML

      替换以前的 Fireworks HTML

      仅更新图像

      仅覆盖图像

  5. 如果出现“选择图像文件夹”对话框,则选择一个文件夹并单击“打开”。

导出 CSS 层

CSS 层可以重叠,彼此堆叠在一起。在 Fireworks 中,正常的 HTML 输出不重叠。

  1. 选择“文件”>“导出”。

  2. 键入文件名并选择目标文件夹。

  3. 从“导出”弹出菜单中选择“CSS 和图像”。

    • 若要仅导出当前状态,请选择“仅限当前状态”。

    • 若要仅导出当前页面,请选择“仅限当前页面”。

    • 若要为图像选择文件夹,请选择“将图像放入子文件夹”。

  4. 单击“选项”以设置 HTML 页面属性。

  5. 单击“浏览”以指定背景图像并设置背景图像平铺:

    • 选择“无重复”以便仅显示一次图像。

    • 选择“重复”,以便横向和纵向重复或平铺图像。

    • 选择“横向重复”,以便横向平铺图像。

    • 选择“纵向重复”选项,以便纵向平铺图像。

  6. 选择在浏览器中使页面左对齐、居中对齐或右对齐。

  7. 单击“确定”,然后单击“保存”。

导出 XHTML

XHTML 是 HTML(网页格式设置和显示的当前标准)和 XML(可扩展标记语言)的结合。XHTML 不仅向后兼容(也就是,当前大多数 Web 浏览器都可以查看它),而且任何显示 XML 内容的设备(如 PDA、移动电话以及其它手提设备)也都可以读取它。

Fireworks 还可以导入 XHTML。请参阅从 HTML 文件创建 Fireworks PNG 文件

有关 XHTML 的详细信息,请访问万维网协会 (W3C) 的 XHTML 规范,网址是:www.w3.org

  1. 选择“文件”>“HTML 设置”,并从“常规”选项卡上的“HTML 样式”弹出菜单中选择一种 XHTML 样式,然后单击“确定”。

  2. 使用任何一种可用于导出或复制 HTML 的方法导出文档。请参阅导出 HTML

    注意:

    在导出到 XHTML 时,Fireworks 使用 UTF-8 编码。

导出使用和不使用 UTF-8 编码的文件

UTF-8(即“第 8 套通用字符集转换格式”)是一种文本编码方法,它允许 Web 浏览器在同一 HTML 页面上显示不同的字符集(例如,中文和英文文本)。默认情况下会打开 UTF-8 编码。

Fireworks 还可以导入使用 UTF-8 编码的文档。请参阅从 HTML 文件创建 Fireworks PNG 文件

导出不使用 UTF-8 编码的文档

  1. 选择“文件”>“HTML 设置”。

  2. 在“文档特定信息”选项卡上,清除“UTF-8 编码”复选框,然后单击“确定”。

  3. 使用任何一种可用于导出或复制 HTML 的方法导出文档。

设置 HTML 导出选项

“HTML 设置”对话框使您可以定义 Fireworks 导出 HTML 的方式。在“文档特定信息”选项卡中所做的更改只影响当前文档。“常规”和“表格”设置是全局首选参数,因此会影响所有的新文档。

  1. 执行下列操作之一:

    • 选择“文件”>“HTML 设置”。

    • 在“导出”对话框中单击“选项”按钮。

  2. 在“常规”选项卡上选择您需要的选项。

    HTML 样式

    为导出的 HTML 选择样式。

    通用 HTML 适用于任何 HTML 编辑器。但是如果文档中包含行为或其它交互内容,则选择一个特定的编辑器(如果它出现在列表中)。

    若要用 XHTML 标准导出文档,请从弹出菜单中选择适当的 XHTML 样式。

    扩展名

    从该弹出菜单中选择一个文件扩展名或输入新的扩展名。

    包含 HTML 注释

    选择此项以包含有关在 HTML 中复制和粘贴的位置的注释。如果文档中包含交互元素(如按钮、行为或变换图像),则建议使用此选项。

    小写文件名称

    选择此项使 HTML 文件及其相关图像文件的名称在导出时变为小写。

    :如果在“扩展名”弹出菜单中选择了大写扩展名,此选项则不会将 HTML 文件的扩展名更改为小写。

    对弹出菜单应用 CSS

    选择此项以便对弹出菜单代码应用 CSS 而不是 JavaScript。可以使用 Dreamweaver 为菜单编索引,以及更新代码中的链接。

    将 CSS 写入外部文件

    选择此项使 CSS 代码写入到外部 .css 文件,该文件导出到与 HTML 文件相同的位置。.css 文件的名称与 HTML 文件的名称相匹配(文件扩展名除外)。选择此选项还会将名为 mm_css_menu.js 的文件导出到与 HTML 文件相同的位置。

    :此选项仅在您选择了“对弹出菜单应用 CSS”选项时可用。

    文件创建器 (Mac OS)

    从该弹出菜单中选择一个相关的应用程序。当在硬盘上双击导出的 HTML 文件时,它将在所选的应用程序中自动打开。

  3. 在“表格”选项卡中选择 HTML 表格的设置。有关信息,请参阅定义导出 HTML 表的方式

  4. 在“文档特定信息”选项卡中,从下列选项中选择:

    切片文件名

    在该弹出菜单中选择用于自动命名切片的公式。可以使用默认设置或选择自己的选项。

    :如果对前三个菜单中的任何一个菜单选择了“无”,Fireworks 将导出互相覆盖的切片文件,从而仅导出单个图形以及一个在每个单元格中都显示该图形的表格。

    默认替换标签

    输入将替换所有正在从 Web 下载的图像和下载失败的图像的文本。在一些浏览器中,当指针经过图像时,此文本还会显示为工具提示。这对于那些有视觉障碍的 Web 用户也是一种帮助。

    导出多个导航栏 HTML 页面(供不存在框架集时使用)

    在导出将多个页面链接在一起的导航栏时选择此项。Fireworks 将为导航栏中的每个按钮导出其它页面。

    包括无切片对象的区域

    选择该选项可包括不存在切片的画布区域。

    UTF-8 编码

    默认情况下打开。允许导出的文档显示多个字符集的字符。若要关闭此选项,请取消选中该复选框。

  5. 若要将这些设置保存为全局默认设置,请单击“设为默认值”。

导出 Adobe PDF 文件

在希望打印 Fireworks 设计或将其分发以进行审阅时,请将其导出到 Adobe PDF。审阅者可以在 Adobe Reader® 或 Acrobat® 中添加注释或回复其他人的注释。有关设置 PDF 审阅的信息,请参阅 Acrobat 帮助。

导出的 PDF 文件将保留所有页面和超文本链接,使审阅者像在 Web 上一样浏览 PDF。但是,与 HTML 原型不同,Adobe PDF 提供防止审阅者编辑或复制设计的安全设置。

  1. 选择“文件”>“导出”。

  2. 从“导出”弹出菜单中选择“Adobe PDF”。

  3. 选择要导出的页面,并选择“在导出后查看 PDF”,以便在 Adobe Reader 或 Acrobat 中自动打开 PDF。

  4. 若要自定义 PDF,请单击“选项”,然后调整以下设置:

    兼容性

    确定哪些 Adobe PDF 应用程序可以打开导出的文件。

    压缩

    确定图像压缩的类型,减小文件大小。通常,JPEG 和 JPEG2000 压缩对于类似于照片的具有渐变颜色的图像压缩效果较好。对于具有大面积纯色、浅色区域的插图,ZIP 是较好的选择。

    品质

    对于 JPEG 或 JPEG2000 压缩,提供图像质量设置。选择高品质时,生成的文件会很大,但图像质量很好。

    转换为灰度

    将所有图像转换为灰度,以减小文件大小。

    启用文本选择

    允许审阅者从导出的文件中复制文本。取消选择该选项将极大地减小文件大小。

    出血值

    确定每个页面上包围图像的空白边框的像素宽度。例如,值 20 表示使用 20 个像素的边框包围每个图像。

    使用口令打开文档

    需要“打开口令”才能打开导出的文件。

    使用口令限制任务

    需要“保护口令”才能执行以下选定功能:打印、编辑、复制和注释。

  5. 单击“确定”关闭“选项”对话框。

  6. 指定文件名和位置,然后单击“保存”。

    注意:

    在导出到 PDF 时,即使 Fireworks 文档中的页面具有透明画布,应用了透明特性的对象也会失去其透明特性。为避免出现这种情况,请在导出到 PDF 之前将画布设置为非透明背景。

视频

使用 Fireworks 以 PDF 或 HTML 文件格式创建客户校样稿 (00:05:32)

了解如何使用“Fireworks 导出”菜单准备 PDF 或 HTML 文档以供客户审批或团队审核。

作者:Tom Green

在 Adobe Acrobat 或 Adobe Reader 中查看导出的 PDF 文件时,请使用以下设置:

  1. 在 Adobe Acrobat 或 Adobe Reader 中选择“编辑”>“首选项”。

  2. 在左侧面板上选择“页面显示”。

  3. 将“自定义分辨率”设为 72 像素/英寸。

  4. 将“缩放”值设为 100%。

导出 FXG 文件

FXG 是 Flash Catalyst、Fireworks、Illustrator 和 Photoshop 所支持的一种文件格式。使用 FXG 导出导出包含矢量和位图图像的文件时,会创建一个名称为 <filename.assets> 的独立文件夹。该文件夹包含与该文件关联的位图图像。

如果从该文件夹删除了任何关联的文件,则导入操作都会失败。

注意:

将 FXG 中没有相应映射标签的元素、滤镜、混合模式、渐变和蒙版导出为位图图形。

  1. 选择“文件”>“导出”并导航到要保存文件的位置。

  2. 输入 FXG 文件的文件名。

  3. 在“导出”对话框中,从“导出”菜单选择“FXG 和图像”。

  4. 单击“保存”。

注意:

当在 Flash Catalyst 中打开导出的 FXG 文件时,在 Fireworks 中超出画布的对象将会全部显示出来。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略