Fireworks 导出固有的 Photoshop (PSD) 文件并保留许多 Photoshop 功能。还可以将 Fireworks 图形导出到 Photoshop 进行详细的图像编辑。

将 Photoshop 图像置入 Fireworks 中

可以使用“文件”>“导入”和“文件”>“打开”命令或通过将文件拖到画布的方法将 Photoshop 图像置入 Fireworks 中。“导入”命令提供对背景层和层文件夹的独特选项的访问。与之相比,“打开”命令和文件拖动方法提供对辅助线和状态选项的访问。

Fireworks 中的已转换和不受支持的 Photoshop 功能

打开或导入 Photoshop 文件时,Fireworks 会使用您指定的导入首选参数将图像转换为 PNG 格式。(请参阅 Photoshop 导入和打开首选项。)

  • 各个层蒙版转换为 Fireworks 对象蒙版。不支持组蒙版。

  • 剪贴蒙版转换为对象蒙版,但其外观会略有变化。为了保持外观,可选择剪贴蒙版首选参数,但这样会导致蒙版不可编辑。

  • 如果存在相应的混合模式,层混合模式将转换为 Fireworks 对象混合模式。

  • 默认情况下会保持层效果。如果希望将这些效果转换为相应的动态滤镜,请选择“层效果”首选参数。然而需要注意的是,相似的效果和滤镜在外观上可能略有不同。

  • “通道”调色板中的第一个 Alpha 通道转换为 Fireworks 图像中的透明区域。Fireworks 不支持其它 Photoshop Alpha 通道。

  • 所有 Photoshop 的色阶和色彩模式都转换为 8 位 RGB 模式。

拖动、打开或导入 Photoshop 图像到 Fireworks 中

您拖动、打开或导入的每个图像将成为新的位图对象。

注意:

在 Windows 中,文件名必须包括扩展名 PSD,这样 Fireworks 才会将它识别为 Photoshop 文件类型。

  1. 请执行下列任一操作:

    • 将 Photoshop 图像或文件拖到打开的 Fireworks 文档中。

    • 选择“文件”>“打开”或“文件”>“导入”,然后定位到 Photoshop (PSD) 文件。

  2. 单击“打开”。

  3. 在出现的对话框中,设置图像选项,然后单击“确定”。

  4. 如果您使用“文件”>“导入”命令,会出现形状类似倒 L 的光标。在画布上,单击您要放置图像左上角的位置。

Photoshop 文件的导入选项

在 Fireworks 中导入或打开 Photoshop 文件时,会出现一个对话框,使您能够指定如何导入图像。您选择的选项决定导入文件的外观和可编辑性。

  1. 指定图像尺寸(用像素或百分比表示),然后指定像素分辨率。若要维持当前的宽高比,请选择“约束比例”。

  2. 如果 Photoshop 文件包含图层复合,请选择要导入的图像版本。选择“显示预览”以显示所选复合的预览。“注释”文本框显示 Photoshop 文件中的注释。

  3. 从底部的弹出菜单中,选择在 Fireworks 中打开 Photoshop 图像的方式:

    维持层的可编辑性优先于外观

    在不牺牲图像外观的情况下尽可能多地保持层结构和文本可编辑性。如果文件包括 Fireworks 不支持的功能,Fireworks 将通过对层进行合并和栅格化来保持文档的外观。以下是一些示例:

    • CMYK 层、调整层以及使用“去底色”选项的图层都与下方的层合并。

    • 使用不支持的层效果的层也可能被合并,具体取决于层的混合模式以及是否存在透明像素。

    维持 Photoshop 图层外观

    拼合每个 Photoshop 图层上的所有对象,然后将每个 Photoshop 图层转换成位图对象。此选项使用户无法在 Fireworks 中编辑 Photoshop 图层。不过,会保持图层组。

    使用自定义首选参数

    使用您在“首选参数”对话框中指定的自定义文件转换设置导入文件。(请参阅 Photoshop 导入和打开首选项。)

    将 Photoshop 层拼合到单个图像

    将 Photoshop 文件作为不带层的平面图像导入。转换的文件不保留任何单个对象。不透明度会保留,但是不可编辑。

  4. 如果使用“文件”>“导入”命令,您可以选择以下选项:

    包括背景层

    从图像的背景层导入对象。

    导入到新文件夹

    将图像导入一个新的带有“Photoshop 导入”标记的层文件夹。

  5. 如果使用“文件”>“打开”命令或将 Photoshop 文件拖到 Fireworks 中,您可以选择以下选项:

    包括辅助线

    将 Photoshop 辅助线保留在它们的原始位置。

    将层转换为状态

    将每个 Photoshop 图层组置于它自己的单个状态中。

关于从 Photoshop 中导入文本

注意:

若要快速导入 Photoshop 文件中的特定文本,请直接将其复制到 Fireworks 中。复制的文本保留所有文本属性。

在导入包含文本的 Photoshop 文件时,Fireworks 会检查系统中是否有所需的字体。如果存在未安装的字体,Fireworks 会提示您替换这些字体或维持它们的外观。

如果 Photoshop 文件中的文本应用了 Fireworks 支持的效果,则在 Fireworks 中仍会应用这些效果。不过,由于 Fireworks 和 Photoshop 应用效果的方式不同,因此每个应用程序中的效果看起来可能不同。

当在 Fireworks 中打开或导入包含文本的 Photoshop 6 或 7 文件时,如果选定了“维持外观”选项,则会显示文本的缓存图像,因此其外观仍和在 Photoshop 中时相同。编辑文本后,实际文本将替换缓存图像。文本的外观可能与原始文本不同。但是,原始字体数据会存储在 PNG 文件中,以便您能够在安装了这些字体的系统上使用原始字体。

注意:

Fireworks 不能以 Photoshop 6 或 7 格式导出文本。如果编辑包含 Photoshop 6 或 7 文本的文档,然后将该文档重新导出到 Photoshop,则该文件将以 Photoshop 5.5 格式导出。但是,如果未对文本进行任何更改,文件将以 Photoshop 6 格式导出。

导入/导出 Photoshop 渐变

导入和导出后的渐变品质取决于渐变类型。渐变的颜色和不透明度可能也有轻微变化。

渐变

导入品质

线性

接近完美。

放射状

接近完美。

对称

接近完美。

菱形

大致匹配(映射为矩形)

角度

大致匹配(映射为圆锥形)

   

渐变

导出品质

线性

接近完美。

放射状

接近完美。

条状

接近完美。

矩形

大致匹配(映射为菱形)

圆锥形

大致匹配(映射为角度)

椭圆形

大致匹配(映射为放射状)

波纹

大致匹配(映射为放射状)

星爆

不完美的匹配(映射为形状渐变)

轮廓, 光泽, 波浪

不完美的匹配(映射为线性)

导入后维持“调整”图层的外观

导入包含调整图层的 PSD 文件时,导入之后维持各图层的外观。

  1. 在“首选参数”对话框中,选择“Photoshop 导入/打开”。

  2. 选择“维持图层调整后的外观”。

维持图层调整后的外观

导入包含调整图层的 PSD 文件时,导入之后维持各图层的外观。确保在该对话框中选择“根据首选参数自定义设置”。

使用 Photoshop 滤镜和插件

可以在“动态滤镜”窗口或“滤镜”菜单中使用许多 Photoshop 及其它第三方滤镜和插件。

注意:

Photoshop 5.5 及早期版本的插件和滤镜受支持。Photoshop 6 或更高版本的插件和滤镜与 Fireworks 不兼容。

使用“首选参数”对话框启用 Photoshop 插件

  1. 请选择“编辑”>“首选参数”(在 Windows 中)或“Fireworks”>“首选参数”(在 Mac OS 中)。

  2. 单击“插件”类别。

  3. 选择 Photoshop 插件。

    “选择文件夹”对话框会打开。

    注意:

    如果该对话框未打开,请单击“浏览”。

  4. 定位到安装 Photoshop 或其它滤镜和插件的文件夹,然后单击“选择”。

  5. 单击“确定”关闭“首选参数”对话框。

  6. 重新启动 Fireworks。

使用“动态滤镜”窗口启用 Photoshop 插件

  1. 在画布上选择任何矢量对象、位图对象或文本块,然后在“属性”检查器中单击“滤镜”标记旁边的加号 (+) 图标。

  2. 从弹出菜单中选择“选项”>“查找插件”。

  3. 定位到安装 Photoshop 或其它滤镜和插件的文件夹,然后单击“选择”。如果出现一条消息,询问您是否要重新启动 Fireworks,请单击“确定”。

  4. 重新启动 Fireworks 以载入滤镜和插件。

    注意:

    或者,您可以将插件直接安装到 Fireworks Plug-ins 文件夹中。

将 Fireworks 图形置入 Photoshop 中

Fireworks 全面支持以 Photoshop (PSD) 格式导出文件。当导出到 Photoshop 中的 Fireworks 图像在 Fireworks 中作为其它 Photoshop 图形重新打开时,它保持原来的可编辑性。Photoshop 用户可以在 Fireworks 中处理图形,然后继续在 Photoshop 中编辑。

注意:

可以使用“PSD 保存”扩展将 Fireworks 文档中的页面和状态快速导出为单独的 PSD 文件。可以从以下位置获得该扩展:http://www.adobe.com/go/learn_fw_psdsave_en

以 Photoshop 格式导出文件

  1. 选择“文件”>“另存为”。

  2. 命名您的文件,然后从“另存为”菜单中选择“Photoshop PSD”。

  3. 若要指定对象、效果和文本的预设导出设置,请单击“选项”。然后,从“设置”菜单中选择下面的预设。

    维持可编辑性优先于外观

    将对象转换为层、保持效果的可编辑性并将文本转换为可编辑的 Photoshop 文本层。如果打算在 Photoshop 中充分编辑图像并且不需要保持 Fireworks 图像的确切外观,请选择此选项。

    维持 Fireworks 外观

    将每个对象转换为一个单独的 Photoshop 图层,同时效果和文本变为不可编辑。如果既要在 Photoshop 中保持对 Fireworks 对象的控制,又要保持 Fireworks 图像的原始外观,请选择此选项。

    较小 Photoshop 文件

    将每一层拼合成一个完全渲染的图像。如果导出一个包含大量 Fireworks 对象的文件,请选择此选项。

    自定义

    使您可以为对象、效果和文本选择具体的设置。

  4. 单击“保存”导出 Photoshop 文件。

    注意:

    Photoshop 5.5 及更低版本无法打开包含的层数多于 100 的文件。如果即将导出的 Fireworks 文档所包含的对象超过 100 个,则必须删除或合并对象。

自定义 Photoshop 导出设置

  1. 在“另存为”对话框中,选择“Photoshop PSD”作为文件类型,然后单击“选项”。

  2. 从“设置”弹出菜单中,选择“自定义”。

  3. 从“对象”弹出菜单中,选择下列选项之一:

    转换为 Photoshop 层

    将各个 Fireworks 对象转换为 Photoshop 图层,并将 Fireworks 蒙版转换为 Photoshop 图层蒙版。

    平面化每个 Fireworks 层

    将每个单独 Fireworks 层上的所有对象平面化,并且每个 Fireworks 层将变为 Photoshop 中的一个层。选择此选项后,将失去在 Photoshop 中编辑 Fireworks 对象的能力。还会失去与 Fireworks 对象相关的功能,如混合模式。

  4. 在“效果”弹出菜单中,选择下列选项之一:

    维持可编辑性

    将 Fireworks 动态滤镜转换为 Photoshop 中相应的效果。如果 Photoshop 中不存在这样的效果,则会被丢失。

    渲染效果

    将效果平面化为它们的对象。选择此选项后,将保留效果的外观,但不能在 Photoshop 中编辑效果。

  5. 在“文本”弹出菜单中,选择下列选项之一:

    维持可编辑性

    将文本转换为可编辑的 Photoshop 图层。Photoshop 不支持的文本格式将会丢失。

    渲染文本

    将文本转换为图像对象。选择此选项后,将保留文本的外观,但不能编辑它。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略