Adobe Flash Builder 4.7 已知问题

欢迎使用 Adobe® Flash® Builder™ 4.7。本文包含 Flash Builder 文档中未涵盖的已知问题和疑难解答提示。

有关 Flex 4.6 SDK 已知问题的信息,请参阅 http://www.adobe.com/go/flex46_sdk_releasenotes_cn

安装和启动

FB-33500:当您在移动设备上使用 Flash Builder 作为 Eclipse Juno 4.2.1 版的插件运行/调试应用程序时,引发 IllegalArgumentException。Flash Builder 4.7 通过了 Eclipse 4.2.0 认证。

FB-35630:当安装路径超过 29 个字符时,Flash Buidler 4.7 安装程序引发长路径错误。

FB-33417:作为 Eclipse 的插件安装 Flash Builder 4.7 时,显示带有警告的安装完成消息。此警告不太会对您的安装造成任何影响。请检查日志获得进一步的详细信息。

移动设备:运行/调试/打包

FB-33478:调试程序连接对话框从 Flash Builder 弹出,虽然 IPA 文件并未通过某些计算机上的 USB 安装在 iOS 设备上。无法安装时请使用 iTunes。

FB-35827:使用 Java 1.7 iOS 打包在 Mac 上失败。要解决此问题,请从 lib/aot/lib/x64 创建 simlink。请参阅该错误了解具体信息。

Flash Builder 常规错误

FB-33402:如果您尝试在 Flash Builder 64 位版本上安装不兼容的 SVN 连接器,则子版本安装失败。请安装独立于平台的纯 Java SVNKit 连接器,以便与 Flash Builder/Eclipse 64 位架构一起使用。请参阅“在 Eclipse 64 位版本上安装子版本”。

FB-33409:SourceMate 在安装后不显示在 Flash Builder 菜单中。SourceMate 3.0 与 Flash Builder 4.7 随附的 ASC 2.0 不兼容。

FB-22429:大型嵌入图像在运行时不对移动应用程序显示。

FB-34189:当 FB 间歇插入 Eclipse 4.2.0 时引发运行时错误。要避免此问题,请关闭透视图并重新打开。

FB-34203:AS 和 MXML 编辑器不在更新后的 Eclipse 中显示。不支持通过“Flash Builder 更新”来更新 Eclipse。

技术说明问题

FB-35577:即使有 FB 4.7 高级许可证,FB 4.7 Flex 自动操作仍限制为 30 行。参见技术说明

FB-30132:当 FB 安装在 Hi-ASCII 文件夹中时,将 FB 插入外部 Eclipse 后不显示 Flash 透视图。参见技术说明

FB-35834:Flash Builder 4.7 不支持在早期版本中创建的工作区,原因是更改默认工作区会删除对 AIR SDK 的引用。参见技术说明

© 2012 Adobe Systems Incorporated. All rights reserved.

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略