Adobe Flash Player 安全更新

发布日期:2014 年 2 月 20 日

漏洞标识符:APSB14-07

优先级:请参见下表

CVE 编号:CVE-2014-0498、 CVE-2014-0499、CVE-2014-0502

平台:所有平台

摘要

Adobe 已发布适用于 Windows 和 Macintosh 的 Adobe Flash Player 12.0.0.44 及更早版本和适用于 Linux 的 Adobe Flash Player 11.2.202.336 及更早版本的安全更新。这些更新修复了可能允许攻击者控制受影响系统的漏洞。根据 Adobe 所收到的报告,编号为 CVE-2014-0502 的漏洞存在着入侵风险,建议用户将产品安装更新到最新版本:

  • 适用于 Windows 和 Macintosh 的 Adobe Flash Player 12.0.0.44 及更早版本的用户应更新至 Adobe Flash Player 12.0.0.70。
  • 适用于 Linux 的 Adobe Flash Player 11.2.202.336 及更早版本的用户应更新至 Adobe Flash Player 11.2.202.341。
  • 随 Google Chrome 安装的 Adobe Flash Player 12.0.0.44 将自动更新至最新的 Google Chrome 版本,该版本将包括适用于 Windows、Macintosh 和 Linux 的 Adobe Flash Player 12.0.0.70。
  • 随 Internet Explorer 10 安装的 Adobe Flash Player 12.0.0.44 将自动更新至最新的 Internet Explorer 10 版本,其中将包括适用于 Windows 8.0 的 Adobe Flash Player 12.0.0.70。
  • 随 Internet Explorer 11 安装的 Adobe Flash Player 12.0.0.44 将自动更新至最新的 Internet Explorer 11 版本,其中将包括适用于 Windows 8.1 的 Adobe Flash Player 12.0.0.70。
  • 适用于 Android 的 Adobe AIR 4.0.0.1390 及更早版本的用户应更新至 Adobe AIR 4.0.0.1628。
  • Adobe AIR 4.0.0.1390 SDK 及更早版本的用户应更新至 Adobe AIR 4.0.0.1628 SDK。
  • Adobe AIR 4.0.0.1390 SDK & Compiler 及更早版本的用户应更新至 Adobe AIR 4.0.0.1628 SDK & Compiler。

 

受影响的软件版本

  • 适用于 Windows 和 Macintosh 的 Adobe Flash Player 12.0.0.44 及更早版本
  • 适用于 Linux 的 Adobe Flash Player 11.2.202.336 及更早版本
  • 适用于 Android 的 Adobe AIR 4.0.0.1390 及更早版本
  • Adobe AIR 3.9.0.1390 SDK 及更早版本
  • Adobe AIR 3.9.0.1390 SDK & Compiler 及更早版本

若要验证在系统上安装的 Adobe Flash Player 的版本,请访问“关于 Flash Player”页面,或者右键单击在 Flash Player 中运行的内容并从菜单中选择“关于 Adobe Flash Player”或“关于 Macromedia Flash Player”。如果您使用多种浏览器,请针对系统中所安装的每种浏览器执行检查。

要验证 Android 的 Adobe Flash Player 版本,请转到“设置”>“应用程序”>“管理应用程序”> Adobe Flash Player x.x。

若要验证系统上安装的 Adobe AIR 的版本,请按照 Adobe AIR 技术说明中的说明操作。

解决方案

Adobe 建议用户按照以下说明更新他们的软件安装:

  • Adobe 建议那些使用 Windows 版和 Macintosh 版 Adobe Flash Player 12.0.0.44 及更早版本的用户,通过 Adobe Flash Player 下载中心下载并更新至最新版本 12.0.0.70;或者通过产品中的更新机制,在出现提示后更新至该版本。
  • Adobe 建议 Linux 版的 Adobe Flash Player 11.2.202.336 及更早版本的用户,通过 Adobe Flash Player 下载中心,下载并更新至 Adobe Flash Player 11.2.202.341。
  • 适用于 Windows 和 Macintosh 的 Flash Player 11.7.700.261 及更早版本的用户无法更新至 Flash Player 12.0.0.44,Adobe 为这些用户提供了 Flash Player 11.7.700.269 更新,可从此处下载。
  • 随 Google Chrome 安装的 Adobe Flash Player 12.0.0.44 将自动更新至最新的 Google Chrome 版本,该版本将包括适用于 Windows、Macintosh 和 Linux 的 Adobe Flash Player 12.0.0.70。
  • 随 Internet Explorer 10 安装的 Adobe Flash Player 12.0.0.44 将自动更新至最新的 Internet Explorer 10 版本,其中将包括适用于 Windows 8.0 的 Adobe Flash Player 12.0.0.70。
  • 随 Internet Explorer 11 安装的 Adobe Flash Player 12.0.0.44 将自动更新至最新的 Internet Explorer 11 版本,其中将包括适用于 Windows 8.1 的 Adobe Flash Player 12.0.0.70。
  • Adobe AIR 4.0.0.1390 SDK 的用户应更新至 Adobe AIR 4.0.0.1628 SDK。
  • Adobe AIR 4.0.0.1390 SDK & Compiler 及更早版本的用户应更新至 Adobe AIR 4.0.0.1680 SDK & Compiler。
  • 适用于 Android 的 Adobe AIR 4.0.0.1390 及更早版本的用户应在 Android 设备上访问 Google Play 以更新至 Adobe AIR 4.0.0.1628。

优先级和严重等级

Adobe 按照以下优先级将这些更新分类,并建议用户将其安装的软件更新至最新版本:

产品 更新后的版本 平台 优先级
Adobe Flash Player 12.0.0.70
Windows 和 Macintosh
1
  12.0.0.70 适用于 Windows 8.0 的 Internet Explorer 10 1
  12.0.0.70 适用于 Windows 8.0 的 Internet Explorer 11 1
  12.0.0.70 适用于 Windows、Macintosh 和 Linux 的 Chrome 1
  11.7.700.269 Windows 和 Macintosh 1
  11.2.202.341 Linux 3
Adobe AIR 4.0.0.1628 Android 3
Adobe AIR SDK 和 Compiler 4.0.0.1628 Windows 和 Macintosh
3
Adobe AIR SDK 4.0.0.1628 Windows 和 Macintosh 3

这些更新解决了软件中严重等级为关键的漏洞。

详细信息

Adobe 已发布适用于 Windows 和 Macintosh 的 Adobe Flash Player 12.0.0.44 及更早版本和适用于 Linux 的 Adobe Flash Player 11.2.202.336 及更早版本的安全更新。这些更新修复了可能允许攻击者控制受影响系统的漏洞。根据 Adobe 所收到的报告,编号为 CVE-2014-0502 的漏洞存在着入侵风险,建议用户将产品安装更新到最新版本:

  • 适用于 Windows 和 Macintosh 的 Adobe Flash Player 12.0.0.44 及更早版本的用户应更新至 Adobe Flash Player 12.0.0.70。
  • 适用于 Linux 的 Adobe Flash Player 11.2.202.336 及更早版本的用户应更新至 Adobe Flash Player 11.2.202.341。
  • 随 Google Chrome 安装的 Adobe Flash Player 12.0.0.44 将自动更新至最新的 Google Chrome 版本,该版本将包括适用于 Windows、Macintosh 和 Linux 的 Adobe Flash Player 12.0.0.70。
  • 随 Internet Explorer 10 安装的 Adobe Flash Player 12.0.0.44 将自动更新至最新的 Internet Explorer 10 版本,其中将包括适用于 Windows 8.0 的 Adobe Flash Player 12.0.0.70。
  • 随 Internet Explorer 11 安装的 Adobe Flash Player 12.0.0.44 将自动更新至最新的 Internet Explorer 11 版本,其中将包括适用于 Windows 8.1 的 Adobe Flash Player 12.0.0.70。
  • 适用于 Android 的 Adobe AIR 4.0.0.1390 及更早版本的用户应更新至 Adobe AIR 4.0.0.1628。
  • Adobe AIR 4.0.0.1390 SDK 及更早版本的用户应更新至 Adobe AIR 4.0.0.1628 SDK。
  • Adobe AIR 4.0.0.1390 SDK & Compiler 及更早版本的用户应更新至 Adobe AIR 4.0.0.1628 SDK & Compiler。

这些更新解决了一个堆溢出漏洞,它可能导致任意代码执行 (CVE-2014-0498)。

这些更新修复了不受内存地址布局随机化限制的内存泄露漏洞 (CVE-2014-0499)。

这些更新解决了可能导致任意代码执行的双重释放漏洞 (CVE-2014-0502)。

受影响的软件     推荐的播放器更新 获取途径
适用于 Windows 和 Macintosh 的 Flash Player 12.0.0.44 及更早版本   12.0.0.70 Flash Player 下载中心
Flash Player 12.0.0.44 及更早版本(网络分发)   12.0.0.70 Flash Player 使用许可
适用于 Linux 的 Flash Player 11.2.202.336 及更早版本   11.2.202.336 Flash Player 下载中心
适用于 Chrome 的 Flash Player 12.0.0.44 及更早版本(Windows、Macintosh 和 Linux)   12.0.0.70
Google Chrome 版本
Internet Explorer 10 for Windows 8.0 中的 Flash Player 12.0.0.44 及更早版本   12.0.0.70
Microsoft 安全建议
Internet Explorer 11 for Windows 8.1 中的 Flash Player 12.0.0.44 及更早版本   12.0.0.70
Microsoft 安全建议
适用于 Android 的 AIR 4.0.0.1390 及更早版本   4.0.0.1628 Google Play
AIR 4.0.0.1390 SDK & Compiler   4.0.0.1628 AIR SDK 下载
AIR 4.0.0.1390 SDK   4.0.0.1628 AIR SDK 下载

鸣谢

Adobe 衷心感谢以下个人和组织,感谢他们报告相关问题并与 Adobe 一起帮助保护我们的客户: