Adobe Flash Player 安全更新

发布日期:2014 年 11 月 11 日

漏洞标识符:APSB14-24

优先级:请参见下表

CVE 编号:CVE-2014-0573、CVE-2014-0574、CVE-2014-0576、CVE-2014-0577、CVE-2014-0581、CVE-2014-0582、CVE-2014-0583、CVE-2014-0584、CVE-2014-0585、CVE-2014-0586、CVE-2014-0588、CVE-2014-0589、CVE-2014-0590、CVE-2014-8437、CVE-2014-8438、CVE-2014-8440、CVE-2014-8441、CVE-2014-8442

平台:所有平台

摘要

Adobe 已为适用于 Windows、Macintosh 和 Linux 的 Adobe Flash Player 发布了安全更新。 这些更新解决了可能允许攻击者控制受影响系统的漏洞。Adobe 建议用户将其安装的产品更新至最新版本:

  • Adobe Flash Player 桌面运行时的 Windows 和 Macintosh 用户应更新至 Adobe Flash Player 15.0.0.223。
  • Adobe Flash Player 扩展支持版本的用户应更新至 Adobe Flash Player 13.0.0.252。
  • Adobe Flash Player 的 Linux 用户应更新至 Adobe Flash Player 11.2.202.418。
  • 如果 Adobe Flash Player 是随 Google Chrome 一起安装,或者是与 Windows 8.x 系统中自带的 Internet Explorer 安装在一起,那么它将会自动更新至最新版本。
  • Adobe AIR 桌面运行时的用户应更新至版本 15.0.0.356。
  • Adobe AIR SDK 和 AIR SDK & Compiler 的用户应更新至版本 15.0.0.356。
  • Adobe AIR 的 Android 用户应更新至 Adobe AIR 15.0.0.356。

受影响的软件版本

  • Adobe Flash Player 15.0.0.189 及更早版本
  • Adobe Flash Player 13.0.0.250 及更早的 13.x 版本
  • 适用于 Linux 的 Adobe Flash Player 11.2.202.411 及更早版本
  • Adobe AIR 桌面运行时 15.0.0.293 及更早版本
  • Adobe AIR SDK 15.0.0.302 及更早版本
  • Adobe AIR SDK & Compiler 15.0.0.302 及更早版本
  • 适用于 Android 的 Adobe AIR 15.0.0.293 及更早版本 

若要验证在系统上安装的 Adobe Flash Player 的版本,请访问“关于 Flash Player”页面,或者右键单击在 Flash Player 中运行的内容并从菜单中选择“关于 Adobe Flash Player”或“关于 Macromedia Flash Player”。如果您使用多种浏览器,请针对系统中所安装的每种浏览器执行检查。

若要验证系统上安装的 Adobe AIR 的版本,请按照 Adobe AIR 技术说明中的说明操作。

解决方案

Adobe 建议用户按照以下说明更新他们的软件安装:

  • Adobe 建议 Adobe Flash Player 桌面运行时的 Windows 和 Macintosh 用户通过访问 Adobe Flash Player 下载中心更新至 Adobe Flash Player 15.0.0.223,或者通过产品中的更新机制在出现提示后更新至该版本。
  • Adobe 建议 Adobe Flash Player 扩展支持版本的用户应该通过访问 http://helpx.adobe.com/cn/flash-player/kb/archived-flash-player-versions.html,更新至版本 13.0.0.252。
  • Adobe 建议 Adobe Flash Player 的 Linux 用户应通过访问 Adobe Flash Player 下载中心,更新至 Adobe Flash Player 11.2.202.418。
  • 随 Google Chrome 一起安装的 Adobe Flash Player 将自动更新至最新的 Google Chrome 版本,其中将包括 Adobe Flash Player 15.0.0.223。
  • 随 Windows 8.x 自带 Internet Explorer 一起安装的 Adobe Flash Player 将会自动更新至最新版本,其中将包括 Adobe Flash Player 15.0.0.223。
  • Adobe 建议 Adobe AIR 桌面运行时的用户应通过访问 Adobe AIR 下载中心更新至版本 15.0.0.356。
  • Adobe 建议 Adobe AIR SDK 的用户应通过访问 Adobe AIR 下载中心更新至版本 15.0.0.356。
  • Adobe 建议 Adobe AIR SDK & Compiler 的用户应通过访问 Adobe AIR 下载中心更新至版本 15.0.0.356。
  • Adobe 建议 Adobe AIR 的 Android 用户应通过从 Google Play Store 下载 Adobe AIR 15.0.0.356 以更新至这一最新版本。

优先级和严重等级

Adobe 按照以下优先级将这些更新分类,并建议用户将其安装的软件更新至最新版本:

产品 受影响的版本 平台 优先级
Adobe Flash Player 桌面运行时 15.0.0.189 及更早版本
Windows 和 Macintosh
1
Adobe Flash Player 扩展支持版本 13.0.0.250 及更早版本 Windows 和 Macintosh
1
适用于 Google Chrome 的 Adobe Flash Player 15.0.0.189 及更早版本 Windows、Macintosh 和 Linux
1
适用于 Internet Explorer 10 和 Internet Explorer 11 的 Adobe Flash Player 15.0.0.189 及更早版本 Windows 8.0 和 8.1 1
Adobe Flash Player 11.2.202.411 及更早版本 Linux 3
       
Adobe AIR 桌面运行时 15.0.0.293 及更早版本 Windows 和 Macintosh 3
Adobe AIR,Android 版 15.0.0.293 及更早版本
Android
3
Adobe AIR SDK 15.0.0.302 及更早版本
Windows、Macintosh、Androd 和 iOS 3
Adobe AIR SDK & Compiler 15.0.0.302 及更早版本
Windows、Macintosh、Android 和 iOS
3

这些更新解决了软件中严重等级为关键的漏洞。

详细信息

Adobe 已为适用于 Windows、Macintosh 和 Linux 的 Adobe Flash Player 发布了安全更新。 这些更新解决了可能允许攻击者控制受影响系统的漏洞。Adobe 建议用户将其安装的产品更新至最新版本:

  • Adobe Flash Player 桌面运行时的 Windows 和 Macintosh 用户应更新至 Adobe Flash Player 15.0.0.223。
  • Adobe Flash Player 扩展支持版本的用户应更新至 Adobe Flash Player 13.0.0.252。
  • Adobe Flash Player 的 Linux 用户应更新至 Adobe Flash Player 11.2.202.418。
  • 如果 Adobe Flash Player 是随 Google Chrome 一起安装,或者是与 Windows 8.x 系统中自带的 Internet Explorer 安装在一起,那么它将会自动更新至最新版本。
  • Adobe AIR 桌面运行时的用户应更新至版本 15.0.0.356。
  • Adobe AIR SDK 和 AIR SDK & Compiler 的用户应更新至版本 15.0.0.356。
  • Adobe AIR 的 Android 用户应更新至 Adobe AIR 15.0.0.356。

这些更新解决了若干可导致代码执行的内存损坏漏洞(CVE-2014-0576、CVE-2014-0581、CVE-2014-8440、CVE-2014-8441)。

这些更新解决了若干可导致代码执行的释放后使用 (use-after-free) 漏洞(CVE-2014-0573、CVE-2014-0588、CVE-2014-8438)。

这些更新解决了可导致代码执行的双重释放漏洞 (CVE-2014-0574)。

这些更新解决了若干可导致代码执行的类型混淆漏洞(CVE-2014-0577、CVE-2014-0584、CVE-2014-0585、CVE-2014-0586、CVE-2014-0590)。

这些更新修复了堆缓冲区溢出型漏洞,该类型的漏洞可能会导致发生代码执行行为(-0582、CVE-2014-、CVE-2014-0589)。

这些更新解决了一个可被用来泄露会话令牌的信息泄露漏洞 (CVE-2014-8437)。

这些更新解决了一个可被用来执行从低级到中级完整性级别权限提升的堆缓冲区溢出漏洞 (CVE-2014-0583)。 

这些更新解决了一个可被用来执行从低级到中级完整性级别权限提升的权限问题 (CVE-2014-8442)。

受影响的软件   推荐的播放器更新 获取途径
Flash Player 桌面运行时
  15.0.0.223

Flash Player 下载中心

Flash Player 分发

Flash Player 扩展支持版本   13.0.0.252 扩展支持
适用于 Linux 的 Flash Player   11.2.202.418 Flash Player 下载中心
适用于 Google Chrome 的 Flash Player   15.0.0.223
Google Chrome 版本
适用于 Internet Explorer 10 和 Internet Explorer 11 的 Flash Player   15.0.0.223
Microsoft 安全建议
AIR 桌面运行时   15.0.0.356 AIR 下载中心
AIR SDK   15.0.0.356
AIR SDK 下载
AIR SDK & Compiler   15.0.0.356
AIR SDK 下载
AIR(用于 Android 操作系统)   15.0.0.356
Google Play

鸣谢

Adobe 衷心感谢以下个人和组织,感谢他们报告相关问题并与 Adobe 一起帮助保护我们的客户: