Adobe Flash Player 安全更新

发布日期:2015 年 3 月 12 日

上次更新日期:2015 年 4 月 15 日

漏洞标识符:APSB15-05

优先级:请参见下表

CVE 编号:CVE-2015-0332、CVE-2015-0333、CVE-2015-0334、CVE-2015-0335、CVE-2015-0336、CVE-2015-0337、CVE-2015-0338、CVE-2015-0339、CVE-2015-0340、CVE-2015-0341、CVE-2015-0342

平台:所有平台

摘要

Adobe 已为适用于 Windows、Macintosh 和 Linux 的 Adobe Flash Player 发布了安全更新。 这些更新解决了可能允许攻击者控制受影响系统的漏洞。Adobe 建议用户将其安装的产品更新至最新版本:

  • Adobe Flash Player 桌面运行时的 Windows 和 Macintosh 用户应更新至 Adobe Flash Player 17.0.0.134。
  • Adobe Flash Player 扩展支持版本的用户应更新至 Adobe Flash Player 13.0.0.277。
  • Adobe Flash Player 的 Linux 用户应更新至 Adobe Flash Player 11.2.202.451。
  • 随 Google Chrome,以及 Windows 8.x 上的 Internet Explorer 一起安装的 Adobe Flash Player 将自动更新至版本 17.0.0.134。
  • Adobe AIR 桌面运行时的用户应更新至版本 17.0.0.144。
  • Adobe AIR SDK 和 AIR SDK & Compiler 的用户应更新至版本 17.0.0.144。
  • Adobe AIR 的 Android 用户应更新至版本 17.0.0.144。

受影响的软件版本

  • Adobe Flash Player 16.0.0.305 及更早版本
  • Adobe Flash Player 13.0.0.269 及更早的 13.x 版本
  • Adobe Flash Player 11.2.202.442 及更早的 11.x 版本
  • AIR 桌面运行时 17.0.0.124 及更早版本
  • AIR SDK 17.0.0.124 及更早版本
  • AIR SDK & Compiler 17.0.0.124 及更早版本
  • 适用于 Android 的 AIR 17.0.0.124 及更早版本

若要验证在系统上安装的 Adobe Flash Player 的版本,请访问“关于 Flash Player”页面,或者右键单击在 Flash Player 中运行的内容并从菜单中选择“关于 Adobe Flash Player”或“关于 Macromedia Flash Player”。如果您使用多种浏览器,请针对系统中所安装的每种浏览器执行检查。

若要验证系统上安装的 Adobe AIR 的版本,请按照 Adobe AIR 技术说明中的说明操作。

解决方案

Adobe 建议用户按照以下说明更新他们的软件安装:

  • Adobe 建议 Adobe Flash Player 桌面运行时的 Windows 和 Macintosh 用户应通过访问 Adobe Flash Player 下载中心,更新至 Adobe Flash Player 17.0.0.134,或者在出现提示时,通过产品中的更新机制进行更新。
  • Adobe 建议 Adobe Flash Player 扩展支持版本的用户应该通过访问 http://helpx.adobe.com/cn/flash-player/kb/archived-flash-player-versions.html,更新至版本 13.0.0.277。
  • Adobe 建议 Adobe Flash Player 的 Linux 用户应通过访问 Adobe Flash Player 下载中心,更新至 Adobe Flash Player 11.2.202.451。
  • 随 Google Chrome 一起安装的 Adobe Flash Player 将自动更新至最新的 Google Chrome 版本,其中将包括 Adobe Flash Player 17.0.0.134。
  • 随 Windows 8.x 自带 Internet Explorer 一起安装的 Adobe Flash Player 将会自动更新至最新版本,其中将包括 Adobe Flash Player 17.0.0.134。
  • Adobe 建议 Adobe AIR 桌面运行时的用户应通过访问 Adobe AIR 下载中心更新至版本 17.0.0.144。 
  • Adobe 建议 Adobe AIR SDK 的用户应通过访问 Adobe AIR 下载中心更新至版本 17.0.0.144。 
  • Adobe 建议 Adobe AIR SDK & Compiler 的用户应通过访问 Adobe AIR 下载中心更新至版本 17.0.0.144。 
  • Adobe 建议 Adobe AIR 的 Android 用户通过从 Google Play Store 下载最新版本以更新至 Adobe AIR 17.0.0.144。

优先级和严重等级

Adobe 按照以下优先级将这些更新分类,并建议用户将其安装的软件更新至最新版本:

产品 受影响的版本 平台 优先级
Adobe Flash Player 桌面运行时 16.0.0.305 及更早版本
Windows 和 Macintosh
1
Adobe Flash Player 扩展支持版本 13.0.0.269 及更早版本 Windows 和 Macintosh
1
适用于 Google Chrome 的 Adobe Flash Player 16.0.0.305 及更早版本 Windows、Macintosh 和 Linux
1
适用于 Internet Explorer 10 和 Internet Explorer 11 的 Adobe Flash Player 16.0.0.305 及更早版本 Windows 8.0 和 8.1 1
Adobe Flash Player 11.2.202.442 及更早版本 Linux 3
AIR 桌面运行时 17.0.0.124 及更早版本 Windows 和 Macintosh 3
AIR SDK 17.0.0.124 及更早版本 Windows、Macintosh、Android 和 iOS 3
AIR SDK & Compiler 17.0.0.124 及更早版本 Windows、Macintosh、Android 和 iOS 3
AIR(用于 Android 操作系统) 17.0.0.124 及更早版本 Android 3

这些更新解决了软件中严重等级为关键的漏洞。

详细信息

Adobe 已为适用于 Windows、Macintosh 和 Linux 的 Adobe Flash Player 发布了安全更新。 这些更新解决了可能允许攻击者控制受影响系统的漏洞。Adobe 建议用户将其安装的产品更新至最新版本:

  • Adobe Flash Player 桌面运行时的 Windows 和 Macintosh 用户应更新至 Adobe Flash Player 17.0.0.134。
  • Adobe Flash Player 扩展支持版本的用户应更新至 Adobe Flash Player 13.0.0.277。
  • Adobe Flash Player 的 Linux 用户应更新至 Adobe Flash Player 11.2.202.451。
  • 随 Google Chrome,以及 Windows 8.x 上的 Internet Explorer 一起安装的 Adobe Flash Player 将自动更新至版本 17.0.0.134。
  • Adobe AIR 桌面运行时的用户应更新至版本 17.0.0.144。
  • Adobe AIR SDK 和 AIR SDK & Compiler 的用户应更新至版本 17.0.0.144。
  • Adobe AIR 的 Android 用户应更新至版本 17.0.0.144。

这些更新解决了若干可导致代码执行的内存损坏漏洞(CVE-2015-0332、CVE-2015-0333、CVE-2015-0335、CVE-2015-0339)。

这些更新解决了若干可导致代码执行的类型混乱漏洞(-2015-、CVE-0334、CVE-2015-0336)。

这些更新解决了可导致绕过跨域策略的漏洞 (CVE-2015-0337)。

这些更新解决了可导致绕过文件上载限制的漏洞 (CVE-2015-0340)。

这些更新修复了可能导致代码执行的整数溢出漏洞 (CVE-2015-0338)。

这些更新解决了若干可能导致代码执行的释放后重用漏洞(-2015-、CVE-0341、CVE-2015-0342)。

受影响的软件   推荐的播放器更新 获取途径
Flash Player 桌面运行时
  17.0.0.134

Flash Player 下载中心

Flash Player 分发

Flash Player 扩展支持版本   13.0.0.277 扩展支持
适用于 Linux 的 Flash Player   11.2.202.451 Flash Player 下载中心
适用于 Google Chrome 的 Flash Player   17.0.0.134 Google Chrome 版本
适用于 Internet Explorer 10 和 Internet Explorer 11 的 Flash Player   17.0.0.134
Microsoft 安全建议
AIR 桌面运行时   17.0.0.144 AIR 下载中心
AIR SDK   17.0.0.144 AIR SDK 下载
AIR SDK & Compiler   17.0.0.144 AIR SDK 下载
AIR(用于 Android 操作系统)   17.0.0.144 Google Play

鸣谢

Adobe 衷心感谢以下个人和组织,感谢他们报告相关问题并与 Adobe 一起帮助保护我们的客户:

  • 来自谷歌“Project Zero”团队的 Chris Evans(CVE-2015-0332、CVE-2015-0335)
  • 来自 Intel Labs 的 Yuki Chen 和 Xiaoning Li,以及来自 McAfee Labs 的 Haifei Li (CVE-2015-0333)
  • 参与谷歌“Project Zero”团队的 Natalie Silvanovich(CVE-2015-0334、CVE-2015-0336)
  • 来自老牌代码安全审计机构 (NCC Group) 的 Soroush Dalili(CVE-2015-0337、CVE-2015-0340)
  • 来自谷歌“Project Zero”团队的 Mark Brand (CVE-2015-0339)
  • 参与 HP Zero Day Initiative 的 Bilou (CVE-2015-0341)
  • 来自 KeenTeam (@K33nTeam) 并参与 Chromium 漏洞奖励计划的 Jihui Lu (CVE-2015-0342)

修订

2015 年 4 月 15 日:添加了已解决本安全公告中所提及的 CVE 的 Adobe AIR 版本