Adobe Flash Player 安全更新

发布日期:2015 年 6 月 9 日

上次更新日期:2015 年 7 月 3 日

漏洞标识符:APSB15-11

优先级:请参见下表

CVE 编号:CVE-2015-3096、CVE-2015-3097、CVE-2015-3098、CVE-2015-3099、CVE-2015-3100、CVE-2015-3101、CVE-2015-3102、CVE-2015-3103、CVE-2015-3104、CVE-2015-3105、CVE-2015-3106、CVE-2015-3107、CVE-2015-3108、CVE-2015-5120

平台:所有平台

摘要

Adobe 已为适用于 Windows、Macintosh 和 Linux 的 Adobe Flash Player 发布了安全更新。 这些更新解决了可能允许攻击者控制受影响系统的漏洞。Adobe 建议用户将其安装的产品更新至最新版本:

  • Adobe Flash Player 桌面运行时的 Windows 和 Macintosh 用户应更新至 Adobe Flash Player 18.0.0.160。
  • Adobe Flash Player 扩展支持版本的 Windows 和 Macintosh 用户应更新至 Adobe Flash Player 13.0.0.292。*
  • Adobe Flash Player 的 Linux 用户应更新至 Adobe Flash Player 11.2.202.466。
  • 随 Google Chrome 一起安装的 Adobe Flash Player 将自动更新至版本 18.0.0.160(Windows 和 Linux)和 18.0.0.161 (Macintosh)。 
  • 随 Windows 8.x 上的 Internet Explorer 一起安装的 Adobe Flash Player 将自动更新至 18.0.0.160。
  • Adobe AIR 桌面运行时的用户应更新至版本 18.0.0.143 (Macintosh) 和 18.0.0.144 (Windows)。
  • Adobe AIR SDK 和 AIR SDK & Compiler 的用户应更新至版本 18.0.0.143 (Macintosh) 和 18.0.0.144 (Windows)。 
  • Adobe AIR 的 Android 用户应更新至版本 18.0.0.143。 

受影响的软件版本

  • 适用于 Windows 和 Macintosh 的 Adobe Flash Player 17.0.0.188 及早期版本
  • 适用于 Windows 和 Macintosh 的 Adobe Flash Player 扩展支持版本 13.0.0.289 及更早的 13.x 版
  • 适用于 Linux 的 Adobe Flash Player 11.2.202.460 及更早的 11.x 版
  • 适用于 Windows 和 Macintosh 的 Adobe AIR 桌面运行时 17.0.0.172 及早期版本
  • 适用于 Windows 和 Macintosh 的 Adobe AIR SDK 和 SDK & Compiler 17.0.0.172 及早期版本
  • 适用于 Android 的 Adobe AIR 17.0.0.144 及更早版本

若要验证在系统上安装的 Adobe Flash Player 的版本,请访问“关于 Flash Player”页面,或者右键单击在 Flash Player 中运行的内容并从菜单中选择“关于 Adobe Flash Player”或“关于 Macromedia Flash Player”。如果您使用多种浏览器,请针对系统中所安装的每种浏览器执行检查。

若要验证系统上安装的 Adobe AIR 的版本,请按照 Adobe AIR 技术说明中的说明操作。

解决方案

Adobe 建议用户按照以下说明更新他们的软件安装:

  • Adobe 建议 Adobe Flash Player 桌面运行时的 Windows 和 Macintosh 用户通过访问 Adobe Flash Player 下载中心更新至 Adobe Flash Player 18.0.0.160,或者在出现提示时,通过产品中的更新机制进行更新.
  • Adobe 建议 Adobe Flash Player 扩展支持版本的用户应该通过访问 http://helpx.adobe.com/cn/flash-player/kb/archived-flash-player-versions.html,更新至版本 13.0.0.292。*
  • Adobe 建议 Adobe Flash Player 的 Linux 用户应该通过访问 Adobe Flash Player 下载中心,更新至 Adobe Flash Player 11.2.202.466。
  • 随 Google Chrome 一起安装的 Adobe Flash Player 将自动更新至最新的 Google Chrome 版本,其中将包括适用于 Windows 和 Linux 的 Adobe Flash Player 18.0.0.160,以及适用于 Macintosh 的 Adobe Flash Player 18.0.0.161。
  • 随 Windows 8.x 自带 Internet Explorer 一起安装的 Adobe Flash Player 将会自动更新至最新版本,其中将包括 Adobe Flash Player 18.0.0.160。
  • Adobe 建议 Adobe AIR 桌面运行时的用户应该通过访问 Adobe AIR 下载中心,更新至版本 18.0.0.143 (Macintosh) 和 18.0.0.144 (Windows)。
  • Adobe 建议 Adobe AIR SDK 和 AIR SDK & Compiler 的用户应该通过访问 Adobe AIR 下载中心,更新至版本 18.0.0.143 (Macintosh) 和 18.0.0.144 (Windows)。
  • Adobe 建议 Adobe AIR 的 Android 用户应该通过访问 Google Play Store 下载最新版本,以更新至 Adobe AIR 18.0.0.143。

*注:从 2015 年 8 月 11 日起,Adobe 将把适用于 Macintosh 和 Windows 的“扩展支持版本”从 Flash Player 13 更新至 Flash Player 18。 要随时获取所有可用的安全更新,用户必须安装 Flash Player 扩展支持版本 18 或更新至最新的可用版本。有关详细信息,请参阅此博客文章

优先级和严重等级

Adobe 按照以下优先级将这些更新分类,并建议用户将其安装的软件更新至最新版本:

产品 受影响的版本 平台 优先级
Adobe Flash Player 桌面运行时 17.0.0.188 及更早版本
Windows 和 Macintosh
1
Adobe Flash Player 扩展支持版本 13.0.0.289 及更早版本 Windows 和 Macintosh
1
适用于 Google Chrome 的 Adobe Flash Player 17.0.0.188 及更早版本 Windows、Macintosh 和 Linux
1
适用于 Internet Explorer 10 和 Internet Explorer 11 的 Adobe Flash Player 17.0.0.188 及更早版本 Windows 8.0 和 8.1 1
Adobe Flash Player 11.2.202.460 及更早版本 Linux 3
AIR 桌面运行时 17.0.0.172 及更早版本 Windows 和 Macintosh  3
AIR SDK 17.0.0.172 及更早版本 Windows、Macintosh、Android 和 iOS  3
AIR SDK & Compiler 17.0.0.172 及更早版本 Windows、Macintosh、Android 和 iOS  3
AIR(用于 Android 操作系统) 17.0.0.144 及更早版本 Android 3

这些更新解决了软件中严重等级为关键的漏洞。

详细信息

Adobe 已为适用于 Windows、Macintosh 和 Linux 的 Adobe Flash Player 发布了安全更新。 这些更新解决了可能允许攻击者控制受影响系统的漏洞。 Adobe 建议用户将其产品安装更新到最新版本:

  • Adobe Flash Player 桌面运行时的 Windows 和 Macintosh 用户应更新至 Adobe Flash Player 18.0.0.160。 
  • Adobe Flash Player 扩展支持版本的 Windows 和 Macintosh 用户应更新至 Adobe Flash Player 13.0.0.292。 
  • Adobe Flash Player 的 Linux 用户应更新至 Adobe Flash Player 11.2.202.466。 
  • 随 Google Chrome 一起安装的 Adobe Flash Player 将自动更新至版本 18.0.0.160(Windows 和 Linux)和 18.0.0.161 (Macintosh)。 
  • 随 Windows 8.x 上的 Internet Explorer 一起安装的 Adobe Flash Player 将自动更新至 18.0.0.160。 
  • Adobe AIR 桌面运行时的用户应更新至版本 18.0.0.143 (Macintosh) 和 18.0.0.144 (Windows)。 
  • Adobe AIR SDK 和 AIR SDK & Compiler 的用户应更新至版本 18.0.0.143 (Macintosh) 和 18.0.0.144 (Windows)。 
  • Adobe AIR 的 Android 用户应更新至版本 18.0.0.143。

这些更新解决了可能被利用以绕过 CVE-2014-5333 修复的漏洞 (CVE-2015-3096)。 

这些更新改进了 Window 7 64 位平台中 Flash 堆的内存地址随机化 (CVE-2015-3097)。 

这些更新解决了可能被利用以绕过同源策略并导致信息泄露的漏洞(CVE-2015-3098、CVE-2015-3099、CVE-2015-3102)。 

这些更新修复了可能导致代码执行的堆溢出漏洞 (CVE-2015-3100)。

这些更新解决了适用于 Internet Explorer 的 Flash 代理中存在的权限问题,该漏洞可能被利用以执行从低完整性级别到中完整性级别的权限提升 (CVE-2015-3101)。   

这些更新修复了可能导致代码执行的整数溢出漏洞 (CVE-2015-3104)。

这些更新解决了一个可能导致代码执行的内存破坏漏洞(CVE-2015-3105、CVE-2015-5120)。

这些更新修复了可能导致代码执行的释放后使用漏洞(CVE-2015-3103、CVE-2015-3106、CVE-2015-3107)。

这些更新解决了可能被用来绕过 ASLR 的内存泄漏漏洞 (CVE-2015-3108)。 

受影响的软件   推荐的播放器更新 获取途径
Flash Player 桌面运行时
  18.0.0.160

Flash Player 下载中心

Flash Player 分发

Flash Player 扩展支持版本   13.0.0.292 扩展支持
适用于 Linux 的 Flash Player   11.2.202.466 Flash Player 下载中心
适用于 Google Chrome 的 Flash Player  

18.0.0.160(Windows 和 Linux)

18.0.0.161 (Macintosh)

Google Chrome 版本
适用于 Internet Explorer 10 和 Internet Explorer 11 的 Flash Player   18.0.0.160
Microsoft 安全建议
AIR 桌面运行时  

18.0.0.143 (Macintosh)

18.0.0.144 (Windows)

AIR 下载中心
AIR SDK  

18.0.0.143 (Macintosh)

18.0.0.144 (Windows)

AIR SDK 下载
AIR SDK & Compiler  

18.0.0.143 (Macintosh)

18.0.0.144 (Windows)

AIR SDK 下载
AIR(用于 Android 操作系统)   18.0.0.143 Google Play

鸣谢

Adobe 衷心感谢以下个人和组织,感谢他们报告相关问题并与 Adobe 一起帮助保护我们的客户:

  • 参与 Chromium 漏洞奖励计划的 bilou(CVE-2015-3106)
  • 来自 Google 互联网安全计划“Project Zero”的 Chris Evans(CVE-2015-3097、CVE-2015-3104、CVE-2015-3105、CVE-2015-3108)
  • 来自 McAfee Labs IPS 团队的 Haifei Li (CVE-2015-3100) 
  • 李普君 (Pujun Li) / PKAV 团队 (pkav.net) (CVE-2015-3102)
  • Malte Batram(CVE-2015-3098、CVE-2015-3099)
  • 来自 Google 互联网安全计划“Project Zero”的 Natalie Silvanovich (CVE-2015-3107)
  • Tomas Polesovsky (CVE-2015-3096)
  • 来自 Venustech ADLAB 的 Wen Guanxing (CVE-2015-3103)
  • 来自奇虎 360 Vulcan 团队 的 Linan Hao (CVE-2015-5120)

修订

2015 年 7 月 3 日:增加了关于 CVE-2015-5120 的参考,该漏洞已在这些更新中得以解决,但是公告因疏忽而将其遗漏了。