Adobe Flash Player 安全更新

发布日期:2016 年 2 月 9 日

漏洞标识符:APSB16-04

优先级:请参见下表

CVE 编号:CVE-2016-0964、CVE-2016-0965、CVE-2016-0966、CVE-2016-0967、CVE-2016-0968、CVE-2016-0969、CVE-2016-0970、CVE-2016-0971、CVE-2016-0972、CVE-2016-0973、CVE-2016-0974、CVE-2016-0975、CVE-2016-0976、CVE-2016-0977、CVE-2016-0978、CVE-2016-0979、CVE-2016-0980、CVE-2016-0981、CVE-2016-0982、CVE-2016-0983、CVE-2016-0984、CVE-2016-0985

平台:Windows、Macintosh 和 Linux

摘要

Adobe 已为 Adobe Flash Player 发布安全更新。这些更新修复了可能允许攻击者控制受影响系统的关键漏洞。

受影响的版本

产品 受影响的版本 平台
Adobe Flash Player 桌面运行时 20.0.0.286 及更早版本
Windows 和 Macintosh
Adobe Flash Player 扩展支持版本 18.0.0.326 及更早版本 Windows 和 Macintosh
适用于 Google Chrome 的 Adobe Flash Player 20.0.0.286 及更早版本 Windows、Macintosh、Linux 和 Chrome OS
适用于 Microsoft Edge 和 Internet Explorer 11 的 Adobe Flash Player 20.0.0.272 及更早版本 Windows 10
适用于 Internet Explorer 11 的 Adobe Flash Player 20.0.0.272 及更早版本 Windows 8.1
适用于 Linux 的 Adobe Flash Player 11.2.202.559 及更早版本 Linux
AIR 桌面运行时 20.0.0.233 及更早版本 Windows 和 Macintosh
AIR SDK 20.0.0.233 及更早版本 Windows、Macintosh、Android 和 iOS
AIR SDK & Compiler 20.0.0.233 及更早版本 Windows、Macintosh、Android 和 iOS
  • 若要验证在系统上安装的 Adobe Flash Player 的版本,请访问“关于 Flash Player”页面,或者右键单击在 Flash Player 中运行的内容并从菜单中选择“关于 Adobe Flash Player”或“关于 Macromedia Flash Player”。如果您使用多种浏览器,请针对系统中所安装的每种浏览器执行检查。
  • 若要验证系统上安装的 Adobe AIR 的版本,请按照 Adobe AIR 技术说明中的说明操作。

解决方案

Adobe 按照以下优先级将这些更新分类,并建议用户将其安装的软件更新至最新版本:

产品 更新版本 平台 优先级 获取途径
Adobe Flash Player 桌面运行时
20.0.0.306 Windows 和 Macintosh
1

Flash Player 下载中心

Flash Player 分发

Adobe Flash Player 扩展支持版本 18.0.0.329 Windows 和 Macintosh
1 扩展支持
适用于 Google Chrome 的 Adobe Flash Player 20.0.0.306 Windows、Macintosh、Linux 和 Chrome OS    1 Google Chrome 版本
适用于 Microsoft Edge 和 Internet Explorer 11 的 Adobe Flash Player 20.0.0.306 Windows 10 1 Microsoft 安全建议
适用于 Internet Explorer 11 的 Adobe Flash Player 20.0.0.306 Windows 8.1
1 Microsoft 安全公告
适用于 Linux 的 Adobe Flash Player 11.2.202.569 Linux 3 Flash Player 下载中心
AIR 桌面运行时 20.0.0.260 Windows 和 Macintosh 3 AIR 下载中心
AIR SDK 20.0.0.260 Windows、Macintosh、Android 和 iOS 3 AIR SDK 下载
AIR SDK & Compiler 20.0.0.260 Windows、Macintosh、Android 和 iOS 3 AIR SDK 下载
  • Adobe 建议 Adobe Flash Player 桌面运行时的 Windows 和 Macintosh 用户在收到提示时[1],通过产品中的更新机制更新到 20.0.0.306,或者通过访问 Adobe Flash Player 下载中心进行更新。
  • Adobe 建议 Adobe Flash Player 扩展支持版本的用户应该通过访问 http://helpx.adobe.com/cn/flash-player/kb/archived-flash-player-versions.html 更新至版本 18.0.0.329。
  • Adobe 建议 Adobe Flash Player 的 Linux 用户通过访问 Adobe Flash Player 下载中心更新至 Adobe Flash Player 11.2.202.569。
  • 随 Google Chrome 一起安装的 Adobe Flash Player 将会自动更新至最新的 Google Chrome 版本,其中将包括适用于 Windows、Macintosh、Linux 和 Chrome OS 的 Adobe Flash Player 20.0.0.306。
  • 随 Windows 10 自带 Microsoft Edge 和 Internet Explorer 一起安装的 Adobe Flash Player 将会自动更新至最新版本,其中将包括 Adobe Flash Player 20.0.0.306。 
  • 随 Windows 8.x 自带 Internet Explorer 一起安装的 Adobe Flash Player 将会自动更新至最新版本,其中将包括 Adobe Flash Player 20.0.0.306。
  • Adobe 建议 AIR 桌面运行时、AIR SDK 以及 AIR SDK & Compiler 的用户通过访问 AIR 下载中心AIR 开发人员中心更新至版本 20.0.0.260。
  • 请访问 Flash Player 帮助页面,获得有关 Flash Player 的安装协助。
 
[1] 对于使用适用于 Windows 的 Flash Player 11.2.x 或更高版本的用户,或者使用适用于 Macintosh 的 Flash Player 11.3.x 或更高版本的用户而言,如果选择了“允许 Adobe 安装更新”选项,则可以自动获取更新。未启用“允许 Adobe 安装更新”选项的用户可在收到提示后通过产品中的更新机制安装更新。

漏洞详情

  • 这些更新修复了可能导致代码执行的类型混淆漏洞 (CVE-2016-0985)。
  • 这些更新修复了可能导致代码执行的 Use-After-Free 漏洞(CVE-2016-0973、CVE-2016-0974、CVE-2016-0975、CVE-2016-0982、CVE-2016-0983、CVE-2016-0984)。
  • 这些更新修复了可能导致代码执行的堆缓冲区溢出漏洞 (CVE-2016-0971)。
  • 这些更新修复了可能导致代码执行的内存破坏漏洞(CVE-2016-0964、CVE-2016-0965、CVE-2016-0966、CVE-2016-0967、CVE-2016-0968、CVE-2016-0969、CVE-2016-0970、CVE-2016-0972、CVE-2016-0976、CVE-2016-0977、CVE-2016-0978、CVE-2016-0979、CVE-2016-0980、CVE-2016-0981)。

鸣谢

  • 通过 HPE Zero Day Initiative 报告的匿名者(CVE-2016-0973、CVE-2016-0975)
  • 来自 Google 互联网安全计划“Project Zero”的 Ben Hawkes、Mateusz Jurczyk 和 Natalie Silvanovich(CVE-2016-0964、CVE-2016-0965、CVE-2016-0967、CVE-2016-0970、CVE-2016-0971、CVE-2016-0972)
  • 来自 Google 互联网安全计划“Project Zero”的 Natalie Silvanovich(CVE-2016-0974、CVE-2016-0984、CVE-2016-0985)
  • 来自 Microsoft Vulnerability Research (MSVR) 的 Nicolas Joly (CVE-2016-0966)
  • NSFOCUS Security Team(CVE-2016-0968、CVE-2016-0969、CVE-2016-0976、CVE-2016-0977、CVE-2016-0978、CVE-2016-0979)
  • 来自 Venustech ADLAB 的 Wen Guanxing(CVE-2016-0981、CVE-2016-0982、CVE-2016-0983)
  • 来自奇虎 360 Vulcan Team 的 Yuki Chen (CVE-2016-0980)