Este artículo proporciona información general sobre las novedades en Adobe Flash Professional CS6.

Compatibilidad con Adobe AIR 3.4 (sólo la actualización 12.0.2 de Flash Professional CS6)

Con la actualización 12.0.2 de Flash Professional CS6, Flash Professional amplia la compatibilidad con AIR 3.4 y Flash Player 11.4. Esta actualización también permite a Flash Professional aprovechar funciones de AIR 3.4 que mejoran el flujo de trabajo de desarrollo de aplicaciones en dispositivos iOS.

Kit de herramientas para CreateJS 1.2

La versión Kit de herramientas para CreateJS 1.2 amplía el soporte de conversión de botones en HTML5. Esta actualización también incluye soluciones para diversos errores relacionados con JSX. Otros problemas, como la omisión de varios fotogramas clave vacíos, también se han solucionado en esta actualización.

Puede descargar e instalar el Kit de herramientas para CreateJS 1.2 desde Adobe Extension Manager CS6. Para obtener más información sobre el Kit de herramientas, consulte Uso del Kit de herramientas para CreateJS de Flash Professional.

Simulación de contenido para móvil en AIR

El nuevo simulador de contenido para móvil permite simular teclas de hardware, acelerómetros, gestos multitáctiles y geolocalización.

Elegir una interfaz de red para depuración remota en AIR

Al publicar una aplicación de AIR en un dispositivo Android o iOS, puede elegir la interfaz de red que desee utilizar para la depuración remota. Flash Pro empaquetará la dirección IP de la interfaz de red seleccionada en la aplicación móvil del modo de depuración. Seguidamente, la aplicación podrá conectarse automáticamente a la IP del host para iniciar una sesión de depuración cuando se inicie en el dispositivo móvil de destino. Para acceder a este parámetro, seleccione Archivo > Configuración de publicación y, a continuación, vaya a la ficha Implementación en el cuadro de diálogo Configuración de AIR. Para obtener más información, consulte Empaquetado de aplicaciones para AIR for IOS y Publicación para Adobe AIR para los artículos de escritorio.

 

Kit de herramientas para CreateJS

El kit de herramientas de Adobe Flash Professional para CreateJS es una extensión para Flash Professional CS6 que permite a diseñadores y animadores crear activos para proyectos de HTML5 con bibliotecas CreateJS de JavaScript de código abierto. La extensión admite la mayoría de funciones básicas de animación e ilustración de Flash Professional, incluidos vectores, mapas de bits, interpolaciones clásicas, sonidos, guías de movimiento, máscaras animadas y creación de scripts de JavaScript en la línea de tiempo. Con un solo clic, el kit de herramientas para CreateJS exporta el contenido del escenario y de la biblioteca como JavaScript que puede previsualizarse en el navegador para empezar a crear expresiones de contenido basado en HTML5 en un abrir y cerrar de ojos.

El kit de herramientas para CreateJS está diseñado para ayudar a los usuarios de Flash Pro en la transición hacia HTML5. Convierte símbolos de la biblioteca y contenido del escenario en JavaScript con formato correcto, comprensible, editable y fácilmente reutilizable por los desarrolladores que quieran añadir interactividad con JavaScript y las API CreateJS, todo en un entorno muy familiar para los usuarios de ActionScript 3. El kit de herramientas para CreateJS también publica una página HTML sencilla para poder previsualizar rápidamente los activos. Para obtener más información, consulte este artículo.

Exportar hojas de Sprite

Ahora es posible exportar una hoja de Sprite seleccionando un símbolo en la biblioteca o en el escenario. Una hoja de Sprite es un archivo de imagen gráfica único que contiene todos los elementos gráficos empleados en el símbolo seleccionado. Los elementos se disponen en formato de mosaico en el archivo. También puede incluir mapas de bits en la biblioteca al seleccionar un símbolo de la biblioteca. Para crear una hoja de Sprite, siga estos pasos:

  1. Seleccione un símbolo en la biblioteca o en el escenario.
  2. Haga clic con el botón derecho del ratón y elija Exportar hoja de Sprite.

Compresión SWF de alta eficiencia

Para archivos SWF destinados a Flash Player 11 o versiones posteriores, hay disponible un nuevo algoritmo de compresión: LZMA. La nueva compresión puede ser hasta un 40% más eficiente, especialmente en archivos con mucho ActionScript o gráficos vectoriales.

  1. Seleccione Archivo > Configuración de publicación
  2. En la sección Avanzado del cuadro de diálogo, seleccione la opción Comprimir película y elija LZMA en el menú.

Publicación en modo directo

Hay disponible una nuevo modo de ventana llamado Directo. Habilita el contenido acelerado por hardware usando Stage3D. (Stage3D requiere Flash Player 11 o versión posterior.)

  1. Seleccione Archivo > Configuración de publicación
  2. Seleccione Envoltorio HTML.
  3. Seleccione Directo en el menú Modo de ventana.

Para obtener más información, consulte este artículo.

Soporte para modo de procesamiento directo en plug-ins de AIR

Esta función lleva el soporte de procesamiento del modo directo de Flash Player a StageVideo/Stage3D en aplicaciones de AIR. Se puede utilizar un nuevo ajuste renderMode=direct en el archivo descriptor de una aplicación de AIR. El modo directo se puede establecer en AIR para escritorio, AIR for iOS y AIR for Android.

Depurar iOS mediante Wi-Fi

Ahora es posible depurar aplicaciones de AIR en iOS a través de Wi-Fi, incluidos puntos de ruptura, entradas y salidas, vigilancia variable y trazado.

Para obtener más información sobre la depuración de aplicaciones de AIR, consulte AIR Debug Launcher.

Soporte para motor de ejecución captador en AIR

El diálogo Configuración de publicación de AIR ahora tiene una opción para incorporar el motor de
package. Una aplicación con motor de ejecución incorporado se puede ejecutar en cualquier equipo de escritorio, dispositivo Android o iOS sin tener que instalar el motor de ejecución de AIR compartido.

Adobe recomienda:

Vea los vídeos de Adobe AIR con compatibilidad con Captive Runtime para móvil y escritorio.

Extensiones nativas en AIR

Es posible incorporar extensiones nativas a las aplicaciones de AIR que se desarrollen en Flash Pro. Al usar extensiones nativas, las aplicaciones pueden acceder a todas las funciones de la plataforma de destino, incluso si el propio motor de ejecución no tiene soporte nativo para ellas.

Obtener la versión más reciente de Flash Player desde Flash Pro

Ahora puede ir directamente a la página de descarga de Flash Player en Adobe.com desde el menú Ayuda de Flash Pro.

Exportar secuencia PNG

Utilice esta función para generar archivos de imagen que Flash Pro y otras aplicaciones puedan usar para generar contenido. Por ejemplo, las secuencias PNG se suelen utilizar en aplicaciones de juegos. Esta función permite exportar una secuencia de archivos PNG desde un elemento de la biblioteca o desde clips de película, símbolos gráficos y botones independientes del escenario.

  1. Seleccione un clip de película, botón o símbolo gráfico individual en la biblioteca o en el escenario.
  2. Haga clic con el botón derecho para mostrar el menú contextual.
  3. Seleccione Exportar secuencia PNG.
  4. En el cuadro de diálogo Guardar del sistema, elija una ubicación para el archivo. Haga clic en Aceptar.
  5. En el cuadro de diálogo Exportar PNG, edite las opciones. Haga clic en Exportar para exportar la secuencia PNG.

Palabras clave: Novedades en Flash CS6, Nuevas prestaciones de Flash Professional CS6, Nuevas prestaciones de Flash CS6, Novedades en Flash Professional CS6

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea