Guía del usuario Cancelar

Crear vínculos

  1. Guía del usuario de Dreamweaver
  2. Introducción
    1. Conceptos básicos sobre diseño web adaptable
    2. Novedades de Dreamweaver
    3. Desarrollo web con Dreamweaver: información general
    4. Dreamweaver / Preguntas frecuentes
    5. Métodos abreviados de teclado
    6. Requisitos del sistema para Dreamweaver
    7. Resumen de funciones
  3. Dreamweaver y Creative Cloud
    1. Sincronizar la configuración de Dreamweaver con Creative Cloud
    2. Bibliotecas Creative Cloud en Dreamweaver
    3. Uso de archivos de Photoshop en Dreamweaver
    4. Trabajar con Adobe Animate y Dreamweaver
    5. Extraer archivos SVG optimizados para la Web desde bibliotecas
  4. Espacios de trabajo y vistas de Dreamweaver
    1. El espacio de trabajo de Dreamweaver
    2. Optimización del espacio de trabajo de Dreamweaver para la implementación visual
    3. Buscar archivos por nombre de archivo o contenido | Mac OS
  5. Configuración de sitios
    1. Acerca de los sitios de Dreamweaver
    2. Configuración de una versión local del sitio
    3. Conectar con servidores de publicación
    4. Configuración de un servidor de prueba
    5. Importación y exportación de la configuración de un sitio de Dreamweaver
    6. Traer sitios web existentes desde un servidor remoto a la raíz del sitio local
    7. Funciones de accesibilidad en Dreamweaver
    8. Ajustes avanzados
    9. Configuración de las preferencias de sitio para transferir archivos
    10. Especificación de la configuración del servidor proxy en Dreamweaver
    11. Sincronizar la configuración de Dreamweaver con Creative Cloud
    12. Uso de Git en Dreamweaver
  6. Administrar archivos
    1. Creación y apertura de documentos
    2. Administración de archivos y carpetas
    3. Carga de archivos al servidor y descarga desde el mismo
    4. Desprotección y protección de archivos
    5. Sincronizar archivos
    6. Comparación de archivos para detectar diferencias
    7. Ocultación de archivos y carpetas en el sitio de Dreamweaver
    8. Activación de Design Notes para sitios de Dreamweaver
    9. Prevención de la posible actuación repentina de Gatekeeper
  7. Maquetación y diseño
    1. Usar ayudas visuales al diseñar
    2. Información sobre el uso de CSS para diseñar la página
    3. Diseño de sitios web interactivos con Bootstrap
    4. Creación y uso de consultas de medios en Dreamweaver
    5. Presentación de contenido en tablas
    6. Colores
    7. Diseño interactivo mediante diseños de cuadrícula fluida
    8. Extract en Dreamweaver
  8. CSS
    1. Aspectos básicos de las hojas de estilos en cascada
    2. Diseño de páginas con el Diseñador de CSS
    3. Uso de preprocesadores de CSS en Dreamweaver
    4. Configuración de las preferencias de estilos CSS en Dreamweaver
    5. Mover reglas CSS en Dreamweaver
    6. Conversión de CSS en línea en una regla CSS en Dreamweaver
    7. Uso de etiquetas div
    8. Aplicación de degradados al fondo
    9. Creación y edición de efectos de transición de CSS3 en Dreamweaver
    10. Formatear código
  9. Contenido de página y activos
    1. Definición de las propiedades de la página
    2. Configuración de propiedades de encabezado CSS y propiedades de vínculo CSS
    3. Uso de texto
    4. Buscar y reemplazar texto, etiquetas y atributos
    5. Panel DOM
    6. Editar en la Vista en vivo
    7. Codificación de documentos en Dreamweaver
    8. Selección y visualización de elementos de la ventana de documento
    9. Configuración de las propiedades de texto en el inspector de propiedades
    10. Revisión ortográfica de una página web
    11. Uso de las reglas horizontales en Dreamweaver
    12. Añadir y modificar combinaciones de fuentes en Dreamweaver.
    13. Trabajo con activos
    14. Inserción y actualización de fechas en Dreamweaver
    15. Creación y gestión de activos favoritos en Dreamweaver
    16. Insertar y editar imágenes en Dreamweaver
    17. Adición de objetos multimedia
    18. Adición de vídeos en Dreamweaver
    19. Insertar vídeo HTML5
    20. Insertar archivos SWF
    21. Adición de efectos de sonido
    22. Insertar audio HTML5 en Dreamweaver
    23. Trabajar con elementos de bibliotecas
    24. Uso de texto árabe y hebreo en Dreamweaver
  10. Establecimiento de vínculos y navegación
    1. Acerca del establecimiento de vínculos y la navegación
    2. Vinculación
    3. Mapas de imágenes
    4. Vínculos de solución de problemas
  11. Widgets y efectos de jQuery
    1. Uso de interfaz de usuario y widgets móviles de jQuery en Dreamweaver
    2. Uso de efectos jQuery en Dreamweaver
  12. Programación de sitios web
    1. Acerca de la programación en Dreamweaver
    2. Entorno de programación en Dreamweaver
    3. Configuración de las preferencias de programación
    4. Personalización de los colores del código
    5. Escritura y edición de código
    6. Sugerencias de código y completado de código
    7. Contraer y expandir código
    8. Reutilizar código con fragmentos
    9. Depuración de código mediante linting
    10. Optimización del código
    11. Edición de código en Vista de diseño
    12. Trabajo con el contenido de Head para páginas
    13. Inserción del lado del servidor incluida en Dreamweaver
    14. Uso de bibliotecas de etiquetas en Dreamweaver
    15. Importación de etiquetas personalizadas a Dreamweaver
    16. Uso de comportamientos de JavaScript (instrucciones generales)
    17. Aplicación de comportamientos JavaScript incorporados
    18. Acerca de XML y XSLT
    19. Realización de transformaciones XSL del lado del servidor en Dreamweaver
    20. Realización de transformaciones XSL en el lado del cliente en Dreamweaver
    21. Adición de entidades de caracteres para XSLT en Dreamweaver
    22. Formatear código
  13. Flujos de trabajo de varios productos
    1. Instalación y uso de extensiones para Dreamweaver
    2. Actualizaciones integradas en Dreamweaver
    3. Insertar documentos de Microsoft Office en Dreamweaver (solo Windows)
    4. Trabajo con Fireworks y Dreamweaver
    5. Edición de contenido en sitios de Dreamweaver con Contribute
    6. Integración de Dreamweaver Business Catalyst
    7. Crear campañas de correo electrónico personalizado
  14. Plantillas
    1. Acerca de las plantillas de Dreamweaver
    2. Reconocimiento de plantillas y documentos basados en plantillas
    3. Crear una plantilla de Dreamweaver
    4. Crear regiones editables en plantillas
    5. Creación de tablas y regiones repetidas en Dreamweaver
    6. Usar regiones opcionales en plantillas
    7. Definición de atributos de etiqueta editables en Dreamweaver
    8. Creación de plantillas anidadas en Dreamweaver
    9. Edición, actualización y eliminación de plantillas
    10. Exportar e importar contenido xml en Dreamweaver
    11. Aplicación o eliminación de una plantilla de un documento existente
    12. Edición de contenido en plantillas de Dreamweaver
    13. Reglas de sintaxis de etiquetas de plantilla en Dreamweaver
    14. Configuración de preferencias de resaltado en regiones de plantillas
    15. Ventajas de usar plantillas en Dreamweaver
  15. Móvil y multipantalla
    1. Creación de consultas de medios
    2. Cambio de la orientación de página para dispositivos móviles
    3. Creación de aplicaciones web para dispositivos móviles con Dreamweaver
  16. Sitios, páginas y formularios web dinámicos
    1. Aspectos básicos de las aplicaciones web
    2. Configuración del ordenador para desarrollo de aplicaciones
    3. Solución de problemas de conexiones a bases de datos
    4. Eliminación de secuencias de comandos de conexión en Dreamweaver
    5. Diseñar páginas dinámicas
    6. Introducción a las fuentes de contenido dinámico
    7. Definir fuentes de contenido dinámico
    8. Añadir contenido dinámico a las páginas
    9. Cambio de contenido dinámico en Dreamweaver
    10. Visualización de registros de bases de datos
    11. Proporcionar datos en vivo y solucionar sus problemas en Dreamweaver
    12. Añadir comportamientos de servidor personalizados en Dreamweaver
    13. Crear formularios con Dreamweaver
    14. Uso de formularios para recopilar información de los usuarios
    15. Crear y activar formularios de ColdFusion en Dreamweaver
    16. Crear formularios web
    17. Compatibilidad mejorada con HTML5 para elementos de formulario
    18. Desarrollar un formulario con Dreamweaver
  17. Creación visual de aplicaciones
    1. Creación de las páginas maestra y de detalles en Dreamweaver
    2. Crear páginas de búsqueda y resultados
    3. Crear una página de inserción de registros
    4. Crear una página de actualización de registros en Dreamweaver
    5. Creación de páginas de eliminación de registros en Dreamweaver
    6. Usar comandos ASP para modificar una base de datos en Dreamweaver
    7. Crear una página de registro
    8. Crear una página de inicio de sesión
    9. Creación de una página para acceso exclusivo de usuarios autorizados
    10. Protección de carpetas en ColdFusion con Dreamweaver
    11. Uso de componentes de ColdFusion en Dreamweaver
  18. Prueba, vista previa y publicación de sitios web
    1. Vista previa de páginas
    2. Vista previa de páginas web de Dreamweaver en varios dispositivos
    3. Comprobación del sitio de Dreamweaver

 

Aprenda a configurar la navegación entre sus páginas web. Enlace archivos y documentos, actualice, cambie y pruebe enlaces en Dreamweaver.

Antes de crear un vínculo, deberá saber cómo funcionan las rutas absolutas, las relativas al documento y las relativas a la raíz del sitio. Puede crear varios tipos de vínculos en un documento:

  • Un vínculo con otro documento o archivo, como un archivo gráfico, de película, PDF o de sonido.
  • Un vínculo de anclaje con nombre, que salta a un emplazamiento específico dentro de un documento.

  • Un vínculo de correo electrónico, que crea un mensaje de correo electrónico en blanco con la dirección del destinatario ya rellenada.

  • Vínculos nulos y de script, que permiten adjuntar comportamientos a un objeto o crear un vínculo que ejecuta código JavaScript.

Puede utilizar el inspector de propiedades y el icono de señalización de archivos para crear vínculos a partir de una imagen, un objeto o texto a otro documento o archivo.

Dreamweaver crea los vínculos a otras páginas del sitio empleando rutas relativas a documentos. También puede indicar a Dreamweaver que cree nuevos vínculos utilizando rutas relativas a la raíz del sitio.

Guarde siempre un archivo nuevo antes de crear una ruta relativa al documento, pues esta no es válida sin un punto de partida preciso. Si crea una ruta relativa al documento antes de guardar el archivo, Dreamweaver utilizará temporalmente una ruta absoluta que comenzará por file:// hasta que guarde el archivo. Cuando guarde el archivo, Dreamweaver convertirá la ruta file:// en una ruta relativa.

Adjuntar comportamientos JavaScript a vínculos

Puede adjuntar un comportamiento a cualquier vínculo de un documento. Puede emplear los comportamientos siguientes a la hora de insertar elementos vinculados a los documentos:

Establecer texto de la barra de estado

Determina el texto de un mensaje y lo muestra en la barra de estado, situada en la parte inferior izquierda de la ventana del navegador. Por ejemplo, puede usar este comportamiento para describir el destino de un vínculo en la barra de estado en lugar de mostrar la URL al que está asociado.

Abrir ventana del navegador

Permite abrir una URL en una nueva ventana. Se pueden ajustar las propiedades de la nueva ventana, incluidos su nombre, tamaño y atributos (si se puede cambiar su tamaño, si tiene barra de menús, etc.).

Menú de salto

Edita un menú de salto. Puede cambiar la lista del menú, indicar otro archivo vinculado o cambiar la ubicación del navegador en el que se abre el documento vinculado.

Crear vínculos con documentos mediante el inspector de propiedades

Puede utilizar el icono de carpeta o el cuadro Vínculo del inspector de propiedades para crear vínculos a partir de una imagen, un objeto o texto a otro documento o archivo.

  1. Seleccione texto o una imagen en la vista de Diseño de la ventana de documento.
  2. Abra el inspector de propiedades (Ventana > Propiedades) y siga uno de estos procedimientos:
    • Haga clic en el icono de carpeta situado a la derecha del cuadro Vínculo para buscar y seleccionar un archivo.

      La ruta del documento vinculado aparecerá en el cuadro de la URL. Utilice el menú emergente Relativa a del cuadro de diálogo Seleccionar archivo para indicar si la ruta es relativa al documento o a la raíz del sitio y, a continuación, haga clic en OK. El tipo de ruta que seleccione solo afectará al vínculo actual. (Puede cambiar la configuración predeterminada del cuadro Relativa a para el sitio.)

    • Escriba la ruta y el nombre de archivo del documento en el cuadro Vínculo.

      Para establecer un vínculo con un documento del sitio, introduzca una ruta relativa al documento o relativa a la raíz del sitio. Para establecer un vínculo con un documento externo al sitio, introduzca una ruta absoluta que incluya el protocolo (por ejemplo, http://). Puede utilizar este método para introducir un vínculo para un archivo que aún no se ha creado.

  3. En la lista desplegable Destino, seleccione una ubicación en la que abrir el documento:

    • _blank carga el documento vinculado en una nueva ventana sin nombre del navegador.
    • _parent carga el documento vinculado en el marco padre o en la ventana padre del marco que contiene el vínculo. Si el marco que contiene el vínculo no está anidado, el documento vinculado se cargará en la ventana completa del navegador.
    • _self carga el documento vinculado en el mismo marco o la misma ventana que el vínculo. Este destino es el predeterminado, por lo que normalmente no es preciso especificarlo.
    • _top carga el documento vinculado en la ventana completa del navegador, eliminando de esta forma todos los marcos.
    • _new carga el documento vinculado en una ventana nueva.

Crear vínculos a documentos mediante el icono de señalización de archivos

  1. Seleccione texto o una imagen en la vista de Diseño de la ventana de documento.
  2. Cree un vínculo de una de estas dos formas:
    • Arrastre el icono de señalización de archivo  (icono de mira telescópica), situado a la derecha del cuadro Vínculo del inspector de propiedades, y señale a un anclaje visible en el documento actual, a un anclaje visible en otro documento abierto, a un elemento que tenga asignado un ID exclusivo o a un documento del panel Archivos.

    • Mantenga pulsada la tecla Mayús y arrastre desde la selección y señale a un anclaje visible en el documento actual, a un anclaje visible en otro documento abierto, a un elemento que tenga asignado un ID exclusivo o a un documento del panel Archivos.

    Solo puede establecer un vínculo con otro documento abierto si los documentos no están maximizados en la ventana de documento. Para organizar los documentos en mosaico, seleccione Ventana > Organizar > Cascada o Ventana > Organizar > Mosaico. Cuando se señala a un documento abierto, este pasa al primer plano de la pantalla mientras se realiza la selección.

Añadir un vínculo mediante el comando Hipervínculo

El comando Hipervínculo permite crear un vínculo de texto hasta una imagen, un objeto u otro documento o archivo.

  1. Sitúe el punto de inserción en el documento donde desea que aparezca el vínculo.
  2. Siga uno de estos procedimientos para que se abra el cuadro de diálogo Hipervínculo:

    • Seleccione Insertar > Hipervínculo.

    • En la categoría Común del panel Insertar, haga clic en el icono Hipervínculo.

  3. En el campo Texto, introduzca el texto del vínculo.
    En el menú desplegable Vínculo, seleccione el nombre del archivo en el que desea crear el vínculo. También puede hacer clic en el icono de carpeta para localizar el archivo para el que desee crear el vínculo.

  4. En el menú emergente Destino, seleccione la ventana en la que deberá abrirse el archivo o escriba su nombre.

    En la lista emergente figuran los nombres de todos los marcos a los que ha asignado nombres en el documento actual. Si indica un marco que no existe, la página vinculada se abrirá en una ventana nueva con el nombre que haya especificado. También puede seleccionar estos nombres de destino reservados:

    • _blank carga el archivo vinculado en una ventana de navegador nueva y sin nombre.
    • _parent carga el archivo vinculado en el conjunto de marcos padre o en la ventana del marco que contiene el vínculo. Si el marco que contiene el vínculo no está anidado, el archivo vinculado se cargará en la ventana completa del navegador.
    • _self carga el archivo vinculado en el mismo marco o ventana que el vínculo. Este destino es el predeterminado, por lo que normalmente no es preciso especificarlo.
    • _top carga el archivo vinculado en la ventana completa del navegador, quitando así todos los marcos.
    • _new carga el documento vinculado en una ventana nueva.
  5. En el cuadro Índice de fichas, introduzca un número para el orden de fichas.
  6. En el cuadro Título, escriba un título de página para el vínculo.
  7. En el cuadro Clave de acceso, introduzca un equivalente de teclado (una letra) para seleccionar el vínculo en el navegador.
  8. Haga clic en OK.

Crear un vínculo a un documento de Word o Excel

Puede insertar un vínculo a un documento de Microsoft Word o Excel en una página existente.

  1. En la vista Diseño, abra la página donde desee que aparezca el vínculo.

  2. Arrastre el archivo de la ubicación actual a la página web de Dreamweaver e inserte el vínculo en el lugar que desea que aparezca. Se abrirá el cuadro de diálogo Insertar documento.

  3. Seleccione Crear un vínculo y, a continuación, haga clic en OK.

    Si el documento para el que está creando un vínculo se encuentra fuera de la carpeta raíz del sitio, Dreamweaver le solicitará que copie el documento en dicha carpeta.

    Al copiar el documento en la carpeta raíz del sitio, se garantiza que el documento se encontrará disponible en el momento de publicar el sitio web.

  4. Cuando cargue la página en el servidor web, asegúrese de cargar también el archivo de Word o Excel. Tras esto, su página incluirá un enlace al documento Word o Excel. El texto del vínculo es el nombre del archivo vinculado. Si lo desea, puede cambiar el texto del vínculo en la ventana de documento.

Configura ruta relativa de vínculos nuevos

De manera predeterminada, Dreamweaver crea vínculos a otras páginas del sitio empleando rutas relativas a documentos. Para utilizar rutas relativas a la raíz del sitio, debe definir en primer lugar una carpeta local en Dreamweaver eligiendo una carpeta raíz local que actúe como equivalente de la raíz del documento en un servidor. Dreamweaver utiliza esta carpeta para determinar las rutas relativas a la raíz del sitio de los archivos.

  1. Seleccione Sitio > Administrar sitios.
  2. En el cuadro de diálogo Administrar sitios, haga doble clic en el sitio deseado en la lista.
  3. En el cuadro de diálogo Configuración del sitio, expanda la Configuración avanzada y seleccione la categoría Datos locales.
  4. Elija la ruta relativa de los vínculos nuevos seleccionando la opción Documento o Raíz del sitio.

    Si se cambia esta configuración, no se convierte la ruta de los vínculos existentes después de hacer clic en Aceptar. La configuración solo afecta a los nuevos vínculos que cree con Dreamweaver.

  5. Haga clic en Guardar.

    La nueva configuración de ruta afecta solo al sitio actual.

Crear vínculos a una parte específica de un documento

Puede utilizar el inspector de propiedades para crear un vínculo a una determinada sección de un documento creando en primer lugar anclajes con nombre. Los anclajes con nombre permiten establecer marcadores en un documento, que a menudo se colocan en una sección específica o en la parte superior del documento. Posteriormente podrá crear vínculos con esos anclajes con nombre que llevarán rápidamente al visitante a la posición indicada.

Para crear un vínculo con un anclaje con nombre, siga este procedimiento de dos pasos. En primer lugar, cree un anclaje con nombre. A continuación, cree un vínculo con dicho anclaje.

Crear un anclaje

  1. En la ventana de documento, seleccione y resalte el elemento que desee definir como anclaje.

  2. Abra el inspector de propiedades y compruebe si el elemento seleccionado tiene un ID. Si el campo ID está en blanco, añada un ID. Por ejemplo, Anclaje.

    Crear un anclaje
    Crear un anclaje

    Después de agregar el ID, observe el cambio en el código. id="<nombre de ID>" se inserta en el código en la selección.

    ID de anclaje en el código
    Adición de anclajes para establecer vínculos

  1. En la vista de Diseño de la ventana de documento, seleccione texto o una imagen para crear un vínculo a partir de ellos.
  2. En el cuadro Vínculo del inspector de propiedades, introduzca un signo de número (#) y el nombre del anclaje. Por ejemplo, para crear un vínculo con un anclaje denominado “top“ en el documento actual, escriba #top. Para crear un vínculo con un anclaje denominado “top“ en un documento distinto de la misma carpeta, escriba nombrearchivo.html#top.
    Nota:

    Los nombres de anclaje distinguen entre mayúsculas y minúsculas.

  1. Abra el documento que contiene el anclaje con nombre.
    Nota:

    Si no ve el anclaje, para que se vea, seleccione Vista > Opciones de vista de diseño > Ayudas visuales > Elementos invisibles en la vista de diseño.

  2. En la vista de Diseño de la ventana de documento, seleccione texto o una imagen para los que quiera crear un vínculo (si es otro documento abierto, deberá cambiar a este).
  3. Siga uno de estos procedimientos:
    • Haga clic en el icono de señalización de archivos (icono de la mira telescópica) situado a la derecha del cuadro de texto Vínculo del inspector de propiedades y arrástrelo hasta el anclaje para el que desee crear el vínculo: un anclaje en el mismo documento o un anclaje en otro documento abierto.

    • En la ventana de documento, pulse la tecla Mayús mientras arrastra el texto o la imagen seleccionada hasta el anclaje para el que desee crear el vínculo: un anclaje en el mismo documento o un anclaje en otro documento abierto.

Crear un vínculo de correo electrónico

Cuando el usuario hace clic en un vínculo de correo electrónico, se abre una nueva ventana de mensaje en blanco (utilizando el programa de correo asociado al navegador del usuario). En la ventana de mensaje de correo electrónico, el cuadro Para cambia automáticamente y se rellena con la dirección indicada en el vínculo del mensaje de correo electrónico.

  1. En la vista de Diseño de la ventana de documento, coloque el punto de inserción donde desea que aparezca el vínculo de correo electrónico o seleccione el texto o la imagen que desea que aparezca como vínculo de correo electrónico.
  2. Siga uno de estos procedimientos para insertar el vínculo:
    • Seleccione Insertar > Vínculo de correo electrónico.

    • En la categoría Común del panel Insertar, haga clic en el botón Vínculo de correo electrónico.

  3. En el cuadro Texto, escriba o edite el texto del correo electrónico.
  4. En el cuadro Correo electrónico, escriba la dirección de correo electrónico y haga clic en Aceptar.
  1. Seleccione texto o una imagen en la vista de Diseño de la ventana de documento.
  2. En el cuadro Vínculo del inspector de propiedades, escriba mailto: seguido de una dirección de correo electrónico.

    No escriba espacios entre los dos puntos y la dirección de correo electrónico.

Rellenar automáticamente la línea de asunto de un mensaje de correo electrónico

  1. Cree un vínculo de correo electrónico empleando el inspector de propiedades como se indica más arriba.
  2. En el cuadro Vínculo del inspector de propiedades, añada ?subject= tras el mensaje de correo electrónico y escriba un asunto detrás del signo igual. No introduzca ningún espacio entre el signo de interrogación y el final de la dirección de correo electrónico.

    La entrada completa se vería así:

    mailto:someone@yoursite.com?subject=Mail from Our Site

Crear vínculos de script y nulos

Un vínculo nulo es un vínculo no designado. Los vínculos nulos se utilizan para adjuntar comportamientos a objetos o texto de una página. Por ejemplo, puede incluir un comportamiento a un vínculo nulo para que cambie una imagen o muestre un elemento con posición absoluta (elemento AP) cuando el puntero se desplace sobre el vínculo.

Los vínculos de script ejecutan código JavaScript o llaman a una función JavaScript. Sirven para dar a los usuarios información adicional sobre un elemento sin salir de la página actual. Los vínculos de script también pueden emplearse para realizar cálculos, validar formularios y otras tareas de procesamiento cuando el usuario hace clic en un elemento específico.

  1. Seleccione texto, una imagen o un objeto en la vista de Diseño de la ventana de documento.
  2. En el inspector de propiedades, escriba javascript:; (la palabra javascript, seguida de dos puntos, seguidos de punto y coma) en el cuadro Vínculo.
  1. Seleccione texto, una imagen o un objeto en la vista de Diseño de la ventana de documento.
  2. En el cuadro Vínculo del inspector de propiedades, escriba javascript: y, a continuación, código JavaScript o una llamada de función (no escriba espacios entre los dos puntos y el código o la llamada).

Actualizar vínculos automáticamente

Dreamweaver puede actualizar los vínculos con origen y destino en un documento cada vez que este se mueva o cambie de nombre en un sitio local. Esta función funciona mejor cuando se almacena todo el sitio (o una sección completa e independiente de este) en el disco local. Dreamweaver no cambia los archivos de la carpeta remota hasta que se colocan o desprotegen los archivos locales en el servidor remoto.

Para acelerar el proceso de actualización, Dreamweaver puede crear un archivo de caché en el que almacenará información sobre todos los vínculos de la carpeta local. El archivo de caché cambia de manera invisible a medida que se van añadiendo, modificando o eliminando vínculos del sitio local.

  1. Seleccione Editar > Preferencias (Windows) o Dreamweaver > Preferencias (Macintosh).
  2. En el cuadro de diálogo Preferencias, seleccione General en la lista de categorías de la izquierda.
  3. En la sección Opciones de documento de las preferencias General, seleccione una opción del menú emergente Actualizar vínculos al mover archivos.

    Siempre

    Se cambiarán automáticamente todos los vínculos con origen y destino en un documento seleccionado cada vez que este se mueva o cambie de nombre.

    Nunca

    No se cambiarán automáticamente todos los vínculos con origen y destino en un documento seleccionado cuando este se mueva o cambie de nombre.

    Mensaje

    Abre un cuadro de diálogo en el que aparecen todos los archivos afectados por el cambio. Haga clic en Actualizar si desea cambiar los vínculos de estos archivos o en No actualizar si desea dejar los archivos como estaban.

  4. Haga clic en OK.

Crear un archivo de caché para el sitio

  1. Seleccione Sitio > Administrar sitios.
  2. Seleccione un sitio y haga clic en Editar.
  3. En el cuadro de diálogo Configuración del sitio, expanda la Configuración avanzada y seleccione la categoría Datos locales.
  4. En la categoría Datos locales, seleccione Activar caché.

    La primera vez que cambie o quite vínculos conectados con archivos de la carpeta local después de iniciar Dreamweaver, Dreamweaver le pedirá que cargue la caché. Si hace clic en Sí, Dreamweaver cargará la caché y actualizará todos los vínculos al archivo que acaba de modificar. Si hace clic en No, el cambio se registrará en la caché, pero Dreamweaver no cargará la caché ni actualizará los vínculos.

    La caché puede tardar unos minutos en cargarse en sitios grandes, ya que Dreamweaver debe comprobar si está actualizada comparando las marcas de hora de los archivos del sitio local con las marcas grabadas en la caché. Si no ha cambiado ningún archivo fuera de Dreamweaver, puede hacer clic en el botón Detener cuando aparezca.

Volver a crear la caché

  1. En el panel Archivos, seleccione Sitio > Avanzadas > Volver a crear caché de sitio.

Cambiar un vínculo en todo el sitio

Además de configurar Dreamweaver para que cambie los vínculos automáticamente cada vez que mueva o cambie de nombre un archivo, puede cambiar manualmente todos los vínculos (incluidos los vínculos nulos, de correo electrónico, FTP y script) para que redirijan a otro lugar.

Esta opción resulta particularmente útil si desea eliminar un archivo con el que están vinculados otros archivos, pero puede utilizarla con otros fines. Por ejemplo, supongamos que vincula las palabras “películas de este mes“ con /películas/julio.html en todo el sitio. Al llegar el 1 de agosto, cambiaría dichos vínculos para que redirigieran a /películas/agosto.html.

  1. Seleccione un archivo en la vista Local del panel Archivos.
    Nota:

    Si va a cambiar un vínculo nulo, de correo electrónico, FTP o script, no necesita seleccionar un archivo.

  2. Seleccione Sitio > Opciones del sitio > Cambiar vínculo en todo el sitio.

  3. Rellene estas opciones en el cuadro de diálogo Cambiar vínculo en todo el sitio:

    Cambiar todos los vínculos a

    Haga clic en el icono de carpeta para localizar y seleccionar el archivo de destino para el que desea anular el vínculo. Si va a cambiar un vínculo de correo electrónico, FTP, nulo o script, escriba el texto completo del vínculo que desea modificar.

    Por vínculos a

    Haga clic en el icono de carpeta para localizar y seleccionar el nuevo archivo para el que desea crear el vínculo. Si va a cambiar un vínculo nulo, de correo electrónico, FTP o script, escriba el texto completo del vínculo de sustitución.

  4. Haga clic en OK.

    Dreamweaver actualizará todos los documentos vinculados al archivo seleccionado, haciendo que enlacen con el nuevo archivo y usando el formato de ruta empleado por el documento (por ejemplo, si la ruta antigua era relativa al documento, la nueva también deberá serlo).

    Después de cambiar un vínculo en todo el sitio, el archivo seleccionado quedará huérfano (es decir, ningún archivo del disco local estará vinculado a él). Entonces podrá eliminarlo sin romper ningún vínculo del sitio local de Dreamweaver.

    Nota:

    Dado que estos cambios se realizan localmente, deberá eliminar manualmente el archivo huérfano correspondiente en la carpeta remota y colocar o desproteger los archivos cuyos vínculos haya modificado para que los visitantes del sitio puedan ver los cambios efectuados.

Comprobar vínculos en Dreamweaver

Los vínculos no están activos en Dreamweaver, es decir, no se puede abrir un documento vinculado haciendo doble clic en el vínculo en la ventana de documento.

  1. Siga uno de estos procedimientos:
    • Haga clic con el botón derecho del ratón en el vínculo y seleccione Abrir página vinculada.

    • Pulse Control (Windows) o Comando (Macintosh) y haga doble clic en el vínculo.

    Nota:

    El documento vinculado debe encontrarse en el disco local.

Logotipo de Adobe

Inicia sesión en tu cuenta