Utilice las ayudas visuales para diseñar en Dreamweaver, que incluyen la configuración de las reglas y de las guías de diseño, así como la utilización de guías con plantillas, cuadrículas de diseño e imágenes de rastreo.

Establecimiento de reglas

Las reglas ayudan a medir, organizar y planificar el diseño. Pueden aparecer en los bordes izquierdo y superior de la página, expresadas en píxeles, pulgadas o centímetros.

  • Para activar y desactivar las reglas, elija Ver > Reglas > Mostrar/Ocultar.
  • Para cambiar el origen, arrastre a cualquier parte de la página el icono de origen de la regla (situado en la esquina superior izquierda de la vista Diseño de la ventana de documento).
  • Para restablecer el origen a su posición predeterminada, seleccione Ver > Opciones de vista de diseño > Restablecer origen.
  • Para cambiar la unidad de medida, seleccione Ver > Reglas y elija Píxeles, Pulgadas o Centímetros.

Establecimiento de guías de diseño

Las guías son líneas que puede arrastrar sobre el documento desde las reglas. Con ellas puede situar y alinear objetos de forma más precisa. También puede utilizar guías para medir el tamaño de los elementos de la página o emular los pliegues (áreas visibles) de los navegadores Web.

Con el fin de ayudarle a alinear elementos, puede ajustar elementos a las guías y ajustar guías a los elementos. (Los elementos deben tener posición absoluta para que funcione la función de ajuste.) También puede bloquear las guías para impedir que otro usuario las mueva accidentalmente.

Creación de una guía horizontal o vertical

  1. Arrastre la guía desde la regla correspondiente.
  2. Sitúe la guía en la ventana de documento y suelte el botón del ratón (vuelva a colocar la guía arrastrándola de nuevo).

    Nota:

    De manera predeterminada, las guías se registran como medidas absolutas en píxeles desde la parte superior o el lado izquierdo del documento y se muestran como relativas al origen de la regla. Para registrar la guía como porcentaje, presione la tecla Mayús mientras crea o mueve la guía.

Visualización u ocultación de guías

  1. Seleccione Ver > Guías > Mostrar guías.

Ajuste de elementos a las guías

  • Para ajustar elementos a guías, seleccione Ver > Opciones de vista de diseño> Guías > Ajustar a guías.
  • Para ajustar guías a elementos, seleccione Ver > Opciones de vista de diseño> Guías > Ajustar guías a elementos.

Nota:

Puede cambiar el tamaño de elementos, como elementos con posición absoluta (elementos PA), tablas e imágenes; los elementos cuyo tamaño cambia se ajustan a las guías.

Bloqueo o desbloqueo de todas las guías

Seleccione Ver > Opciones de vista de diseño> Guías > Bloquear guías.

Visualización y desplazamiento de una guía a una ubicación concreta

  1. Mantenga el puntero del ratón sobre la guía para ver su posición.
  2. Haga doble clic en la guía.
  3. Introduzca la nueva posición en el cuadro de diálogo Mover guía y haga clic en OK.

Visualización de la distancia entre guías

Presione Control (Windows) o Comando (Macintosh) y pase el puntero del ratón por cualquier lugar situado entre las dos guías.

Nota:

La unidad de medida es la misma que la utilizada para las reglas.

Emulación del pliegue (área visible) de un navegador Web

Seleccione Ver > Opciones de vista de diseño > Guías y luego seleccione un tamaño de navegador predefinido del menú.

Eliminación de una guía

Arrastre la guía hacia fuera del documento.

Cambio de la configuración de guías

  1. Seleccione Ver > Opciones de vista de diseño > Guías > Editar guías, establezca las siguientes opciones y haga clic en OK.

    Color de guías

    Establece el color de las líneas de la guía. Haga clic en la muestra de color y seleccione un color en el Selector de colores o escriba un número hexadecimal en el cuadro de texto.

    Color de distancia

    Especifica el color de las líneas que aparecen como indicadores de distancia al pasar el puntero del ratón entre las guías. Haga clic en la muestra de color y seleccione un color en el Selector de colores o escriba un número hexadecimal en el cuadro de texto.

    Mostrar guías

    Hace que las guías estén visibles en la vista Diseño.

    Ajustar a guías

    Hace que los elementos de la página se ajusten a las guías al mover los elementos por la página.

    Bloquear guías

    Bloquea las guías en el lugar en que se encuentran.

    Ajustar guías a elementos

    Ajusta las guías a los elementos de la página al arrastrar las guías.

    Borrar todo

    Borra todas las guías de la página.

Utilización de guías con plantillas

Cuando se añaden guías a una plantilla de Dreamweaver, todas las instancias de la plantilla heredan las guías. Las guías de instancias de plantilla, sin embargo, se consideran regiones editables para que los usuarios puedan modificarlas. La ubicación original de las guías modificadas en las instancias de plantilla se restaura cuando se actualiza la instancia con la plantilla maestra.

También puede añadir sus propias guías a instancias de una plantilla. Las guías añadidas de esta forma no se sobrescriben cuando la instancia de la plantilla se actualiza con la plantilla maestra.

Uso de la cuadrícula de diseño

La cuadrícula muestra una serie de líneas horizontales y verticales en la ventana de documento. Resulta útil para colocar objetos con precisión. Puede hacer que los elementos de la página con posición absoluta se ajusten automáticamente a la cuadrícula cuando los mueva y cambiar la cuadrícula o controlar el comportamiento de ajuste especificando una configuración. El ajuste funciona independientemente de si la cuadrícula se encuentra o no visible.

Visualización u ocultación de la cuadrícula

Seleccione Ver > Opciones de vista de diseño > Cuadrícula > Mostrar cuadrícula.

Activación o desactivación del ajuste

Seleccione Ver > Opciones de vista de diseño > Cuadrícula > Ajustar a cuadrícula.

Cambio de la configuración de cuadrícula

  1. Seleccione Ver > Opciones de vista de diseño > Cuadrícula > Configuración de cuadrícula.

  2. Configure las opciones y haga clic en OK para aplicar los cambios.

    Color

    Establece el color de las líneas de la cuadrícula. Haga clic en la muestra de color y seleccione un color en el Selector de colores o escriba un número hexadecimal en el cuadro de texto.

    Mostrar cuadrícula

    Hace que la cuadrícula esté visible en la vista Diseño.

    Ajustar a cuadrícula

    Hace que los elementos de la página se ajusten a las líneas de la cuadrícula.

    Espaciado

    Controla la separación entre las líneas de la cuadrícula. Introduzca un número y seleccione Píxeles, Pulgadas o Centímetros en el menú.

    Visualización

    Especifica si las líneas de la cuadrícula deben mostrarse como líneas o como puntos.

    Nota:

    Si no está seleccionada la opción Mostrar cuadrícula, la cuadrícula no aparecerá en el documento y los cambios no serán visibles.

Utilización de una imagen de rastreo

Puede utilizar una imagen de rastreo como guía para recrear un diseño de página creado en una aplicación gráfica como Adobe Freehand o Fireworks.

Una imagen de rastreo es una imagen JPEG, GIF o PNG que se sitúa en el fondo de la ventana de documento. Puede ocultar la imagen, configurar su opacidad y cambiar su posición.

La imagen de rastreo solo se encuentra visible en Dreamweaver; no puede verse en la página desde un navegador. Cuando está visible la imagen de rastreo, la imagen y el color de fondo reales no están visibles en la ventana de documento; no obstante, se encontrarán visibles cuando la página se muestre en un navegador.

Colocación de una imagen de rastreo en la ventana de documento

  1. Siga uno de estos procedimientos:
    • Seleccione Ver > Opciones de vista de diseño > Imagen de rastreo > Cargar.

    • Seleccione Archivo > Propiedades de la página y, a continuación, en la categoría Imagen de rastreo, haga clic en Examinar (situado junto al cuadro de texto Imagen de rastreo).

  2. Navegue hasta el archivo de imagen y haga clic en OK.

  3. En el cuadro de diálogo Propiedades de la página, especifique la transparencia de la imagen arrastrando el control deslizante Transparencia y luego haga clic en OK.

    Para cambiar a otra imagen de rastreo o cambiar la transparencia de la imagen de rastreo actual en cualquier momento, seleccione Archivo > Propiedades de la página.

Visualización u ocultación de la imagen de rastreo

Seleccione Ver > Opciones de vista de diseño > Imagen de rastreo > Mostrar.

Cambio de la posición de una imagen de rastreo

  1. Seleccione Ver > Opciones de vista de diseño > Imagen de rastreo > Ajustar posición.

    • Para especificar de forma precisa la posición de la imagen de rastreo, introduzca valores de coordenadas en los cuadros X e Y.

    • Para mover la imagen de píxel en píxel, utilice las teclas de flecha.

    • Para mover la imagen de cinco en cinco píxeles, presione Mayús y una tecla de flecha.

Restablecimiento de la posición de la imagen de rastreo

  1. Seleccione Ver > Opciones de vista de diseño > Imagen de rastreo > Restablecer posición.

    La imagen de rastreo regresará a la esquina superior izquierda de la ventana de documento (0,0).

Alineación de la imagen de rastreo con un elemento seleccionado

  1. Seleccione un elemento de la ventana de documento.
  2. Seleccione Ver > Opciones de vista de diseño > Imagen de rastreo > Alinear con selección.

    La esquina superior izquierda de la imagen de rastreo se alineará con la esquina superior izquierda del elemento seleccionado.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea