Création et utilisation d’instances de symboles dans Animate

  1. Guide de l’utilisateur d’Adobe Animate
  2. Présentation d’Animate
    1. Nouveautés d’Adobe Animate
    2. Glossaire visuel
    3. Configuration requise pour Animate
    4. Raccourcis clavier d’Animate
    5. Utilisation de plusieurs types de fichiers dans Animate
  3. Animation
    1. Principes de base de l’animation dans Animate
    2. Utilisation des images et des images-clés dans Animate
    3. Animation image par image dans Animate
    4. Utilisation d’une animation interpolée classique dans Animate
    5. Outil Pinceau
    6. Guide du mouvement
    7. Interpolation de mouvement et ActionScript 3.0
    8. À propos de l’animation d’une interpolation de mouvement
    9. Animation d’une interpolation de mouvement
    10. Création d’une animation d’interpolation de mouvement
    11. Utilisation des images-clés de propriété
    12. Animation d’une position à l’aide d’une interpolation
    13. Modification des interpolations de mouvement avec l’Éditeur de mouvement
    14. Modification de la trajectoire de mouvement d’une animation d’interpolation
    15. Manipulation d’interpolations de mouvement
    16. Ajout d’accélérations personnalisées
    17. Création et application de présélections de mouvement
    18. Configuration de plages d’interpolation d’une animation
    19. Utilisation d’interpolations de mouvement enregistrées au format XML
    20. Interpolations de mouvement et interpolations classiques : comparatif
    21. Interpolation de forme
    22. Utilisation de l’animation de l’outil de segment dans Animate
    23. Utilisation du squelettage de personnage dans Animate
    24. Utilisation de calques de masque dans Adobe Animate
    25. Utilisation de séquences dans Animate
  4. Interactivité
    1. Création de boutons avec Animate
    2. Conversion de projets Animate en d’autres formats de document
    3. Création et publication de documents HTML5 Canvas dans Animate
    4. Ajout d’interactivité à l’aide de fragments de code dans Animate
    5. Création de composants HTML5 personnalisés
    6. Utilisation de composants dans HTML5 Canvas
    7. Création de composants personnalisés : exemples
    8. Fragments de code des composants personnalisés
    9. Pratiques recommandées – Publicité avec Animate
    10. Création et publication de contenu de réalité virtuelle
  5. Espace de travail et workflow
    1. Création et gestion des pinceaux
    2. Utilisation de polices Google Fonts dans les documents HTML5 Canvas
    3. Utilisation des bibliothèques Creative Cloud et d’Adobe Animate
    4. Utilisation de la scène et du panneau Outils pour Animate
    5. Workflow et espace de travail Animate
    6. Utilisation de polices web dans les documents HTML5 Canvas
    7. Scénarios et ActionScript
    8. Utilisation de plusieurs scénarios
    9. Définition des préférences
    10. Utilisation des panneaux de création Animate
    11. Création de calques de scénario avec Animate
    12. Exportation d’animations pour les applications mobiles et les moteurs de jeu
    13. Déplacement et copie d’objets
    14. Modèles
    15. Recherche et remplacement de contenu dans Animate
    16. Commandes Annuler et Rétablir, et panneau Historique
    17. Raccourcis clavier
    18. Utilisation du scénario dans Animate
    19. Création d’extensions HTML
    20. Options d’optimisation des images et des GIF animés
    21. Paramètres d’exportation des images et des fichiers GIF
    22. Panneau Éléments dans Animate
  6. Multimédia et vidéo
    1. Transformation et combinaison d’objets graphiques dans Animate
    2. Création et utilisation d’instances de symboles dans Animate
    3. Vectorisation de l’image
    4. Utilisation du son dans Adobe Animate
    5. Exportation de fichiers SVG
    6. Création de fichiers vidéo en vue de les utiliser dans Animate
    7. Comment ajouter une vidéo dans Animate
    8. Utilisation des points de repère vidéo
    9. Dessin et création d’objets avec Animate
    10. Remodelage des lignes et des formes
    11. Traits, remplissages et dégradés avec Animate CC
    12. Utilisation d’Adobe Premiere Pro et d’After Effects
    13. Panneaux Couleur dans Animate CC
    14. Ouverture de fichiers Flash CS6 à l’aide d’Animate
    15. Utilisation de texte classique dans Animate
    16. Placement d’illustrations dans Animate
    17. Images bitmap importées dans Animate
    18. Graphiques 3D
    19. Utilisation de symboles dans Animate
    20. Dessin de traits et de formes avec Adobe Animate
    21. Utilisation de bibliothèques dans Animate
    22. Exportation de sons
    23. Sélection d’objets dans Animate CC
    24. Utilisation de fichiers AI d’Illustrator dans Animate
    25. Application de motifs avec l’outil Pinceau pulvérisateur
    26. Application de modes de fusion
    27. Disposition d’objets
    28. Automatisation des tâches à l’aide du menu Commandes
    29. Texte multilingue
    30. Utilisation de la caméra dans Animate
    31. Utilisation d’Animate avec Adobe Scout
    32. Utilisation de fichiers Fireworks
    33. Filtres graphiques
    34. Sons et ActionScript
    35. Préférences de dessin
    36. Dessin avec l’outil Plume
  7. Plateformes
    1. Conversion de projets Animate en d’autres formats de document
    2. Prise en charge des plateformes personnalisées
    3. Création et publication de documents HTML5 Canvas dans Animate
    4. Création et publication d’un document WebGL
    5. Assemblage d’applications AIR pour iOS
    6. Publication d’applications AIR pour Android
    7. Publication pour Adobe AIR for Desktop
    8. Paramètres de publication d’ActionScript
    9. Pratiques recommandées – Organisation du code ActionScript dans une application
    10. Utilisation d’ActionScript avec Animate
    11. Pratiques recommandées – Recommandations sur l’accessibilité
    12. Accessibilité dans l’espace de travail Animate
    13. Écriture et gestion des scripts
    14. Activation de la prise en charge des plateformes personnalisées
    15. Présentation de la prise en charge des plateformes personnalisées
    16. Création de contenu accessible
    17. Utilisation du plug-in de prise en charge des plateformes personnalisées
    18. Débogage du code ActionScript 3.0
    19. Activation de la prise en charge des plateformes personnalisées
  8. Exportation et publication
    1. Exportation de fichiers d’Animate CC
    2. Publication OAM
    3. Exportation de fichiers SVG
    4. Exportation d’images et de vidéos avec Animate
    5. Publication de documents AS3
    6. Exportation d’animations pour les applications mobiles et les moteurs de jeu
    7. Exportation de sons
    8. Exportation de fichiers vidéo QuickTime
    9. Contrôle de la lecture vidéo externe à l’aide d’ActionScript
    10. Pratiques recommandées – Conseils pour la création de contenu pour appareils mobiles
    11. Pratiques recommandées – Conventions des vidéos
    12. Pratiques recommandées – Recommandations sur la création d’applications SWF
    13. Pratiques recommandées – Structuration des fichiers FLA
    14. Pratiques recommandées d’optimisation des fichiers FLA pour Animate
    15. Paramètres de publication d’ActionScript
    16. Spécification des paramètres de publication pour Animate
    17. Exportation de fichiers de projection
    18. Exportation d’images et de GIF animés
    19. Modèles de publication HTML
    20. Utilisation d’Adobe Premiere Pro et d’After Effects
    21. Partage et publication rapides de vos animations

Création d’occurrences

Une fois que vous avez créé un symbole, vous pouvez créer des occurrences de ce symbole aux emplacements de votre choix dans votre document, voire dans d’autres symboles. Lorsque vous modifiez le symbole, Animate met automatiquement à jour toutes ses occurrences.

Les noms d’occurrences des objets se créent dans l’inspecteur des propriétés. Le nom ainsi attribué permet de désigner les occurrences d’un même symbole dans ActionScript. Pour pouvoir contrôler les occurrences avec ActionScript®, il est impératif que leur nom soit unique. 

Vous pouvez spécifier des effets de couleur, affecter des actions, définir un mode d’affichage graphique et changer le comportement de nouvelles occurrences dans l’inspecteur des propriétés. Le comportement de l’occurrence est, sauf indication contraire, identique au comportement du symbole. Toute modification effectuée affecte uniquement l’occurrence, pas le symbole.

Création d’une occurrence de symbole

  1. Sélectionnez un calque dans le scénario. Animate peut placer des occurrences dans les images-clés uniquement, toujours sur le calque courant. Si vous ne sélectionnez pas d’image-clé, l’occurrence sera ajoutée par Animate à la première image-clé située à gauche de l’image en cours.

    Remarque :

    une image-clé est une image dans laquelle vous définissez les changements d’un effet d’animation. Pour plus d’informations, voir Insertion d’images dans le scénario.

  2. Sélectionnez Fenêtre > Bibliothèque.

  3. Faites glisser le symbole de la bibliothèque jusqu’à la scène.

  4. Si vous avez créé une occurrence d’un symbole graphique, sélectionnez Insertion > Scénario > Image pour ajouter le nombre d’images contenant le symbole graphique.

Affectation d’un nom à une occurrence

  1. Sélectionnez l’occurrence sur la scène.

  2. Sélectionnez Fenêtre > Propriétés et saisissez un nom dans le champ Nom de l’occurrence.

Modification des propriétés des occurrences

Chaque occurrence de symbole possède ses propres propriétés, distinctes de celles du symbole. Vous pouvez modifier la teinte, la transparence et la luminosité d’une occurrence, redéfinir son comportement (convertir, par exemple, un graphique en clip) et indiquer le mode de lecture de l’animation dans une occurrence de graphique. Vous pouvez également incliner, faire pivoter ou redimensionner une occurrence sans affecter le symbole.

Vous pouvez en outre nommer une occurrence de clip ou de bouton pour permettre la modification de ses propriétés avec ActionScript. Pour en savoir plus, voir Objets et classes dans Formation à ActionScript 3.0. Pour modifier les propriétés d’une occurrence, utilisez l’inspecteur des propriétés (Fenêtre > Propriétés).

Les propriétés d’une occurrence sont enregistrées avec cette dernière. Si vous modifiez un symbole ou reliez une occurrence à un autre symbole, les propriétés que vous avez modifiées s’appliquent toujours à l’occurrence.

Définition de la visibilité d’une occurrence

Vous pouvez rendre invisible une occurrence de symbole sur la scène en désactivant la propriété Visible. Pour de meilleures performances de rendu, utilisez la propriété Visible au lieu de définir la propriété Alpha du symbole sur 0.

Pour utiliser la propriété Visible, vous devez définir le lecteur sur Flash Player 10.2 ou une version ultérieure. Par ailleurs, cette propriété est uniquement compatible avec les occurrences de clip, de bouton et de composant.

  1. Sélectionnez l’occurrence sur la scène.

  2. Dans la section Affichage du panneau Propriétés, désactivez la propriété Visible.

Modification de la couleur et de la transparence d’une occurrence

Chaque occurrence d’un symbole peut avoir son propre effet de couleur. Pour définir les options de couleur et de transparence des occurrences, vous utiliserez l’inspecteur des propriétés. Les paramètres de l’inspecteur des propriétés s’appliquent également aux bitmaps placés dans les symboles.

Lorsque vous modifiez la couleur et la transparence d’une occurrence dans une image donnée, Animate effectue la modification dès qu’il affiche cette image. Pour effectuer des modifications de couleur progressives, vous devez appliquer une interpolation de mouvement. Lors de l’interpolation des couleurs, vous entrez différents paramètres d’effet dans les images-clés de début et de fin d’une occurrence, puis interpolez les paramètres pour faire évoluer les couleurs de l’occurrence au fil du temps.

L’interpolation modifie progressivement la couleur ou la transparence d’une occurrence.

Remarque :

Si vous appliquez un effet de couleur à un symbole de clip contenant plusieurs images, Animate applique l’effet à chaque image du symbole.

  1. Sélectionnez l’occurrence sur la scène, puis choisissez Fenêtre > Propriétés.
  2. Dans l’inspecteur des propriétés, sélectionnez l’une des options suivantes dans le menu Style de la section Effets de couleur :

    Luminosité

    Règle l’aspect clair ou sombre relatif de l’image, mesuré sur une échelle allant du noir (–100 %) au blanc (100 %). Pour régler la luminosité, cliquez sur le triangle et faites glisser le curseur de défilement ou saisissez une valeur dans la zone de texte.

    Teinte

    Colore l’occurrence avec la même nuance. Utilisez le curseur Teinte de l’inspecteur des propriétés pour sélectionner le pourcentage de teinte qui va de transparent (0 %) à entièrement saturé (100 %). Pour régler la teinte, cliquez sur le triangle et faites glisser le curseur de défilement ou saisissez une valeur dans la zone de texte. Pour sélectionner une couleur, saisissez les valeurs de rouge, de vert et de bleu dans les champs respectifs. Vous pouvez également cliquer sur la puce de couleur et sélectionner l’une des couleurs dans le Sélecteur de couleur.

    Alpha

    Ajuste la transparence de l’occurrence, de transparente (0 %) à complètement saturée (100 %). Pour définir la valeur alpha, cliquez sur le triangle et faites glisser le curseur de défilement ou saisissez une valeur dans la zone de texte.

    Avancé

    Permet d’ajuster séparément les valeurs de rouge, vert et bleu, ainsi que la transparence d’une occurrence. Cela est très utile lorsque vous voulez créer et animer des effets de couleur subtils dans des objets tels que les bitmaps. Les commandes situées à gauche permettent de réduire les valeurs de couleur ou de transparence d’un pourcentage spécifique. Les commandes de droite permettent de réduire ou d’augmenter les valeurs de couleur ou de transparence d’une valeur constante.

    Les valeurs de couleur rouge, vert, bleu et alpha en cours sont multipliées par les valeurs de pourcentage, puis ajoutées aux valeurs constantes dans la colonne de droite pour obtenir les nouvelles valeurs de couleur. Par exemple, si la valeur de rouge actuelle est égale à 100, le réglage du curseur de gauche à 50 % et du curseur de droite à 100 % donne une nouvelle valeur de rouge égale à 150 ([100 x 0,5] + 100 = 150). 

    Remarque : Les paramètres avancés du panneau Effet implémentent la fonction (a * y+ b)= x, où a est le pourcentage spécifié dans l’ensemble de champs de gauche, y est la couleur du bitmap d’origine, b est la valeur spécifiée dans l’ensemble des champs de droite et x est l’effet obtenu (entre 0 et 255 pour RVB et entre 0 et 100 pour la transparence alpha).

    Vous pouvez aussi modifier la couleur d’une occurrence à l’aide de l’objet ColorTransform d’ActionScript. Pour des informations détaillées sur l’objet Color, voir ColorTransform dans le Guide de référence du langage ActionScript 2.0 ou dans le Guide de référence du langage et des composants ActionScript 3.0.

Permutation des occurrences

Vous pouvez affecter un symbole différent à une occurrence pour afficher une occurrence qui, tout en préservant les propriétés d’origine de l’occurrence (effets de couleur, actions des boutons, etc.), sera différente.

Par exemple, imaginons que vous créez un dessin animé avec un symbole de rat comme personnage, mais que vous décidez de remplacer le personnage par un chat. Vous pouvez remplacer le symbole de rat par celui du chat et afficher le personnage mis à jour approximativement au même endroit dans toutes les images.

Affectation d’un symbole différent à une occurrence

  1. Sélectionnez l’occurrence sur la scène, puis choisissez Fenêtre > Propriétés.

  2. Cliquez sur le bouton Échanger dans l’inspecteur des propriétés.

  3. Sélectionnez le symbole par lequel vous souhaitez remplacer celui actuellement affecté à l’occurrence. Pour dupliquer un symbole sélectionné, cliquez sur Dupliquer le symbole, puis sur OK.

    La duplication vous permet de créer un nouveau symbole à partir d’un symbole existant dans la bibliothèque et réduit les opérations de copie si vous créez plusieurs symboles qui ont très peu de différences.

Remplacement de toutes les occurrences d’un symbole

  1. Faites glisser un symbole ayant le même nom que celui devant être remplacé d’un panneau Bibliothèque dans celui du fichier FLA que vous êtes en train de modifier, puis cliquez sur Remplacer. Si vous avez des dossiers dans la bibliothèque, vous devez faire glisser le nouveau symbole dans le même dossier que celui qui contient le symbole que vous remplacez.

Changement du type d’une occurrence

Vous pouvez changer le type d’une occurrence afin d’en redéfinir le comportement dans une application Animate. Par exemple, si une occurrence graphique contient un effet d’animation que vous souhaitez exécuter indépendamment du scénario de l’animation principale, vous pouvez redéfinir cette occurrence en tant qu’occurrence de clip.

  1. Sélectionnez l’occurrence sur la scène, puis choisissez Fenêtre > Propriétés.
  2. Sélectionnez Graphique, Bouton ou Clip dans le menu de l’inspecteur des propriétés.

Définition de la lecture en boucle pour les occurrences graphiques

Vous pouvez déterminer l’exécution des séquences de l’animation à l’intérieur d’une occurrence graphique dans l’application Animate en définissant des options dans l’inspecteur des propriétés.

Un symbole graphique animé est lié au scénario du document dans lequel il est placé. En revanche, un symbole de clip possède son propre scénario indépendant. L’animation des symboles graphiques animés, qui utilisent le même scénario que le document principal, est affichée en mode d’édition d’animation. Les symboles de clip s’affichent sous la forme d’objets statiques sur la scène et non sous la forme d’animations dans l’environnement de création d’Animate.

  1. Sélectionnez une occurrence de graphique sur la scène, puis choisissez Fenêtre > Propriétés.
  2. Sélectionnez une option d’animation dans le menu Options de la section Boucle de l’inspecteur des propriétés :

    Boucle

    Lit en boucle toutes les séquences de l’animation contenues dans l’occurrence en cours, selon le nombre d’images occupées par l’occurrence.

    Lire une seule fois

    Lit la séquence d’animation à partir de l’image que vous spécifiez et jusqu’à la fin de l’animation, puis s’arrête.

    Image unique

    Affiche une image de la séquence d’animation. Spécifiez l’image que vous souhaitez afficher.

  3. Pour spécifier la première image du symbole graphique à afficher lors de la boucle, entrez un numéro d’image dans le champ de texte Première. L’option Une seule image utilise également le numéro d’image spécifié ici.

Sélecteur d’image

Utilisez le Sélecteur d’image pour prévisualiser et choisir la première image d’un symbole graphique. Dans les versions précédentes, vous ne pouviez pas prévisualiser les images sans modifier le symbole en mode Édition. Cette fonction améliore l’expérience des utilisateurs qui travaillent sur des workflows d’animations du type Synchronisation des lèvres.

Remarque :

Le panneau Sélecteur d’image fonctionne uniquement avec des symboles graphiques ; il est désactivé pour les clips ou les symboles de type bouton. Assurez-vous que vous avez converti vos actifs en symboles avant d’utiliser cette fonction.

  1. Sélectionnez un symbole graphique, puis accédez au panneau Propriétés > Lecture en boucle >Utiliser le sélecteur d’image pour ouvrir le panneau Sélecteur d’image ou sélectionnez Fenêtre > Sélecteur d’image

    Sélecteur d’image

  2. Le symbole sélectionné est chargé dans le panneau du sélecteur d’image.

    Personnage sur la scène
    Personnage sur la scène

  3. Cliquez sur une image afin de la définir comme première image pour le symbole sélectionné.

    Vue Liste
    Vue Liste

    Vue Vignettes
    Vue Vignettes

    Boucle et images uniques
    Boucle et images uniques

    Voici les options disponibles dans le panneau du sélecteur d’image :

    Liste (option par défaut) Affiche les images dans une liste verticale.

    Vignette Affiche les images en vue grille et les réajuste lorsque le panneau est redimensionné.

    Créer l’image-clé Cette option permet de créer une image-clé automatiquement lorsque vous sélectionnez une position dans le panneau Sélecteur d’image. 

    Verrouiller le symbole actuel Cette option permet de travailler avec le même symbole même si l’image sélectionnée change.

    Ouvrir un nouveau panneau Sélecteur d’image Travaillez avec plusieurs symboles en les chargeant dans des panneaux de sélecteur d’image distincts.

    Boucle Présente les différentes options de lecture en boucle des images, telles que Boucle, Lire une seule fois et Image unique.

    Curseur Ajuste la taille de l’aperçu.

    Bouton à gauche du curseur Permet d’inclure plus d’images dans la vue.

    Bouton à droite du curseur Permet d’inclure moins d’images dans la vue.

    Liste déroulante des options de filtre Affiche les différentes options de filtre d’image.

Création d’une image-clé

Si l’option Créer l’image-clé est activée, il suffit de sélectionner une image dans le sélecteur d’image pour créer automatiquement les images-clés.

Création d’une image-clé
Création d’une image-clé

Épinglage du symbole actuel et ouverture de nouveaux panneaux d’image

Dans le sélecteur d’image, une option permet d’épingler le symbole actuel. Le symbole reste ainsi chargé dans le panneau et vous pouvez l’utiliser même si l’image sélectionnée change.

Une fois un symbole épinglé, il est mémorisé tant qu’il existe dans la bibliothèque ou jusqu’à ce qu’il soit explicitement désépinglé.

Dans le sélecteur d’image, une autre option permet d’utiliser plusieurs symboles en les chargeant dans des panneaux séparés.

Épinglage du symbole actuel
Épinglage du symbole actuel

Ouverture d’un nouveau panneau Sélecteur d’image
Ouverture d’un nouveau panneau Sélecteur d’image

Remarque :

Si vous tentez d’utiliser le sélecteur d’image lorsqu’aucune instance de symbole épinglé n’est disponible sur l’image active, un message s’affiche vous invitant à désépingler le symbole.

Options de filtrage des images

Animate permet de filtrer les images dans le panneau, comme suit :

  • Toutes les images : affiche toutes les images.
  • Images-clés : affiche uniquement les images-clés .
  • Étiquettes : affiche uniquement les images avec étiquette.
Options de filtrage des images
Options de filtrage des images

Synchronisation automatique des lèvres

La synchronisation des lèvres automatique permet de placer plus facilement et rapidement les formes de bouche appropriées sur le scénario, en fonction du calque audio sélectionné. Vous pouvez y parvenir à l’aide d’une liste existante de poses de bouche, dessinées dans un symbole graphique. Lorsque vous appliquez la synchronisation des lèvres automatique sur un symbole graphique, les images-clés sont automatiquement créées à différentes positions correspondant aux visèmes audio, après analyse du calque audio spécifié. Une fois l’opération terminée, vous pouvez effectuer des réglages supplémentaires en utilisant des workflows standard et le sélecteur d’images.

Un visème est une image faciale générique qui peut être utilisée pour indiquer un son. 

Création d’une synchronisation des lèvres

Suivez les étapes indiquées ci-dessous pour commencer à créer une synchronisation des lèvres. :

  1. Créez un symbole graphique (pose de bouche).

    Dans le symbole graphique, vous pouvez dessiner toutes les poses de bouche/tous les visèmes.

  2. Dans le scénario principal, importez un fichier audio dans un nouveau calque.

    Remarque :
    La synchronisation labiale automatique fonctionne mieux lorsque le paramètre de synchronisation audio est défini sur En continu.
    Exemple de symbole avec calque audio
    Exemple de symbole avec calque audio

  3. Sélectionnez le symbole graphique de la bouche. Dans l’inspecteur des propriétés, cliquez sur Synchronisation des lèvres.

    Synchronisation labiale dans l’inspecteur des propriétés
    Synchronisation labiale dans l’inspecteur des propriétés

    La boîte de dialogue Créer une synchronisation des lèvres s’ouvre. Par défaut, les douze types de visèmes de base s’affichent comme illustré dans la capture d’écran ci-dessous :

    Créer une synchronisation des lèvres
    Créer une synchronisation des lèvres

  4. Cliquez sur n’importe quel visème pour modifier son mappage de pose de bouche. Une fenêtre contextuelle s’affiche alors avec toutes les poses figurant dans le symbole graphique. Sélectionnez l’image appropriée dans la fenêtre contextuelle pour la définir pour le visème en cours.

    Modification de la pose de bouche pour chaque visème
    Modification de la pose de bouche pour chaque visème

  5. Sélectionnez le calque audio pour lequel les lèvres doivent être synchronisées. Cliquez sur le bouton Synchroniser.

    Capture d’écran du scénario après application de la synchronisation labiale
    Capture d’écran du scénario après application de la synchronisation labiale

    Remarque :

    La synchronisation labiale automatique s’applique à la plage d’images sur laquelle le symbole graphique sélectionné est présent. Vous pouvez également sélectionner plusieurs images-clés pour appliquer la synchronisation labiale sur l’ensemble de la plage d’images sélectionnée.

  6. Appuyez sur Ctrl + Entrée pour exécuter le fichier et afficher l’aperçu de la sortie.

    Vous pouvez afficher le fichier animé avec les mouvements de bouche générés automatiquement qui sont également synchronisés avec le fichier audio.

Séparation d’une occurrence de symbole

Pour rompre le lien entre une occurrence et un symbole et transformer cette dernière en une collection de formes et de lignes dissociées, vous devez dissocier l’occurrence. Cela est particulièrement utile lorsque vous souhaitez effectuer des modifications importantes sur l’occurrence sans affecter d’autres occurrences. 

Les modifications apportées au symbole source d’une occurrence n’ont aucune incidence sur l’occurrence après que celle-ci ait été séparée.

  1. Sélectionnez l’occurrence sur la scène.
  2. Sélectionnez Modification > Séparer. L’occurrence est divisée en ses divers éléments graphiques.
  3. Utilisez les outils de peinture et de dessin pour modifier ces éléments selon vos préférences.

Obtention d’informations sur les occurrences sur la scène

L’inspecteur des propriétés et le panneau Info affichent les informations suivantes sur les occurrences sur la scène :

  • L’inspecteur des propriétés permet d’afficher le comportement et les paramètres d’une occurrence : pour tous les types d’occurrences, les paramètres de couleur, l’emplacement et la taille ; pour les graphiques, le mode de boucle et la première image contenant le graphique ; pour les boutons, le nom de l’occurrence (s’il a été affecté) et l’option de suivi ; pour les clips, le nom d’occurrence (s’il a été affecté). Pour l’emplacement, l’inspecteur des propriétés affiche les coordonnées x et y du point d’alignement du symbole.

  • Dans le panneau Info, vous pouvez afficher l’emplacement et la taille de l’occurrence sélectionnée, l’emplacement de son point d’alignement, les valeurs de rouge (R), de vert (V), de bleu (B) et alpha (A) affectées (si le remplissage de l’occurrence est uni) et l’emplacement du pointeur. La section Position et taille de l’inspecteur des propriétés affiche les coordonnées x et y du point d’alignement ou de transformation du symbole. Vous pouvez basculer entre l’affichage des coordonnées du point d’alignement ou de transformation.

  • Dans l’explorateur d’animations, vous pouvez afficher le contenu du document en cours, y compris les occurrences et les symboles.

    Vous pouvez afficher dans le panneau Actions toute action affectée à un bouton ou un clip.

Obtention d’informations sur une occurrence

  1. Sélectionnez l’occurrence sur la scène.

  2. Affichez l’inspecteur des propriétés (Windows > Propriétés) ou le panneau que vous souhaitez utiliser :

    • Pour afficher le panneau Info, sélectionnez Fenêtre > Info.

    • Pour afficher l’explorateur d’animations, sélectionnez Fenêtre > Explorateur d’animations.

    • Pour afficher le panneau Actions, sélectionnez Fenêtre > Actions.

Affichage de la définition du symbole sélectionné dans l’explorateur d’animations

  1. Cliquez sur le bouton Afficher les boutons, les clips et les graphiques en haut de l’explorateur d’animations.

  2. Cliquez avec le bouton droit de la souris de la souris (Windows) ou appuyez sur la touche Contrôle (Macintosh), puis sélectionnez Afficher les occurrences de symboles et Atteindre la définition de symbole. Vous pouvez également sélectionner ces options dans le menu de l’explorateur d’animations (coin supérieur droit).

Atteinte de la séquence contenant les occurrences d’un symbole sélectionné

  1. Affichez les définitions du symbole

  2. Cliquez avec le bouton droit de la souris de la souris (Windows) ou appuyez sur la touche Contrôle (Macintosh), puis sélectionnez Afficher les éléments de l’animation et Atteindre la définition de symbole. Vous pouvez également sélectionner ces options dans le menu de l’explorateur d’animations (coin supérieur droit).

Logo Adobe

Accéder à votre compte