Handboek Annuleren

Gegevens samenvoegen met behulp van het deelvenster Variabelen

  1. Illustrator Handboek
  2. Kennismaken met Illustrator
    1. Inleiding tot Illustrator
      1. Nieuw in Illustrator
      2. Algemene vragen
      3. Systeemvereisten voor Illustrator
      4. Illustrator voor Apple silicon
    2. Werkruimte
      1. Basisbeginselen van de werkruimte
      2. Sneller leren met het deelvenster Ontdekken van Illustrator
      3. Documenten maken
      4. Werkbalk
      5. Standaardsneltoetsen
      6. Sneltoetsen aanpassen
      7. Inleiding in tekengebieden
      8. Tekengebieden beheren
      9. De werkruimte aanpassen
      10. Deelvenster Eigenschappen
      11. Voorkeuren instellen
      12. Werkruimte voor aanraken
      13. Ondersteuning voor Microsoft Surface Dial in Illustrator
      14. Bewerkingen ongedaan maken en ontwerpgeschiedenis beheren
      15. Weergave draaien
      16. Linialen, rasters en hulplijnen
      17. Toegankelijkheid in Illustrator
      18. Veilige modus
      19. Illustraties weergeven
      20. De Touch Bar gebruiken met Illustrator
      21. Bestanden en sjablonen
    3. Gereedschappen in Illustrator
      1. Overzicht van gereedschappen
      2. Selectiegereedschappen
        1. Selectie
        2. Direct selecteren
        3. Groep selecteren
        4. Toverstaf
        5. Lasso
        6. Tekengebied
      3. Navigatiegereedschappen
        1. Handje
        2. Weergave draaien
        3. Zoomen
      4. Schildergereedschappen
        1. Verloop
        2. Net
        3. Vormen maken
      5. Tekstgereedschappen
        1. Tekst
        2. Tekst op een pad
        3. Verticale tekst
      6. Tekengereedschappen
        1. Pen
        2. Ankerpunt-toevoegen
        3. Ankerpunt verwijderen
        4. Ankerpunt
        5. Kromming
        6. Lijnsegment
        7. Rechthoek
        8. Afgeronde rechthoek
        9. Ovaal
        10. Veelhoek
        11. Ster
        12. Penseel
        13. Klodderpenseel
        14. Potlood
        15. Shaper
        16. Segment
      7. Bewerkingsgereedschappen
        1. Roteren
        2. Spiegelen
        3. Schalen
        4. Schuin
        5. Breedte
        6. Vrije transformatie
        7. Pipet
        8. Overvloeien
        9. Gummetje
        10. Schaar
        11. Meetgereedschap
    4. Generatieve AI (niet beschikbaar op het vasteland van China)
      1. Een vectorillustratie genereren met een tekstinstructie
      2. De kleuren in uw illustraties aanpassen met een tekstinstructie
    5. Snelle actie
      1. Retro tekst
      2. Tekst met neon gloed
      3. Ouderwetse tekst
      4. Opnieuw kleuren
      5. Schetsen omzetten in vectoren
  3. Illustrator op het web (Beta)
    1. Overzicht van Illustrator op het web (Beta)
    2. Veelgestelde vragen over Illustrator op het web (Beta)
    3. Veelgestelde vragen over het oplossen van problemen
    4. Sneltoetsen voor Illustrator op het web (Beta)
    5. Vormen maken en combineren op het web
    6. Tekst toevoegen en bewerken op het web
    7. Kleuren en verlopen toepassen op het web
    8. Paden tekenen en bewerken op het web
    9. Werken met clouddocumenten op het web
    10. Deelnemers uitnodigen om te bewerken op het web
  4. Illustrator op de iPad
    1. Inleiding in Illustrator op de iPad
      1. Overzicht van Illustrator op de iPad
      2. Veelgestelde vragen over Illustrator op de iPad
      3. Systeemvereisten | Illustrator op de iPad
      4. Wat u wel of niet kunt doen in Illustrator op de iPad
    2. Werkruimte
      1. De werkruimte van Illustrator op de iPad
      2. Snelknoppen en bewegingen
      3. Sneltoetsen voor Illustrator op de iPad
      4. Uw app-instellingen beheren
    3. Documenten
      1. Werken met documenten in Illustrator op de iPad
      2. Photoshop- en Fresco-documenten importeren
    4. Objecten selecteren en rangschikken
      1. Herhaalde objecten maken
      2. Objecten laten overvloeien
    5. Tekenen
      1. Paden tekenen en bewerken
      2. Vormen tekenen en bewerken
    6. Tekst
      1. Werken met tekst en lettertypen
      2. Tekstontwerpen langs een pad maken
      3. Uw eigen lettertypen toevoegen
    7. Werken met afbeeldingen
      1. Rasterafbeeldingen omzetten in vectoren
    8. Kleur
      1. Kleuren en verlopen toepassen
  5. Clouddocumenten
    1. Basisbeginselen
      1. Werken met Illustrator-clouddocumenten
      2. Illustrator-clouddocumenten delen en eraan samenwerken
      3. Documenten ter beoordeling delen
      4. Cloudopslag voor Adobe Illustrator upgraden
      5. Illustrator-clouddocumenten | Algemene vragen
    2. Problemen oplossen
      1. Problemen met het maken of opslaan van clouddocumenten in Illustrator oplossen
      2. Problemen met clouddocumenten in Illustrator oplossen
  6. Inhoud toevoegen en bewerken
    1. Tekenen en meten
      1. Basisbeginselen van tekenen
      2. Paden bewerken
      3. Pixel-perfecte illustraties tekenen
      4. Tekenen met de pen, het potlood of het gereedschap Kromming
      5. Eenvoudige lijnen en vormen tekenen
      6. Rechthoekige rasters en poolrasters tekenen
      7. Flakkeringen tekenen en bewerken
      8. Afbeeldingen overtrekken
      9. Een pad vereenvoudigen
      10. Symboolgereedschappen en symboolsets
      11. Padsegmenten aanpassen
      12. Een bloem ontwerpen in 5 eenvoudige stappen
      13. Een perspectiefraster maken en bewerken
      14. Objecten op een perspectiefraster tekenen en wijzigen
      15. Objecten gebruiken als symbolen voor herhaald gebruik
      16. Paden met pixeluitlijning tekenen voor webworkflows
      17. Afmetingen meten en weergeven
    2. 3D-objecten en materialen
      1. Over 3D-effecten in Illustrator
      2. 3D-afbeeldingen maken
      3. Illustraties toewijzen aan 3D-objecten
      4. 3D-tekst maken
      5. 3D-objecten maken
    3. Kleur
      1. Kleuren
      2. Kleuren selecteren
      3. Stalen gebruiken en maken
      4. Kleuren aanpassen
      5. Het deelvenster Adobe Color-thema's gebruiken
      6. Kleurgroepen (harmonieën)
      7. Deelvenster Kleurthema's
      8. Illustraties opnieuw kleuren
    4. Schilderen
      1. Informatie over schilderen
      2. Schilderen met vullingen en lijnen
      3. Groepen van Actieve verf
      4. Verlopen
      5. Penselen
      6. Transparantie- en overvloeiingsmodi
      7. Lijnen toepassen op een object
      8. Patronen maken en bewerken
      9. Netten
      10. Patronen
    5. Objecten selecteren en rangschikken
      1. Objecten selecteren
      2. Lagen
      3. Objecten groeperen en uitbreiden
      4. Objecten verplaatsen, uitlijnen en verdelen
      5. Objecten stapelen    
      6. Objecten vergrendelen, verbergen en verwijderen
      7. Objecten kopiëren en dupliceren
      8. Objecten roteren en spiegelen
      9. Objecten verstrengelen
      10. Realistische mock-ups maken
    6. Objecten omvormen
      1. Afbeeldingen uitsnijden
      2. Objecten transformeren
      3. Objecten combineren
      4. Objecten knippen, splitsen en verkleinen
      5. Marionet verdraaien
      6. Objecten schalen, schuintrekken en vervormen
      7. Objecten laten overvloeien
      8. Omvormen met omhulsels
      9. Objecten omvormen met effecten
      10. Nieuwe vormen maken met de gereedschappen Shaper en Vormen maken
      11. Werken met actieve hoeken
      12. Verbeterde workflows voor omvormen met ondersteuning voor aanraking
      13. Uitknipmaskers bewerken
      14. Actieve vormen
      15. Vormen maken met het gereedschap Vormen maken
      16. Algemene bewerking
    7. Tekst
      1. Tekst en ander werk toevoegen met tekstobjecten
      2. Genummerde lijsten en lijsten met opsommingstekens maken
      3. Tekstgebied beheren
      4. Lettertypen en typografie
      5. Tekst in afbeeldingen omzetten in bewerkbare tekst
      6. Basisopmaak toevoegen aan tekst
      7. Geavanceerde opmaak toevoegen aan tekst
      8. Tekst importeren en exporteren
      9. Alinea's opmaken
      10. Speciale tekens
      11. Tekst op een pad maken
      12. Teken- en alineastijlen
      13. Tabs
      14. Ontbrekende lettertypen zoeken (Typekit-workflow)
      15. Arabische en Hebreeuwse tekst
      16. Lettertypen | Veelgestelde vragen en tips voor probleemoplossing
      17. Een 3D-teksteffect maken
      18. Creatieve typografische ontwerpen
      19. Tekst schalen en roteren
      20. Regelafstand en tekenafstand
      21. Woordafbreking en regelafbreking
      22. Spelling- en taalwoordenboeken
      23. Aziatische tekens opmaken
      24. Composers voor Aziatische schriften
      25. Tekstontwerpen maken met overvloeiobjecten
      26. Een tekstposter maken met Afbeeldingen overtrekken
    8. Speciale effecten maken
      1. Werken met effecten
      2. Afbeeldingsstijlen
      3. Vormgevingskenmerken
      4. Schetsen en mozaïeken maken
      5. Slagschaduw, gloed en doezeleffect
      6. Overzicht van effecten
    9. Webafbeeldingen
      1. Aanbevolen procedures voor het maken van webafbeeldingen
      2. Grafieken
      3. SVG
      4. Segmenten en afbeeldingen met hyperlinks
  7. Importeren, exporteren en opslaan
    1. Importeren
      1. Meerdere bestanden plaatsen
      2. Gekoppelde en ingesloten bestanden beheren
      3. Informatie over koppelingen
      4. Het insluiten van afbeeldingen ongedaan maken
      5. Illustraties importeren uit Photoshop
      6. Bitmapafbeeldingen importeren
      7. Adobe PDF-bestanden importeren
      8. EPS-, DCS- en AutoCAD-bestanden importeren
    2. Creative Cloud Libraries in Illustrator 
      1. Creative Cloud Libraries in Illustrator
    3. Opslaan
      1. Illustraties opslaan
    4. Exporteren
      1. Illustrator-illustraties gebruiken in Photoshop
      2. Een illustratie exporteren
      3. Assets verzamelen en exporteren in batches
      4. Bestanden in een pakket opnemen
      5. Adobe PDF-bestanden maken
      6. CSS extraheren | Illustrator CC
      7. Adobe PDF-opties
      8. Deelvenster Documentinfo
  8. Afdrukken
    1. Voorbereiden op afdrukken
      1. Documenten instellen voor afdrukken
      2. Het paginaformaat en de afdrukstand wijzigen
      3. Snijtekens opgeven voor bijsnijden of uitlijnen
      4. Aan de slag met een groot canvas
    2. Afdrukken
      1. Overdrukken
      2. Afdrukken met kleurbeheer
      3. Afdrukken met PostScript
      4. Afdrukvoorinstellingen
      5. Drukkersmarkeringen en afloopgebieden
      6. Transparante illustraties afdrukken en opslaan
      7. Overvullen
      8. Kleurscheidingen afdrukken
      9. Verlopen, netten en kleurovervloeiingen afdrukken
      10. Witte overdruk
  9. Taken automatiseren
    1. Gegevens samenvoegen met behulp van het deelvenster Variabelen
    2. Automatiseren met behulp van scripts
    3. Automatiseren met behulp van handelingen
  10. Problemen oplossen 
    1. Crashproblemen
    2. Bestanden herstellen na een crash
    3. Problemen met bestanden
    4. Ondersteunde bestandsindelingen
    5. Problemen met GPU-stuurprogramma's
    6. Problemen met Wacom-apparaten
    7. Problemen met DLL-bestanden
    8. Geheugenproblemen
    9. Problemen met voorkeurenbestanden
    10. Lettertypeproblemen
    11. Printerproblemen
    12. Foutrapport delen met Adobe
    13. De prestaties van Illustrator verbeteren

Voeg een Illustrator-document samen met een gegevensbronbestand (CSV- of XML-bestand) met behulp van het deelvenster Variabelen om zo meerdere varianten van uw illustratie te maken. U kunt de namen van deelnemers op badges voor evenementen wijzigen of afbeeldingen in webbanners en ansichtkaarten aanpassen zonder dat u uw illustraties opnieuw hoeft te maken. Maak één ontwerp en produceer daarna snel variaties door de namen of afbeeldingen vanuit een gegevensbronbestand te importeren.

Maak met behulp van het deelvenster Variabelen aangepaste variaties van uw ontwerpsjabloon voor verschillende projecten, zoals afdrukbare posters, banners en evenementbadges.

Voordat u verdergaat

U hebt alleen maar een gegevensbronbestand en een doeldocument nodig om een gegevens samen te voegen. 

  • Het gegevensbronbestand bevat de informatie die in elke versie van het doeldocument anders is, zoals de namen, foto's en de adressen van de geadresseerden van een standaardbrief. Een gegevensbronbestand is een kommagescheiden bestand (.csv) of een extensible markup language-bestand (.xml). 
  • Het doeldocument is een Illustrator-document met de basisillustratie om te gebruiken als sjabloon. Dit document kan de plaatsaanduiding voor het gegevensveld bevatten en de items die in dezelfde versie van het samengevoegde document blijven.

De functionaliteit om gegevens samen te voegen gebruiken

Gegevens samenvoegen is beschikbaar vanuit het deelvenster Variabelen in Illustrator (Venster > Variabelen). Het type en de naam van iedere variabele in het document worden vermeld in het deelvenster. Als de variabele aan een object is gekoppeld, wordt in de kolom Objecten de naam van het gekoppelde object weergegeven zoals dit wordt weergegeven in het deelvenster Lagen. U kunt de rijen sorteren door te klikken op de items in de kopbalk: op de naam van de variabele, de objectnaam of het type variabele.

Deelvenster Variabelen

A. Gegevensset B. Deelvenstermenu C. Schakelen tussen gegevenssets D. Naam van het gekoppelde object E. Naam van de variabele F. Type variabele G. Variabelen vergrendelen H. Object dynamisch maken I. Zichtbaarheid dynamisch maken J. Binding van variabelen opheffen K. Variabelen maken L. Variabelen verwijderen 

Basisstappen voor het samenvoegen van gegevens

  1. Maak een Illustrator-document dat u als sjabloon wilt gebruiken.

  2. Stel uw brongegevensbestand in als csv- of xml-indeling. Zie Een gegevensbronbestand voorbereiden voor meer informatie.

  3. Importeer een gegevensbronbestand in Illustrator met behulp van het deelvenster Variabelen. Zie Een gegevensbronbestand importeren voor meer informatie.

  4. Bind een variabele aan een object in de sjabloon. Zie Variabelen binden aan objecten voor meer informatie.

  5. Bekijk een voorvertoning van het document met elke gegevensset voordat u alle bestanden exporteert. Zie Een voorvertoning van het document bekijken met elke gegevensset voor meer informatie.

  6. Exporteer een batch bestanden uit de gegevens via het deelvenster Handelingen in Illustrator. Zie Bestanden exporteren via het deelvenster Handelingen voor meer informatie.

Een gegevensbronbestand voorbereiden

Gegevensbronbestanden moeten een CSV-bestand (kommagescheiden) of een XML-bestand (Extensible Markup Language) zijn.

Uw CSV-bronbestanden instellen

In een kommagescheiden bestand (.CSV-bestand) worden records van elkaar gescheiden door alinea-einden en velden door komma's of tabs. Het gegevensbronbestand kan ook tekst of paden bevatten die naar afbeeldingen op een schijf verwijzen. Doe voordat u een CSV-bestand importeert het volgende, zodat Illustrator het type variabele kan herkennen.

  1. Open uw spreadsheet.

  2. Geef uw gegevensveldnaam op in de eerste rij van het spreadsheet. Doe hierna het volgende:

    • Typ aan het begin van de naam van het gegevensveld een "apenstaartje" (@) om tekst of paden in te voegen die naar afbeeldingsbestanden verwijzen. Het @-symbool hoeft alleen in de eerste regel te worden ingevoegd. De volgende regels moeten de paden voor de afbeelding bevatten.
    • Typ aan het begin van de naam van het gegevensveld een percentagesymbool (%) voor grafieken en een hashtag-symbool (#) voor zichtbaarheid.
    • Om de zichtbaarheid van een object te bepalen, geeft u waar of onwaar op voor elk gegevensveld.
    Opmerking:
    • De gegevensveldnamen in uw spreadsheet mogen geen spaties bevatten. U kunt bijvoorbeeld het gegevensveld de naam Naam_bedrijf geven in plaats van Bedrijfsnaam
    • Ook de paden naar afbeeldings- en grafiekbestanden mogen geen spaties bevatten. Het pad van een beeldbestand moet C:\Foto's\WimBakker in plaats van C:\Foto's\Wim Bakker zijn.
    • Alle grafiekbestanden die gekoppeld zijn vanuit uw gegevensbronbestand, moeten worden opgeslagen als een kommagescheiden bestand (.csv).
    • Als er een foutbericht wordt weergegeven als u het @-symbool typt aan het begin van het veld, typt u een apostrof (') vóór het @-symbool (bijvoorbeeld '@Afbeeldingen) om de functie te valideren. In sommige toepassingen, zoals Microsoft Excel, is het @-symbool gereserveerd voor functies.

    (Windows) Voorbeeld van afbeeldings- en grafiekreferenties in gegevensbronbestand

    Naam

    Leeftijd

    @Foto's

    %Grafieken

    #Zichtbaarheid

    Wim Bakker

    36

    C:\Afbeeldingen\WimBakker.jpg

    C:\Afbeeldingen\WimBakker.csv

    Waar

    Janssens

    53

    C:\Mijn documenten\janssens.jpg

    C:\Mijn documenten\janssens.csv

    Waar

    Maria Ruiz

    26

    C:\Afbeeldingen\Ruiz.jpg

    C:\Afbeeldingen\Ruiz.csv

    Onwaar

    (macOS) Voorbeeld van afbeeldings- en grafiekreferenties in gegevensbronbestand

    Naam

    Leeftijd

    @Foto's

    %Grafieken

    #Zichtbaarheid

    Wim Bakker

    36

    /Users/foto's/WimBakker.jpg

    /Users/foto's/WimBakker.csv

    Waar

    Janssens

    53

    /Users/familie/foto's/janssens.jpg

    /Users/familie/foto's/janssens.csv

    Waar

    Maria Ruiz

    26

    /Users/alfa/foto's/Ruiz.jpg

    /Users/alfa/foto's/Ruiz.csv

    Onwaar

  3. Voer uw gegevens in het spreadsheet in.

  4. Voer een van de volgende handelingen uit:

    • Sla spreadsheets gemaakt met de nieuwste versie van Microsoft Excel (2016) op in de volgende bestandsindelingen:
      • CSV (Kommagescheiden) (*.csv)
      • CSV (MS-DOS) (*.csv)
    • Sla spreadsheets gemaakt met Apple Numbers op in de CSV-indeling met Unicode (UTF-8)-codering.
    Opmerking:

    CSV-bestanden die in de hierboven vermelde indelingen worden geëxporteerd, worden momenteel ondersteund in Illustrator. Andere CSV-bestandsindelingen zoals Macintosh Comma Separated (.csv) worden niet ondersteund voor het samenvoegen van gegevens.

Een XML-bestand voorbereiden

  1. Definieer een variabele in uw document. Zie Variabelen binden aan objecten voor meer informatie.

  2. Selecteer de knop Gegevensset vastleggen  in het deelvenster Variabelen.

  3. Nadat u het gewenste aantal gegevenssets hebt gemaakt, selecteer u Variabelenbibliotheek opslaan in het menu van het deelvenster Variabelen om gegevenssets op te slaan als een XML-bestand. Geef een bestandsnaam en een locatie op en selecteer Opslaan.

    De variabelen die u in Illustrator hebt gemaakt exporteren als een XML-bestand

  4. Bewerk nu het XML-bestand in een tekstverwerker zoals Notepad++ (Windows) of TextWrangler (macOS) om uw gegevenssets aan dit bestand toe te voegen.

    Voorbeeld: het bewerken van een XML-bestand met een tekstverwerker

    A. Het pad van de afbeelding vervangen B. De tekstreeks vervangen  

  5. Selecteer Variabelenbibliotheek laden in het menu van het deelvenster Variabelen om uw XML-bestand in Illustrator te importeren. Selecteer het XML-bestand en selecteer Openen.

    Variabelen importeren in Illustrator

Een gegevensbronbestand importeren

Als u variabelen aan de gewenste gegevens wilt binden, importeert u een gegevensbron in het deelvenster Variabelen. Er kan slechts één gegevensbronbestand per document worden geselecteerd.

  1. Kies Venster > Variabelen.

  2. Selecteer Importeren in het deelvenster Variabelen.

  3. Selecteer in het dialoogvenster Variabelenbibliotheek laden een gegevensbronbestand in de CSV- of XML-indeling en selecteer Openen.

  4. U kunt de gegevensset later bewerken of verwijderen of de naam ervan wijzigen door deze te kiezen in de vervolgkeuzelijst Gegevensset en daarna de opties te bewerken.

    • Selecteer een gegevensset in de lijst Gegevensset in het deelvenster Variabelen om te schakelen tussen gegevenssets. U kunt ook de knop Vorige gegevensset of Volgende gegevensset selecteren.
    • Als u de gegevens op het tekengebied wilt toepassen op de huidige gegevensset, kiest u Gegevensset bijwerken in het menu van het deelvenster Variabelen.
    • Als u de naam van een gegevensset wilt wijzigen, bewerkt u de tekst rechtstreeks in het tekstvak Gegevensset. U kunt dubbelklikken op het woord Gegevensset (links naast het tekstvak Gegevensset), een nieuwe naam invoeren en OK selecteren.
    • Als u een gegevensset wilt verwijderen, selecteert u het pictogram Verwijderen. U kunt ook Gegevensset verwijderen selecteren in het menu van het deelvenster Variabelen.
    Opmerking:

    CSV-bestanden (UTF-8 door komma's gescheiden) die dubbelbytetekens bevatten en die zijn gemaakt met Excel, kunnen niet worden geïmporteerd in het deelvenster Variabelen. Als u hetzelfde bestand in de tekstindeling opent en vervolgens opslaat als CSV met UTF-8-codering, wordt het bestand correct geïmporteerd.

Variabelen binden aan objecten

U gebruikt variabelen om te bepalen welke elementen u in een sjabloon wilt wijzigen. U kunt vier typen variabelen definiëren: Zichtbaarheid, Tekstreeks, Gekoppeld bestand en Grafiekgegevens. Het type van de variabele geeft aan welke objectkenmerken kunnen worden gewijzigd (dat wil zeggen, dynamisch zijn). Het type en de naam van iedere variabele in het document worden vermeld in het deelvenster. Als de variabele aan een object is gekoppeld, wordt in de kolom Objecten de naam van het gekoppelde object weergegeven zoals dit wordt weergegeven in het deelvenster Lagen.

Type variabele

Pictogram dat het type van een variabele aangeeft

Definitie

Variabelen van het type Zichtbaarheid

Illustratie tonen of verbergen.

Variabelen van het type Tekstreeks

Een tekstreeks vervangen.

Variabelen van het type Gekoppeld bestand

Het object in het tekengebied vervangen door een object uit een ander bestand.

Variabelen van het type Grafiekgegevens

De waarden in een grafiek vervangen.

Variabele zonder type (niet gekoppeld)

Niet gebonden aan een object.

Volg deze stappen om variabelen te definiëren in Illustrator:

  1. Selecteer een object.

  2. Selecteer in het deelvenster Variabelen (Venster > Variabelen) de variabele waaraan u het object wilt binden.

  3. Selecteer de knop Object dynamisch maken om het object aan de variabele te binden.

Volg deze stappen om een variabele te maken zonder deze aan een object te binden:

  1. Selecteer de knop Nieuwe variabele  in het deelvenster Variabelen.

  2. Als u een object aan de variabele wilt binden, selecteert u het object en de variabele en selecteert u de knop Zichtbaarheid dynamisch maken of de knop Object dynamisch maken .

Opmerking:

Variabelenamen ondersteunen geen surrogaatpaar en 4-byte tekens. Als u deze tekens gebruikt in een variabelenaam, wordt er een foutmelding weergegeven.

Werken met variabelen

U kunt de naam of het type van een variabele bewerken, de binding van een variabele opheffen en een variabele vergrendelen via het deelvenster Variabelen.

Als u de binding van een variabele opheft, wordt de koppeling tussen de variabele en het object verbroken. Als u variabelen vergrendelt kunt u geen variabelen maken of verwijderen of opties voor variabelen bewerken. U kunt echter wel objecten aan vergrendelde variabelen binden en deze binding weer opheffen.

De naam en het type van een variabele wijzigen

  1. Selecteer de variabele in het deelvenster Variabelen en selecteer Variabele-opties in het deelvenstermenu.

De binding van een variabele opheffen

  1. Selecteer de knop Binding van variabele opheffen  in het deelvenster Variabelen.

Alle variabelen in een document vergrendelen of ontgrendelen

  1. Selecteer de knop Variabelen vergrendelen  of de knop Variabelen ontgrendelen in het deelvenster Variabelen.

Variabelen verwijderen

U kunt een variabele uit het deelvenster Variabelen verwijderen. Als u een variabele verwijdert die is gekoppeld aan een object, wordt het object statisch (tenzij het object ook is gekoppeld aan een variabele van een ander type).

  1. Selecteer een variabele die u wilt verwijderen.

  2. Voer een van deze stappen uit:

    • Selecteer de knop Variabele verwijderen  in het deelvenster Variabelen.

    • Als u een variabele wilt verwijderen zonder dat er een bevestiging wordt weergegeven, sleept u de variabele naar de knop Variabele verwijderen.

Dynamische objecten bewerken

U kunt de gegevens wijzigen die zijn gekoppeld aan een variabele door het object te bewerken waaraan de variabele is gekoppeld. Als u bijvoorbeeld werkt met een variabele van het type Zichtbaarheid, kunt u de zichtbaarheidsstatus van het object wijzigen in het deelvenster Lagen. Door dynamische objecten te bewerken kunt u meerdere gegevenssets maken in de sjabloon.

  1. Selecteer een dynamisch object in het tekengebied of voer een van de volgende stappen uit om automatisch een dynamisch object te selecteren:

    • Houd Alt (Windows) of Option (macOS) ingedrukt en klik op een variabele in het deelvenster Variabelen.

    • Selecteer een variabele in het deelvenster Variabelen en selecteer Gebonden object selecteren in het menu van het deelvenster Variabelen.

    • Selecteer Alle gebonden objecten in het menu van het deelvenster Variabelen om alle dynamische objecten te selecteren.

  2. Bewerk de gegevens die aan het object zijn gekoppeld als volgt:

    • Bewerk de tekst in het tekengebied.

    • Vervang de afbeelding via het deelvenster Koppelingen of de opdracht Bestand > Plaatsen voor gekoppelde bestanden.

    • Bewerk de gegevens voor grafieken in het dialoogvenster Grafiekgegevens.

    • Bewerk alle objecten met dynamische zichtbaarheid door in het deelvenster Lagen de zichtbaarheid van een object te wijzigen.

Dynamische objecten identificeren met XML-id's

In het deelvenster Variabelen worden de namen van de dynamische objecten uit het deelvenster Lagen weergegeven. Als u de sjabloon voor gebruik met andere Adobe-producten opslaat in de SVG-indeling, moeten deze objectnamen voldoen aan de naamgevingsconventies voor XML. XML-namen moeten bijvoorbeeld beginnen met een letter, onderstrepingsteken of dubbele punt en mogen geen spaties bevatten.

Illustrator wijst automatisch een geldige XML-id toe aan elk dynamische object dat u maakt. Als u objectnamen met XML-id's wilt weergeven, bewerken of exporteren, kiest u Bewerken > Voorkeuren > Eenheden (Windows) of Illustrator > Voorkeuren > Eenheden (macOS). Selecteer vervolgens XML-id.

Een voorvertoning van het document bekijken met elke gegevensset

Om te kunnen zien hoe uw afbeeldingen er uiteindelijk uitzien, kunt u deze voorvertonen voordat u de bestanden exporteert. Gebruik de pijltoetsen naast Gegevensset in het deelvenster Variabelen om te navigeren en een voorvertoning weer te geven van de gewenste gegevensset in uw document.

Bestanden exporteren via het deelvenster Handelingen

Zodra u variabelen en een of meer gegevenssets hebt gedefinieerd, kunt u in de modus Batch illustraties uitvoeren met gebruik van de gegevenssetwaarden. Ga als volgt te werk:

  1. Neem via het deelvenster Handelingen (Venster > Handelingen) een handeling op om uw document op te slaan in de gewenste indeling. Zie Automatiseren met behulp van handelingen voor meer informatie.

  2. Kies Batch in het menu van het deelvenster Handelingen en selecteer de handeling die u hebt gemaakt in de vorige stap.

  3. Selecteer bij Bron Gegevenssets om de handeling af te spelen op elke gegevensset in het huidige bestand.

  4. Geef bij Doel aan wat er met de verwerkte bestanden moet gebeuren. U kunt de bestanden geopend laten zonder de wijzigingen op te slaan (Geen), de bestanden sluiten en opslaan op de huidige locatie (Opslaan en sluiten) of de bestanden op een andere locatie opslaan (Map).

    Afhankelijk van de geselecteerde optie voor Doel kunt u aanvullende opties instellen voor het opslaan van de bestanden. Zie Een handeling uitvoeren op een batch bestanden voor meer informatie.

  5. Selecteer OK.

Een sjabloon opslaan voor gegevenssamenvoeging

Wanneer u variabelen definieert in een Illustrator-document, maakt u een sjabloon voor gegevenssamenvoeging. U kunt de sjabloon opslaan in SVG-indeling voor gebruik met andere Adobe-producten, zoals Adobe® Graphics Server. Een ontwikkelaar die werkt met Adobe Graphics Server kan bijvoorbeeld de variabelen in het SVG-bestand direct binden aan een database of een andere gegevensbron.

  1. Kies Bestand > Opslaan als, geef een bestandsnaam op, selecteer SVG als bestandsindeling en klik op Opslaan.

  2. Klik op Meer opties en kies Gegevens van Adobe Graphics Server opnemen. Alle benodigde gegevens voor het vervangen van variabelen worden dan opgenomen in het SVG-bestand.

  3. Klik op OK.

Problemen bij het importeren van uw CSV-bestand?

Als u de foutmelding: De binnenkomende variabelenbibliotheek is ongeldig krijgt bij het uploaden van een CSV-gegevensbronbestand, dient u te controleren of:

  • Het CSV-bestand niet leeg is.
  • De spreadsheets die u hebt gemaakt met de nieuwste versie van Microsoft Excel worden opgeslagen als CSV-bestand (kommagescheiden) (*.csv) of CSV (MS-DOS) (*.csv) en of de bestanden gemaakt met Apple Numbers worden opgeslagen als CSV-indeling met Unicode-codering (UTF-8). Gegevensbronbestanden die in een andere bestandsindeling zijn opgeslagen, zoals Macintosh Comma Separated (*.csv), niet worden ondersteund voor het samenvoegen van gegevens.
  • Alle kolommen een gegevensveldnaam hebben. In Illustrator wordt bijvoorbeeld het foutbericht weergegeven als een kolom in uw gegevensbronbestand wel gegevens bevat, maar geen gegevensveldnaam heeft.
  • In het gegevensbronbestand hoeft geen lege kolom tussen gevulde kolommen te staan. In Illustrator wordt het foutbericht bijvoorbeeld weergegeven als kolom B en D in uw gegevensbronbestand gegevens bevatten, maar kolom C leeg is.
Voorbeeld: fouten bij het voorbereiden van een CSV-bronbestand voor het samenvoegen van gegevens

A. Gegevensveldnaam ontbreekt voor een kolom B. Er staat een lege kolom tussen gevulde kolommen 

  • De gegevensveldnamen in uw spreadsheet bevatten geen spaties.
  • Ook de paden naar afbeeldings- en grafiekbestanden bevatten geen spaties.
  • De grafiekbestanden die gekoppeld zijn vanuit uw gegevensbronbestand worden opgeslagen als kommagescheiden bestanden (.csv).

verwante bronnen

Praat met ons

Wij horen graag van u. Deel uw mening met de Adobe Illustrator-community

 Adobe

Krijg sneller en gemakkelijker hulp

Nieuwe gebruiker?