Различные параметры экспорта в Character Animator.

Когда сцена собрана, ее можно экспортировать для использования в других приложениях, например After Effects или Premiere Pro. Также возможен экспорт в папку, которую отслеживает Adobe Media Encoder для автоматизации процесса рендеринга сцены и ее экспорта в любой формат, поддерживаемый Adobe Media Encoder. Форматом экспорта по умолчания является H.264 с шаблоном настроек Соответствие источнику — высокая скорость. Далее описана процедуры импорта экспортированной сцены в другие приложения, экспорта марионетки и предоставление ее другим пользователям, а также экспорта синхронизации губ в After Effects.

С помощью Dynamic Link можно открыть сцену непосредственно в After Effects или Premiere Pro и поддерживать связь в реальном времени с исходной сценой в Character Animator. Изменения в сцене, выполненные в Character Animator, автоматически отображаются при переходе в After Effects или Premiere Pro.

Для импорта сцены в After Effects или Premiere Pro с помощью Dynamic Link выполните одно из следующих действий:

  • Перетащите сцену из панели «Проект» в Character Animator на панель «Проект» в After Effects или Premiere Pro. Начните перетаскивать сцену в Character Animator (Alt/Command+клавиша табуляции) в After Effects или Premiere Pro, затем отпустите ее на панели «Проект».
  • Выполните импорт сцены из файла .chproj следующим образом:
  1. Выберите файл проекта Character Animator (.chproj) для импорта, выбрав Файл > Импорт > Файл в After Effects, выбрав Файл > Импорт в Premiere Pro или воспользовавшись медиабраузером в любом из приложений.

  2. Выберите сцену в проекте для импорта.

    Сцена отобразится на панели «Проект» в виде видеоматериала Dynamic Link, который можно добавлять в композицию или эпизод аналогично любому другому видеоматериалу. Приложение Character Animator не требуется запускать при использовании сцены в After Effects или Premiere Pro.

Экспорт с помощью динамической ссылки

Экспорт с помощью динамической ссылки
Узнайте, как экспортировать проекты с использованием динамической ссылки

Экспорт в файловый формат для импорта в другие приложения

Можно выполнять экспорт непосредственно в формат фильма (H.264) с помощью Adobe Media Encoder или в набор изображений PNG и файл WAV. Экспортируемый файл фильма можно сразу воспроизвести или, аналогично файлам PNG/WAV, импортировать в другие приложения для дальнейшего использования. При использовании с After Effects и Premiere Pro отдельный файл фильма проще импортировать, а также управлять им, чем набором PNG-изображений и отдельным звуковым файлом. Кадр сцены также можно по выбору экспортировать в формате PNG.

Экспорт сцены в качестве файла фильма с помощью Adobe Media Encoder

Можно непосредственно экспортировать сцену из Character Animator в формат фильма с помощью Adobe Media Encoder. Форматом фильма по умолчанию является H.264.

  1. Выберите или откройте сцену, затем настройте длительность сцены (на панели «Свойства») для ограничения экспортируемых файлов.

    Длительность сцены указывается более светлым фоном на панели «Таймлайн».

  2. Выберите пункт Файл > Экспорт > Видео через Adobe Media Encoder и укажите расположение и имя файла.

    Adobe Media Encoder запускается и добавляет запись для сцены в очередь. Первый запуск Adobe Media Encoder может занять несколько секунд. Кроме того, окно Adobe Media Encoder может не переместиться на передний план, поэтому может потребоваться переключить его вручную.

  3. В Adobe Media Encoder отрегулируйте все настройки для элемента в очереди, затем нажмите кнопку «Запустить очередь» (зеленая кнопка воспроизведения).

    Форматом экспорта по умолчанию является H.264 с шаблоном настроек «Соответствие источнику — высокая скорость», но при необходимости можно внести изменения.

    Готовый файл фильма можно сразу воспроизвести или импортировать в другое приложение для дальнейшего использования.

Экспорт сцены в качестве набора изображений PNG и файла WAV

  1. Выберите или откройте сцену.

  2. Выберите Файл > Экспорт > Набор изображений PNG и WAV (Cmd+Opt+M/Ctrl+Alt+M), затем укажите место и базовое имя файла для записываемой сцены. Базовым именем файла по умолчанию является имя сцены.

    В операционной системе Mac: если вы указали имя существующей папки, программа предложит заменить его. В Windows, если указать существующее имя вложенной папки, просто будет осуществлен переход в эту вложенную папку. 

    Во время экспорта входы камеры и микрофона отключаются.

    Для вас будет создана вложенная папка на основе указанного имени, куда будут помещены файлы набора изображений PNG и звуковой файл WAV (48 кГц). Вложенная папка открывается автоматически.Файл .xml создается рядом свложенной папкойи может использоваться для импорта содержимого вложенной папки в приложения, которые могут импортировать такие файлы.

Экспорт кадра сцены

Текущее содержимое кадра сцены на панели Сцена можно экспортировать в PNG-файл изображения.
Чтобы экспортировать текущий кадр сцены, выберите Файл > Экспорт > Кадр (Command+Option+S/Ctrl+Alt+S). Можно указать местоположение и имядляPNG-файла.

Примечание.

Обратите внимание, что цвет фона панели Сцена не сохранен и PNG-файл будет иметь прозрачный фон. Кроме того, в файле не появятся сетки марионеток (если они отображались).

Импорт экспортированной сцены в другие приложения

Импорт сцены в After Effects

PNG-файл и WAV-файл необходимо вручную импортировать в After Effects из Character Animator. При импорте эпизода PNG видеоряда интерпретируется в соответствии с частотой кадров сцены Character Animator.

Импорт сцены в Premiere Pro

Выполните импорт экспортированного файла .xml на панель «Проект». Создается эпизод из набора изображений PNG и файла WAV.

Импорт сцены в Adobe Media Encoder

Добавьте экспортированный файл .xml на панель «Очередь», затем настройте параметры формата и выходной файл.

Примечание.

Можно также настроить папку отслеживания, которая будет автоматически кодировать набор изображений PNG и файл WAV для экспортированного файла .xml в формат фильма или статического изображения.

Экспорт марионетки и предоставление к ней общего доступа для других пользователей

Если необходимо отправить марионетку другим пользователям Character Animator или создать архив структуры марионетки для повторного использования в других проектах, создайте марионетку с общим доступом, отдельный файл со всеми необходимыми графическими объектами.

Порядок предоставления общего доступа к марионетке:

  1. Выберите марионетку на панели «Проект» или откройте марионетку (на панели «Проект») на панели «Проект».
  2. Выберите Файл > Экспорт > Марионетка, затем введите имя файла .puppet или щелкните правой кнопкой мыши марионетку на панели Проект и выберите команду Экспорт марионетки.
  3. Отправьте данный файл .puppet другим пользователям посредствомсовместно используемойссылки илидругим способом.
  4. Чтобы открыть общую марионетку, выполните импорт файла .puppet в меню Файл > Импорт или посредством перетаскивания файла на панель «Проект».

Примечание. Марионетки с общим доступом являются независимыми и содержат связанные с ними графические объекты. При необходимости можно изменить ссылку в марионетке и указать общий экземпляр графического объекта. Изменения параметров в марионетке при выборе на таймлайне или любые записанные дубли для дорожки марионетки не включаются в файл .puppet. Кроме того, варианты поведения для импортированной марионетки обновляются для использования версий вариантов поведения, доступных в текущем проекте. 

Потоковая передача сцены в реальном времени на другие устройства или в другие приложения

Функция «Трансляция» используется для отображения экрана на внешнем мониторе или стороннем видеоустройстве. Можно также отправлять сцены в другие приложения, например Facebook Live и YouTube, для показа анимации в режиме реального времени с помощью функции трансляции. Дополнительные сведения о потоковой передаче см. в разделе Потоковая передача сцены в реальном времени. Если вам нужны подсказки, рекомендации и обходные решения в отношении потоковой передачи, см. раздел Подсказки и рекомендации по потоковой передаче.

Синхронизация губ: экспорт дублей в After Effects

Перенеситевиземы Character Animator в After Effects и используйте их для разных персонажей, выполнив приведенные ниже действия.

  1. На панели Таймлайн правой кнопкой щелкните Дубль синхронизации губ > Копировать виземы для After Effects. Все данные о виземах копируются в буфер обмена как данные ключевого кадра «Перераспределение времени» для использования в After Effects.

  2. В After Effects настройте композицию, содержащую другие  виземы с интервалами в одну секунду и учитывающую порядок следования в контекстном меню «Виземы» в Character Animator. Когда значение времени равно 0 секунд, форма губ должна быть нейтральной (то есть, без виземы). На 1 секунде разместите визему «А-а», на секунде 2 — визему D и т. д.

  3. Теперь вложите эту композицию в другую, в которой содержится лицо персонажа. Убедитесь, что в этой композиции и в сцене проекта Character Animator используется одинаковая частота кадров.

  4. Чтобы вставить ключевые кадры перераспределения времени, которые вы скопировали на первом этапе, во вложенную композициювизем,перейдите в меню Правка > Вставить.

  5. Теперь выберите все ключевые кадры «Перераспределение времени» и измените значение интерполяции ключевого кадра на тип «Остановка».

    Совет: также можно скопировать данные в программу для работы с электронными таблицами, изменить значения по необходимости, а затем скопировать данные в буфер обмена системы для вставки в After Effects.

Экспорт сцены в формат видео с альфа-каналом

Если требуется экспортировать сцены в файл видео с альфа-каналом, чтобы прозрачные или полупрозрачные области сцены могли показывать фон при добавлении в другой видеоматериал в After Effects или другие приложения, данную сцену можно отправить в Adobe Media Encoder с помощью отдельной команды меню.

  • Чтобы экспортировать сцену в формат видео с альфа-каналом, выделите сцену, а затем выберите Файл > Экспорт > Видео с альфа-каналом через Adobe Media Encoder

Данная сцена добавляется в очередь Adobe Media Encoderqueue,и настраивается на использование формата QuickTime с шаблоном настроек «GoPro CineForm RGB, 12 бит с альфа-каналом».

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет