Проект Character Animator — это набор марионеток, сцен и сопутствующих элементов (например, файлов графических объектов и звуковых файлов). Можно создавать отдельные проекты для организации соответствующей работы, например для эпизода мультфильма или для конкретного клиента. Каждый проект хранится на диске в отдельной папке.

Создание и открытие проектов

Проект по умолчанию «Проект Character Animator» располагается в папке пользователя Documents/Adobe/Character Animator/Preview (Mac) или Documents\Adobe\Character Animator\Preview (Win). В любое время можно переключаться на другой проект. При запуске Character Animator программа открывает проект, который был закрыт последним, чтобы можно было продолжить работу над ним. Если текущий проект найти не удается, программа открывает или создает проект по умолчанию.

Создание проекта

Выберите Файл > Создать проект. Укажите местоположение и название проекта и нажмите кнопку Сохранить. Будет создана папка проекта с файлом проекта по умолчанию (файл .chproj), причем обоим элементам будет присвоено имя, заданное проекту.

Примечание.

По мере работы в проектом Character Animator постоянно создает и обновляет файлы в папке проекта на диске. Избегайте создания проектов и работы с проектами, файлы которых расположены в папке, для которой выполняется синхронизация или резервное копирование.

Открытие проекта

Выберите Файл > Открыть проект (Ctrl+O), выберите проект (.chproj), затем нажмите Открыть.

Открытие последнего проекта

Выберите проект в меню Файл > Открыть последний проект. Текущий проект отображается в списке первым.

Нахождение текущего проекта на диске

Чтобы показать и выбрать папку текущего проекта на диске, выберите Файл > Показать проект в Проводнике (Windows) или Файл > Показать проект в Finder (Mac OS).

Импорт содержимого другого проекта

Можно импортировать содержимое другого проекта и повторного использовать его сцены и марионетки в текущем проекте.

Порядок импорта содержимого проекта:

  • Выберите Файл > Импорт, затем выберите.файл chproj в папке проекта.

На панели Проект создается новая папка, и в эту папку помещается копия содержимого проекта.

Если исходные медиафайлы (графические объекты и звук) изначально были в папке Ch Media этого импортированного проекта (или в одной из вложенных папок) на диске, копии этих файлов добавляются в папку Ch Media текущего проекта. Эти файлы добавляются в папку Gathered Media.

Если исходные файлы существуют за пределами папки проекта, импортированные элементы ссылаются на их текущее положение вместо создания копии.

Поддерживаемые форматы файлов

Поддержка формата JPEG для марионеток и циклов

  • Один файл JPEG (*.jpg или *.jpeg) можно импортировать как однослойную марионетку (щелкните Файл > Импорт). 
  • Наборы изображений JPEG можно импортировать как циклы (щелкните Файл > Импортировать цикл).

Поддержка форматов EPS и SVG для графических объектов марионеток

В Character Animator поддерживаются графические объекты марионеток в форматах EPS (.eps) и SVG (.svg или .svgz). Поскольку это векторные форматы, к ним могут быть применены функция Рендеринг в качестве вектора и поведение «Покачивание».

Примечание.

Старые версии форматов файлов EPS и SVG не всегда могут сохранить полную иерархию уровней, поэтому некоторые детали могут отображаться на панели «Марионетка» сплющенными.

Растеризация объектов Illustrator (векторной графики)

Для контроля максимального качества векторной графики при ее растеризации служит свойство Разрешение из раздела Марионетка панели Свойства. По умолчанию задано значение 200 %. Его можно увеличить до 400 %. Уменьшите это значение до разрешения черновика (50 %) или низкого разрешения (100 %), если необходимо уменьшить изображение и освободить память.

Примечание.

Сцены отправляемые в After Effects, Premiere Pro или Adobe Media Encoder посредством Dynamic Link, растеризуются. Если в этих приложениях потребуется увеличить видеоряд, используйте больший размер сцены в Character Animator, чтобы сохранить детализацию.

Использование содержимого Adobe Animate CC (.fla)

Используйте графический объект из документа Adobe Animate CC (.fla) в Character Animator, экспортировав графический объект в формат SVG.

Примечание.

Будет экспортирован только текущий кадр сцены Adobe Animate.

Чтобы экспортировать графический объект Adobe Animate в формате SVG для использования в Character Animator, выполните указанные ниже действия.

  1. Откройте сцену в документе Adobe Animate.

  2. Выберите: Файл > Параметры публикации.

  3. Задайте выходной формат как SVG-изображение, выходное имя как имя нужного каталога и имя для файла .svg, а также любые другие нужные настройки.

  4. Нажмите «Опубликовать».

    Затем опубликованный файл .svg можно импортировать в Character Animator.

Организация элементов проекта

В текущем проекте можно изменять порядок элементов проекта на панели «Проект» в различных папках в соответствии со своими потребностями. 

На панели «Проект» можно сортировать элементы по имени или типу. Нажмите заголовок столбца для изменения направления сортировки.

Добавление папки

Чтобы добавить папку, выберите Файл > Создать папку, введите имя для папки, затем нажмите клавишу Enter или нажмите вне текстового поля.

Новая папка создается на том же уровне, что и самый внешний выбранный элемент проекта, или внутри выбранной папки.

Чтобы дублировать графический объект, марионетку и аудио на панели Проект, выберите элемент, который необходимо дублировать, и выберите Правка > Дублировать.

Удаление папки

Чтобы удалить папку, выберите ее, затем выберите Правка > Удалить (клавиша Delete или Backspace).

Перемещение элементов между папками

Чтобы перемещать элементы между папками, выберите элементы, затем перетащите их в другую папку.

Переименование элемента проекта

Чтобы переименовать элемент проекта (марионетку, сцену, папку и так далее), выберите его и нажмите клавишу Enter. Чтобы сохранить изменения, введите новое имя и нажмите клавишу Enter либо щелкните за пределами текстового поля. Вместо этого нажмите клавишу Esc, чтобы отменить изменения.

Примечание.

При перетаскивании элемента в папку, где содержится другой элемент с таким же именем, перетаскиваемый элемент следует переименовать. Переименование элемента таким образом, чтобы его имя совпадало с именем существующего элемента в той же папке, запрещено — рядом с текстовым полем появляется красный значок «x». Наведите указатель на значок «x», чтобы отобразить сообщение об ошибке.

Удаление элемента

Чтобы удалить элемент, выберите его, затем нажмите клавишу Delete или Backspace или выберите Правка > Удалить.

Поиск импортированных файлов на диске

Чтобы найти импортированные файлы на диске, щелкните правой кнопкой мыши марионетку, графический объект или элемент аудио на панели «Проект». Затем выберите команду Показать в Finder (Mac) /Проводнике (Windows) в контекстном меню. Для марионеток появляется файл графического объекта для самого нижнего слоя.

Копирование импортированных файлов графического объекта или звуковых файлов в проект

Для сбора копий импортированных файлов графических объектов и звуковых файлов в папку проекта для более простого предоставления общего доступа к проекту выберите Файл > Копировать медиафайлы в папку проекта. Файлы копируются во вложенную папку Gathered Media в папке проекта Ch Media. Файлы в исходных местах не удаляются.

Отмена, повтор и история

В программе Character Animator предоставляется неограниченное число операций отмены и повтора действий, даже действия из предыдущих сеансов работы в Character Animator. Изменения проекта Character Animator сохраняются автоматически.

Отмена и повтор изменений

Чтобы отменить или повторить изменения, выполните одно из следующих действий:

  • Выберите Правка > Отменить (Cmd/Ctrl+Z) или Повторить (Shift+Cmd/Ctrl+Z).
  • Выберите действие на панели «История» (Окно > История).

Удаление истории отмены операций

Чтобы удалить историю отмены операций, выберите Файл > Очистить историю, затем нажмите Очистить историю.

Использование закладок на промежуточное состояние

Закладки на промежуточное состояние используются для запоминания определенного состояния проекта. Такие маркеры создаются в истории проекта и вызываются для восстановления нужного состояния проекта. Закладки позволяют отслеживать различные вариации проекта в рамках одного и того же проекта.

Примечание.

Невозможно отменить создание, переименование или удалениезакладки, так как это влияет на историю проекта. Кроме того, при очистке истории (команда меню Файл > Очистить историю) удаляются история и все закладки проекта.

Использование закладок на промежуточное состояние

  1. Чтобы создать новую закладку на текущее состояние, в левом нижнем углу панели нажмите кнопку Новая закладка на промежуточное состояние или выберите Файл > Новая закладка на промежуточное состояние.

    Новая закладка появляется в верхней части панели История со сплошным значком закладки. Соответствующее промежуточное состояние появляется в нижней части со значком закладки меньшего размера, который указывает на создание закладки на данное состояние. Если навести указатель мыши на закладку, отображается дата и точное время ее создания.

    Использование закладок
    Использование закладок
  2. Чтобы восстановить состояние закладки из истории проекта, щелкните закладку.

    Примечание.

    Если на панели Сцена не отображаются ожидаемые результаты, попробуйте на панели нажать кнопку Обновить сцену.

  3. Чтобы переименовать закладку, щелкните ее правой кнопкой мыши и выберите команду Переименовать или, если закладка выбрана, нажмите Return (macOS) или Enter (Windows). Измените имя, а затем нажмите Return/Enter.

  4. Чтобы удалить закладку, щелкните ее правой кнопкой мыши и выберите команду Удалить, или наведите указатель мыши на закладку, а затем нажмите кнопку x.

    Подсказка: для переименования или удаления закладки ее не нужно выбирать (и восстанавливать соответствующее состояние из истории проекта).

Автоматические закладки

При выполнении описанных ниже действий закладки создаются автоматически.

  • Если отменить несколько операций, а затем выполнить некоторую новую операцию (например, создать папку), предыдущие операции, которые можно повторить, больше не отображаются в истории отмен/повторов. Автоматическая закладка создается для предыдущего состояния проекта. В качестве ее имени берется имя последнего состояния плюс число операций, которые можно повторить. Например, «Выполнение записи + 5 повторов».
  • Если выбрать закладку на промежуточное состояние, которое не входит в текущую историю отмен/повторов,автоматическая закладка создается для предыдущего состояния проекта. В качестве ее имени берется имя последнего состояния плюс число операций, которые можно повторить (если есть). Например, «Задать масштаб 80 или 75 + 1 отмена».
  • При удалении закладки автоматическая закладка создается. Данная автоматическая закладка получает имя после удалениязакладки, а под именем автоматической закладки отображается время исходного создания и последующего удаления закладки.
  • При удалении открытии проекта автоматическая закладка создается для состояния проекта на момент его открытия.

Просмотр автоматических закладок

Установите флажок Показывать автоматические закладки в меню панели История. Снимите флажок, чтобы отобразились вручную созданные закладки

Флажок «Показывать автоматические закладки»
Флажок «Показывать автоматические закладки»

На экране автоматически созданные закладки отличаются от закладок, созданных вручную, контурными значками закладок. Самая последняя автоматическая закладка появляется в нижней части списка. Автоматически создаваемые закладки можно восстанавливать, переименовать и удалять. При переименовании автоматическая закладка становится обычной и для ее просмотра включается верхняя часть панели История.

Создание копии проекта

Можно сохранить проект под новым именем, чтобы экспериментировать с изменениями или сохранять разные версии работы.

Чтобы сохранить проект под новым именем выберите Файл > Сохранить как, затем укажите новое место и имя для проекта. Сохраненный проект содержит копии марионеток, сцен и записей, включая файлы графических объектов и звуковые файлы, которые ранее были сохранены во вложенной папке Ch Media. Программа Character Animator не копирует файлы, которых нет в папке проекта, а история очищается.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет