Действия марионеток в сцене можно захватывать во время записи. Каждая запись конкретного активированного параметра поведения марионетки называется дублем.

На таймлайне сцены (показанном на панели «Таймлайн») каждый экземпляр марионетки отображается в виде доступного для выбора элемента дорожки. При выборе элемента на панели «Свойства» показываются варианты поведения источника (основное определение) марионетки, а также переопределенные значения параметров поведения для этого конкретного экземпляра. Например, одну и ту же марионетку можно добавлять в сцену несколько раз, при этом у элемента дорожки каждой марионетки будет различное преобразование «Положение» для размещения в сцене.

У сцены есть три режима:

  • Остановить: сцена открывается в этом режиме. Варианты поведения (за исключением «Дыхание», «Слои цикла», «Физика», «Средство фиксации меток», «Преобразовать» и «Покачивание») не влияют на марионетку, пока она не будет активирована для записи. Пока не выполнена активация, для поведения в положении индикатора текущего времени используется последний записанный дубль (указатель воспроизведения). В случае приостановки никакое импортированное аудио, включая аудио в дублях,не воспроизводится. Вы можете отрепетировать варианты поведения в этом режиме — запись не осуществляется.
  • Воспроизведение: в этом режиме воспроизводятся дубли и звук. Индикатор текущего времени перемещается во времени. Изменения значений параметров поведения не влияют на результаты, если дубль с тем же параметром существует в заданное время; если данных дублей не существует, значение параметра используется, но не записывается.
  • Запись: во время записи значения для активированных параметров поведения записываются как дубли для каждого параметра и все существующие дубли воспроизводятся. Также возможна запись с меньшей скоростью для более точногозахвата действий. Воспроизведение всегда осуществляется на нормальной скорости.

Для этих режимов существуют элементы управления переносом. Используя эти режимы, можно выполнять простую запись действий персонажа, воспроизведение, а также просмотр записанных дублей и повторную запись действий персонажа с целью исправления ошибок. Это позволяет записывать различные входные сигналы и несколько дублей слоев с несколькими дорожками.

Кнопка Перейти к началу позволяет перенести текущее время к началу сцены (в режиме остановки) или началу воспроизведения (в режиме воспроизведения). Кнопки Переход к предыдущему кадру и Перейти к следующему кадру позволяют перейти к предыдущему или следующему во времени кадру (в режиме остановки).

Если открыть рабочие среды Оснастка или Поток, элементы управления переносом не отображаются на панели в качестве элементов управления по умолчанию. Чтобы отобразить элементы управления переносом, выберите Всегда показывать элементы управления воспроизведением и записью в меню рабочей среды Оснастка или Поток.

 

Примечание.

Аппаратура для ввода и вывода звука должна иметь одинаковую частоту дискретизации.

Запись дублей

С помощью записи дубля делается движение вашей головы, чтобы управлять лицом марионетки, перетаскивание руки персонажа, чтобы помахать рукой, и другие действия для захвата выполнения. Эти действия выполняются в рабочей среде Запись.

Обратный отсчет до записи

Перед началом записи по умолчанию запускается обратный отсчет трех секунд. За это время необходимо подготовиться к записи или задать необходимую позу марионетки. Чтобы включить или выключить обратный отсчет, выполните следующее действие:

  • откройте панель Таймлайн и установите флажок Обратный отсчет перед записью
Обратный отсчет перед записью
Обратный отсчет перед записью

Запись действия ваших марионеток

  1. При необходимости выполните калибровку видео- и аудиовходов:

    • Чтобы управлять марионеткой по веб-камере, убедитесь, что нажата кнопка «Вход камеры» (синий значок) на панели «Камера и микрофон». Кроме того, чтобы улучшить результаты отслеживания лица, задайте позу покоя с помощью кнопки «Выбор позы покоя».
    • Чтобы записать звук во время действия, убедитесь, что нажата кнопка «Вход микрофона» (настройка по умолчанию) на панели «Камера и микрофон». Если включено, индикатор громкости звука отслеживает уровни входного аудиосигнала в диапазоне от –48 дБ до 0 дБ. Индикатор становится красным при значении 0 дБ. Если индикатор показывает сообщение «Низкий уровень звука» попробуйте увеличить уровень звука для микрофона на панели управления операционной системы или подвинуться ближе к микрофону.
  2. Чтобы активировать дорожку для записи, выберите марионетку (элемент ее дорожки или имя марионетки в заголовке дорожки на левой стороне панели).

    Выбранная/активированная марионетка позволяет ограничить запись лишь ее дорожкой. По умолчанию, если нажать дорожку марионетки или заголовок или добавить марионетку к сцене, отменяется выбор/активация других марионеток в сцене. Чтобы выбрать несколько марионеток в целях активации для записи, нажмите кнопку Cmd/Ctrl и левую кнопку мыши. Дорожка активированной марионетки отображается на красном фоне в заголовке дорожки.

  3. На панели «Свойства» включите кнопку «Активация для записи» (маленький круг рядом с именем поведения) для всех вариантов поведения, которые необходимо записать для марионетки.Такжевключите кнопки «Активация для записи» для отдельных параметров поведения, которые требуется зафиксировать в дубле.

    Активированные варианты поведения отображаются с красным кружком (похожим на небольшую кнопку записи). Если поведение активировано, его активированный параметр также отображается с красным кружком рядом с именем параметра. Значения для активированных параметров поведения будут захватываться на активированных дорожках. Можно переключаться между различными марионетками для захвата путем выбора (активации) элемента или заголовка дорожки марионетки без необходимости отмены активации поведения других марионеток.

    Если кнопка «Активация для записи» поведения затемненного красного цвета, это означает, что ни один из его параметров не активирован. Деактивированные варианты поведения не включены в следующую запись.

  4. (Дополнительно) Чтобы захватить подробные движения поведения «Перетаскивание» или других вариантов поведения, задайте скорость записи меньше обычной скорости. Например, выберите половинную скорость (0,5x).

    Запись происходит медленнее, а воспроизведение осуществляется с нормальной скоростью.

    Примечание.

    Отключите параметр «Вход микрофона» во избежание искажений голоса.

  5. Установите время начала записи.

    Можно начать в начале сцены, нажав кнопку Перейти к началу, включить воспроизведение, а затем остановить его в заданное время. Также можно нажать или выполнить прокрутку линейки времени в верхней части панели «Таймлайн».

    Примечание.

    Для «входа в запись» во время воспроизведения можно просто начать запись (описано далее) без предварительной приостановки.

  6. Начните запись, нажав кнопку «Запись» на панели «Сцена».

    Примечание.

    В случае повторной записи сцены, если не требуется записывать предыдущие звуковые дубли, используйте наушники во время записи.

  7. Выполните действия с помощью ввода с веб-камеры, микрофона, клавиатуры и мыши, и внесите изменения в значения активированных параметров поведения.

    Примечание.

    Если для поведения активированы параметры «Вход камеры» и «Аудиовход», но соответствующие кнопки «Вход камеры» и «Вход микрофона» (на панели «Камера и микрофон») не нажаты, для этих параметров дубли не захватываются. Аналогичным образом, если активировать параметры «Ввод с помощью мыши» и «Ввод с клавиатуры», но не щелкать мышью на панели «Сцена» или не нажимать клавишу, дубли не будут захвачены.

  8. Остановите запись, нажав «Запись» еще раз или нажав «Остановить».

     

Записанный дубль сохраняется в папке Recordings (Записи) на диске (в папке Ch Media, вложенной в папку текущего проекта). Дубль также импортируется на панель «Проект» в папке Recordings и добавляется в сцену. Если вход микрофона записывался, WAV-файл этой записи отображается как элемент аудиодорожки.

Дорожка марионетки по умолчанию свернута. Под строкой элемента дорожки марионетки появляется строка сводки дубля более светлых цветов, указывающая на наличие записанных дублей.

Примечание.

Чтобы выбрать камеру, выберите ее в меню панели «Камера и микрофон». Доступные источники камер перечислены по именам.

  • Если нет доступных совместимых камер, в меню панели отображается сообщение Камера не обнаружена.
  • Если есть задержка получения первого кадра видео, в меню панели отображается сообщение Ожидание камеры.
  • Если камеру необходимо выбрать в меню панели или нет доступных камер, в меню панели отображается сообщение Камера не выбрана.
  • Если во время запуска Character Animator камера используется другим приложением, отображается сообщение Выбрано камера недоступна.
  • Если выбранная камера больше не доступна, например, если она отключена, отображается сообщение Камера отключена.

 

Если кнопка «Вход камеры» по какой-то причине отключается, при ее нажатии (включении) предпринимается попытка снова получить видео от выбранной камеры.

Активация марионетки для записи

У каждой дорожки марионетки есть собственная кнопка Активация для записи, которой можно управлять отдельно от выбранной дорожки марионетки. 

Активация дорожки марионетки для записи
Активация дорожки марионетки для записи

Если нажать на элементы дорожки марионетки или заголовки дорожки, по-прежнему включается активация для данной марионетки. Если отменить выбор дорожки марионетки, нажав за ее пределами (например, изменив дубль или строку визем на другой дорожке марионетки), ранее активированные дорожки марионеток по-прежнему останутся активированными.
Можно активировать несколько дорожек марионеток, удерживая нажатой клавишу Shift или Cmd/Ctrl и одновременно щелкнув кнопки «Активация для записи» для этих дорожек. Чтобы дорожки марионеток не деактивировались, выбирайте только дубли или виземы на дорожках или аудиодорожках марионетки.

Выбор камеры

Чтобы выбрать камеру, выберите ее в меню панели Камера и микрофон. Доступные источники камер перечислены по именам.

Выбор камеры из доступных вариантов
Выбор камеры из доступных вариантов

Если нет доступных совместимых камер, в меню панели отображается сообщение Камера не обнаружена. В случае проблем с входом камеры на панели отображается одна из следующих ошибок:

  • Если есть задержка получения первого кадра видео, отображается сообщение об ошибке Ожидание камеры.
  • Если камеру необходимо выбрать в меню панели или нет доступных камер, отображается сообщение Камера не выбрана.
  • Если во время запуска Character Animator камера используется другим приложением, отображается сообщение Выбранокамера недоступна.
  • Если выбранная камера больше не доступна, например, если она отключена, отображается сообщение об ошибке Камера отключена.

Если кнопка «Вход камеры» по какой-то причине отключается, при ее нажатии (включении) предпринимается попытка снова получить видео от выбранной камеры.

Скорость записи

Чтобы захватить более детальные движения, процесс записи и выполнения можно осуществлять на скорости ниже частоты кадров сцены.

Чтобы изменить скорость записи для сцены, выполните следующие действия.

  • Откройте сцену на панели «Сцена», а затем измените параметр «Скорость записи» в нижней части панели.

Указанные параметры сцены будут использоваться для следующей созданной сцены.

Рабочая область таймлайна

На таймлайне сцены имеется рабочая область, которую можно включить, чтобы ограничить операции определенным диапазоном кадров сцены. Данную рабочую область можно включить при необходимости и отключить, когда она не нужна.

Чтобы включить или отключить рабочую область, выполните указанные ниже действия.

  • Щелкните панель рабочей области наверху линейки времени или активируйте команду Включить рабочую область в меню Таймлайн или Контекст над панелью рабочей области.
  • При перетаскивании любой части отключенной панели рабочей области она включается.
а) Рабочая область отключена, б) рабочая область включена
а) Рабочая область отключена, б) рабочая область включена

Во включенном состоянии панель рабочей области имеет светло-серый цвет, а ее диапазон выделен в области дорожки. В отключенном состоянии панель рабочей области имеет тонкий темно-серый цвет.

Настройка рабочей области

Чтобы изменить время начала или конца рабочей области, выполните одно из следующих действий:

• перетащите левый край (начало) или правый край (конец) панели рабочей области;

• Поместитеуказатель воспроизведенияна конкретный кадр во времени, а затем выберите Задать начало рабочей области по указателю воспроизведения (Option/Alt+I) или Задать конец рабочей области по указателю воспроизведения (Option/Alt+O) в меню Таймлайн или контекстном меню панели рабочей области.

Примечание. Время начала невозможно установить после конца рабочейобласти,или наоборот.

Чтобы задать рабочую область в соответствии с выбранными дорожками или панелями дублей:

Выберите Задать рабочую область по выделению (Option/Alt+/) в меню Таймлайн или контекстном меню панели рабочей области. Рабочая область будет охватывать самые ранние и самые последние времена выбранного участка.

Чтобы сдвинуть рабочую область по времени, выполните указанные ниже действия.

Перетащите панель рабочей области за середину по горизонтали. При перетаскивании краев или середины панели рабочей области ее начало и конец привязываются к началу или концу панелей дорожек, панелей дублей и маркеров марионетки. Аналогично, при перетаскивании краев панелей дорожек, панелей дублей или маркеров марионетки они привязываются к началу или концу панели рабочей области.

Переход к началу или концу рабочей области

Чтобы перейти к началу или концу рабочей области, выполните указанные ниже действия.

  • Правой кнопкой мыши щелкните над панелью рабочей области, затем в контекстном меню выберите Перейти в начало рабочей области или Перейти в конец рабочей области.
  • Используйте комбинации клавиш Option/Alt+стрелка влево и Option/Alt+стрелка вправо.

Редактирование выбранных дублей с помощью рабочей области

Когда рабочая область включена, вы можете вносить следующие правки:

  • Для удаления сегмента выбранных дублей в рабочей области выберите Таймлайн > Очистить, чтобы выйти из зазора (нет записей в рабочей области), или Таймлайн > Удалить рябь, чтобы закрыть зазор, сдвинув выбранные дубли, изначально расположенные после рабочей области, в начало рабочей области.
а) До, б) очистить, в) удалить рябь
а) До, б) очистить, в) удалить рябь
  • Чтобы вставить зазор по времени в длительность рабочей области для выбранных дублей, выберите Таймлайн > Вставить время.
а) До, б) вставить время
а) До, б) вставить время

Команды Очистить, Удалить рябь и Вставить время также доступны в контекстном меню над панелью рабочей области.

Циклическое воспроизведение в рабочей области

Когда рабочая область включена, воспроизведение сцены автоматически зацикливается в пределах рабочей области. Воспроизведение начинается в текущеевремя,а цикл запускается, когдауказатель воспроизведениядостигает конца рабочей области. Еслиуказатель воспроизведениянаходится после рабочей области, воспроизведение не зацикливается.

Запись дублей с помощью рабочей области

Если рабочая область включена, команда Таймлайн > Записать дубль для рабочей области (Cmd/Ctrl+3) создает новый дубль. Новый дубль затрагивает продолжительность рабочей области для вооруженных вариантов поведения.Новый дубль покрывает продолжительность рабочей области для активированных параметров поведения.

Экспорт рабочей области

Когда рабочая область включена, команды экспорта сцены (Файл > Экспорт > Видео через Adobe Media Encoder и Файл > Экспорт > Набор изображений PNG и WAV) используют только заданный сегмент времени в рабочей области.

Примечание. В сценах с марионетками, в которых используются моделирования физической среды («Качание», «Столкновение», «Частицы»), по-прежнему требуется рендеринг кадров перед началом рабочей области (т. е., подготовка), чтобы экспортировать предполагаемые результаты для этих кадров в рабочей области.

Когда рабочая область отключена, эти команды экспортируют сцену с полной продолжительностью.

Примечание. Рабочая область игнорируется при перетаскивании сцены в After Effects или Premiere Pro. Длительность сцены используется в этих рабочих процессах Dynamic Link.

Обрезка сцены по рабочей области

Когда рабочая область включена, вы можете обрезать сцену только по отрезку времени в рабочей области, выбрав Таймлайн > Обрезать сцену по рабочей области или ту же команду в контекстном меню над панелью рабочей области.

Скорость воспроизведения

Настройка скорости воспроизведения позволяет просматривать более детальные движения или изменения в производительности при воспроизведении сцены на более низкой скорости. Этот элемент управления можно использовать в сочетании с управляемой скоростью записи.

Чтобы изменить скорость воспроизведения сцены, откройте сцену на панели «Сцена» и измените параметр «Скорость воспроизведения», выбрав элемент управления «Скорость воспроизведения и записи». Этот параметр находится в нижней части панели.

Если скорости воспроизведения и записи отличаются, указываются оба значения, а скорость записи выделена красным цветом. Если они совпадают, отображается только одно значение.

В отличие от других свойств сцены, но подобно скорости записи новые сцены всегда по умолчанию воспроизводятся при нормальной скорости (1.0x) вместо использовавшейся последний раз скорости воспроизведения.

Воспроизведение действия

После записи дублей воспроизведите записи, чтобы проверить свою работу.

Чтобы начать с определенного времени в сцене,

Нажмите или перетащите линейку времени (в верхней части панели «Таймлайн»). При перетаскивании также выполняется перемотка звука в сцене.

Чтобы начать воспроизведение,

нажмите кнопку «Воспроизведение» или пробел. Записанные дубли воспроизводятся, а отображаемый тайм-код обновляется соответствующим образом.

Чтобы управлять скоростью воспроизведения для сцены,

откройте сцену на панели «Сцена», затем измените настройку «Скорость воспроизведения» в элементе управления «Скорость воспроизведения и записи» в нижней части панели.

Если скорости воспроизведения и записи отличаются, указываются оба значения, а скорость записи выделена красным цветом. Если обе скорости одинаковы, отображается только одно значение.

Чтобы остановить воспроизведение,

Нажмите кнопку «Остановить» или пробел еще раз.

Курсор воспроизведения по умолчанию привязывается к границам кадра, и при увеличении масштаба на панели «Таймлайн» можно видеть продолжительность кадра, затененную светло-синим цветом (аналогично затенению в After Effects и Photoshop).

Примечание.

На панели «Сцена» отображается среднее время в длительности кадра, но звук может воспроизводиться в течение всей длительности кадра. Операции с дорожками и дублями, например запись, разделение и привязка, осуществляются на красной линии (левая грань).

Чтобы отменить привязку курсора воспроизведения к границам кадра для более точного расположения или перемотки звука, удерживайте клавишу Cmd (Mac) или Ctrl (Windows) во время перетаскивания курсора воспроизведения.

Повторное воспроизведение диапазона времени

По умолчанию при остановке воспроизведения указатель воспроизведения остается в месте остановки, однако вы можете вернуть указатель воспроизведенияко времени начала проигранного ранее отрезка, чтобы можно было воспроизвести тот же диапазон времени, нажав клавишу «Пробел». Эта возможность полезна при синхронизации визем для слова или фразы.
Чтобы вернуть указатель воспроизведения ко времени начала при остановке воспроизведения, выполните следующее действие:

  • Выберите Таймлайн > Возврат в начало при остановке на панели параметров.

Прокрутка времени с помощью клавиатуры

Для прокрутки времени в сцене можно использовать следующие комбинации клавиш.

  • PAGE UP или PAGE DOWN: прокрутка влево или вправо на одну «страницу» в видимом диапазоне времени.
  • CMD/CTRL + PAGE UP или CMD/CTRL + PAGE DOWN: прокрутка влево или вправо на меньший отрезок времени, чем одна страница.

Прокрутка содержимого панели «Таймлайн» во время воспроизведения и записи

Чтобыуказатель воспроизведения оставался видимым, содержимое панели «Таймлайн» прокручивается во время воспроизведения или записи.

Чтобы избежать прокрутки во время воспроизведения и записи, выполните следующее действие:

  • Отключите параметр Таймлайн > Прокрутка во время произведения.

Дубли удержания

Если нужно расширить записанное действие позы персонажа (дубли) в текущий момент времени, создайте дубль удержания. Дубли удержания дублируют значения выбранных дублей в положении указателя воспроизведения, позволяя расширить их до требуемой длительности и дополнительно смешать их с раннее записанными дублями.  Чтобы создать дубль удержания, выполните следующие действия:

  1. Переместите указатель воспроизведения к кадру с изображением позы, которую нужно удержать.

    Подсказка: деактивируйте дорожку марионетки, чтобы увидеть результат записанных дублей.

  2. Выберите один или несколько дублей, значения которых в текущий момент необходимо удержать.

  3. Выберите Таймлайн > Создать дубль удержания (Command+Shift+Option+D/Ctrl+Shift+Alt+D).

Над каждым выбранным дублем есть новый односекундный дубль удержания. Можно изменять длительность и перемещать дубли удержания нужным образом и даже смешивать их в дублях под ними для более плавных переходов. Деления вдоль нижнего края каждого дубля удержания, указывают, что это постоянное значение, расширяющееся до более ранних и более поздних моментов времени.

Примечание.

Дубли удержания для дублей с синхронизацией губ или триггерами можно расширить от любого конца, но начало строки визем или триггеров не расширяются автоматически.  По-прежнему их можно перетаскивать вручную.

Отображение или скрытие записанных дублей для марионетки

Чтобы отобразить или скрыть записи марионетки, нажмите треугольник раскрытия меню рядом с именем марионетки в заголовке дорожки на панели «Таймлайн». Каждый записанный параметр поведения отображается в виде отдельной строки проекции, на которой представлены краткие сведения о дублях на ней. Если строки проекции не отображаются в элементе дорожки марионетки, убедитесь, что по крайней мере один параметр поведения был активирован для записи, и что эта дорожка была выбрана/активирована перед записью.

Можно изменить все дубли для параметра из соответствующей строки проекции, или внести более точные изменения в определенные дубли путем нажатия треугольника раскрытия меню для строки проекции.

Примечание.

Если для параметра записано несколько дублей, в первую очередь будет использована самая верхняя строка дубля, и информация из любой строки дубля под ней будет игнорироваться (и отображаться без цвета с затенением). Точки перехода между дублями для параметра указываются вертикальной линией на строке проекции параметра.

Для запуска с начала сцены

Нажмите кнопку «Перейти к началу» или клавишу Home.

Воспроизведения: повторно используемые и запускаемые записи

Воспроизведения позволяют запускать записанные дубли для марионетки в реальном времени или повторной записи. Используйте это, чтобы сделать созданиезаписии воспроизведение более легким и эффективным. Информацию о воспроизведении см. в разделе Воспроизведения: повторно используемые и запускаемые записи.

Запись поведения в группах дублей

Группы дублейвключитьсовмещать несколько действий для отдельной метки, не влияя на действия других перетаскиваемых меток. Поведение «Перетаскивание» позволяет записывать каждую перетаскиваемую метку, которая перемещается, в качестве отдельной группы дублей. В случае группировки дублей перетаскивания по перетаскиваемым меткам вам не требуется использовать несколько видов поведения «Перетаскивание» для захвата нескольких перетаскиваемых меток. На панели «Таймлайн» каждый дубль перетаскивания, сгруппированный по имени метки, показан как «Метка (имя метки)».

Пошаговая запись для захвата дублей из одного или двух кадров

Вы можете захватить текущую позу персонажа, в частности параметры поведения, активированные для записи, как дубли из одного или двух кадров для соответствующей анимации (из одного или двух кадров). Например, если для параметра «После перемещения» поведения «Перетаскивание» задано значение «Удерживание на месте», можно задать позу для рук персонажа, записать однокадровый дубль, сменить позу, записать другой однокадровый дубль и т. д. Как для любого другого записанного дубля его длительность можно увеличить позднее, например, чтобы персонаж удерживал позу дольше.

Для записи дублей из одного или двух кадров для активированных параметров, выберите «Таймлайн» > «Запись дубля с 1 кадром» (Cmd/Ctrl+1) или «Запись дубля с 2 кадрами» (Cmd/Ctrl+2).

Можно накладывать действия в начале и конце дубля для плавного перехода между существующими дублями или между дублем и внешним видом по умолчанию. Также можно настраивать длительность наложения или быстро настраивать наложение дубля с длительностью по умолчанию. Дополнительные сведения см. в разделе Наложение действий.

Настройка синхронизации и изменение порядка содержимого сцены

Можно изменить синхронизацию и порядок марионеток, записанных дублей и звука для точной настройки своей работы. Марионетки и звук отображаются как элементы дорожки (более крупные строки), а записанные дубли отображаются как более короткие строки под элементами дорожки марионетки. Можно также увеличивать или уменьшать масштаб во времени для более удобного доступа к строкам дорожки или временного обзора сцены.

При увеличении длительности кадра на шкале времени на панели «Таймлайн» горизонтальный центр кадра обозначается пунктирной линией, чтобы показать точное время создания элемента дорожки или дубля.

Перетащите ползунок масштабирования таймлайна или нажмите кнопку «Увеличение таймлайна», «Уменьшение таймлайна» или «Масштабирование таймлайна для размещения по всей сцене» в правом нижнем углу панели «Таймлайн». Для каждой кнопки имеется комбинация клавиш клавиатуры (–, = и \).

Прокрутка времени при увеличении масштаба

Используйте горизонтальную полосу прокрутки под прокручиваемой областью панели «Таймлайн» или горизонтальное смахивание на трекпаде.

Прокрутка группы марионеток и аудиодорожек

Используйте вертикальную полосу прокрутки или смахните вертикально на трекпаде.

Выбор или отмена выбора элементов дорожки

  • Нажмите название дорожки (для марионетки) или строку элемента дорожки для выбора. 
    Выберите элемент дорожки для марионетки для изменения значений параметров поведения для экземпляра марионетки в сцене, переопределяя значения в исходном (основном) определении марионетки. 
    При выборе дорожки марионетки марионетка автоматически активируется для записи.
  • Чтобы переключить выбор марионетки, удерживая клавишу Shift или Cmd/Ctrl, нажмите элемент дорожки или имя дорожки марионетки (заголовок дорожки в левой части панели). Переключение выбора позволяет выбрать несколько марионеток одновременно.
  • Чтобы отменить все содержимое, нажмите вне любой строки элементов дорожки.

Иерархическое выделение

Элементы выбранной дорожки выделяются на панели «Таймлайн» сплошной синей заливкой. Если для марионетки выбрана строка дублей или проекции (непосредственно или после записи дублей), строка окрашивается в сплошной синий цвет. Дорожка марионетки выделяется синим контуром, обозначающим, что в иерархии марионетки выбраны какие-либо элементы. Благодаря этому иерархическому выделению параметры поведения марионетки также становятся видимыми на панели «Свойства» и изменяются сразу после настройки дублей.

Выбор или отмена выбора дублей

  • Нажмите дубль для выбора его и других дублей, захваченных во время одного сеанса записи. Эти дубли связаны по умолчанию и их можно одновременно перетаскивать и обрезать.
  • Удерживая клавишу Shift или Cmd/Ctrl, нажмите дубль для переключения выбора между связанными дублями.
Если одновременно записываются несколько параметров, их дубли связаны. По умолчанию, при выборе одного дубля связанные дубли не выбираются и не изменяются, но можно управлять всеми связанными дублями одновременно, выбрав команду «Сопряженный выбор» в меню «Таймлайн».
Если выбран дубль, соответствующий раздел строки сводки (вместе с нижним элементом дорожки марионетки) выделяется синим цветом, что позволяет получить информацию, когда дорожка свернута и не видны строки дублей.

Разделение элементов и дублей дорожки

Уменьшите элемент или дубль дорожки марионетки или звука, разделив его по месту курсора воспроизведения (текущего времени). Эта операция фактически дублирует выбор и обрезает исходную и новую строки.

Порядок разделения элементов и дублей дорожек:

  1. Выберите элементы и поместите курсор воспроизведения на время разделения.
  2. Выберите Правка > Разделить (Shift+Cmd/Ctrl+D).

Дублирование элементов и дублей дорожки

Создайте копию элемента или дубля дорожки для последующего использования.

Порядок дублирования элемента или дублей дорожки:

  1. Выберите элементы или дубли.
  2. Выберите Правка > Дублировать (Cmd/Ctrl+D).

Настройка синхронизации элемента или дубля дорожки

  • Чтобы сместить его по времени, перетащите среднюю часть данной строки по горизонтали.
  • Чтобы обрезать время начала или окончания, перетащите левый или правый конец строки.

Расширение строки дубля с любого из концов сохраняет записанные значения дубля до исходной точки входа и после исходной точки выхода дубля.

Примечание.

Если разделить дубль, расширение точки разделения просто открывает обрезанную часть.

Переопределение привязки к краям для более точного управления

Удерживайте клавишу Cmd/Ctrl при перетаскивании строки элемента или кадра дорожки.

Изменение порядка дорожки

Чтобы изменить порядок дорожки, например изменить порядок рендеринга марионетки, выберите дорожку, затем выберите Таймлайн > Упорядочить > Переместить вверх или Переместить вниз или нажмите клавиши Cmd+стрелка вверх/вниз или Ctrl+стрелка вверх/вниз.

Удаление элемента дорожки

Выберите элемент дорожки, затем выберите Правка > Удалить или нажмите клавишу Delete или Backspace. Удаление элемента аудиодорожки не приводит к удалению самой дорожки.

Перемещение дублей

Для перемещения вверх или вниз выбранных дублей с тем же параметром используются команды Таймлайн > «Вниз» или «Вверх» . Данные команды можно по-прежнему использовать для выбранных дорожек.

Удаление дубля

Выберите строку дубля и нажмите клавишу Delete или выберите Правка > Удалить.

  • Чтобы удалить дубли марионетки, выберите все дубли и нажмите клавишу Delete.
  • Чтобы удалить дорожку марионетки, нажмите клавишу Delete после удаления кадров и выделения дорожки марионетки.

Повторное использование дублей между марионетками и проектами

Дубли всех типов можно вырезать, копировать и вставлять между марионетками и проектами. Чтобы повторно использовать дубль, выполните следующие действия:

  1. Выберите дубли для повторного использования.

    • Чтобы удалить их из марионетки, выберите Правка > Вырезать (Command/Ctrl+X). 
    • Чтобы сохранить исходные дубли и дублировать их, выберите Правка > Копировать (Command/Ctrl+C).
  2. Выберите другой элемент дорожки марионетки на панели Таймлайн в текущем или другом проекте. Переместите указатель воспроизведения туда, где должен начинаться дубль, и выберите Правка > Вставить (Command/Ctrl+V).

Выбранный дубль вставляется относительно указателя воспроизведения. Любое поведение, связанное со скопированными дублями, применяется к целевой марионетке, если у нее нет таких вариантов поведения. Если у марионетки есть несколько вариантов поведения (для данного дубля), то каждый из них получает копию дубля. Также можно копировать несколько дублей. Они вставляются в том порядке, в котором были выбраны.

Дополнительные сведения о переносе из Character Animator визем в After Effects для использования в других персонажах, см. в разделе Синхронизация губ: экспорт дублей в After Effects.

Примечание.

  • При вставке поведения, которое по умолчанию скрыто, но не скрыто во время копирования (слои цикла), новый экземпляр вставляется скрытым.
  • Примененные варианты поведения всегда добавляются на верхний уровень марионетки, даже если дубль был скопирован для поведения, расположенного ниже в структуре марионетки.
  • Во вставленных вариантах поведения не сохраняются пользовательские имена вариантов поведения.
  • Скопированные дубли для нескольких экземпляров одного поведения (два экземпляра лица в разных местах в структуре марионетки) вставляются в отдельный экземпляр поведения.

Наложение действий

Можно осуществлять наложение действий в начале и конце дубля для плавного перехода между внешним видом марионетки по умолчанию и ее записанными действиями. Также можно настраивать длительность наложения или быстро задавать длительность по умолчанию.

Наложение параметров поведения дубля

1. Разверните строку марионетки и проекции, которая содержит накладываемый дубль. 

Можно осуществлять наложение следующих дублей:

  • Числовые параметры, например «Сила ветра» для поведения «Качание» или «Масштаб» для поведения «Преобразовать»
  • Параметры угла, например «Поворот» для поведения «Преобразовать»
  • Параметр «Вход камеры» для поведения «Лицо»
  • Параметр «Сенсорный ввод и ввод с помощью мыши» для поведения «Перетаскивание»

2. Выполните одно из следующих действий:

  • Для использования собственной длительности наложения перетащите небольшой квадрат в один из верхних углов внутри строки дубля; курсор изменяется на палец со стрелками с обеих сторон при наведении на квадрат. Чем дальше курсор от края строки, тем точнее можно усиливать или ослаблять записанное действие.
  • Чтобы использовать длительность наложения по умолчанию (полсекунды), выберите строку проекции или дубля, затем выберите подменю Таймлайн > Наложение дублей. Можно накладывать только входящую (Наложение на входе), исходящую (Наложение на выходе) или обе стороны (Наложение на входе и выходе) дубля. Можно дальше настраивать длительность, перетаскивая небольшие квадраты.
  • Для циклического просмотра доступных вариантов длительности по умолчанию выберите Таймлайн > Наложение дублей > Следующее наложение (Cmd/Ctrl+B) или Предыдущее наложение (Shift+Cmd/Ctrl+B).

При обрезке дубля входящая (левая сторона) и исходящая (правая сторона) длительности наложения не изменяются, пока длительность строки дубля не станет меньше длительностей наложения.

Примечание.

Команды Таймлайн > Наложение дублейзадают длительность по умолчанию для входящих и исходящих наложений, но не задают переход для кривой конкретного типа. Настройка по умолчанию: Увеличение и уменьшение замедления.

Порядок задания переходной кривой наложения

1. Правой кнопкой мыши щелкните над входящим наложением, а затем выберите Смешение на кривой, над исходящим наложением и выберите Смешение вне кривой или посередине строки дубля и выберите Наложение.

2. Выберите тип перехода в подменю: Нет ослабления (линейная кривая), Увеличение замедления (увеличение замедления наложения), Уменьшение замедления (уменьшение замедления наложения) или Увеличение и уменьшение замедления (замедление обоих концов наложения).

Удаление наложения дубля

Выполните одно из следующих действий:

  • Выберите Таймлайн > Наложение дублей > Удаление наложения.
  • Перетащите небольшой квадрат в сторону одного из краев строки дубля.

Маркеры

Маркеры позволяют добавлять пометки в определенные изменения (например, когда персонаж смотрит влево) на таймлайне сцены. При достижении маркеров остановки можно остановить воспроизведение. При этом можно в любое время переключаться между обычным информационным маркером и маркером остановки.

Чтобы создать маркер, переместите указатель воспроизведения к нужному моменту времени, а затем выполните одно из следующих действий:

  • Для обычного маркера выберите Таймлайн > Добавить маркер (Ctrl + 8 на компьютере Mac, доп. * в ОС Windows).
  • Для маркера остановки выберите Таймлайн > Добавить маркер остановки (Ctrl + Shift + 8 на компьютере Mac, Shift + доп. * в ОС Windows). Значок для маркера остановки имеет вид небольшого квадрата.

Примечание. Обычный маркер можно переключить на маркер остановки или наоборот. Чтобы переключить, правой кнопкой мыши щелкните маркер и включите или отключите флажок Остановка воспроизведения для настройки Маркер.

  • Чтобы переименовать маркер, дважды щелкните его (или нажмите клавишу Enter) и введите новое имя.
  • Для перемещения маркера в другую временную точку перетащите его по горизонтали. Маркеры можно привязывать к другим элементам на таймлайне и наоборот.
  • Чтобы удалить маркер, выберите его (для выбора нескольких элементов удерживайте нажатой клавишу Shift), а затем выберите Правка > Удалить.

Работа с маркерами

Работа с маркерами
Узнайте, как работать с маркерами

Форма аудиосигнала и изменение размера аудиодорожки

На аудиодорожке представлена форма сигнала аудиофайла, с помощью которой можно настроить синхронизацию марионеток, дублей и визем в соответствии со звуком. По умолчанию аудиодорожки в два раза шире других дорожек, но при необходимости ширину можно изменить, перетащив нижний край заголовка дорожки по вертикали.

Изменение размера аудиодорожки
Изменение размера аудиодорожки

Сворачивание вида дублей параметра

По умолчанию несколько записей для некоторого параметра создают строки дублей на отдельных строках на панели Таймлайн, однако их можно свернуть в одну полосу, чтобы уменьшить вертикальную прокрутку и по-прежнему иметь доступ к ним по отдельности.

Нажмите спиральную стрелку, чтобы свернуть или развернуть дубли параметра. Спиральная стрелка отображается, только если у параметра есть несколько дублей. 

Свернутый вид дублей
Свернутый вид дублей

Когда строки дублей свернуты в одну полосу, можно нажимать ее отдельные части, чтобы выбрать отдельные строки дублей. Если дубль выбран, информация о нем отображается на его строке, видны кривые смешения и можно регулировать маркеры смешения.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет