Марионетки — это объекты/персонажи, которые создаются из графических объектов Photoshopили Illustrator.Именно управление этими объектами выполняется для создания действий персонажа. В любое время можно переключиться в Photoshop или Illustrator, чтобы внести изменения в графический объект или добавить теги в Character Animator для управления поведением.

Марионетка имеет слои, некоторые из которых являются группами. Слои с стрелками вниз называются группами. Можно выбирать слои и изменять их свойства, собирать марионетку из деталей на панели «Проект» (включая детали от различных марионеток или файлов графических объектов), менять порядок и расположение слоев, а также скрывать или отображать слои.

Создать марионетку можно из правильно структурированного файла графического объекта. Можно также начать с пустой марионетки, а затем построить ее из фрагментов других марионеток или файлов импортированных графических объектов. Кроме того, можно дублировать марионетку, чтобы создать другую версию для дополнительной работы.

Затем можно выбрать слои и метки и назначить им теги, чтобы управлять их поведением. Сведения о назначении тегов см. в разделе Подготовка графического объекта.

Мастер персонажей на базе Adobe Sensei создает стилизованную марионетку Character Animator за секунды. Для создания марионеток используются изображения пользователя, полученные веб-камерой, и любая часть опорного графического объекта. Дополнительные сведения см. в разделе Создание марионетки с помощью мастера персонажей.

Создание марионетки в Character Animator из графического объекта

Чтобы создать марионетку из файла PSD или AI, выполните следующие действия.
  1. Выберите Файл > Импорт (Cmd/Ctrl + I).

  2. Выберите один или несколько файлов AI или PSD, после чего нажмите кнопку Открыть.

    Для каждого выбранного файла графического объекта на панели «Проект» создается марионетка (которой присваивается имя файла графического объекта).

Создание марионетки на основе шаблона

Для создания марионетки на основе файла шаблона PSD или AI воспользуйтесь ссылкой на марионетку «Хлоя» в рабочей среде «Запуск». Экземпляр файла шаблона в формате PSD или AI копируется в папку проекта, импортируется в проект и добавляется в новую сцену, а файл PSD или AI открывается в Photoshop или Illustrator для внесения изменений. После сохранения изменений в файл перейдите назад в Character Animator. Марионетка будет соответствующим образом изменена.

Создание пустой марионетки

Чтобы создать пустую марионетку, выберите пункты Марионетка > Создать пустую марионетку, а затем присвойте имя элементу марионетки.

Примечание.

К пустой марионетке не применяются какие-либо варианты поведения по умолчанию.

Дублирование марионетки

Чтобы дублировать марионетку, выделите ее, после чего выберите Правка > Дублировать (Cmd/Ctrl + D).

Дублирование элемента марионетки на панели «Проект» позволяет создать отдельную копию всех групп и слоев в марионетке. Это позволяет сохранить изменения в одной марионетке, не влияя на дублируемую марионетку.

Общий доступ к марионетке

Чтобы предоставить другим пользователям Character Animator доступ к марионетке, экспортируйте ее в качестве файла .puppet. Файл марионетки представляет собой готовый к импорту, автономный файл, который содержит все графические объекты, связанные с марионеткой.

  1. На панели «Проект» выберите или откройте марионетку.

  2. Выберите Файл > Экспорт > Марионетка и присвойте имя файлу PUPPET.

  3. Отправьте файл PUPPET другому пользователю с помощью общей ссылки или любого другого способа обмена файлами.

  4. Чтобы открыть общедоступную марионетку, импортируйте файл PUPPET, выбрав Файл > Импорт или перетащив его на панель «Проект».

    Примечание.

    • Можно повторно связать марионетку с общедоступным экземпляром графического объекта.
    • Изменения параметров марионетки, выбранной на таймлайне, или любые записанные кадры для дорожки марионетки не входят в файл PUPPET.
    • Варианты поведения, включенные в импортированную марионетку, обновляются для использования версий поведения, доступных в текущем проекте.

Циклические марионетки

Создать марионетку с циклическим выполнением можно из набора изображений (в формате PNG), а затем использовать ее с поведением «Слои цикла». Это поведение отображает каждый слой марионетки по порядку, что может быть полезно, если нужно повторить заданный образец.

Создание циклической марионетки

  1. Откройте марионетку на панели «Марионетка» и выберите Добавить цикл или Файл > Импортировать цикл

  2. Если циклическая марионетка создается с помощью параметра Добавить цикл, выберите файл из набора изображений PNG или JPEG.

    Примечание.

    Наборы изображений представляют собой файлы PNG с одним и тем же базовым именем и числовым суффиксом, например Flap001.png, Flap002.png и т. д.

    На панели «Проект» создается марионетка со слоями цикла, примененными и названными в зависимости от имени набора изображений PNG или JPEG, которая затем добавляется поверх выбранного в данный момент слоя на панели «Марионетка».

  3. Если циклическая марионетка создается с помощью параметра Импортировать цикл PNG, перетащите созданную циклическую марионетку с панели «Проект» в марионетку на панели «Марионетка».

    Примечание.

    • В циклических марионетках, созданных с помощью команды меню Импортировать цикл , параметр Запуск поведения слоев цикла задается со значением Немедленно, чтобы при добавлении марионетки на сцену автоматически воспроизводился цикл. 
    • В циклических марионетках, созданных с помощью кнопки Добавить цикл, параметр Запуск задан со значением При активации, что может оказаться полезным в том случае, если цикл будет  запускаться нажатием клавиши.
    • Все слои, кроме первого слоя, в циклической марионетке выключены по умолчанию. Кроме того, все они заданы со значением Скрыть другие в группе таким образом, что при нажатии значка слоя с изображением глазного яблока ранее отображенный слой автоматически скрывается.

Помещение марионеток на сцену

Прежде чем просматривать марионетку и управлять ею, сначала необходимо поместить ее на сцену. На сцену можно добавить несколько марионеток.

Чтобы поместить марионетку на сцену, выполните одно из следующих действий.

  • Выберите марионетку на панели «Проект», а затем щелкните Добавить в новую сцену или выберите Объект > Добавить в новую сцену.
  • Перетащите марионетку с панели «Проект» на сцену, открытую на панели «Сцена» или «Таймлайн».
  • Если панели «Сцена» и «Таймлайн» отображаются пустыми (т. е. сцены не открыты), перемещенная марионетка добавляется на новую сцену.
  • Перетащите марионетку на существующую сцену, указанную на панели «Проект».

Марионетка появится на сцене, а на панели «Таймлайн» будет отображен и выбран элемент дорожки для марионетки. С помощью этого элемента дорожки можно настраивать параметры, относящиеся к указанному экземпляру марионетки.

Примечание. Вновь импортированные марионетки по умолчанию располагаются в центре сцены. Используйте параметр поведения Преобразовать, чтобы изменить расположение марионетки на сцене.

Редактирование исходного графического объекта марионетки

Графический объект, связанный с марионеткой, можно обновить без необходимости повторного создания с нуля марионетки и всех примененных вариантов поведения и изменений их параметров.

Чтобы изменить графический объект, на основе которого создана марионетка, выполните следующие действия.

  1. Выберите марионетку на панели «Проект» или слой марионетки на панели «Марионетка», а затем щелкните Правка > Редактировать оригинал (Cmd/Ctrl + E). Если у вас есть файл марионетки, открытый в Photoshop или Illustrator, можно напрямую перейти в эти программы и отредактировать файлы, после чего изменения будут автоматически синхронизированы. Запустится приложение, по умолчанию связанное с графическим объектом марионетки (например, Photoshop для файлов PSD, Illustrator для файлов AI). Откройте графический объект.

  2. Измените графический объект по мере необходимости, после чего сохраните изменения. Важно сохранить изменения в файлах графических объектов, чтобы эти изменения отобразились в программе Character Animator.

  3. Вернитесь в Character Animator. Измененный файл должен автоматически распознаваться и обновляться.

  4. Если программа Character Animator не может обнаружить измененный графический объект, подождите несколько секунд.

Видео: Создании марионетки с нуля

Видео: Создании марионетки с нуля
Dave Werner

Примечание. В учебном видеопособии Создание марионетки с нуля объясняется, как создать марионетку в Photoshop с нуля и «оживить» ее в Adobe Character Animator.

Когда марионетка выбрана на панели «Проект» или открыта на панели «Марионетка», в разделе «Марионетка» панели свойств указан путь к исходному графическому объекту, а в подсказке отображается полный путь. Если файл графического объекта не удается найти, имя файла выделяется желтым цветом, а в подсказке отображается префикс Отсутствует.

Чтобы связать заново или заменить исходный графический объект, щелкните имя файла на панели свойств и выберите файл графического объекта для использования.

Замена исходной марионетки дорожки марионетки

Можно обновить или заменить марионетку на панели «Таймлайн» даже после записи дублей для нее. Это позволяет сохранить существующие записи при добавлении нового содержимого к марионетке, если сохраняется общая структура марионетки.

Чтобы заменить исходную марионетку дорожки марионетки, выполните одно из следующих действий:

  • Выберите дорожку марионетки на панели «Таймлайн». Затем, удерживая нажатой клавишу Option (Mac) или Alt (Windows), перетащите марионетку на выбранную дорожку марионетки на панели Таймлайн.
  • Выберите на панели Проект марионетку на замену. Затем правой кнопкой мыши щелкните в области заголовка (с левой стороны) дорожки марионетки и выберите Заменить марионеткой, выбранной на панели Проект.

Удаляются все записанные дубли частей исходной марионетки, которых уже нет марионетке на замену.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет