После оптимизации документа или изображения его можно экспортировать (или сохранить, в зависимости от типа исходного файла).

Документ можно экспортировать (или, в некоторых случаях, сохранить) как единое изображение в формате GIF, JPEG или в другом графическом формате. Можно также экспортировать весь документ в виде файла HTML и связанных файлов изображений, экспортировать только выбранные фрагменты или указанную область. Возможен также экспорт состояний и слоев документа Fireworks в виде отдельных файлов изображений.

Заданное по умолчанию местоположение, куда Fireworks экспортирует файлы, определяется в следующем порядке:

  1. Местоположение экспорта текущего документа, устанавливаемое при экспорте документа и последующем сохранении файла PNG

  2. Текущее местоположение для экспорта/сохранения, устанавливаемое при переходе от местоположения по умолчанию в диалоговом окне «Сохранить», «Сохранить как», «Сохранить копию» или «Экспорт» к другому местоположению

  3. Местоположение текущего файла

  4. Заданное по умолчанию местоположение, куда в данной операционной системе сохраняются новые документы или изображения

    При сохранении изображений Fireworks руководствуется другим набором правил для определения местоположения сохраняемого документа по умолчанию. Дополнительную информацию см. в разделе Сохранение файлов Fireworks.

Экспорт страниц в виде файлов изображений

  1. Выберите команду «Файл» > «Экспорт».

  2. Выберите местоположение для экспортируемых файлов.

  3. Выполните одно из следующих действий:

    • Выберите «Только изображения» во всплывающем меню «Экспорт» и снимите или установите флажок в поле «Только текущая страница». Страницы экспортируются в формат изображения, установленный на панели «Оптимизировать».

    • Во всплывающем меню «Экспорт» выберите пункт «Страницы в файлы», в меню «Экспортировать как» — пункт «Изображения». Страницы экспортируются в формат изображения, установленный на панели «Оптимизировать».

    • Во всплывающем меню «Экспорт» выберите пункт «Страницы в файлы», в меню «Экспортировать как» — пункт «Fireworks PNG». Каждая страница экспортируется как отдельный файл PNG, обратно совместимый с Fireworks 8.

    Примечание.

    Чтобы экспортировать все страницы в выбранный формат, выделите все страницы, а затем оптимизируйте настройки.

Экспорт одного изображения

Если работа выполняется над существующим файлом изображения, открытым в Fireworks, то его можно сохранить, а не экспортировать. Дополнительную информацию см. в разделе Сохранение документов в других форматах.

Примечание.

Для экспорта отдельных изображений документа, необходимо сначала фрагментировать документ, а затем выполнить экспорт соответствующих фрагментов.

  1. На панели «Оптимизировать» выберите формат файла и задайте параметры, связанные с этим форматом.

  2. Выберите команду «Файл» > «Экспорт».

  3. Выберите местоположение для экспортируемого файла изображения.

    Веб-графику обычно рекомендуется помещать в одну из папок локального веб-сайта.

  4. Выберите имя файла без расширения. Расширение добавляется при экспорте на основе типа файла.

  5. Во всплывающем меню «Экспорт» выберите вариант «Только изображения».

  6. Нажмите кнопку «Сохранить».

Экспорт фрагментированного документа

По умолчанию при экспорте фрагментированного документа Fireworks экспортируется файл HTML и связанные с ним изображения. Экспортированный файл HTML можно просмотреть в веб-браузере или импортировать в другое приложение для дальнейшего редактирования.

Перед экспортом убедитесь, что в диалоговом окне «Настройка HTML» выбран соответствующий стиль HTML. См. Настройка параметров экспорта HTML.

Экспорт всех фрагментов

  1. Выберите команду «Файл» > «Экспорт».

  2. Перейдите в папку на жестком диске, в которую будет выполняться экспорт.

  3. Во всплывающем меню «Экспорт» выберите «HTML и изображения».

  4. Введите имя файла в поле «Имя файла» (для Windows) или «Сохранить как» (для Mac OS).

  5. Во всплывающем меню «HTML» выберите «Экспорт HTML-файла».

  6. Во всплывающем меню «Экспорт» выберите «Экспорт фрагментов».

  7. (Необязательно) Установите флажок «Поместить изображения во вложенную папку».

  8. Нажмите кнопку «Сохранить».

Экспорт выбранных фрагментов

  1. Щелкая мышью при нажатой клавише Shift, выделите несколько фрагментов.

  2. Выберите команду «Файл» > «Экспорт».

  3. Выберите папку для хранения экспортируемых файлов, например, папку на локальном веб-сайте.

  4. Во всплывающем меню «Экспорт» выберите «HTML и изображения».

  5. Выберите имя файла без расширения. Расширение добавляется при экспорте на основе типа файла.

    Если выполняется экспорт нескольких фрагментов, Fireworks использует введенное имя как основу имени всех экспортируемых графических объектов, кроме тех, имя которых было специально указано на панели «Слои» или в Инспекторе свойств.

  6. Во всплывающем меню «Экспорт» выберите «Экспорт фрагментов».

  7. Для экспорта только выделенных перед экспортом фрагментов, установите флажок «Только выделенные фрагменты», а также убедитесь, что флажок «Включить области без фрагментов» не установлен.

  8. Нажмите кнопку «Сохранить».

Обновление фрагмента

Если вы уже экспортировали фрагментированный документ и позднее внесли изменения в исходный документ Fireworks, то можно просто обновить измененное изображение или фрагмент. Для упрощения поиска фрагмента замены дайте ему понятное имя.

  1. Скройте фрагмент, выполните редактирование в расположенной под ним области.

  2. Отобразите фрагмент снова.

  3. Щелкните фрагмент правой кнопкой мыши (для Windows) или при нажатой клавише Control (для Macintosh), затем выберите «Экспортировать выбранный фрагмент».

  4. Выберите папку, в которой расположен исходный фрагмент, укажите то же базовое имя и нажмите кнопку «Сохранить».

  5. При появлении запроса о замене существующего файла нажмите кнопку «ОК».

    Примечание.

    Не изменяйте размеры фрагмента по сравнению с размерами оригинального экспортированного файла, иначе после обновления фрагмента документ HTML может исказиться непредвиденным образом.

Экспорт анимации

После создания и оптимизации анимации ее можно экспортировать. Анимацию можно экспортировать в виде файла одного из следующих типов:

Анимированные GIF-файлы

Эти файлы лучше всего подходят для создания иллюстраций и мультипликационных графических объектов.

Flash SWF или Fireworks PNG (экспорт не требуется)

Для импорта анимации в приложение Flash экспортируйте ее как файл SWF. Или не выполняйте экспорт, импортируя исходный файл Fireworks PNG непосредственно в приложение Flash. В этом случае можно импортировать все слои и состояния анимации и затем редактировать их во Flash. См. раздел Работа с Flash.

Несколько файлов

Экспорт состояний или слоев анимации в виде нескольких файлов полезен при наличии большого количества символов на различных слоях одного объекта. Например, в виде нескольких файлов можно экспортировать баннер, если каждая буква в названии компании анимирована. См. Экспорт состояний или слоев документа в виде нескольких файлов

Если документ содержит несколько объектов анимации, посредством вставки фрагментов можно выполнить экспорт каждой анимации с различными значениями таких параметров, как повтор и задержка состояния.

Импорт анимированного файла GIF

  1. Выберите «Выделение» > «Отменить выделение», чтобы снять выделение всех фрагментов и объектов, затем выберите формат файла «Анимированный GIF» на панели «Оптимизировать».

  2. Выберите команду «Файл» > «Экспорт».

  3. Введите имя файла и выберите местоположение для экспорта.

  4. Нажмите кнопку «Сохранить».

Экспорт нескольких анимированных файла GIF с различными значениями параметров анимации

  1. Чтобы выделить несколько объектов анимации, щелкайте их, удерживая нажатой клавишу Shift.

  2. Выберите «Редактирование» > Вставить > «Прямоугольный фрагмент» или «Многоугольный фрагмент».

  3. В появившемся окне сообщения нажмите «Несколько».

  4. Поочередно выберите все фрагменты и установите для них значения параметров анимации на панели «Состояния».

  5. Выделите все фрагменты, которые необходимо анимировать, и установите для них на панели «Оптимизировать» формат файла «Анимированный GIF».

  6. Щелкните фрагмент правой кнопкой мыши (для Windows) или при нажатой клавише Control (для Macintosh), затем выберите «Экспортировать выбранный фрагмент». В диалоговом окне «Экспорт» введите имя для каждого файла, укажите местоположение и нажмите кнопку «Сохранить».

Экспорт состояний или слоев документа в виде нескольких файлов

Программа Fireworks позволяет экспортировать каждый слой или состояние документа в виде отдельного файла изображения, используя выбранные на панели «Оптимизировать» параметры оптимизации. Имена слоев или состояний определяют имена экспортируемых файлов. Этот вариант экспорта иногда используется для экспорта анимации.

  1. Выберите команду «Файл» > «Экспорт».

  2. Введите имя файла и выберите папку назначения.

  3. Во всплывающем меню «Экспорт» выберите один из следующих параметров.

    Состояния в файлы

    Экспортирует состояния в виде нескольких файлов.

    Слои в файлы

    Экспортирует слои в виде нескольких файлов. 

    Примечание. Экспортирует все слои текущего состояния.

  4. Чтобы автоматически обрезать каждое экспортируемое изображения для включения только объектов каждого состояния, установите флажок «Обрезать изображения». Чтобы, наоборот, включить весь холст (включая пустые области под объектами), снимите флажок с этого параметра.

  5. Нажмите кнопку «Сохранить».

Экспорт области из документа

  1. Выберите инструмент «Экспорт области» на панели «Инструменты» .

  2. Перетягиванием задайте границы области, соответствующей экспортируемой части документа.

    Примечание.

    Положение области можно изменять в процессе перетягивания. Нажав кнопку мыши, нажмите и удерживайте клавишу «Пробел», затем перетяните область в другую часть холста. Отпустите «Пробел», чтобы продолжить рисование границ области.

    Область экспорта после отпускания кнопки мыши остается выбранной.

  3. При необходимости измените размеры экспортируемой области:

    • Чтобы пропорционально изменить размер выделенной области экспорта, перетяните маркер, удерживая Shift.

    • Чтобы изменить размер выделенной области из центральной точки, перетяните маркер, удерживая Alt (Windows) или Option (Mac OS).

    • Чтобы изменить размер выделенной области из центральной точки, сохраняя пропорции, перетяните маркер, удерживая Alt (Windows) или Option (Mac OS).

  4. Выполните двойной щелчок внутри области экспорта, чтобы перейти к диалоговому окну «Просмотр изображения».

  5. В окне «Просмотр изображения» при необходимости измените параметры, затем нажмите кнопку «Экспорт».

  6. Введите имя файла и выберите папку назначения.

  7. Во всплывающем меню «Экспорт» выберите вариант «Только изображения».

  8. Нажмите кнопку «Сохранить».

    Примечание.

    Для отмены выделения без выполнения экспорта выполните двойной щелчок вне области экспорта, нажмите клавишу Esc или выберите другой инструмент.

Экспорт HTML

Если специально не выбрано другое, при экспорте фрагментированного документа Fireworks выполняется экспорт файла HTML и его изображений. Выбрать способ экспорта HTML в Fireworks можно в диалоговом окне «Настройка HTML».

Fireworks создает файл на «чистом» HTML, совместимый с большинством веб-браузеров и редакторов HTML. По умолчанию для экспорта определена кодировка UTF-8.

В Fireworks экспортировать файл HTML можно различными способами.

  • Экспортировать документ в файл HTML, который можно позднее открыть для изменения в редакторе HTML.

  • Экспортировать каждую страницу файла Fireworks в отдельный файл HTML.

  • Скопировать HTML-код документа в буфер обмена Fireworks, затем вставить код прямо в существующий документ HTML.

  • Экспортировать файл HTML, открыть его в редакторе HTML, вручную скопировать необходимые строки кода из файла и вставить их в другой документ HTML.

  • Экспортировать HTML в виде слоев каскадной таблицы стилей (Cascading Style Sheet, CSS) и кода XHTML.

  • Использовать команду «Обновить HTML» для внесения изменений в ранее созданный файл HTML.

    В Fireworks код HTML можно экспортировать в форматах Generic, Dreamweaver, Microsoft® FrontPage® и Adobe GoLive®.

    Примечание: Adobe Dreamweaver обеспечивает тесную интеграцию с Fireworks. Fireworks экспортирует HTML в Dreamweaver иначе, чем для других редакторов HTML. Информацию об экспорте Fireworks HTML в Dreamweaver см. в разделе Работа с Dreamweaver.

    Вариант экспорта, в котором созданные Fireworks файлы HTML передаются в другие приложения, оптимально подходит для коллективной работы. Этот метод разделяет рабочий процесс на этапы, при этом один сотрудник выполняет работу в одном приложении, а другой позднее продолжает ее с помощью другого приложения.

Включение комментариев в экспортированный HTML

Комментарии в созданном Fireworks HTML начинаются маркером <!-- и заканчиваются маркером -->. Все, что находится между парой этих маркеров, не интерпретируется ни как код JavaScript, ни как код HTML.

  1. Перед экспортом установите флажок «Включить комментарии HTML» на вкладке «Общие» диалогового окна «Настройка HTML».

Результаты экспорта

При экспорте или копировании HTML из Fireworks генерируется:

  • Код HTML, необходимый для сборки изображений из фрагментов, а также код JavaScript интерактивных элементов, если они содержатся в документе. Созданный Fireworks файл HTML содержит ссылки на экспортируемые изображения, а фоновым цветом веб-страницы устанавливает цвет холста.

  • Файлы изображений, количество которых зависит от количества фрагментов документа и количества состояний кнопок.

  • При необходимости файл spacer.gif. Spacer.gif — это файл GIF прозрачного изображения размером 1 на 1 пиксель, используемый Fireworks как разделитель для заполнения пустых ячеек таблицы с фрагментами изображения. Экспорт разделителя в Fireworks можно включить или отключить.

  • При экспорте всплывающих меню экспортируются следующие файлы: mm_css_menu.js и .css-файл, содержащий код CSS всплывающего меню. Если всплывающие меню содержат подменю, экспортируется также файл arrows.gif.

  • Если код HTML экспортируется или копируется в Dreamweaver, создаются файлы заметок разработчика, улучшающие интеграцию между Fireworks и Dreamweaver. Эти файлы имеют расширение .mno.

Экспорт Fireworks HTML

  1. Выберите команду «Файл» > «Экспорт».

  2. Перейдите в папку на жестком диске, в которую будет выполняться экспорт.

  3. Во всплывающем меню «Экспорт» выберите «HTML и изображения».

  4. Нажмите кнопку «Параметры» и во всплывающем меню «Стиль HTML» на вкладке «Общие» диалогового окна «Настройка HTML» выберите редактор HTML. Если используемый редактор HTML в списке не указан, выберите «Generic».

    Примечание.

    Важно правильно указать в поле «Стиль HTML» используемый редактор HTML; в противном случае интерактивные элементы, такие как кнопки и ролловеры, могут работать неправильно после импорта в редактор HTML.

  5. Нажмите кнопку «ОК».

  6. Во всплывающем меню «HTML» выберите «Экспорт HTML-файла».

  7. Если документ содержит фрагменты, выберите вариант «Экспортировать фрагменты» во всплывающем меню «Фрагменты».

  8. Для сохранения изображений в отдельной папке выберите «Поместить изображения во вложенную папку». Пользователь может выбрать нужную папку или использовать папку по умолчанию Images программы Fireworks.

  9. При экспорте многостраничного документа Fireworks для экспорта всех страниц документа в виде отдельных документов HTML необходимо снять флажок «Только текущая страница».

  10. Нажмите кнопку «Сохранить».

    После экспорта созданные Fireworks файлы можно увидеть на жестком диске. Файлы изображений и HTML создаются в местоположении, указанном в диалоговом окне «Экспорт».

Копирование кода HTML в буфер обмена

В Fireworks есть два способа копирования кода HTML в буфер обмена. Можно воспользоваться командой «Копировать код HTML» меню «Редактирование» или выбрать параметр «Копировать в буфер обмена» во всплывающем меню «HTML» диалогового окна «Экспорт». После этого код HTML можно вставить в документ используемого редактора HTML.

При определении способа вставки кода HTML Fireworks в другие приложения учитывайте следующие недостатки копирования кода HTML в буфер обмена:

  • Изображения нельзя сохранить в подпапку. Они должны находиться в той же папке, где будет расположен файл HTML, содержащий вставленный код HTML. Исключением является копирование кода HTML в Dreamweaver.

  • Все ссылки и пути, используемые во всплывающих меню Fireworks, будут указывать на жесткий диск. Этого не происходит при копировании кода HTML в Dreamweaver.

  • При использовании редактора HTML, кроме Dreamweaver или Microsoft FrontPage, код JavaScript, связанный с кнопками, вариантами поведения и замещающими изображениями, может действовать неправильно, хотя будет скопирован успешно.

    Если описанные недостатки мешают нормальной работе, вместо копирования кода HTML в буфер обмена используйте вариант «Экспорт HTML-файла».

    Примечание: Перед копированием кода HTML проверьте выбор соответствующего стиля HTML и установку флажка «Включить комментарии HTML» на вкладке «Общие» диалогового окна «Настройка HTML».

Копирование кода HTML Fireworks с использованием диалогового окна «Копировать код HTML»

  1. Выберите пункт меню «Редактирование» > «Копировать код HTML».

  2. Следуйте инструкциям мастера. После появления запроса укажите требуемую папку назначения, в которой будут сохранены экспортируемые изображения. В этой же папке должен находиться и сам файл HTML.

    Примечание.

    При вставке кода HTML в Dreamweaver местоположение экспорта изображений не имеет значения кроме того, что изображения должны находиться на том же сайте Dreamweaver, что и файл HTML, в который вставляется код.

Копирование кода HTML Fireworks с использованием диалогового окна «Экспорт»

  1. Выберите команду «Файл» > «Экспорт».

  2. В диалоговом окне «Экспорт» укажите папку для сохранения экспортируемых изображений. В этой же папке должен находиться и сам файл HTML.

    Примечание.

    При вставке кода HTML в Dreamweaver местоположение экспорта изображений не имеет значения кроме того, что изображения должны находиться на том же сайте Dreamweaver, что и файл HTML, в который вставляется код.

  3. Во всплывающем меню «Экспорт» выберите «HTML и изображения».

  4. Во всплывающем меню «HTML» выберите «Копировать в буфер обмена».

  5. Если документ содержит фрагменты, выберите вариант «Экспортировать фрагменты» во всплывающем меню «Фрагменты».

  6. Нажмите кнопку «Параметры», укажите используемый редактор HTML в диалоговом окне «Настройка HTML» и нажмите кнопку «ОК».

  7. Нажмите кнопку «Сохранить».

Вставка скопированного из Fireworks кода HTML в документ HTML

  1. В редакторе HTML откройте существующий документ HTML или создайте новый. Сохраните документ в папке с экспортированными изображениями.

    Примечание.

    При использовании Dreamweaver сохранять файл HTML именно в ту папку, где находятся экспортированные изображения, не обязательно. При экспорте изображений из Fireworks на сайт Dreamweaver и сохранении файла HTML в папке на этом сайте программа Dreamweaver разрешает пути к связанным с файлом изображениям.

  2. Просмотрите код HTML и поместите точку вставки между тегами <BODY>.

    Примечание.

    Код HTML, скопированный из Fireworks, не включает открывающие и закрывающие теги <HTML> и <BODY>.

  3. Вставьте код HTML.

    Если это возможно, при копировании в буфер обмена экспортируйте изображения именно в ту папку, в которой они должны находиться на веб-сайте. В Fireworks используются относительные URL-адреса документов, поэтому при перемещении файла HTML или файлов изображений URL-ссылки нарушаются.

Копирование кода из экспортированного файла Fireworks и его вставка в другой файл HTML

  1. Откройте экспортированный из Fireworks файл HTML в редакторе HTML.

  2. Выделите необходимый код и скопируйте его в буфер обмена.

  3. Откройте существующий документ HTML или создайте новый.

  4. Вставьте код в новый файл HTML. Копировать теги <HTML> и <BODY> не требуется, поскольку эти теги уже должны присутствовать в документе HTML, в который выполняется вставка кода.

    Если флажок «Включить комментарии HTML» в диалоговом окне «Настройка HTML» программы Fireworks установлен, выполните содержащиеся в комментариях инструкции по копированию и вставке кода в соответствующее место файла.

  5. Если документ Fireworks содержит интерактивные элементы, скопируйте код JavaScript.

    Код JavaScript заключается в теги <SCRIPT> и находится в разделе <HEAD> документа. Скопируйте и вставьте весь раздел <SCRIPT>, если в документе, куда выполняется вставка, нет раздела <SCRIPT>. Если же такой раздел существует, необходимо скопировать и вставить лишь содержимое раздела <SCRIPT> в существующий раздел <SCRIPT>, не переписывая при этом исходного содержимого существующего раздела. Кроме того, убедитесь, что в разделе <SCRIPT> после вставки кода не появятся дублирующие функции JavaScript.

Обновление экспортированного файла HTML

Обновление позволяет внести изменения в документ Fireworks HTML, экспортированный ранее, это полезно при необходимости обновления только части документа.

Примечание.

Команда «Обновить HTML» работает с документами Dreamweaver не так, как с прочими документами HTML. Дополнительную информацию см. в разделе Работа с Dreamweaver.

При обновлении можно заменить лишь изменившиеся изображения, а можно перезаписать весь код и все изображения. Если выбрана замена только изменившихся изображений, то все изменения, внесенные в файл HTML после экспорта из Fireworks, сохраняются.

Примечание.

При необходимости внесения в макет документа существенных изменений рекомендуется вносить их в программе Fireworks и затем выполнить повторный экспорт файла HTML.

  1. Выберите пункт меню «Файл» > «Обновить HTML».

  2. Выберите файл для обновления.

  3. Нажмите кнопку «Открыть».

  4. Выполните одно из следующих действий:

    • Если созданный код HTML Fireworks не обнаружен в документе, на экране отображается соответствующее сообщение. Нажмите кнопку «ОК» для добавления созданного кода HTML Fireworks в конец документа.

    • Если созданный код HTML Fireworks не обнаружен в документе, выберите в диалоговом окне один из следующих вариантов и нажмите кнопку «ОК»:

      Заменить изображения и связанный с ними HTML-код

      Заменяет ранее созданный Fireworks HTML-код.

      Обновить только изображения

      Перезаписывает только изображения.

  5. Если появится диалоговое окно «Выбрать папку с изображениями», укажите папку и нажмите кнопку «Открыть».

Экспорт слоев CSS

Слои CSS могут перекрываться и накладываться друг на друга. В программе Fireworks обычный вывод HTML не перекрывается.

  1. Выберите команду «Файл» > «Экспорт».

  2. Введите имя файла и выберите папку назначения.

  3. Во всплывающем меню «Экспорт» выберите «CSS и изображения».

    • Чтобы экспортировать только текущее состояние, выберите «Только текущее состояние».

    • Чтобы экспортировать только текущую страницу выберите «Только текущая страница».

    • Установите флажок «Поместить изображения во вложенную папку», если необходимо выбрать папку для изображений.

  4. Чтобы задать свойства страницы HTML, нажмите кнопку «Параметры».

  5. Чтобы задать фоновое изображение и мозаичное размещение фонового изображения, нажмите кнопку «Обзор»

    • Выберите «Не повторять», чтобы однократно вывести изображение на экран.

    • Выберите «Повторять», чтобы повторять (или расположить мозаичным способом) изображение по горизонтали и вертикали.

    • Выберите «Повторять-x», чтобы расположить изображение мозаичным способом по горизонтали.

    • Выберите «Повторять-y», чтобы расположить изображение мозаичным способом по вертикали.

  6. Выберите выравнивание страницы в браузере: по левому краю, по центру или по правому краю.

  7. Нажмите кнопку «ОК», а затем «Сохранить».

Экспорт XHTML

XHTML — это объединение языков HTML, современного стандарта в области форматирования и отображения веб-страниц, и XML (Extensible Markup Language). Код XHTML отличается обратной совместимостью, т. е. отображается любыми современными веб-браузерами, и поддерживается всеми устройствами, способными отображать содержимое в формате XML: КПК, мобильными телефонами и другими портативными устройствами.

Программа Fireworks также поддерживает импорт кода XHTML. См. Создание файлов Fireworks PNG на основе файлов HTML.

Дополнительные сведения о коде XHTML см. в спецификации XHTML на сайте World Wide Web Consortium (W3C) www.w3.org.

  1. Выберите пункт меню «Файл» > «Настройка HTML», выберите стиль XHTML во всплывающем меню «Стиль HTML» на вкладке «Общие», затем нажмите кнопку «ОК».

  2. Экспортируйте документ любым из доступных способов экспорта или копирования кода HTML. См. Экспорт HTML.

    Примечание.

    В Fireworks при экспорте в код XHTML используется кодировка UTF-8.

Экспорт файлов в кодировке UTF-8 и в других кодировках

Стандарт UTF-8 (Universal Character Set Transformation Format-8) определяет способ кодирования текста, позволяющий веб-браузерам одновременно отображать различные национальные наборы символов на одной HTML-странице. По умолчанию кодировка UTF-8 включена.

Кроме того, Fireworks поддерживает импорт документов в кодировке UTF-8. См. Создание файлов Fireworks PNG на основе файлов HTML.

Экспорт документов без использования кодировки UTF-8

  1. Выберите пункт меню «Файл» > «Настройка HTML».

  2. На вкладке «Для документа» снимите флажок «Кодировка UTF-8», затем нажмите кнопку «ОК».

  3. Экспортируйте документ любым из доступных способов экспорта или копирования кода HTML.

Настройка параметров экспорта HTML

Диалоговое окно «Настройка HTML» позволяет определять способ экспорта кода HTML из Fireworks. Изменения, сделанные на вкладке «Для документа» влияют только на текущий документ. Настройки «Общие» и «Таблица» — это глобальные установки, применяемые ко всем создаваемым документам.

  1. Выполните одно из следующих действий:

    • Выберите пункт меню «Файл» > «Настройка HTML».

    • В диалоговом окне «Экспорт» щелкните кнопку «Параметры».

  2. На вкладке «Общие» выберите необходимые параметры.

    Стиль HTML

    Выберите стиль экспортируемого HTML.

    Стиль «Generic HTML» совместим с любым редактором HTML. Если документ содержит варианты поведения или другие интерактивные элементы, выберите в списке именно используемый вами редактор HTML.

    Для экспорта документа в формате XHTML, выберите соответствующий стиль XHTML во всплывающем меню «Стиль HTML».

    Расширение

    Выберите расширение файла во всплывающем меню или введите собственный вариант.

    Включить комментарии HTML

    Выберите, чтобы включить комментарии, сообщающие, откуда нужно копировать строки HTML-кода и куда их нужно вставлять. Рекомендуется установить этот параметр, если документ содержит интерактивные элементы, такие как кнопки, варианты поведения или замещающие изображения.

    Имя файла в нижнем регистре

    Выберите, чтобы при экспорте все буквы имен HTML-файла и связанных с ним файлов изображений преобразовывались в строчные.

    Примечание. Этот параметр не изменяет расширение файла HTML на нижний регистр при выборе верхнего регистра во всплывающем меню «Расширение».

    Использовать CSS для всплывающих меню

    Выберите, чтобы использовать CSS, а не JavaScript в коде всплывающих меню. Для индексирования меню и обновления связей в коде можно использовать Dreamweaver.

    Записать CSS во внешний файл

    Выберите, чтобы записать код CSS во внешний файл .css, экспортируемый в ту же папку, что и файл HTML. Имя создаваемого файла .css будет таким же, как и имя файла HTML (они отличаются только расширением). При выборе этого параметра также выполняется экспорт файла mm_css_menu.js в то же расположение, в котором сохраняется файл HTML.

    Примечание. Этот параметр доступен только при выборе параметра «Использовать CSS для всплывающих меню».

    File Creator (Mac OS)

    Выберите связанное с файлом приложение во всплывающем меню. После двойного щелчка на сохраненном на диске экспортированном файле HTML этот файл автоматически открывается в назначенном приложении.

  3. На вкладке «Таблица» задайте настройки для таблиц HTML. Дополнительную информацию см. в разделе Определение способов экспорта таблиц HTML.

  4. На вкладке «Для документа» выполните при необходимости следующие действия.

    Имена файлов фрагментов

    Выберите схему автоматического назначения имен фрагментам с помощью всплывающих меню «Автоматическое именование фрагментов». Можно воспользоваться значениями по умолчанию или выбрать собственную схему.

    Примечание. Если в любом из первых трех меню будет выбрано «Нет», имена создаваемых файлов будут совпадать, и при экспорте файлов фрагментов Fireworks перезапишет одни файлы другими, в результате останется единственное экспортированное изображение, на которое будут ссылаться все ячейки создаваемой таблицы.

    Alt-тег по умолчанию

    Введите текст, который должен выводиться вместо изображений, пока они загружаются из Интернета, а также если при загрузке происходит ошибка. В некоторых браузерах этот текст может также отображаться как всплывающая подсказка, когда указатель мыши помещается над изображением. Кроме того, сопроводительный текст полезен интернет-пользователям с ослабленным зрением.

    Экспортировать несколько HTML-страниц панели навигации (для использования без наборов кадров)

    Выберите при экспорте панели навигации, связывающей вместе несколько страниц, Fireworks экспортирует дополнительные страницы для каждой кнопки на панели навигации.

    Включить области без объектов фрагментов

    Выберите, чтобы включить области холста, которые не закрыты фрагментами.

    Кодировка UTF-8

    Включена по умолчанию. Позволяет отображать в экспортируемом документе символы из различных наборов. Для отключения этого параметра снимите флажок.

  5. Для сохранения этих параметров в качестве глобальных параметров по умолчанию щелкните «Задать параметры по умолчанию».

Экспорт файлов Adobe PDF

Если требуется напечатать или разослать проект Fireworks для рецензирования, экспортируйте его в Adobe PDF. В Adobe Reader® и Acrobat® рецензенты могут добавлять свои комментарии и отвечать на комментарии других рецензентов. Дополнительную информацию о настройке рецензий PDF см. в Справке по Acrobat.

В экспортируемых файлах PDF сохраняются все гипертекстовые ссылки, позволяя программам просмотра переходить по ним, как на веб-странице. Однако в отличие от прототипов HTML Adobe PDF поддерживает параметры защиты, не позволяющие рецензентам редактировать или копировать дизайны.

  1. Выберите пункт меню «Файл» > «Экспорт».

  2. Во всплывающем меню «Экспорт» выберите «Adobe PDF».

  3. Выберите страницы для экспорта и установите флажок «Показать PDF-файл после экспорта», чтобы автоматически открыть файл PDF в Adobe Reader или Acrobat.

  4. Для настройки PDF щелкните «Параметры» и задайте следующие настройки:

    Совместимость

    Определяет программы Adobe PDF, которые могут открывать экспортируемый файл.

    Сжатие

    Определяет тип сжатия изображения, снижая размер файла. В целом, сжатие JPEG и JPEG2000 дают лучшие результаты при обработке таких изображений, как фотографии с плавными переходами между цветами. ZIP является наилучшим выбором для изображений с большими областями сплошных, неконтрастных цветов.

    Качество

    Для сжатия JPEG или JPEG2000 предлагаются настройки качества изображения. При выборе качества «Высокое» создаются файлы большого размера с хорошим качеством изображения.

    Преобразовать в градации серого

    Преобразует все изображения в градации серого, уменьшая размер файла.

    Разрешить выделение текста

    Позволяет рецензентам копировать текст из экспортированного файла. Чтобы значительно уменьшить размер файла, снимите этот флажок.

    Величина выпуска за обрез

    Определяет ширину в пикселях пустой границы, окружающей изображение каждой страницы. Например, значение 20, означает наличие границы в 20 пикселей вокруг каждого изображения.

    Пользовательский пароль для открытия документа

    Требуется ввести пароль для открытия экспортированного файла.

    Пользовательский пароль для ограничения задач

    Требуется ввести пароль защиты для выполнения следующих функций: печать, редактирование, копирование и комментирование.

  5. Нажмите кнопку «ОК», чтобы закрыть диалоговое окно «Параметры».

  6. Укажите имя и расположение и нажмите кнопку «Сохранить».

    Примечание.

    Если у страниц документа Fireworks прозрачный холст, объекты с любыми примененными прозрачностями потеряют характеристики прозрачности при экспорте файла в PDF. Чтобы избежать этого, сделайте фон холста непрозрачным, прежде чем выполнять экспорт в PDF.

Видео

Создание версий для утверждения клиентом в формате PDF или HTML с помощью Fireworks (00:05:32)

Узнайте, как подготовить документ в формате PDF или HTML для утверждения клиентом или группового рецензирования с помощью меню «Экспорт» в Fireworks.

Автор: Том Грин (Tom Green)

При просмотре экспортированных файлов PDF в Adobe Acrobat или Adobe Reader используйте следующие настройки:

  1. В Adobe Acrobat или Adobe Reader выберите «Правка» > «Установки».

  2. Слева выберите «Отображение страницы».

  3. Задайте для параметра «Пользовательское разрешение» значение 72 пикселя на дюйм.

  4. Задайте для параметра «Масштаб» значение 100%.

Экспорт файлов FXG

Формат файла FXG поддерживается программами Flash Catalyst, Fireworks, Illustrator и Photoshop. При экспорте файлов, содержащих векторные и растровые изображения, при помощи функции «Экспорт FXG», создается отдельная папка <имя_файла.assets>. В ней содержатся растровые изображения, которые используются в файле.

При удалении любого из этих изображений операция импорта будет невозможна.

Примечание.

Элементы, фильтры, режимы наложения, градиенты и маски, для которых в файле FXG нет тега отображения, экспортируются в виде растровой графики.

  1. Выберите команду «Файл» > «Экспорт» и укажите путь к папке, в которой необходимо сохранить файлы.

  2. Введите имя файла FXG.

  3. В меню «Экспорт» диалогового окна «Экспорт» выберите пункт «FXG и изображения».

  4. Нажмите кнопку «Сохранить».

Примечание.

Объекты, часть которых расположена за пределами Fireworks, отображаются полностью при открытии экспортируемого файла FXG в программе Flash Catalyst.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет