Fireworks импортирует оригинальные файлы Photoshop (PSD) и сохраняет многие возможности Photoshop. Также можно экспортировать графику Photoshop для детального редактирования изображения.

Помещение изображений Photoshop в Fireworks

Изображения Photoshop помещаются в Fireworks посредством команд «Файл» > «Импорт» и «Файл» > «Открыть», либо перетаскивание файлов на холст. Команда «Импорт» предоставляет доступ к уникальным параметрам для уровня фона и папок уровней. В то же время, команда «Открыть» и метод перетаскивания предоставляют доступ к параметрам для направляющих и состояний.

Преобразуемые и неподдерживаемые в Fireworks возможности Photoshop

При открытии или импорте файла Photoshop программа Fireworks преобразует изображение в формат PNG с помощью заданных пользователем установок импорта (см. раздел Установки импорта в Photoshop и открытия файлов).

  • Отдельные слои-маски преобразуются в маски объектов Fireworks. Сгруппированные маски не поддерживаются.

  • Обтравочные маски преобразуются в маски объектов, но их внешний вид меняется незначительно. Для сохранения внешнего вида с потерей возможностей редактирования выберите параметр «Обтравочные маски».

  • Режимы наложения слоев преобразуются в режимы наложения для объектов Fireworks, если соответствующие режимы существуют.

  • Эффекты слоев по умолчанию сохраняются. Чтобы преобразовать эти эффекты в соответствующие живые фильтры, установите параметр «Эффекты слоя». Однако следует иметь в виду, что оформление сходных эффектов и фильтров может незначительно отличаться.

  • Первый альфа-канал в палитре «Каналы» преобразуется в прозрачные области изображения Fireworks. Fireworks не поддерживает дополнительные альфа-каналы Photoshop.

  • Все глубины цвета и режимы Photoshop преобразуются в 8-битный RGB.

Перетаскивание, открытие или импорт изображений Photoshop в Fireworks

Каждое перетаскиваемое, открываемое или импортируемое изображение становится новым растровым объектом.

Примечание.

В операционной системе Windows имена файлов должны содержать расширение PSD, чтобы Fireworks мог распознать тип файла Photoshop.

  1. Выполните одно из следующих действий.

    • Перетащите изображение Photoshop или файл в открытый документ Fireworks.

    • Выберите «Файл» > «Импорт» или «Файл» > «Открыть» и перейдите к выбранному файлу Photoshop (PSD).

  2. Нажмите кнопку «Открыть».

  3. В появившемся диалоговом окне установите параметры изображения и нажмите кнопку «OK».

  4. При использовании команды «Файл» > «Импорт» курсор приобретает форму перевернутой буквы «L». Нажмите место на холсте, в котором вы хотите расположить левый верхний угол изображения.

Параметры импорта для файлов Photoshop

При импорте или открытии файла Photoshop в Fireworks появляется диалоговое окно, позволяющее указать параметры импорта изображения. Выбираемые параметры определяют оформление и редактируемость импортируемых файлов.

  1. Укажите размеры изображения в пикселях или процентах, задайте разрешение в пикселях. Для сохранения текущего соотношения между высотой и шириной выберите «Сохранить пропорции».

  2. Если файл Photoshop содержит композиции слоев, то укажите, какой вариант изображения следует импортировать. Выберите «Просмотр» для предварительного просмотра выбранной композиции. В текстовом поле «Комментарии» отображаются комментарии из файла Photoshop.

  3. Во всплывающем меню в нижней части окна выберите способ открытия изображений Photoshop в Fireworks:

    Сохранить приоритет возможностей редактирования слоя перед внешним видом

    Максимально сохраняет структуру уровня и редактируемость текста без ухудшения внешнего вида изображения. Если файл содержит возможности, не поддерживаемые Fireworks, то Fireworks сохраняет внешний вид документа посредством объединения и растеризации слоев. Примеры:

    • Слои CMYK, корректирующие слои и слои, использующие параметр «Просвечивание», объединяются с нижележащими уровнями.

    • Слои, использующие неподдерживаемые эффекты слоя, могут объединяться в зависимости от режима наложения слоя и наличия прозрачных пикселей.

    Сохранить внешний вид слоев Photoshop

    Сводит все объекты в каждом слое Photoshop и преобразует каждый слой Photoshop в растровый объект. Этот параметр блокирует возможность редактирования слоев Photoshop в Fireworks. Однако поддержка групп слоев сохраняется.

    Применять пользовательские установки

    Импортирует файл, используя пользовательские параметры преобразования файлов, указанные в диалоговом окне «Установки» (см. раздел Установки импорта в Photoshop и открытия файлов).

    Свести слои Photoshop в единое изображение

    Импортирует файл Photoshop как сведенное изображение без слоев. В преобразованном файле отдельные объекты не сохраняются. Непрозрачность сохраняется, но ее нельзя редактировать.

  4. При использовании команды «Файл» > «Импорт» можно выбрать следующие параметры:

    Включить фоновые слои

    Включает импорт объектов из фонового слоя изображения.

    Импортировать в новую папку

    Импортирует изображение в новую папку слоев с именем Photoshop Import.

  5. При использовании команды «Файл» > «Открыть» или перетаскивании файла Photoshop в Fireworks можно выбрать следующие параметры:

    Включить направляющие

    Сохраняет направляющие Photoshop на исходных позициях.

    Преобразовать слои в состояния

    Помещает каждую группу слоев Photoshop в отдельное состояние.

Об импорте текста из Photoshop

Примечание.

Для быстрого импорта указанного текста в файл Illustrator скопируйте его напрямую в Fireworks. В копируемом тексте сохраняются все текстовые атрибуты.

При импорте файла Photoshop, содержащего текст Fireworks проверяет наличие необходимых шрифтов в системе. Если шрифты не установлены, Fireworks предлагает выбрать их замену или сохранение внешнего вида.

Если к тексту в файле Photoshop применены эффекты, поддерживаемые программой Fireworks, эти эффекты сохраняются и после переноса файла в Fireworks. Однако поскольку Fireworks и Photoshop могут применять эффекты различным образом, результирующее изображение в этих программах может различаться.

При открытии содержащих текст файлов Photoshop версий 6 или 7, если установлен параметр «Сохранять внешний вид», то отображается кэшированное изображение текста, вид которого полностью совпадает с видом изображения в Photoshop. При редактировании текста кэшированное изображение заменяется текущим текстом. Внешний вид текста может отличаться от исходного. Однако данные оригинальных шрифтов сохраняются в файле PNG, поэтому пользователь может использовать эти шрифты в системах, на которых они установлены.

Примечание.

Fireworks не может экспортировать текст в форматах Photoshop 6 или 7. Если после редактирования документа, содержащего текст в формате Photoshop 6 или 7, выполняется экспорт документа обратно в Photoshop, то файл экспортируется в формате Photoshop 5.5. Однако если в текст не вносились какие-либо изменения, файл экспортируется в формате Photoshop 6.

Импорт/экспорт градиентов Photoshop

Качество градиента после операций импорта и экспорта зависит от типа градиента. Цвет и непрозрачность градиентов может незначительно измениться.

Градиент

Качество импорта

Линейный

Почти идеальное.

Радиальный

Почти идеальное.

Зеркально отображенный

Почти идеальное.

Ромб

Приблизительное соответствие (преобразование в прямоугольник).

Угол

Приблизительное соответствие (преобразование в конус).

   

Градиент

Качество экспорта

Линейный

Почти идеальное.

Радиальный

Почти идеальное.

Панели

Почти идеальное.

Прямоугольник

Приблизительное соответствие (преобразование в ромб).

Конус

Приблизительное соответствие (преобразование в угловой).

Эллипс

Приблизительное соответствие (преобразование в радиальный).

Рябь

Приблизительное соответствие (преобразование в радиальный).

Многолучевая звезда

Неточное соответствие (преобразование в градиент по форме).

Контур, глянец, волны

Неточное соответствие (преобразование в линейный).

Сохранение внешнего вида корректирующих слоев после импорта

При импорте файла PSD с корректирующим слоем внешний вид отдельных слоев сохраняется.

  1. В диалоговом окне «Установки» перейдите к параметрам импорта из Photoshop и открытия файлов.

  2. Установите параметр «Сохранить внешний вид скорректированных слоев».

Сохранение внешнего вида скорректированных слоев

При импорте файла PSD с корректирующим слоем внешний вид отдельных слоев сохраняется. В диалоговом окне должен быть установлен параметр «Пользовательские параметры из установок».

Использование фильтров и плагинов Photoshop

Пользователь может использовать множество фильтров и плагинов, принадлежащих Photoshop и сторонним разработчикам, как посредством окна «Живые фильтры», так и посредством меню «Фильтры».

Примечание.

Поддерживаются плагины и фильтры Photoshop 5.5 и более ранних версий. Плагины и фильтры Photoshop 6 и последующих версий не совместимы с Fireworks.

Разрешение плагинов Photoshop с использованием диалогового окна «Установки»

  1. Выберите меню «Редактирование» > «Установки» (Windows) или «Fireworks» > «Установки» (Mac OS).

  2. Нажмите категорию «Плагины».

  3. Выберите элемент «Плагины Photoshop».

    Откроется диалоговое окно «Выберите папку».

    Примечание.

    Если это диалоговое окно не открывается, нажмите кнопку «Обзор».

  4. Перейдите в папку, в которой установлены фильтры и плагины, принадлежащие Photoshop или сторонним разработчикам, затем нажмите кнопку «Открыть».

  5. Нажмите кнопку «ОК», чтобы закрыть диалоговое окно «Установки».

  6. Перезапустите Fireworks.

Включение плагинов Photoshop с использованием диалогового окна «Живые фильтры»

  1. Выберите любой векторный объект, растровый объект или блок текста на холсте и нажмите значок плюса (+) рядом с надписью «Фильтры» в Инспекторе свойств.

  2. Выберите пункт меню «Параметры» > «Найти плагины» в появившемся всплывающем меню.

  3. Перейдите в папку, в которой установлены фильтры и плагины, принадлежащие Photoshop или сторонним разработчикам, затем нажмите кнопку «Открыть». При появлении запроса о перезапуске Fireworks, нажмите кнопку «ОК».

  4. Перезапустите Fireworks, чтобы загрузить фильтры и плагины.

    Примечание.

    Также плагины можно установить непосредственно в папку Plug-ins Fireworks.

Передача графики Fireworks в Photoshop

Fireworks обеспечивает широкие возможности экспорта файлов в формате Photoshop (PSD). Изображение Fireworks, экспортированное в Photoshop, при повторном открытии в Fireworks сохраняет те же возможности редактирования, как и любой другой графический объект Photoshop. Пользователи Photoshop могут выполнить некоторые действия по редактированию изображения в Fireworks, а затем продолжить редактирование в Photoshop.

Примечание.

С помощью расширения PSD Save можно быстро экспортировать страницы и состояния из документа Fireworks в отдельные файлы PSD. Загрузить это расширение можно по адресу: http://www.adobe.com/go/learn_fw_psdsave_ru

Экспорт файла в формате Photoshop

  1. Выберите команду «Файл» > «Сохранить как».

  2. Введите имя файла и выберите «Photoshop PSD» в меню «Сохранить как».

  3. Чтобы указать предустановленные параметры экспорта для объектов, эффектов и текста, нажмите «Параметры». Выберите предварительные установки в меню «Параметры».

    Сохранить приоритет возможностей редактирования перед внешним видом

    Объекты преобразуются в слои, возможность редактирования эффектов сохраняется, а текст преобразуется в редактируемые текстовые слои Photoshop. Выберите этот вариант, если изображение будет интенсивно редактироваться в Photoshop, а необходимости сохранить точный внешний вид исходного изображения Fireworks нет.

    Сохранять внешний вид Fireworks

    Каждый объект преобразуется в отдельный слой Photoshop, при этом эффекты и текст становятся нередактируемыми. Выберите этот вариант, если необходимо обеспечить работу с отдельными объектами Fireworks в Photoshop, но при этом внешний вид исходного изображения Fireworks должен быть сохранен в точности.

    Файл Photoshop меньшего размера

    Все слои сводятся в объединенное изображение. Выберите этот вариант, если экспортируемый файл содержит большое количество объектов Fireworks.

    Пользовательская

    Позволяет отдельно задать настройки для объектов, эффектов и текста.

  4. Нажмите кнопку «Сохранить», чтобы экспортировать файл Photoshop.

    Примечание.

    Photoshop 5.5 и более ранние версии не могут открывать файлы, содержащие более 100 слоев. Если экспортируемый документ Fireworks содержит больше 100 объектов, необходимо удалить или объединять часть объектов.

Настройка параметров экспорта в Photoshop

  1. В диалоговом окне «Сохранить как» выберите «Photoshop PSD» в качестве типа файла и нажмите «Параметры».

  2. Выберите «Пользовательский» во всплывающем меню «Параметры».

  3. Во всплывающем меню «Объекты» выберите один из следующих вариантов.

    Преобразовать в слои Photoshop

    Отдельные объекты Fireworks преобразуются в слои Photoshop, а маски Fireworks преобразуются в слои-маски Photoshop.

    Свести каждый слой Fireworks

    Все объекты на каждом отдельном слое Fireworks сводятся, после чего каждый слой Fireworks преобразуется в слой Photoshop. При выборе этого варианта возможность редактирования отдельных объектов Fireworks в Photoshop теряется. Также теряются связанные с объектами Fireworks свойства, такие как режимы наложения.

  4. Во всплывающем меню «Эффекты» выберите один из следующих вариантов.

    Сохранять возможности редактирования

    Преобразует живые фильтры Fireworks в их эквиваленты в Photoshop. Если аналогичный эффект в Photoshop отсутствует, он удаляется.

    Рендеринг эффектов

    Выполняет сведение эффектов с объектами. При выборе этого параметра внешний вид эффектов сохраняется, но возможность их редактирования в Photoshop отсутствует.

  5. Во всплывающем меню «Текст» выберите один из следующих вариантов.

    Сохранять возможности редактирования

    Текст преобразуется в редактируемый слой Photoshop. Форматирование текста, не поддерживаемое в Photoshop, теряется.

    Рендеринг текста

    Текст преобразуется в объект-изображение. При выборе этого параметра внешний вид текста сохраняется, но возможность его редактирования в Photoshop отсутствует.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет