В данной статье представлен обзор новых возможностей Adobe Flash Professional CS6.

Поддержка Adobe AIR 3.4 (только обновление 12.0.2 для Flash Professional CS6)

После установки обновления 12.0.2 для Flash Professional CS6 в Flash Professional расширяется поддержка AIR 3.4 и Flash Player 11.4. Это обновление позволяет использовать следующие важные функции, добавленные в AIR 3.4, которые в значительной мере усовершенствуют рабочий процесс публикации приложений в iOS.

Расширение Toolkit for CreateJS 1.2

В версии Toolkit for CreateJS 1.2 была расширена поддержка перевода кнопок на HTML5. Кроме того, это обновление содержит исправления некоторых ошибок, связанных с JSX. Другие проблемы, такие как пропуск нескольких пустых ключевых кадров, также были устранены.

Toolkit for CreateJS 1.2 можно загрузить и установить с помощью Adobe Extension Manager CS6. Дополнительные сведения о расширении Toolkit в см. статье Использование Flash Professional Toolkit for CreateJS.

Эмуляция мобильного содержимого для AIR

Новый эмулятор мобильного содержимого позволяет эмулировать аппаратные клавиши, акселерометр, сенсорный экран Multi-Touch и службы геолокации.

Выбор сетевого интерфейса для удаленной отладки AIR

При публикации приложения AIR на устройстве Android или iOS можно выбрать тип сетевого интерфейса для удаленной отладки. Flash Pro добавит IP-адреса выбранного сетевого интерфейса в пакет отладочной версии мобильного приложения. После запуска приложения на целевом мобильном устройстве оно может подключиться к сеансу отладки на главном компьютеру по указанному IP-адресу. Для доступа к этой настройке выберите «Файл» > «Параметры публикации» и откройте вкладку «Развертывание» в диалоговом окне настроек AIR. Дополнительные сведения см. в статьях Упаковка приложений для AIR for iOS и Публикация для Adobe AIR for Desktop.

 

Расширение Toolkit for CreateJS

Adobe Flash Professional Toolkit for CreateJS — это расширение для Flash Professional CS6, с помощью которого дизайнеры и аниматоры могут создавать активы для проектов HTML5 с использованием библиотек CreateJS JavaScript с открытым кодом. Расширение поддерживает большинство основных возможностей работы с анимациями и иллюстрациями Flash Professional, включая векторы, растровые изображения, классические анимации, звуки, направляющие движения, анимированные маски и разработку сценариев JavaScript на временной шкале. Расширение Toolkit for CreateJS позволяет одним нажатием кнопки экспортировать содержимое в рабочей области и библиотеке, например JavaScript, для предварительного просмотра в браузере, благодаря чему можно быстро начать создавать привлекательное содержимое на основе HTML5.

С помощью расширения Toolkit for CreateJS пользователи Flash Pro могут выполнить переход к HTML5. Оно преобразует символы в библиотеке и содержимое в рабочей области в правильно отформатированный понятный код JavaScript, который разработчики могут редактировать и использовать для добавления интерактивных возможностей с помощью API-интерфейсов JavaScript и CreateJS, которые знакомы пользователям ActionScript 3. Расширение Toolkit for CreateJS также публикует простую страницу HTML, благодаря чему можно быстро просматривать активы. Дополнительные сведения см. в этой статье.

Экспорт листов спрайтов

Добавлена возможность экспорта листа спрайтов путем выбора символа в библиотеке или в рабочей области. Лист спрайтов представляет собой одиночный графический файл, содержащий все графические элементы, используемые в выбранном символе. Элементы упорядочены в файле по схеме «плитка». Также при выборе символа в библиотеке можно добавлять в нее растровые изображения. Для создания листа спрайтов выполните следующие действия:

  1. Выберите символ в библиотеке или в рабочей области.
  2. Щелкните на нем правой кнопкой мыши и выберите пункт «Экспортировать лист спрайтов».

Высокоэффективное сжатие SWF

Для SWF-файлов, предназначенных для использования с Flash Player 11 или более поздних версий, доступен новый алгоритм сжатия LZMA. Эффективность нового алгоритма может достигать 40 % и особенно хорошо проявляется при обработке файлов, содержащих большое количество сценариев ActionScript или векторной графики.

  1. Выберите «Файл» > «Параметры публикации».
  2. В разделе «Дополнительно» диалогового окна выберите в меню для параметра «Сжать ролик» значение «LZMA».

Публикация в режиме прямого ускорения

Доступен новый режим окна «Прямое ускорение», который позволяет включить возможности аппаратного ускорения для содержимого с использованием Stage3D. (Для работы Stage3D требуется Flash Player 11 или более поздней версии.)

  1. Выберите «Файл» > «Параметры публикации».
  2. Выберите «Оболочка HTML».
  3. В меню «Режим окна» выберите пункт «Прямое ускорение».

Дополнительные сведения см. в этой статье.

Поддержка визуализации с прямым ускорением модулями AIR

Данная возможность расширяет поддержку прямого ускорения в Flash Player для StageVideo/Stage3D, добавляя ее в приложения AIR. В файле дескриптора приложения AIR доступна новая настройка renderMode=direct. Режим прямого ускорения можно установить для AIR for Desktop, AIR for iOS и AIR for Android.

Отладка в ОС iOS через Wi-Fi

Добавлена возможность отладки приложений AIR в ОС iOS через интерфейс Wi-Fi с поддержкой точек останова, пошаговой отладки, просмотром переменных и трассировкой.

Дополнительные сведения об отладке приложений AIR см. в разделе Запуск отладчика AIR.

Поддержка встроенной среды выполнения для AIR

В диалоговое окно «Параметры публикации» для AIR добавлен параметр для встраивания среды выполнения AIR в пакет приложения
. Приложение с внедренной средой выполнения может запускаться на любом настольном компьютере, устройстве Android или iOS без установки общих файлов среды выполнения AIR.

Рекомендации Adobe:

Просмотрите видеоролики Adobe AIR с поддержкой связанного времени выполнения для мобильных устройств и компьютера.

Собственные расширения для AIR

В приложения AIR можно добавлять собственные расширения, разработанные с помощью Flash Pro. Использование собственных расширений открывает приложениям доступ ко всем возможностям целевой платформы, даже если среда выполнения не имеет встроенной поддержки соответствующих функций.

Загрузка последней версии Flash Player из Flash Pro

Теперь можно перейти непосредственно на страницу загрузки Flash Player на сайте Adobe.com из меню «Справка» в Flash Pro.

Экспорт последовательности PNG

Данная функция предназначена для генерации файлов изображений, которые можно использовать в Flash Pro и других приложениях для создания содержимого. Например, последовательности изображений PNG часто применяются при разработке игр. Эта функция позволяет экспортировать последовательность PNG-файлов из элемента библиотеки или отдельных роликов, графических символов и кнопок в рабочей области.

  1. Выберите отдельный ролик, кнопку, графический символ в библиотеке или в рабочей области
  2. Нажмите правую кнопку мыши, чтобы отобразить контекстное меню.
  3. Выберите Экспортировать последовательность PNG.
  4. В системном диалоговом окне сохранения выберите место, куда следует сохранить выходные файлы. Нажмите кнопку «ОК».
  5. В диалоговом окне Экспортировать PNG выберите нужные настройки. Нажмите кнопку Экспорт , чтобы экспортировать последовательность изображений PNG.

Ключевые слова: новые возможности Flash CS6, новые возможности Flash Professional CS6, новые возможности Flash CS6, новые возможности Flash Professional CS6

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет