Устранение неполадок, связанных с дизайном и компоновкой в веб-сайтах Adobe Muse. Поиск невидимых объектов и объектов вне полей.

Примечание.

Новые функции больше не добавляются в Adobe Muse. Поддержка этого приложения будет прекращена 26 марта 2020 г. Для получения подробной информации и поддержки посетите страницу прекращения обслуживания Adobe Muse.

Проблемы привязки, как правило, возникают из-за объектов, находящихся за пределами компоновки. Такие проблемы обычно возникают при копировании содержимого из компоновок большего размера в компоновки меньшего размера. Например, объекты могут оказаться за пределами компоновки при копировании из компоновки для настольных компьютеров в компоновку для мобильных устройств. Их невозможно заметить в случае, если вы отключили отображение краев рамки.

При публикации такой компоновки в браузере отображается пространство, содержащее объекты, которые находятся за ее пределами. Лишнее пространство портит внешний вид страницы.

Удалите объекты, лежащие за пределами компоновки.

  1. Выберите «Правка» > «Выделить все».

  2. Посмотрите на объекты, лежащие за пределами компоновки, и запомните их.

  3. В зависимости от ситуации переместите объекты в текущую компоновку или удалите их.

    Примечание.

    Во избежание удаления связанных объектов, которые нужно сохранить, выберите пункт меню «Объект» > «Разблокировать все на странице» (Object > Unlock All on page).

    Выберите пункт меню «Объект» > «Разблокировать все на странице», чтобы не удалять связанные объекты
    Выберите пункт меню «Объект» > «Разблокировать все на странице», чтобы не удалять связанные объекты

Найдите скрытые слои

  1. Выберите команду «Окно» > «Слои».

  2. Убедитесь в том, что все слои отображаются (для всех слоев должен быть показан значок глаза).

  3. Если слой скрыт, нажмите в столбце слева, чтобы включить его отображение.

  4. Выберите «Правка» > «Выделить все», и найдите все объекты или контейнеры за пределами компоновки.

    Выберите «Правка» > «Выделить все», и найдите все объекты за пределами компоновки
    Выберите «Правка» > «Выделить все», и найдите все объекты за пределами компоновки
  5. В зависимости от ситуации переместите объекты в текущую компоновку или удалите их.

Найдите объекты, находящиеся рядом с полями или отбрасывающие тень

Если вы пользуетесь более ранней версией Muse, найдите все объекты, находящиеся рядом с полями, к которым применен эффект отбрасывания тени. Перетащите объект целиком (с тенью) в пределы компоновки.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет