Обновления системы безопасности для Adobe Flash Player

Дата выпуска: 14 февраля 2017 г.

Последнее обновление: 13 апреля 2017 г.

Идентификатор уязвимости: APSB17-04

Приоритет: см. таблицу ниже

Номер CVE: CVE-2017-2982,CVE-2017-2984, CVE-2017-2985, CVE-2017-2986, CVE-2017-2987, CVE-2017-2988,CVE-2017-2990, CVE-2017-2991, CVE-2017-2992, CVE-2017-2993, CVE-2017-2995, CVE-2017-2996

Платформа: Windows, Macintosh, Linux и Chrome OS

Сводка

Компания Adobe выпустила обновления системы безопасности Adobe Flash Player для Windows, Macintosh, Linux и Chrome OS. В этих обновлениях устранены критические уязвимости, которые потенциально могли позволить злоумышленнику получить контроль над уязвимой системой.

Затронутые версии

Продукт Затронутые версии Платформа
Настольная среда выполнения Adobe Flash Player 24.0.0.194 и более ранних версий Windows, Macintosh и Linux
Adobe Flash Player для Google Chrome 24.0.0.194 и более ранних версий Windows, Macintosh, Linux и Chrome OS
Adobe Flash Player для Microsoft Edge и Internet Explorer 11 24.0.0.194 и более ранних версий Windows 10 и 8.1
  • Для получения информации о версии Adobe Flash Player, установленной на компьютере, обратитесь к веб-странице «About Flash Player» или нажмите правой кнопкой мыши контент, загруженный во Flash Player, и выберите в меню «About Adobe (или Macromedia) Flash Player». При использовании нескольких браузеров эту проверку необходимо провести для каждого из них.  

Решение

Adobe категоризирует эти обновления при помощи следующих рейтингов приоритета и рекомендует пользователям обновлять установленное программное обеспечение до последних версий.

Продукт Обновленные версии Платформа Рейтинг приоритета Доступность
Настольная среда выполнения Adobe Flash Player 24.0.0.221 Windows и Macintosh 1 Центр загрузки Flash Player 
Распространение Flash Player
Adobe Flash Player для Google Chrome 24.0.0.221  Windows, Macintosh, Linux и Chrome OS 1 Выпуски Google Chrome
Adobe Flash Player для Microsoft Edge и Internet Explorer 11 24.0.0.221 Windows 10 и 8.1 1 Советы корпорации Майкрософт по безопасности
Настольная среда выполнения Adobe Flash Player 24.0.0.221 Linux 3 Центр загрузки Flash Player
  • Компания Adobe рекомендует пользователям настольной среды выполнения Adobe Flash Player для Windows, Macintosh и Linux обновить программное обеспечение до версии 24.0.0.221 с помощью функции обновления продукта [1] или посетив центр загрузки Adobe Flash Player.
  • Приложение Adobe Flash Player, установленное вместе с Google Chrome, будет обновлено автоматически до последней версии браузера Google Chrome, которая будет включать Adobe Flash Player 24.0.0.221 для Windows, Macintosh, Linux и Chrome OS.
  • Приложение Adobe Flash Player, установленное вместе с Microsoft Edge и Internet Explorer 11 для Windows 10 и 8.1, будет обновлено автоматически до последней версии, которая будет включать Adobe Flash Player 24.0.0.221.
  • Посетите страницу справки Flash Player для получения информации по установке Flash Player.

[1] На компьютерах пользователей Flash Player 11.2.x и более поздних версий для Windows и Flash Player 11.3.x и более поздних версий для Macintosh, на которых задано обновление без уведомлений, обновление будет выполняться автоматически. Пользователи, которые не задали обновление без уведомлений, могут также установить обновление с помощью средства обновлений, встроенного в продукт, после появления соответствующего напоминания.

Сведения об уязвимости

  • В этих обновлениях устранена уязвимость, связанная со смешением типов, которая могла привести к выполнению кода (CVE-2017-2995).
  • В этих обновлениях исправлена проблема целочисленного переполнения, которая могла привести к выполнению кода (CVE-2017-2987).
  • В этих обновлениях устранена уязвимость защиты доступа к освобожденной памяти, которая могла привести к выполнению кода (CVE-2017-2982, CVE-2017-2985, CVE-2017-2993).
  • В этих обновлениях исправлена проблема, связанная с переполнением буфера, которая могла привести к выполнению кода (CVE-2017- 2984, CVE-2017-2986, CVE-2017-2992).
  • В этих обновлениях исправлена проблема, связанная с повреждением памяти, которая могла привести к выполнению кода (CVE-2017-2988, CVE-2017-2990, CVE-2017-2991, CVE-2017-2996).

Благодарности

Adobe приносит благодарность следующим людям и организациям за сообщение о релевантных проблемах и за помощь Adobe в обеспечении защиты наших клиентов:

  • Матеуш Юржик и Натали Сильванович, Google Project Zero (CVE-2017-2985, CVE-2017-2986, CVE-2017-2988, CVE-2017-2992).
  • Николас Джоули, Microsoft Vulnerability Research (CVE-2017-2993).
  • Тао Ян, Palo Alto Networks (CVE-2017-2982, CVE-2017-2996).
  • Кай Лу, Лаборатория Fortinet FortiGuard, работает по программе Chromium Vulnerability Rewards (CVE-2017-2984, CVE-2017-2990, CVE-2017-2991).
  • Пользователь bo13oy из лаборатории CloverSec, сотрудничающий в рамках программы Zero Day Initiative компании Trend Micro (, CVE-2017-2995).

Компания Adobe выражает благодарность следующим людям и организациям за сообщение об этих проблемах и за содействие в защите пользователей:

  • Данеш Кижакинан, FireEye, а также Питере Пи, TrendMicro (CVE-2015-5122)
  • Питер Пи, TrendMicro, а также slipstream/RoL (@TheWack0lian) (CVE-2015-5123)

Редакции

13 апреля 2017 г.: удалена ссылка на проблему безопасности CVE -2017-2994, которая была исключена из бюллетеня по ошибке. Перенесена ссылка на CVE-2017-2994 из этого выпуска в APSB17-07