Modifier votre espace de travail Dreamweaver selon vos besoins. Apprendre comment déplacer, redimensionner, ancrer, faire sortir d’un dock, réduire ou développer des fenêtres et des panneaux.

Pour créer un espace de travail personnalisé, vous déplacez et manipulez les fenêtres de document et les panneaux. Vous pouvez également enregistrer des espaces de travail, puis passer de l’un à l’autre.

Ancrage et annulation d’ancrage de panneaux

Un dock est un ensemble de panneaux ou de groupes de panneaux affichés ensemble, généralement en position verticale. Pour ancrer et annuler l’ancrage des panneaux, insérez-les dans le dock et déplacez-les hors du dock.

  • Pour ancrer un panneau, cliquez sur l’onglet correspondant et faites-le glisser dans le dock, au-dessus, sous ou entre d’autres panneaux.

  • Pour ancrer un groupe de panneaux, cliquez sur sa barre de titre (barre vide de couleur unie située au-dessus des onglets) et faites-le glisser dans le dock.

  • Pour supprimer un panneau ou un groupe de panneaux, faites-le glisser en dehors du dock en cliquant sur l’onglet ou la barre de titre. Vous pouvez faire glisser l’élément vers un autre dock ou le rendre flottant.

Déplacement de panneaux

Lorsque vous déplacez des panneaux, des zones de largage en surbrillance bleue apparaissent : il s’agit des zones dans lesquelles vous pouvez déplacer le panneau. Vous pouvez, par exemple, déplacer un panneau vers le haut ou vers le bas en le faisant glisser sur la fine zone de largage bleue située au-dessus ou sous un autre panneau. Si vous faites glisser le panneau vers un emplacement autre qu’une zone de largage, ce dernier flotte dans l’espace de travail.

Remarque :

la position de la souris active la zone de largage (au lieu de la position du panneau). Si la zone de largage ne s’affiche pas, faites glisser la souris à l’emplacement où devrait se situer la zone de largage.

  • Pour déplacer un panneau, faites-le glisser en cliquant sur son onglet.

  • Pour déplacer un groupe de panneaux, faites glisser la barre de titre.

Remarque :

Pour empêcher l’ancrage d’un panneau, appuyez sur la touche Ctrl (Windows) ou Commande (Mac OS) lors de son déplacement. Pour annuler l’opération, appuyez sur la touche Echap lors du déplacement du panneau.

Ajout et suppression de panneaux

Lorsque vous supprimez tous les panneaux d’un dock, ce dernier disparaît. Vous pouvez créer un dock en déplaçant les panneaux vers le bord droit de l’espace de travail jusqu’à ce qu’une zone de largage soit visible.

  • Pour supprimer un panneau, cliquez sur son onglet avec le bouton droit de la souris (Windows) ou en appuyant sur la touche Contrôle (Mac), puis sélectionnez l’option Fermer ; vous pouvez également le désélectionner dans le menu Fenêtre.

  • Pour ajouter un panneau, sélectionnez-le dans le menu Fenêtre et ancrez-le à l’emplacement de votre choix.

Manipulation de groupes de panneaux

  • Pour déplacer un panneau dans un groupe, faites glisser son onglet vers la zone de largage en surbrillance située dans le groupe.

Ajout d’un panneau à un groupe
Ajout d’un panneau à un groupe

  • Pour réorganiser les panneaux d’un groupe, faites glisser l’onglet du panneau de votre choix vers son nouvel emplacement.

  • Pour rendre un panneau flottant, faites-le glisser en dehors du groupe au moyen de son onglet.

  • Pour déplacer un groupe, faites glisser la barre de titre (zone située au-dessus des onglets).

Empilage de panneaux flottants

Lorsque vous faites sortir un panneau de son dock et que vous le placez en dehors de toute zone de largage, ce panneau flotte dans l’espace de travail. Un panneau flottant peut être placé à n’importe quel endroit dans l’espace de travail. Vous pouvez empiler des panneaux ou groupes de panneaux flottants de sorte qu’ils se comportent comme une seule entité lorsque vous faites glisser la barre de titre supérieure.

Panneaux empilés flottants
Panneaux empilés flottants

  • Pour empiler des panneaux flottants, cliquez sur un onglet pour faire glisser le panneau correspondant vers la zone de largage située au bas d’un autre panneau.

  • Pour modifier l’ordre d’empilage, cliquez sur un onglet afin de faire glisser le panneau correspondant vers le haut ou vers le bas.

Remarque :

prenez soin de « déposer » l’onglet sur l’étroite zone de largage située entre les panneaux, plutôt que sur la large zone de largage située dans une barre de titre.

  • Pour rendre un panneau ou groupe de panneaux de la pile flottant, déplacez-le hors de la pile au moyen de son onglet ou de sa barre de titre.

Redimensionnement des panneaux

  • Pour réduire ou agrandir un panneau, un groupe de panneaux ou une pile de panneaux, cliquez deux fois sur un onglet. Vous pouvez également double-cliquer sur la zone d’onglets (l’espace vide situé à côté des onglets).

  • Pour redimensionner un panneau, faites glisser l’un de ses côtés. Cette méthode de redimensionnement ne fonctionne pas toujours, notamment avec le panneau Couleur de Photoshop.

Réduction et développement des icônes de panneaux

Vous pouvez réduire des panneaux à la taille d’icônes afin de limiter l’encombrement de l’espace de travail. Dans certains cas, les panneaux sont réduits de la sorte dans l’espace de travail par défaut.

Panneaux réduits à la taille d’icônes
Panneaux réduits à la taille d’icônes

Panneaux agrandis
Panneaux agrandis

  • Pour réduire ou développer toutes les icônes de panneau d’une colonne, cliquez sur la double flèche située dans la partie supérieure du dock.

  • Pour développer une seule icône de panneau, cliquez sur cette dernière.

  • Pour redimensionner les icônes de panneau afin de voir les icônes uniquement (et non les libellés), réglez la largeur du dock jusqu’à ce que le texte ne soit plus visible. Pour afficher à nouveau le texte, augmentez la largeur du dock.

  • Pour réduire à la taille d’une icône un panneau qui a été développé, cliquez sur son onglet, sur son icône ou sur la double flèche affichée dans sa barre de titre.

Remarque :

Dans certaines applications, si vous sélectionnez l’option Réduction automatique des panneaux en icône dans les préférences d’interface ou les options d’interface utilisateur, une icône de panneau développée est réduite automatiquement lorsque vous cliquez en dehors de cette dernière.

  • Pour ajouter un panneau flottant ou un groupe de panneaux à un dock d’icônes, faites-le glisser au moyen de son onglet ou de sa barre de titre (les panneaux sont réduits automatiquement à la taille d’icônes lorsque vous les ajoutez à un dock d’icônes).
  • Pour déplacer une icône de panneau (ou un groupe d’icônes de panneau), faites-la glisser. Vous pouvez déplacer des icônes de panneau vers le haut et vers le bas dans le dock, dans d’autres docks (elles apparaissent dans le style du panneau de ce dock) ou en dehors du dock (elles apparaissent sous la forme d’icônes flottantes).

Création d’espaces de travail personnalisés

En enregistrant la taille et la position actuelles des panneaux comme espace de travail nommé, vous gardez la possibilité de restaurer cet espace par la suite, et ce, même si vous avez déplacé ou fermé un panneau. Les noms des espaces de travail enregistrés sont visibles dans le sélecteur d’espace de travail de la barre d’outils du document.

Pour enregistrer un espace de travail personnalisé :

  1. Sélectionnez Fenêtre > Présentation de l’espace de travail > Nouvel espace de travail.
  2. Attribuez un nom à l’espace de travail.
L’espace de travail est enregistré et apparaît dans le sélecteur d’espace de travail de la barre d’outils du document.

Pour supprimer un espace de travail personnalisé :

Pour ouvrir la boîte de dialogue Gérer les espaces de travail, sélectionnez l’option Gérer les espaces de travail dans le sélecteur d’espace de travail de la barre d’application. Sélectionnez l’espace de travail, puis cliquez sur Supprimer.

Affichage de l’espace de travail ou basculement d’un espace de travail à l’autre

  1. Sélectionnez un espace de travail dans le sélecteur d’espace de travail de la barre d’application.

Affichage de documents à onglets (Mac uniquement)

Vous pouvez afficher plusieurs documents dans une seule fenêtre de document avec des onglets qui identifient chacun des documents. Vous pouvez aussi les afficher sous la forme d’une partie de l’espace de travail flottant dans laquelle chaque document s’affiche dans sa propre fenêtre.

Ouverture d’un document à onglets dans une fenêtre séparée

Cliquez en maintenant la touche Ctrl enfoncée sur l’onglet, puis sélectionnez Déplacer dans une nouvelle fenêtre dans le menu contextuel.

Modification du paramètre de document à onglets par défaut

  1. Sélectionnez Dreamweaver > Préférences, puis la catégorie Général.
  2. Sélectionnez ou désélectionnez Ouvrir les documents dans des onglets, puis cliquez sur OK.

Dreamweaver ne modifie pas l’affichage des documents ouverts lorsque vous modifiez les préférences. En revanche, une fois que vous avez sélectionné une nouvelle préférence, les documents ouverts s’affichent en fonction de cette dernière.

L’écran d’accueil s’affiche lorsque vous démarrez Dreamweaver ou lorsqu’aucun document n’est ouvert. Vous pouvez masquer l’écran d’accueil puis l’afficher de nouveau ultérieurement selon vos besoins. Lorsque l’écran d’accueil est masqué et qu’aucun document n’est ouvert, la fenêtre de document est vide.

À propos de la personnalisation de Dreamweaver dans les systèmes multiutilisateurs

Dreamweaver peut être personnalisé selon les besoins, même dans les systèmes multiutilisateurs tels que Windows XP ou Mac OS X.

Dreamweaver empêche que la configuration personnalisée d’un utilisateur n’affecte celle d’un autre. Pour ce faire, la première fois que vous exécutez Dreamweaver sur l’un des systèmes multiutilisateurs reconnus, l’application crée des copies de différents fichiers de configuration. Ces fichiers sont enregistrés dans un dossier vous appartenant.

Par exemple, sous Windows XP, ils se trouvent dans C:\Documents and Settings\nom d’utilisateur\Application Data\Adobe\Dreamweaver\fr_FR\Configuration, qui est caché par défaut. Pour afficher les fichiers et dossiers cachés, choisissez Outils > Options des dossiers dans l’Explorateur Windows, cliquez sur l’onglet Affichage, puis activez l’option Afficher les fichiers et dossiers cachés.

Sous Windows Vista, ils se trouvent dans C:\Utilisateurs\nom d’utilisateur\AppData\Roaming\Adobe\Dreamweaver \fr_FR\Configuration, qui est caché par défaut. Pour afficher les fichiers et dossiers cachés, choisissez Outils > Options des dossiers dans l’Explorateur Windows, cliquez sur l’onglet Affichage, puis activez l’option Afficher les fichiers et dossiers cachés.

Sous Mac OS X, ils sont situés dans votre dossier personnel, dans Utilisateurs/nom_utilisateur/Bibliothèque//Application Support/Adobe/Dreamweaver/Configuration.

Si vous réinstallez ou mettez Dreamweaver à jour, Dreamweaver crée automatiquement des copies de sauvegarde des fichiers de configuration existants. Ainsi, si vous avez personnalisé manuellement ces fichiers, vos modifications restent disponibles.

Définition des préférences générales de Dreamweaver

  1. Choisissez Édition > Préférences (Windows) ou Dreamweaver > Préférences (Macintosh).
  2. Parmi les options suivantes, définissez celles de votre choix :

    Ouvrir les documents dans des onglets

    Permet d’ouvrir tous les documents dans une seule fenêtre contenant des onglets que vous utilisez pour passer d’un document à l’autre (Macintosh uniquement).

    Afficher l’écran d’accueil

    Affiche l’écran d’accueil de Dreamweaver lorsque vous démarrez Dreamweaver ou qu’aucun document n’est ouvert.

    Rouvrir les documents au démarrage

    Ouvre tous les documents qui étaient ouverts lorsque vous avez fermé Dreamweaver. Si cette option n’est pas sélectionnée, Dreamweaver affiche l’écran d’accueil ou un écran vide au démarrage (selon les paramètres définis pour l’option Afficher l’écran d’accueil).

    Avertir à l’ouverture de fichiers en lecture seule

    Vous informe lorsque le fichier que vous ouvrez est en lecture seule (verrouillé). Vous pouvez déverrouiller/extraire le fichier, l’afficher en lecture seule ou annuler l’action.

    Activer les fichiers associés

    Permet de savoir quels fichiers sont associés au document actuel (par exemple des fichiers CSS ou JavaScript). Dreamweaver affiche un bouton pour chaque fichier associé en haut du document. Si vous cliquez sur l’un de ces boutons, le fichier correspondant est ouvert.

    Découvrir les fichiers à association dynamique

    Permet d’indiquer si les fichiers à association dynamique doivent apparaître automatiquement dans la barre d’outils Fichiers associés, ou uniquement après une interaction manuelle. Vous pouvez également désactiver la recherche de fichiers à association dynamique.

    Mettre à jour les liens lors de la suppression de fichiers

    Détermine ce qui se passe lorsque vous déplacez, renommez ou supprimez un document dans un site. Vous pouvez définir cette préférence de trois façons différentes: les liens sont toujours automatiquement mis à jour, les liens ne sont jamais mis à jour ou un message vous demande s’il convient d’exécuter une mise à jour (Voir Mettre les liens à jour automatiquement.)

    Afficher la boîte de dialogue lors de l’insertion d’un objet

    Détermine si Dreamweaver vous invite à entrer des informations supplémentaires lorsque vous insérez des images, des tableaux, des animations Shockwave et certains autres objets à l’aide du panneau Insertion ou du menu Insertion. Si cette option est désactivée, aucune boîte de dialogue ne s’affiche ; dans ce cas, précisez le fichier source pour les images, le nombre de lignes dans un tableau, etc. dans l’inspecteur Propriétés. Lorsque vous insérez des images avec effet de survol ou du code HTML Fireworks, une boîte de dialogue s’affiche toujours, quel que soit le réglage de cette option. (Pour remplacer temporairement ce paramètre, appuyez sur la touche Ctrl (Windows) ou Commande (Macintosh) tout en cliquant avec la souris lorsque vous créez et insérez des objets.)

    Activer l’entrée en ligne à deux octets

    Permet d’entrer un texte à deux octets directement dans la fenêtre de document, si vous utilisez un environnement de développement ou un kit linguistique facilitant la saisie de texte à deux octets (les caractères japonais, par exemple). Si cette option est désélectionnée, une fenêtre de saisie de texte s’affiche, dans laquelle vous entrez et convertissez le texte à deux octets ; le texte apparaît dans la fenêtre de document après avoir été accepté.

    Passer en paragraphe normal après le titre

    Indique qu’en appuyant sur la touche Entrée (Windows) ou Retour (Macintosh) à la fin d’un paragraphe de titre en mode Création ou En direct, vous créez un nouveau paragraphe indiqué par une balise p (un paragraphe de titre est indiqué par une balise de titre, telle que h1 ou h2). Lorsque cette option est désactivée, en appuyant sur la touche Entrée ou Retour à la fin d’un paragraphe de titre, vous créez un nouveau paragraphe indiqué par la même balise de titre (ce qui vous permet de saisir plusieurs titres à la suite les uns des autres, puis d’ajouter les détails ultérieurement).

    Autoriser plusieurs espaces consécutifs

    Indique qu’en entrant deux espaces ou plus en mode Création ou En direct, vous créez des espaces insécables qui s’affichent sous forme de plusieurs espaces dans un navigateur (par exemple, vous pouvez taper deux espaces entre les phrases, tout comme vous le faites sur une machine à écrire). Cette option est conçue principalement pour les personnes qui utilisent les traitements de texte. Lorsque cette option est désactivée, les espaces multiples sont traités comme des espaces simples (car les navigateurs traitent les espaces multiples comme des espaces simples).

    Utiliser <strong> et <em> au lieu de <b> et <i>

    Détermine que Dreamweaver applique la balise strong lorsque vous effectuez une action qui appliquerait normalement la balise b, et la balise em lorsque vous effectuez une action qui appliquerait normalement la balise i. Ces actions incluent notamment le fait de cliquer sur les boutons Gras ou Italique de l’inspecteur Propriétés de texte en mode HTML et de choisir Format > Style > Gras ou Format > Style > Italique. Pour utiliser les balises b et i dans vos documents, désélectionnez cette option.

    Remarque :

    le World Wide Web Consortium recommande d’éviter les balises b et i ; les balises strong et em fournissent des informations plus sémantiques que les balises b et i.

    Avertir lors du placement de régions modifiables dans des balises <p> ou <h1> - <h6>

    Indique si un message d’avertissement s’affiche lorsque vous enregistrez un modèle Dreamweaver présentant une région modifiable dans une balise de paragraphe ou d’en-tête. Le message vous informe que les utilisateurs ne pourront pas créer de paragraphes supplémentaires dans la région. Cette option est activée par défaut.

    Centrer

    Spécifie si vous voulez centrer des éléments à l’aide de la balise div align="center" ou de la balise center lorsque vous cliquez sur le bouton Centrer de l’inspecteur Propriétés.

    Remarque :

    l’utilisation de ces deux méthodes de centrage n’est plus recommandée depuis les spécifications de HTML 4.01. Il est conseillé d’utiliser les feuilles de style CSS. Ces méthodes sont encore techniquement applicables à la spécification XHTML 1.0 transitionnel, mais ne sont plus reconnues dans les spécifications XHTML 1.0 Strict.

    Nombre maximum d’étapes d’historique

    Détermine le nombre maximal d’étapes que le panneau Historique conserve et affiche. (la valeur par défaut doit être suffisante pour la plupart des utilisateurs). Si le nombre d’étapes dépasse la valeur indiquée, les étapes les plus anciennes sont supprimées.

    Pour plus d’informations, voir Automatisation des tâches.

    Dictionnaire orthographique

    Affiche la liste des dictionnaires disponibles. Si un dictionnaire contient plusieurs dialectes ou conventions orthographiques (par exemple, l’anglais britannique et l’anglais américain), les dits dialectes sont répertoriés individuellement dans le menu contextuel Dictionnaire.

Définition des préférences de police pour les documents sous Dreamweaver

Le codage d’un document détermine la façon dont le document s’affiche dans un navigateur. Les préférences de polices de Dreamweaver vous permettent d’utiliser un texte affiché dans la police et la taille de votre choix. Toutefois, les polices sélectionnées dans la boîte de dialogue Préférences des polices n’influent que sur la façon dont les documents s’affichent sous Dreamweaver. Elles n’ont aucun impact sur la façon dont ils s’affichent dans le navigateur d’un visiteur. Pour modifier la façon dont les polices s’affichent dans un navigateur, vous devez modifier le texte à l’aide de l’inspecteur Propriétés ou en appliquant une règle CSS.

Pour plus d’informations sur la définition du codage par défaut des nouveaux documents, voir Création et ouverture de documents.

  1. Cliquez sur Édition > Préférences (Windows) ou Dreamweaver > Préférences (Macintosh).
  2. Sélectionnez la catégorie Polices dans la liste de gauche.
  3. Sélectionnez le type de codage désiré (par exemple, Occidental ou Japonais) dans la liste Paramètres de la police.

    Remarque :

    pour afficher un document en langue asiatique, il est indispensable que votre système d’exploitation prenne en charge les polices à deux octets.

  4. Sélectionnez une police et un format à utiliser pour chaque catégorie du codage sélectionné.

    Remarque :

    pour qu’une police apparaisse dans les menus contextuels correspondants, il est indispensable de l’installer sur votre ordinateur. Par exemple, si vous souhaitez visualiser un texte rédigé en japonais, il vous faut installer un jeu de caractères japonais au préalable.

    Proportionnelle

    La police proportionnelle est utilisée par Dreamweaver pour afficher du texte normal (par exemple, un texte contenu dans des paragraphes, des en-têtes et des tableaux). La valeur par défaut varie en fonction des polices installées sur votre système. Pour la plupart des systèmes français, la police proportionnelle par défaut est Times New Roman 12 pt (moyen) sous Windows et Times 12 pt sous Mac OS.

    Police fixe

    La police fixe est utilisée par Dreamweaver pour afficher du texte dans les balises pre, code et tt. La valeur par défaut varie en fonction des polices installées sur votre système. Pour la plupart des systèmes français, la police fixe par défaut est Courier New 10 pt (petit) sous Windows et Monaco 12 pt sous Mac OS.

    Mode Code

    Police utilisée dans tout le texte qui apparaît dans le mode d’affichage Code et dans l’inspecteur de code. La valeur par défaut varie en fonction des polices installées sur votre système.

Personnalisation des couleurs de surbrillance de Dreamweaver

Les préférences de surbrillance servent à personnaliser les couleurs utilisées sous Dreamweaver pour identifier les zones d’un modèle, les éléments d’une bibliothèque, les balises tierces, les éléments de mise en forme et le code.

Modification de la couleur de surbrillance

  1. Choisissez Édition > Préférences, puis la catégorie Surbrillance.
  2. Cliquez sur le sélecteur de couleur située près de l’objet dont vous souhaitez modifier la couleur de surbrillance, puis utilisez la palette de couleur pour sélectionner une nouvelle couleur. Vous pouvez également saisir une valeur hexadécimale.

Activation ou désactivation de la surbrillance d’un objet

  1. Choisissez Édition > Préférences, puis la catégorie Surbrillance.
  2. Cochez ou décochez l’option Afficher située près de l’objet dont vous souhaitez activer ou désactiver la couleur de surbrillance.

Restauration des préférences par défaut

Pour connaître les procédures de rétablissement des préférences par défaut de Dreamweaver, voir la Tech Note 83912.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne