Po optimalizaci můžete grafiku nebo dokument exportovat (nebo uložit, podle typu původního souboru).

Dokument můžete exportovat (nebo v některých případech uložit) jako jeden obraz v souboru GIF, JPEG nebo v jiném grafickém formátu. Můžete také exportovat celý dokument jako soubor HTML a přidružené obrazové soubory, pouze vybrané řezy nebo zadanou oblast. Kromě toho můžete exportovat stavy a vrstvy aplikace Fireworks jako samostatné obrazové soubory.

Standardní umístění, do kterého Fireworks exportuje soubory, je určeno následovně (v tomto pořadí):

  1. Současné předvolby exportu dokumentu, které jsou definované, pokud jste již někdy dokument exportovali a pak uložili soubor PNG.

  2. Současné umístění exportu/uložení, které je definováno pokaždé, když procházíte z výchozího umístění v dialogových oknech Uložit, Uložit jako nebo Exportovat

  3. Umístění aktuálního souboru

  4. Výchozí umístění, kam jsou ukládány nové dokumenty nebo obrazy ve vašem operačním systému

    Standardní umístění, do kterého Fireworks ukládá dokumenty, je ale určeno jinými kritérii. Další informace najdete v části Uložení souborů Fireworks.

Export stránek jako obrazových souborů

  1. Vyberte Soubor > Exportovat.

  2. Vyberte místo pro exportované soubory.

  3. Proveďte jednu z následujících akcí:

    • V rozbalovací nabídce Export vyberte možnost Pouze obrazy a pak zaškrtněte políčko Pouze současná stránka nebo jeho zaškrtnutí zrušte. Stránky jsou exportovány do formátu obrazu nastaveného na panelu Optimalizace.

    • Z rozbalovací nabídky Exportovat vyberte možnost Stránky na soubory a v rozbalovací nabídce Exportovat jako vyberte možnost Obrazy. Stránky jsou exportovány do formátu obrazu nastaveného na panelu Optimalizace.

    • Z rozbalovací nabídky Exportovat vyberte Stránky na soubory a vyberte Fireworks PNG v rozbalovací nabídce Exportovat jako. Každá stránka je exportována jako samostatný soubor PNG, který je zpětně kompatibilní s aplikací Fireworks 8.

    Poznámka:

    Chcete-li exportovat všechny stránky ve vybraném formátu, vyberte všechny stránky a potom optimalizujte nastavení.

Export jednoho obrazu

Pokud pracujete s existujícím obrazem, který jste otevřeli ve Fireworks, můžete ho místo exportu uložit. Další informace naleznete v části Ukládání dokumentů v jiných formátech .

Poznámka:

Chcete-li exportovat pouze určité obrazy v dokumentu, musíte nejdříve dokument rozdělit na řezy a exportovat pouze požadované řezy.

  1. Na panelu Optimalizace vyberte formát souboru a nastavte možnosti specifické pro daný formát.

  2. Vyberte Soubor > Exportovat.

  3. Vyberte umístění, do kterého chcete obrazový soubor exportovat.

    Pro webovou grafiku je nejlepším umístěním většinou složka v lokálním webovém místě.

  4. Zadejte název souboru bez přípony. Přípona bude přidána během exportu na základě typu souboru.

  5. V rozbalovací nabídce Exportovat vyberte příkaz Pouze obrazy.

  6. Klepněte na Uložit.

Export dokumentu rozděleného na řezy

Standardně se při exportu dokumentu Fireworks rozděleného na řezy exportuje soubor HTML a související obrazy. Exportovaný soubor HTML lze zobrazit ve webovém prohlížeči nebo importovat do jiných aplikací pro další úpravy.

Před exportem se ujistěte, že jste v dialogovém okně Nastavení HTML vybrali odpovídající styl HTML. Viz část Nastavení voleb exportu HTML.

Export všech řezů

  1. Vyberte Soubor > Exportovat.

  2. Přejděte do složky na pevném disku, do které chcete exportovat.

  3. V rozbalovací nabídce Export vyberte možnost HTML a obrazy.

  4. Do pole Název souboru (Windows) nebo Uložit jako (Mac OS) zadejte název souboru.

  5. V rozbalovací nabídce HTML vyberte možnost Exportovat soubor HTML.

  6. V rozbalovací nabídce Řezy vyberte možnost Exportovat řezy.

  7. (Volitelně) Vyberte položku Uložit obrazy do podsložky.

  8. Klepněte na Uložit.

Export vybraných řezů

  1. Chcete-li vybrat více řezů, klepněte s klávesou Shift .

  2. Vyberte Soubor > Exportovat.

  3. Vyberte umístění, do kterého chcete exportované soubory uložit, například složku na místním webu.

  4. V rozbalovací nabídce Export vyberte možnost HTML a obrazy.

  5. Zadejte název souboru bez přípony. Přípona bude přidána během exportu na základě typu souboru.

    Pokud exportujete více řezů, Fireworks použije název, který zadáte jako kořenový název pro všechny exportované grafiky, kromě těch, které jste pojmenovali vlastním názvem pomocí panelu Vrstvy nebo inspektoru Vlastnosti.

  6. V rozbalovací nabídce Řezy vyberte možnost Exportovat řezy.

  7. Chcete-li exportovat pouze řezy, které jste vybrali před exportem, vyberte možnost Pouze vybrané řezy, a ověřte, že volba Zahrnout oblasti bez řezů není vybraná.

  8. Klepněte na Uložit.

Aktualizace řezu

Pokud jste již exportovali dokument rozdělený na řezy a následně jste provedli změny původního dokumentu v aplikaci Fireworks, můžete aktualizovat pouze obraz nebo řez, které se změnily. Pro usnadnění vyhledání náhradních řezů pro ně zadejte vlastní názvy.

  1. Skryjte řez a upravte oblast pod ním.

  2. Zobrazte řez znovu.

  3. Klepněte pravým tlačítkem myši (systém Windows) nebo s klávesou Control (systém Mac OS) na řez a vyberte možnost Exportovat vybraný řez.

  4. Vyberte stejnou složku jako pro původní řez, zadejte stejný základní název a klepněte na Uložit.

  5. Při dotazu na nahrazení existujícího souboru klepněte na OK.

    Poznámka:

    Neměňte ve Fireworks velikost řezu nad jeho originální velikost exportu, v dokumentu HTML by se po aktualizaci řezu mohly vyskytnout neočekávané důsledky.

Export animace

Až animaci vytvoříte a optimalizujete, můžete ji exportovat. Animaci můžete exportovat jako kterýkoli z následujících typů souborů:

Animované obrazy GIF

Animované obrazy GIF dávají nejlepší výsledky pro kliparty nebo kresby karikatur.

Flash SWF nebo Fireworks PNG (není nutný export)

Animaci exportujte jako soubor SWF, chcete-li ji importovat do aplikace Flash. Nebo vynechejte krok exportu a importujte zdrojový soubor Fireworks PNG přímo do aplikace Flash. Pomocí této přímé metody můžete importovat všechny vrstvy a stavy animace a pak je dále upravovat v aplikaci Flash. Viz Práce s aplikací Flash.

Více souborů

Export stavů nebo vrstev animace je užitečný, pokud máte mnoho symbolů pro stejný objekt na různých vrstvách. Můžete například exportovat reklamní proužek jako více souborů, pokud je každé písmeno v názvu společnosti animované v samostatné grafice. Viz část Export stavů nebo vrstev jako více souborů.

Pokud dokument obsahuje více než jednu animaci, můžete ke každé animaci vložit řezy a exportovat každou s jiným nastavením animace, například opakování nebo zpoždění snímku.

Export animovaného souboru GIF

  1. Zvolte Výběr > Odznačit, abyste odznačili všechny řezy a objekty, a jako formát souboru v panelu Optimalizace vyberte Animovaný GIF.

  2. Vyberte Soubor > Exportovat.

  3. Zadejte název souboru a vyberte cílové umístění.

  4. Klepněte na Uložit.

Export více animovaných souborů GIF s různým nastavením animace

  1. Klepněte s klávesou Shift na animace a tím vyberte všechny animace.

  2. Vyberte možnost Úpravy > Vložit > Obdélníkový řez nebo Mnohoúhelníkový řez.

  3. V poli zprávy klepněte na položku Více.

  4. Vyberte každý řez jednotlivě a pomocí panelu Stavy nastavte pro každý jiné nastavení.

  5. Vyberte všechny řezy, které chcete animovat, a jako formát souboru v panelu Optimalizace vyberte Animovaný GIF.

  6. Chcete-li řezy exportovat jednotlivě, klepněte pravým tlačítkem myši (systém Windows) nebo s klávesou Control (systém Mac OS) na řez a vyberte možnost Exportovat vybraný řez. V dialogovém okně Exportovat zadejte název každého souboru, vyberte umístění a klepněte na Uložit.

Export stavů nebo vrstev jako více souborů

Aplikace Fireworks může každý stav nebo vrstvu v dokumentu exportovat jako samostatný obrazový soubor, použije při tom nastavení optimalizace určené v panelu Optimalizace. Název vrstvy nebo stavu určuje název každého exportovaného souboru. Tato metoda exportu se někdy používá k exportu animací.

  1. Vyberte Soubor > Exportovat.

  2. Zadejte název souboru a vyberte cílovou složku.

  3. V rozbalovací nabídce Export vyberte možnost:

    Stavy do souborů

    Exportuje stavy jako více souborů.

    Vrstvy do souborů

    Exportuje vrstvy jako více souborů.

    Poznámka: Tato volba exportuje všechny vrstvy aktuálního stavu.

  4. Chcete-li automaticky oříznout každý exportovaný obraz tak, aby obsahoval pouze objekty v jednotlivých stavech, vyberte možnost Oříznout obrazy. Chcete-li místo toho zahrnout celé plátno (včetně prázdných oblastí pod objekty), zrušte výběr této možnosti.

  5. Klepněte na Uložit.

Export oblasti z dokumentu

  1. Na panelu nástrojů vyberte nástroj Export oblasti .

  2. Tažením vyznačte hranice výběru definující část dokumentu, která se má exportovat.

    Poznámka:

    Polohu hranice výběru můžete v průběhu tažení upravit. Se stisknutým tlačítkem myši stiskněte a podržte mezerník a pak přetáhněte hranici výběru na jiné místo na plátně. Po uvolnění mezerníku můžete pokračovat v kreslení hranic výběru.

    Když uvolníte tlačítko myši, exportovaná oblast zůstane vybraná.

  3. V případě potřeby změňte velikost exportované oblasti:

    • Chcete-li proporcionálně změnit hranice oblasti exportu, stiskněte klávesu Shift a přetáhněte úchyt myší.

    • Chcete-li změnit velikost ohraničovacího rámečku ze středového bodu, podržte klávesu Alt (systém Windows) nebo Option (systém Mac OS) a přetáhněte úchyt myší.

    • Chcete-li zachovat poměr stran a změnit velikost ohraničovacího rámečku ze středového bodu, podržte klávesy Alt a Shift (systém Windows) nebo Option a Shift (systém Mac OS) a přetáhněte úchyt myší.

  4. Poklepáním uvnitř hranic výběru exportované oblasti přejdete do Náhledu obrazu.

  5. Upravte nastavení v Náhledu obrazu a klepnete na Exportovat.

  6. Zadejte název souboru a vyberte cílovou složku.

  7. V rozbalovací nabídce Exportovat vyberte Pouze obrazy.

  8. Klepněte na Uložit.

    Poznámka:

    Chcete-li akci zrušit bez exportu, poklepejte vně hranice výběru exportované oblasti, stiskněte Escape nebo vyberte jiný nástroj.

Export do formátu HTML

Pokud neurčíte jinak, budete při exportu dokumentu aplikace Fireworks rozděleného na řezy exportovat soubor HTML a jeho obrazy. Chcete-li definovat, jak Fireworks exportuje HTML, použijte dialogové okno Nastavení HTML.

Fireworks generuje čisté HTML, které může číst většina webových prohlížečů a editorů HTML. Ve výchozím nastavení bude pro export použito kódování UTF-8.

Existuje mnoho různých způsobů, jak exportovat Fireworks HTML:

  • Exportujte soubor HTML, který můžete později upravit v editoru HTML.

  • Exportujte každou stránku v souboru Fireworks a rozdělte soubor HTML.

  • Zkopírujte kód HTML do schránky ve Fireworks a pak vložte tento kód přímo do existujícího dokumentu HTML.

  • Exportujte soubor HTML, otevřete ho v editoru HTML, ručně zkopírujte oddíly kódu do souboru a vložte tento kód do jiného dokumentu HTML.

  • HTML můžete exportovat také jako vrstvy CSS (Cascading Style Sheet) a jako XHTML.

  • Příkazem Aktualizovat HTML proveďte změny v souboru HTML, který jste předtím vytvořili.

    Aplikace Fireworks umožňuje exportovat HTML v obecném formátu a ve formátu Dreamweaver, Microsoft® FrontPage® a Adobe GoLive®.

    Poznámka: Adobe Dreamweaver sdílí těsné spojení s Fireworks. Fireworks exportuje HTML do aplikace Dreamweaver odlišně od exportu pro jiné editory HTML. Pokud exportujete soubor Fireworks HTML do aplikace Dreamweaver, vyhledejte informace v tématu Práce s aplikací Dreamweaver.

    Metoda exportu HTML Fireworks do dalších aplikací je ideální, pokud pracujete v týmovém prostředí. Tato metoda rozdělí pracovní postup do segmentů, aby jedna osoba mohla provést úlohu v jedné aplikaci a další mohla práci převzít později a použít jinou aplikaci.

Zahrnutí komentářů do exportovaného HTML

Komentář v souboru Fireworks HTML začíná znaky <!-- a končí znaky -->. Vše mezi těmito dvěma značkami není interpretováno jako kód HTML nebo JavaScript.

  1. Před exportem vyberte volbu Včetně komentářů HTML v záložce Obecné v dialogovém okně Nastavení HTML.

Výsledky exportu

Při exportu nebo kopírování souboru HTML z aplikace Fireworks se generují následující položky:

  • Kód HTML nezbytný k sestavení obrazů rozdělených na řezy a kód JavaScriptu, pokud dokument obsahuje interaktivní elementy. Fireworks HTML obsahuje odkazy na exportované obrazy a nastaví barvu pozadí webové stránky na barvu plátna.

  • Jeden nebo více obrazových souborů v závislosti na počtu řezů v dokumentu a na tom, kolik stavů zahrnete do tlačítek.

  • Soubor s názvem spacer.gif, pokud je to nutné. Spacer.gif je průhledný soubor GIF velikosti 1 x 1 obrazový bod, který aplikace Fireworks používá k opravě problémů s mezerami, když jsou obrazy rozdělené na řezy znovu sestaveny v tabulce HTML. Můžete zvolit, zda má Fireworks exportovat vymezovač (spacer).

  • Pokud exportujete libovolné rozbalovací nabídky, budou exportovány následující soubory: mm_css_menu.js a soubor .css obsahující kód rozbalovací nabídky CSS. Pokud rozbalovací nabídky obsahují podnabídky, exportuje se také soubor arrows.gif.

  • Pokud exportujete nebo kopírujete HTML do aplikace Dreamweaver, vytvoří se soubory s poznámkami, které usnadňují integraci Fireworks a Dreamweaver. Tyto soubory mají příponu .mno.

Export formátu Fireworks HTML

  1. Vyberte Soubor > Exportovat.

  2. Přejděte do složky na pevném disku, do které chcete exportovat.

  3. V rozbalovací nabídce Export vyberte možnost HTML a obrazy.

  4. Klepněte na tlačítko Volby a vyberte svůj editor HTML z rozbalovací nabídky Styl HTML v záložce Všeobecné dialogového okna Nastavení HTML. Pokud váš editor HTML není v seznamu, vyberte Obecný.

    Poznámka:

    Je důležité, abyste editor HTML vybrali jako styl HTML, aby interaktivní elementy, například tlačítka a efekty přechodu myší, po importu do editoru HTML fungovaly správně.

  5. Klepněte na tlačítko OK.

  6. V rozbalovací nabídce HTML vyberte možnost Exportovat soubor HTML.

  7. Pokud váš dokument obsahuje řezy, vyberte Exportovat řezy z rozbalovací nabídky Řezy.

  8. Chcete-li obrazy uložit do samostatné složky, vyberte možnost Uložit obrazy do podsložky. Můžete vybrat konkrétní složku nebo použít výchozí složku pro obrazy aplikace Fireworks.

  9. Pokud exportujete dokument Fireworks s více stranami, zrušte zaškrtnutí políčka Pouze současná stránka, aby se všechny stránky exportovaly do samostatných dokumentů HTML.

  10. Klepněte na Uložit.

    Po exportu uvidíte soubory, které aplikace Fireworks vyexportovala, na svém pevném disku. Obrazy a soubor HTML jsou vygenerovány v místě, které jste určili v dialogovém okně Exportovat.

Kopírování kódu HTML do schránky

Kód HTML můžete ve aplikaci Fireworks kopírovat do schránky jedním ze dvou způsobů. Můžete použít příkaz Kopírovat kód HTML nebo můžete v dialogovém okně Exportovat vybrat volbu Kopírovat do schránky. Později kód HTML vložíte do dokumentu v preferovaném editoru HTML.

Při rozhodování, jak vložit kód Fireworks HTML do jiných aplikací, zvažte následující nevýhody kopírování kódu HTML do schránky:

  • Nemáte možnost uložit obrazy do podsložky. Musí zůstat ve stejné složce jako soubor HTML, kam vložíte zkopírovaný HTML. Výjimkou je HTML kopírovaný do aplikace Dreamweaver.

  • Všechny odkazy nebo cesty použité v rozbalovacích nabídkách Fireworks budou mapovány na váš pevný disk. Výjimkou je HTML kopírovaný do aplikace Dreamweaver.

  • Pokud používáte jiný editor HTML než Dreamweaver nebo Microsoft FrontPage, kód JavaScriptu přidružený k tlačítkům, chováním a obrazům efektu přechodu se zkopíruje, ale nemusí fungovat správně.

    Pokud to pro vás představuje problém, použijte místo kopírování HTML do schránky volbu Exportovat HTML.

    Poznámka: Předtím, než kód HTML zkopírujete, se ujistěte, že jste vybrali odpovídající styl HTML a zvolili možnost Včetně komentářů HTML na záložce Obecné v dialogovém okně Nastavení HTML.

Kopírování kódu Fireworks HTML pomocí možnosti Kopírovat kód HTML

  1. Vyberte Úpravy > Kopírovat kód HTML.

  2. Postupujte podle pokynů v průvodci. Po zobrazení příslušné výzvy určete cílovou složku pro exportované obrazy. Musí to být umístění, kde bude uložený váš soubor HTML.

    Poznámka:

    Pokud se chystáte vložit kód HTML do aplikace Dreamweaver, nezáleží na tom, kam obrazy exportujete, pokud budou uloženy do stejného webového místa aplikace Dreamweaver jako soubor HTML, do kterého vložíte kód.

Kopírování kódu Fireworks HTML pomocí dialogového okna Exportovat

  1. Vyberte Soubor > Exportovat.

  2. V dialogovém okně Exportovat, určete složku jako cíl pro exportované obrazy. Musí to být stejné umístění, ve kterém bude uložený soubor HTML.

    Poznámka:

    Pokud se chystáte vložit kód HTML do aplikace Dreamweaver, nezáleží na tom, kam obrazy exportujete, pokud budou uloženy do stejného webového místa aplikace Dreamweaver jako soubor HTML, do kterého vložíte kód.

  3. V rozbalovací nabídce Export vyberte možnost HTML a obrazy.

  4. V rozbalovací nabídce HTML vyberte možnost Kopírovat do schránky.

  5. Pokud váš dokument obsahuje řezy, vyberte Exportovat řezy z rozbalovací nabídky Řezy.

  6. Klepněte na tlačítko Volby, vyberte editor HTML z dialogového okna Nastavení HTML a klepněte na tlačítko OK.

  7. Klepněte na Uložit.

Načtení kódu HTML kopírovaného z aplikace Fireworks do dokumentu HTML

  1. Ve svém editoru HTML otevřete existující dokument HTML nebo vytvořte nový. Uložte dokument do stejného umístění, do kterého jste exportovali obrazy.

    Poznámka:

    Pokud používáte Dreamweaver, není nutné uložit soubor HTML do stejného umístění jako exportované obrazy. Pokud exportujete obrazy z aplikace Fireworks na web aplikace Dreamweaver a uložíte soubor HTML do umístění na tomto webu, aplikace Dreamweaver automaticky přeloží cesty k přidruženým obrazům.

  2. Zobrazte kód HTML a umístěte ukazatel mezi značky <BODY>.

    Poznámka:

    Kód HTML kopírovaný z aplikace Fireworks neobsahuje počáteční nebo koncové značky <HTML> a <BODY>.

  3. Vložte kód HTML.

    Pokud je to při kopírování do schránky možné, exportujte obrazy do umístění, ve kterém budou uloženy na webu. Fireworks používá URL relativní k dokumentu, takže když se HTML nebo obrazy přesunou, odkazy URL se přeruší.

Kopírování kódu z exportovaného souboru aplikace Fireworks a vložení do jiného dokumentu HTML

  1. Otevřete exportovaný soubor HTML z Fireworks v editoru HTML.

  2. Zvýrazněte potřebný kód a zkopírujte ho do schránky.

  3. Otevřete existující dokument HTML nebo vytvořte nový.

  4. Vložte kód do nového souboru HTML. Značky <HTML> a <BODY> nemusíte kopírovat, protože by měly být již součástí cílového dokumentu HTML.

    Pokud zvolíte Včetně komentářů HTML v dialogovém okně Nastavení HTML ve Fireworks, postupujte podle pokynů v komentářích a zkopírujte a vložte kód do příslušného umístění.

  5. Pokud dokument aplikace Fireworks obsahuje interaktivní prvky, zkopírujte kód jazyka JavaScript.

    Kód jazyka JavaScript je obklopen značkami <SCRIPT> a je umístěn v oddílu <HEAD> dokumentu. Zkopírujte a vložte celý oddíl <SCRIPT>, pokud cílový dokument oddíl <SCRIPT> dosud nemá. V takovém případě byste měli zkopírovat a vložit pouze obsah oddílu <SCRIPT> do existujícího oddílu <SCRIPT>. Buďte přitom opatrní a nepřepište obsah existujícího oddílu. Zajistěte také, aby po vložení kódu nebyly některé funkce JavaScriptu v oddílu <SCRIPT> duplikované.

Aktualizace exportovaného kódu HTML

Aktualizace umožňuje provést změny dokumentu HTML aplikace Fireworks, který jste dříve exportovali, a je užitečná, pokud potřebujete aktualizovat pouze část dokumentu.

Poznámka:

Aktualizovaný HTML funguje u dokumentů aplikace Dreamweaver jinak než u ostatních dokumentů HTML. Další informace najdete v tématu Práce s aplikací Dreamweaver.

Při aktualizaci můžete nahradit pouze obrazy, které se změnily, nebo přepsat kód všech obrazů. Pokud necháte nahradit pouze obrazy, které se změnily, zachovají se všechny změny provedené v souboru HTML vně Fireworks.

Poznámka:

V případě rozsáhlých změn v rozvržení dokumentu proveďte změny ve Fireworks a exportujte znovu soubor HTML.

  1. Vyberte Soubor > Aktualizovat HTML.

  2. Vyberte soubor, který chcete aktualizovat.

  3. Klepněte na Otevřít.

  4. Proveďte jednu z následujících akcí:

    • Pokud se nenajde žádný HTML generovaný ve Fireworks, klepněte na OK, abyste na konec dokumentu vložili nový HTML.

    • Pokud se HTML generovaný ve Fireworks najde, vyberte jednu z následujících voleb a klepněte na OK:

      Nahradit obrazy a jejich HTML

      Nahradí předcházející kód HTML aplikace Fireworks.

      Aktualizovat jen obrazy

      Přepíše pouze obrazy.

  5. Pokud se zobrazí dialogové okno Vybrat složku s obrazy, vyberte složku a klepněte na Otevřít.

Exportovat vrstvy CSS

Vrstvy CSS mohou přesahovat jedna druhou a být navrstveny přes sebe. Ve Fireworks normální výstup HTML nemá přesahy.

  1. Vyberte Soubor > Exportovat.

  2. Zadejte název souboru a vyberte cílovou složku.

  3. V místní nabídce Export vyberte možnost CSS a obrazy.

    • Chcete-li exportovat pouze aktuální stav, vyberte možnost Pouze aktuální stav.

    • Chcete-li exportovat pouze aktuální stránku, vyberte možnost Pouze aktuální stránka.

    • Chcete-li zvolit složku pro obrazy, klepněte na možnost Uložit obrazy do podsložky.

  4. Klepnutím na položku Volby nastavíte vlastnosti stránky HTML.

  5. Klepněte na možnost Procházet, chcete-li zadat obraz pozadí a nastavit jeho dlaždicové opakování:

    • Výběrem možnosti Neopakovat zobrazíte obraz pouze jedenkrát.

    • Pokud vyberete volbu Opakovat, obraz se bude dlaždicově opakovat ve vodorovném i svislém směru.

    • V případě, že vyberete volbu Opakovat-x, obraz se bude dlaždicově opakovat ve vodorovném směru.

    • Pokud vyberete volbu Opakovat-y, obraz se bude dlaždicově opakovat ve svislém směru.

  6. Vyberte zarovnání stránky v prohlížeči z možností vlevo, na střed a vpravo.

  7. Klepněte na OK a pak klepněte na Uložit.

Export kódu XHTML

XHTML je kombinace HTML, současného standardu pro formátování a zobrazování webových stránek, a XML (Extensible Markup Language). XHTML je nejen zpětně kompatibilní, což znamená, že většina současných webových prohlížečů ho může zobrazit, ale také ho může číst libovolné zařízení, které zobrazuje obsah XML, například zařízení PDA, mobilní telefony a ostatní přenosná zařízení.

Fireworks může XHTML také importovat. Viz část Vytváření souborů Fireworks PNG ze souborů HTML.

Další informace o formátu XHTML najdete ve specifikacích XHTML sdružení World Wide Web Consortium (W3C) na webu www.w3.org.

  1. Vyberte možnosti Soubor > Nastavení HTML, vyberte styl XHTML z rozbalovací nabídky Styl HTML v záložce Obecné a klepněte na tlačítko OK.

  2. Exportujte dokument pomocí libovolné metody dostupné pro export nebo kopírování HTML. Viz část Export do formátu HTML.

    Poznámka:

    Fireworks při exportu do XHTML používá kódování UTF-8.

Export souborů s kódováním a bez kódování UTF-8

UTF-8 (Universal Character Set Transformation Format-8) je metoda kódování textu, která webovým prohlížečům umožňuje zobrazit různé znakové sady (například čínský a anglický text) na stejné stránce HTML. Kódování UTF-8 je standardně zapnuto.

Fireworks také může importovat dokumenty, které používají kódování UTF-8. Viz část Vytváření souborů Fireworks PNG ze souborů HTML.

Export dokumentů bez kódování UTF-8

  1. Vyberte Soubor > Nastavení HTML.

  2. Na záložce Specifické pro dokument zrušte zaškrtnutí políčka kódování UTF-8 a klepněte na tlačítko OK.

  3. Exportujte dokument pomocí libovolné metody dostupné pro export nebo kopírování HTML.

Nastavení voleb exportu HTML

Dialogové okno Nastavení HTML umožňuje definovat, jak Fireworks exportuje HTML. Změny provedené na kartě Specifické pro dokument ovlivňují pouze aktuální dokument. Nastavení Všeobecné a Tabulka jsou globální předvolby a ovlivní všechny nové dokumenty.

  1. Proveďte jednu z následujících akcí:

    • Vyberte Soubor > Nastavení HTML.

    • Klepněte na tlačítko Volby v dialogovém okně Export.

  2. Na kartě Obecné vyberte preferované možnosti.

    Styl HTML

    Vyberte styl exportovaného HTML.

    Obecný HTML funguje v libovolném editoru HTML. Nicméně pokud váš dokument obsahuje chování nebo jiný interaktivní obsah, vyberte svůj specifický editor, pokud se zobrazuje v seznamu.

    Chcete-li svůj dokument exportovat pomocí standardu XHTML, vyberte příslušné styly XHTML z rozbalovací nabídky.

    Přípona

    Vyberte příponu souboru z rozbalovacího nabídky nebo zadejte novou.

    Včetně komentářů HTML

    Výběrem této možnosti zahrnete komentáře o tom, kam se má v HTML kopírovat a vkládat. Tato volba se doporučuje, pokud dokument obsahuje interaktivní prvky, například tlačítka, chování nebo obrazy efektu přechodu myší.

    Název souboru malými písmeny

    Tuto možnost vyberte, pokud má být název souboru HTML a přidružených obrazových souborů při exportu uveden malými písmeny.

    Poznámka: Tato možnost nezmění příponu souboru HTML na malá písmena, pokud byla v rozbalovací nabídce Přípona vybrána velká písmena.

    Použít CSS pro rozbalovací nabídky

    Výběrem této možnosti pro kód rozbalovacích nabídek použijete místo kódu v jazyce JavaScript kód CSS. K indexování nabídek i k aktualizaci odkazů v rámci kódu můžete použít aplikaci Dreamweaver.

    Zapsat CSS do externího souboru

    Výběrem této možnosti zapíšete kód CSS do externího souboru s příponou CSS, který bude exportován do stejného umístění jako soubor HTML. Název souboru .css se shoduje s názvem souboru HTML (kromě přípony souboru). Když vyberete tuto volbu, exportuje se také soubor s názvem mm_css_menu.js do stejného umístění jako soubor HTML.

    Poznámka: Tato možnost je k dispozici, pouze pokud jste vybrali možnost Použít CSS pro rozbalovací nabídky.

    Tvůrce souborů (Mac OS)

    Vyberte související aplikaci z rozbalovací nabídky. Když poklepete na exportovaný soubor HTML na svém pevném disku, automaticky se otevře ve vybrané aplikaci.

  3. v záložce Tabulka vyberte nastavení pro tabulky HTML. Další informace najdete v tématu Definování způsobu exportu tabulek HTML.

  4. V záložce Specifické pro dokument vyberte následující volby:

    Názvy souboru řezu

    Vyberte vzorec pro automatické pojmenování řezů v rozbalovacích nabídkách. Můžete použít standardní nastavení nebo zvolit vlastní volby.

    Poznámka: Pokud jako volbu pro kteroukoli ze tři prvních nabídek vyberete možnost Žádné, aplikace Fireworks vyexportuje soubory řezů, které se vzájemně přepisují, a výsledkem je jedna exportovaná grafika a tabulka, která zobrazuje tuto grafiku v každé buňce.

    Výchozí tag Alt

    Zadejte text, který se zobrazí místo všech obrazů stahovaných z webu a místo obrazů, které se nepodaří stáhnout. V některých prohlížečích se může zobrazit také jako tip, když ukazatel prochází přes obraz. To také pomáhá uživatelům webu se zrakovým postižením.

    Exportovat více stránek HTML navigačního pruhu (pro použití bez sad rámců)

    Tuto možnost vyberte při exportu navigačního panelu, který spojuje několik stránek. Aplikace Fireworks exportuje další stránky pro jednotlivá tlačítka na navigačním panelu.

    Zahrnout oblasti bez objektů řezu

    Vyberte tuto možnost, pokud chcete zahrnout oblasti plátna, které nejsou zakryty řezy.

    Kódování UTF-8

    Standardně zapnuto. Umožňuje exportovat zobrazené znaky dokumentu z více znakových sad. Chcete-li tuto možnost vypnout, zrušte zaškrtnutí políčka.

  5. Pokud chcete toto nastavení uložit jako globální výchozí nastavení, klepněte na možnost Nastavit výchozí..

Export souborů Adobe PDF

Pokud potřebujete vytisknout návrh aplikace Fireworks nebo jej distribuovat za účelem revize, exportujte jej do souboru Adobe PDF. Recenzenti mohou přidávat komentáře a odpovídat na komentáře ostatních v aplikacích Adobe Reader® a Acrobat®. Informace o nastavení revizí v dokumentech PDF najdete v nápovědě k aplikaci Acrobat.

V exportovaných souborech PDF zůstanou zachovány všechny stránky a hypertextové odkazy, což recenzentům umožňuje procházení stejným způsobem jako na webu. Na rozdíl od prototypů HTML však aplikace Adobe PDF poskytuje nastavení zabezpečení, které recenzentům zabrání v úpravách či kopírování návrhů.

  1. Zvolte Soubor > Exportovat.

  2. Z rozbalovací nabídky Exportovat vyberte Adobe PDF.

  3. Zvolte stránky pro export a výběrem možnosti Zobrazit PDF po exportu automaticky otevřete soubor PDF v aplikaci Adobe Reader nebo Acrobat.

  4. Chcete-li soubor PDF přizpůsobit, klepněte na položku Volby a pak upravte následující nastavení:

    Kompatibilita

    Určuje, které prohlížeče Adobe PDF mohou exportovaný soubor otevřít.

    Komprese

    Určuje typ komprese obrazu zmenšující velikost souboru. Všeobecně dává komprese JPEG a JPEG2000 lepší výsledky pro takové obrazy, jako jsou fotografie s postupnými přechody mezi barvami. Formát ZIP je vhodnější pro ilustrace s velkými plochami s plnými barvami bez barevných přechodů.

    Kvalita

    Pro kompresi JPEG nebo JPEG2000 nabízí nastavení kvality obrazu. Výběrem Vysoké kvality vytvoříte velký soubor s dobrou kvalitou obrazu.

    Převést na stupně šedi

    Převede všechny obrazy na stupně šedi, zároveň sníží velikost souboru.

    Aktivovat výběr textu

    Recenzenti mohou z exportovaného souboru kopírovat text. Zrušením této volby výrazně snížíte velikost souboru.

    Hodnota přesahu

    Určuje šířku prázdného okraje ohraničujícího obraz na jednotlivých stránkách v obrazových bodech. Například hodnota 20 ohraničí jednotlivé obrazy okrajem o šířce 20 obrazových bodů.

    Použít heslo pro otevření dokumentu

    Vyžaduje otvírací heslo pro otevření exportovaného souboru.

    Použít heslo pro omezení úloh

    Vyžaduje bezpečné heslo pro provádění těchto vybraných funkcí: Tisk, úprav, kopírování a komentáře.

  5. Klepnutím na tlačítko OK zavřete dialogové okno Volby.

  6. Zadejte název souboru a jeho umístění a klepněte na tlačítko Uložit.

    Poznámka:

    Pokud mají stránky v dokumentu aplikace Fireworks průhledné plátno, při exportu do PDF ztratí objekty s jakoukoli aplikovanou průhledností svoji průhlednost. Tomu zabráníte tak, že před exportem do PDF nastavíte u plátna neprůhledné pozadí.

Video

Create client proofs as PDF or HTML files using Fireworks (Vytváření klientských náhledů jako PDF nebo HTML pomocí aplikace Fireworks, 00:05:32)

Zjistěte, jak využít nabídku Fireworks Export k vytvoření dokumentu PDF nebo HTML pro schválení klientem nebo kontrolu v rámci týmu.

Tom Green

Při zobrazení exportovaných souborů PDF v programu Adobe Acrobat nebo Adobe Reader použijte následující nastavení:

  1. V programu Adobe Acrobat nebo Adobe Reader zvolte možnost Úpravy > Předvolby.

  2. V levém panelu vyberte možnost Zobrazení stránky.

  3. Možnost Vlastní rozlišení nastavte na hodnotu 72 pixelů na jeden palec.

  4. Hodnotu Zvětšení nastavte na 100 %.

Export do souborů FXG

FXG je souborový formát podporovaný aplikacemi Flash Catalyst, Fireworks, Illustrator a Photoshop. Když exportujete soubor s vektorovými nebo bitmapovými obrazy pomocí exportu FXG, vytvoří se samostatná složka s názvem <názevsouboru.datovézdroje>. Složka obsahuje bitmapové obrazy přidružené k souboru.

Pokud některý z přidružených souborů z této složky odstraníte, operace importu selže.

Poznámka:

Prvky, filtry, režimy prolnutí, přechody a masky, pro které není v souboru FXG odpovídající mapovací tag, se vyexportují jako bitmapová grafika.

  1. Vyberte příkaz Soubor > Exportovat a přejděte do umístění, do kterého chcete uložit soubory.

  2. Zadejte název pro soubor FXG.

  3. V dialogu Exportovat vyberte v nabídce Export možnost FXG a obrazy.

  4. Klepněte na Uložit.

Poznámka:

Objekty, které v aplikaci Fireworks přesahují přes plátno, se při otevření exportovaného FXG souboru v aplikaci Flash Catalyst nezobrazí.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online