• Vektory, bitmapy a animace Fireworks i grafiky pro tlačítka s více stavy můžete snadno importovat, kopírovat a vkládat nebo exportovat pro použití v aplikaci Adobe Flash®.

  • Text TLF z aplikace Flash je zkopírován jako prázdný bitmapový obraz do aplikace Fireworks spuštěné v systému Windows. Text TLF převeďte na text ASCII a importujte je do aplikace Fireworks.

  • Funkce spuštění a úprav usnadňuje úpravy grafik Fireworks z programu Flash. Při práci v programu Flash jsou vždy použity předvolby spuštění a úprav zadané v aplikaci Fireworks.

  • Styl HTML v programu Flash nepodporuje kód rozbalovacích nabídek. Chování tlačítek Fireworks a další typy interaktivity se do programu Flash neimportují.

Umístění grafik Fireworks do programu Flash

Import nebo kopírování souboru PNG Fireworks umožňuje nejlépe kontrolovat, jak jsou grafiky a animace přidány do programu Flash. Je možné také importovat soubory JPEG, GIF, PNG a SWF, které byly exportovány z aplikace Fireworks.

Poznámka:

Při importu nebo kopírování a vložení grafik Fireworks do programu Flash se některé atributy ztratí, například živé filtry a textury. Efekt přechodu obrysu nelze importovat ani kopírovat a vložit do dokumentu Flash z aplikace Fireworks. Flash podporuje pouze plné výplně, výplně přechodem a základní tahy.

Import souborů PNG Fireworks do programu Flash

Můžete importovat zdrojové soubory PNG Fireworks přímo do programu Flash a nemusíte je exportovat do jiného grafického formátu. Všechny vektory, bitmapy, animace a grafiky pro tlačítka s více stavy lze importovat z Fireworks do programu Flash.

Poznámka:

Chování tlačítek a další typy interaktivity Fireworks se do programu Flash neimportují, protože chování Fireworks jsou podporována JavaScriptem, který je mimo formát souboru. Flash používá interní kód ActionScript.

  1. Uložte dokument v aplikaci Fireworks.

  2. Přepněte do otevřeného dokumentu v programu Flash.

  3. (Volitelně) Klepněte na klíčový stav a vrstvu, do které chcete importovat obsah Fireworks.

  4. Vyberte Soubor > Importovat.

  5. Přejděte k souboru PNG a vyberte jej.

  6. V dialogovém okně Import dokumentu Fireworks proveďte jednu z následujících akcí:

    • Vyberte možnost Importovat jako jeden sloučený bitmapový obraz.

    • Vyberte volby importu ve dvou rozbalovacích nabídkách.

  7. Vyberte způsob importu textu.

  8. Klepněte na tlačítko OK.

    Poznámka:

    Vybrané možnosti v dialogovém okně Import dokumentu Fireworks jsou uloženy a použity jako výchozí nastavení.

Možnosti importu grafiky, vektorových objektů a textu z aplikace Fireworks

Volby importu grafiky

Importovat jako jeden sloučený bitmapový obraz

Importuje jeden obraz bez možnosti úprav.

Importovat všechny stránky do nových stavů jako filmové klipy

Importuje všechny stránky v souboru PNG do nové vrstvy Flash, která přebírá název tohoto souboru PNG. Klíčový stav se vytvoří v nové vrstvě v místě aktuálního stavu, první stránka souboru PNG se umístí jako filmový klip v tomto stavu a všechny ostatní stránky se umístí jako filmové klipy ve stavech následujících za tímto stavem. Hierarchie vrstev a stavy v souboru PNG zůstanou zachovány.

Importovat stránku 1 do aktuálního stavu jako filmový klip

Obsah vybrané stránky se importuje jako filmový klip, který je umístěn do aktivního stavu a vrstvy v souboru Flash. Hierarchie vrstev a stavy v souboru PNG zůstanou zachovány.

Importovat všechny stránky do nových scén jako filmové klipy

Importuje všechny stránky ze souboru PNG a mapuje každou z nich na novou scénu jako filmový klip. Všechny vrstvy a stavy uvnitř stránek zůstanou zachovány. Pokud již scény v souboru Flash existují, proces importu přidá nové scény za existující scény.

Importovat stránku 1 do nové vrstvy

Vybraná stránka se importuje jako nová vrstva. Stavy se do časové řady importují jako samostatné stavy.

Volby importu vektorových objektů

Importovat jako bitmapy, aby se zachoval vzhled

Zachová upravitelnost vektorových objektů, pokud nemají speciální výplně, tahy nebo efekty, které program Flash nepodporuje. Flash převede takové objekty na neupravitelné bitmapové obrazy, aby zachoval jejich vzhled.

Importovat jako upravitelné cesty

Zachová upravitelnost všech vektorových objektů. Pokud objekty obsahují speciální výplně, tahy nebo efekty, které program Flash nepodporuje, mohou tyto vlastnosti vypadat po importu jinak.

Volby importu textu

Importovat jako bitmapy, aby se zachoval vzhled

Zachová upravitelnost textu, pokud nemá speciální výplně, tahy nebo efekty, které program Flash nepodporuje. Flash převede takový text na neupravitelný bitmapový obraz, aby zachoval jeho vzhled.

Poznámka:

Text TLF z aplikace Flash je zkopírován jako prázdný bitmapový obraz do aplikace Fireworks.

Zachovat celý text upravitelný

Zachová upravitelnost celého textu. Pokud textové objekty obsahují speciální výplně, tahy nebo efekty, které program Flash nepodporuje, mohou tyto vlastnosti vypadat po importu jinak.

Kopírování nebo přetažení grafiky aplikace Fireworks do programu Flash

Při kopírování grafiky do starších verzí programu Flash, než je Flash 8, vyberte možnosti Úpravy > Kopírovat obrysy cesty.

Poznámka:

Může být nutné objekty rozdělit (Upravit > Rozdělit), aby je bylo možné ve programu Flash upravovat jako samostatné vektorové objety.

  1. Vyberte ve Fireworks objekty, které chcete kopírovat.

  2. Vyberte možnosti Úpravy > Kopírovat a v místní nabídce aplikace Flash klepněte na možnost Kopírovat.

  3. Vytvořte v programu Flash nový dokument a zvolte Úpravy > Vložit nebo soubor přetáhněte přímo z Fireworks do programu Flash.

  4. V dialogovém okně Importovat dokument Fireworks vyberte volbu Do:

    Aktuální stav jako filmový klip

    Vkládaný obsah se vkládá jako filmový klip, který je umístěn do aktivního stavu a vrstvy v souboru Flash. Hierarchie vrstev a stavy v souboru PNG zůstanou zachovány.

    Nová vrstva

    Vložený obsah se importuje jako nová vrstva. Stavy se do časové řady importují jako samostatné stavy.

  5. Vyberte způsob importu vektorových objektů.

  6. Vyberte způsob importu textu.

  7. Klepněte na tlačítko OK.

    Poznámka:

    Vybrané možnosti v dialogovém okně Import dokumentu Fireworks jsou uloženy a použity jako výchozí nastavení.

Struktura knihoven aplikace Flash

Objekty Fireworks se importují do složky objektů Fireworks v knihovně aplikace Flash. Tato složka má následující strukturu:

Složka Soubor 1 // Pojmenovaná podle názvu souboru Fireworks

  • Složka Stránka 1 // Pojmenovaná podle názvu stránky (pokud je více stránek)

    — Stránka 1 // Pojmenovaná podle názvu stránky

    — — Složka Stav 1 // Pojmenovaná podle názvu stavu (pokud je více stavů)

    — — Stav 1 // Pojmenovaná podle názvu stavu

    — — — Symbol 1 ve stavu 1 // Pojmenovaný podle názvu symbolu

    — — — Symbol 2 ve Stavu 1

    ...

    — Složka sdílených vrstev // Sdílené vrstvy ve stavech na stránce 1

    — — Složka sdílené vrstvy // Pojmenovaná podle názvu sdílené vrstvy

    — — Symbol sdílené vrstvy

  • Složka Stránka 2

    — Stránka 2

    — Symbol 1 na stránce 2 (Pro stránku bez stavů)

    ...

  • Složka vzorových stránek

    — Vzorová stránka

    — Symbol 1 na vzorové stránce

    ...

    — Složka sdílených vrstev // Sdílené vrstvy na stránkách

    — — Složka sdílené vrstvy // Pojmenovaná podle názvu sdílené vrstvy

    — — Symbol sdílené vrstvy

Import symbolů Fireworks do programu Flash

Při importu symbolů Fireworks do programu Flash zvažte následující okolnosti:

  • Pokud symbol používá měřítko s 9 řezy, jsou čtyři vodítka řezu importovány a zachovány v programu Flash. Měřítko s 9 řezy však není zachováno pro animace. Importované symboly se ukládají do knihovny aplikace Flash jako symboly.

  • Měkké úpravy aplikované na bohaté symboly se ztratí. Vzorová kopie daného symbolu se importuje.

  • Bohaté grafické symboly se ukládají jako soubor PNG a soubor JSF. Importuje se pouze soubor PNG. Pokud je daný symbol vytvořen z několika cest, sloučí se tyto cesty do jednoho symbolu.

  • Pokud chcete dosáhnout plné funkčnosti bohatých symbolů v programu Flash, nahraďte je verzí symbolu v programu Flash.

Zachování viditelnosti a zamknutí

Objekty a vrstvy, které jsou v souboru PNG skryté, se importují skryté a zůstávají v programu Flash skryté. Části bohatých grafických symbolů, které nejsou viditelné, se ale neimportují (například stavy tlačítek Přes a Dole).

Pokud je vrstva zamknutá nebo skrytá, zdědí toto nastavení všechny objekty a podvrstvy uvnitř vrstvy a zachovají ho při importu do programu Flash.

Pokud importujete jednu stránku do nové vrstvy v programu Flash, je vytvořena jedna vrstva pro celou stránku a jsou zobrazeny všechny objekty. Atributy viditelnosti a uzamčení nejsou zachovány.

Podporované efekty vrstev aplikace Photoshop

Živý efekt aplikace Photoshop – Vržený stín

Mapování je následující:

  • velikost se mapuje na blurX, blurY

  • vzdálenost se mapuje na vzdálenost

  • barva se mapuje na barvu

  • úhel se mapuje na 180 – (úhel efektu aplikace Photoshop)

Živý efekt aplikace Photoshop – Vnitřní stín

Mapování je následující:

  • velikost se mapuje na blurX, blurY

  • vzdálenost se mapuje na vzdálenost

  • barva se mapuje na barvu

  • úhel se mapuje na 180 – (úhel efektu aplikace Photoshop)

Živý efekt aplikace Photoshop – Vnější záře

Mapování je následující:

  • krytí je mapováno na sílu

  • barva se mapuje na barvu

  • velikost se mapuje na blurX, blurY

Živý efekt aplikace Photoshop – Vnitřní záře

Mapování je následující:

  • krytí je mapováno na sílu

  • barva se mapuje na barvu

  • velikost se mapuje na blurX, blurY

  • Objekty s libovolnými jinými efekty vrstev aplikace Photoshop se rastrují.

Export grafiky Fireworks do jiných formátů pro použití v programu Flash

Grafiky Fireworks můžete exportovat jako soubory JPEG, GIF, PNG a Adobe Illustrator 8 (AI) a pak je importovat do programu Flash.

I když je formát PNG nativním formátem pro Fireworks, jsou grafické soubory PNG exportované z Fireworks odlišné od zdrojových souborů PNG, které ukládáte ve Fireworks. Podobně jako soubory GIF nebo JPEG obsahují exportované soubory PNG pouze data obrazu bez dalších informací o řezech, vrstvách, interaktivitě, živých filtrech nebo dalším editovatelném obsahu.

Export grafiky a animací Fireworks jako souborů SWF

Grafiky a animace Fireworks lze exportovat jako soubory Flash SWF. Pokud chcete zachovat formátování velikosti a barvy tahu, vyberte v dialogovém Volby exportu SWF pro Flash možnost Zachovat vzhled.

Při exportu do formátu SWF je ztraceno následující formátování: režimy prolnutí, vrstvy, masky (aplikované před exportem), objekty řezu, obrazové mapy, chování, výplně vzorků a přechody obrysu.

  1. Vyberte Soubor > Uložit jako.

  2. Zadejte název souboru a vyberte cílovou složku.

  3. Jako formát vyberte Adobe Flash SWF.

  4. Klepněte na možnost Volby. Potom vyberte volbu pro objekty:

    Zachovat cesty

    Umožňuje zachovat upravitelnost cest. Efekty a formátování se ztratí.

    Zachovat vzhled

    Převede vektorové objekty na bitmapové objekty podle potřeby a zachová vzhled aplikovaných tahů a výplní. Upravitelnost se ztratí.

  5. Vyberte volbu pro text:

    Zachovat upravitelnost

    Umožňuje zachovat upravitelnost textu. Efekty a formátování se ztratí.

    Převést na cesty

    Převede text na cesty, zachová přitom všechna vlastní vyrovnání párů a mezery, která jste zadali v aplikaci Fireworks. Ztratí se upravitelnost jako text.

  6. Nastavte kvalitu obrazů JPEG pomocí rozbalovacího jezdce Kvalita JPEG.

  7. Vyberte stavy, které chcete exportovat, a kmitočet snímků ve stavech za sekundu.

  8. Klepněte na tlačítko OK a na tlačítko Uložit jako v dialogovém okně Export.

Export 8bitových souborů PNG s průhledností

Pokud chcete exportovat 8bitové soubory PNG s průhledností, stačí importovat zdrojové soubory PNG Fireworks do programu Flash. Při exportu 8bitových souborů PNG s průhledností postupujte následujícím způsobem:

  1. V aplikaci Fireworks klepněte na možnosti Okno > Optimalizovat a otevřete panel Optimalizace.

  2. Vyberte PNG 8 jako formát souboru pro export a průhlednost alfa z rozbalovací nabídky Průhlednost.

  3. Vyberte Soubor > Exportovat.

  4. V rozbalovací nabídce Uložit jako typ vyberte možnost Pouze obrazy.

  5. Soubor pojmenujte a uložte.

Import exportované grafiky a animací Fireworks do programu Flash

  1. Vytvořte v programu Flash nový dokument.

    Poznámka:

    Pokud importujete grafiky Fireworks do existujícího souboru Flash, vytvořte v programu Flash novou vrstvu.

  2. Vyberte možnosti Soubor > Importovat a vyhledejte grafický nebo animační soubor.

  3. Klepnutím na Otevřít soubor importujte.

Použití aplikace Fireworks k úpravě grafiky v programu Flash

Díky integraci funkce spuštění a úprav můžete použít aplikaci Fireworks k provedení změn grafiky importované do programu Flash, a to v případě, že grafika nebyla exportována z aplikace Fireworks.

Poznámka:

Nativní soubory PNG Fireworks importované do programu Flash tvoří výjimku. Soubor PNG je nutné importovat jako sloučený bitmapový obraz.

Pokud byla grafika exportována z aplikace Fireworks a uložili jste původní soubor PNG, můžete soubor PNG upravit v aplikaci Fireworks v rámci aplikace Flash. Až se vrátíte do programu Flash, bude aktualizovaný jak soubor PNG, tak grafika ve Flashi.

  1. V programu Flash klepněte pravým tlačítkem myši (Windows) nebo se stisknutou klávesou Ctrl (Mac OS) na grafický soubor v panelu Knihovna dokumentu.

  2. V rozbalovací nabídce vyberte možnost Upravit ve Fireworks.

    Poznámka:

    Pokud se v rozbalovací nabídce neobjeví příkaz Upravit ve Fireworks, zvolte Upravit pomocí a vyhledejte aplikaci Fireworks.

  3. V poli Najít zdroj klepněte na možnost Ano a vyhledejte původní soubor PNG pro svoji grafiku Fireworks, a pak klepněte na možnost Otevřít.

  4. Upravte obraz a po dokončení změn klepněte na tlačítko Done (Hotovo).

    Aplikace Fireworks exportuje nový soubor grafiky do aplikace Flash a uloží původní soubor PNG.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online