Fireworks importuje nativní soubory PSD (Photoshop) a zachovává většinu funkcí aplikace Photoshop. Je také možné exportovat grafiku Fireworks do aplikace Photoshop a provést zde podrobné úpravy obrazu.

Umístění obrazů aplikace Photoshop do aplikace Fireworks

Obrazy Photoshop lze do aplikace Fireworks vložit pomocí příkazů Soubor > Import a Soubor > Otevřít nebo přetažením souborů myší na plátno. Příkaz Import umožňuje přístup k jedinečným volbám pro vrstvu pozadí a složky vrstev. Příkaz Otevřít a přetažení myší naopak umožňují přístup k volbám pro vodítka a stavy.

Převedené a nepodporované funkce aplikace Photoshop ve Fireworks

Pokud otevřete nebo importujete soubor aplikace Photoshop, Fireworks převede obraz do formátu PNG pomocí určených předvoleb pro import. (Viz Předvolby importu a otevření souborů z aplikace Photoshop.)

  • Jednotlivé masky vrstev převádí na masky objektů Fireworks. Skupinové masky nejsou podporované.

  • Ořezové masky se převádějí na masky objektů, avšak jejich vzhled se mírně změní. Pro zachování vzhledu (se ztrátou možnosti úprav) můžete vybrat předvolbu Ořezové masky.

  • Režimy prolnutí pro vrstvy se převedou na režimy prolnutí pro objekty aplikace Fireworks, pokud existují odpovídající režimy.

  • Standardně se zachovají efekty vrstvy. Pokud si přejete převést tyto efekty na odpovídající Živé filtry, zvolte předvolbu Efekty vrstvy. Uvědomte si však, že vzhled podobných efektů a filtrů se může mírně lišit.

  • První alfa kanál v panelu kanálů převede na průhledné oblasti v obrazu Fireworks. Fireworks nepodporuje další alfa kanály aplikace Photoshop.

  • Všechny režimy a hloubky barev aplikace Photoshop se převádějí na 8bitové RGB.

Přetažení, otevření nebo import obrazů aplikace Photoshop do aplikace Fireworks

Každý obraz, který přetáhnete, otevřete nebo importujete, se stane novým bitmapovým objektem.

Poznámka:

V systému Windows musejí názvy souborů Photoshop obsahovat příponu PSD, aby mohla aplikace Fireworks rozpoznat tento typ souboru.

  1. Proveďte jeden z následujících úkonů:

    • Přetáhněte obraz nebo soubor z aplikace Photoshop do otevřeného dokumentu Fireworks.

    • Vyberte možnosti Soubor > Otevřít nebo Soubor > Importovat a přejděte k souboru aplikace Photoshop (PSD).

  2. Klepněte na Otevřít.

  3. Ve zobrazeném dialogovém okně nastavte volby obrazu a klepněte na tlačítko OK.

  4. Pokud jste použili příkaz Soubor > Import, zobrazí se kurzor ve tvaru obráceného písmene L. Na plátně klepněte na místo, kam chcete umístit levý horní roh obrazu.

Volby importu pro soubory aplikace Photoshop

Pokud importujete nebo otevřete soubor aplikace Photoshop v aplikaci Fireworks, můžete v dialogovém okně zadat, jak chcete obraz importovat. Vybrané volby určují vzhled a možnosti úprav importovaných souborů.

  1. Zadejte rozměry obrazu v pixelech nebo procentech a zadejte rozlišení pixelů. Chcete-li zachovat současný poměr šířky a výšky, vyberte možnost Zachovat proporce.

  2. Pokud soubor aplikace Photoshop obsahuje kompozice vrstev, určete, která verze obrazu se bude importovat. Vyberte možnost Zobrazit náhled, chcete-li zobrazit náhled vybrané kompozice. V textovém poli Poznámky se zobrazí poznámky ze souboru aplikace Photoshop.

  3. Z dolní místní nabídky vyberte způsob, jakým se obrázek aplikace Photoshop otevře v aplikaci Fireworks:

    Zachovat upravitelnost vrstvy před vzhledem

    Zachová se co nejvíce ze struktury vrstev a upravitelnosti textu bez toho, že by se obětoval vzhled obrazu. Pokud soubor obsahuje funkce, které aplikace Fireworks nepodporuje, zachová aplikace Fireworks vzhled dokumentu pomocí sloučení a rastrování vrstev. Zde jsou uvedeny příklady:

    • Vrstvy CMYK, vrstvy úprav a vrstvy, které využívají volbu Vyřadit, jsou sloučeny se spodními vrstvami.

    • Vrstvy, které používají nepodporované efekty vrstvy, je možné sloučit v závislosti na režimu prolnutí vrstvy a přítomnosti průhledných pixelů.

    Zachovat vzhled vrstev aplikace Photoshop

    Sloučí všechny objekty v jednotlivých vrstvách aplikace Photoshop a převede každou vrstvu aplikace Photoshop na bitmapový objekt. Tato volba neumožňuje upravovat vrstvy aplikace Photoshop v aplikaci Fireworks. Skupiny vrstev jsou však zachovány.

    Použít vlastní předvolby

    Importuje soubor pomocí vlastního nastavení převodu souboru zadaného v dialogovém okně Předvolby. (Viz Předvolby importu a otevření souborů z aplikace Photoshop.)

    Sloučit vrstvy aplikace Photoshop do jednoho obrazu

    Importuje soubor aplikace Photoshop jako sloučený obraz bez vrstev. Převedený soubor nezachovává žádné jednotlivé objekty. Krytí je zachováno, ale nelze je upravovat.

  4. Pokud jste použili příkaz Soubor > Import, můžete vybrat následující volby:

    Včetně vrstvy pozadí

    Importuje objekty z vrstvy pozadí obrazu.

    Import do nové složky

    Importuje obraz do nové složky vrstvy s názvem Import z aplikace Photoshop.

  5. Jestliže jste použili příkaz Soubor > Otevřít nebo přetáhli soubor aplikace Photoshop myší do aplikace Fireworks, můžete vybrat následující volby:

    Zahrnout vodítka

    Zachová vodítka aplikace Photoshop v původní pozici.

    Převést vrstvy na stavy

    Umístí jednotlivé skupiny vrstev aplikace Photoshop do vlastního stavu.

Import textu z aplikace Photoshop

Poznámka:

Jestliže chcete rychle importovat určitý text v souboru aplikace Photoshop, zkopírujte jej přímo do aplikace Fireworks. Zkopírovaný text si zachová všechny atributy textu.

Při importu souborů Photoshop obsahujících text aplikace Fireworks zkontrolujte potřebná písma v systému. Pokud nejsou písma nainstalována, aplikace Fireworks zobrazí výzvu k jejich nahrazení nebo zachování vzhledu.

Pokud má text v souboru aplikace Photoshop aplikovány efekty, které aplikace Fireworks podporuje, budou tyto efekty aplikované v aplikaci Fireworks. Ale protože Fireworks a Photoshop aplikují efekty odlišně, může se vzhled efektů v obou aplikacích lišit.

Pokud v aplikaci Fireworks otevíráte nebo importujete soubory aplikace Photoshop 6 nebo 7, které obsahují text, a vybrali jste přitom volbu Zachovat vzhled, zobrazí se obraz textu uložený do mezipaměti, takže jeho vzhled zůstává stejný, jako byl v aplikaci Photoshop. Po provedení úprav textu je obraz v mezipaměti nahrazen vlastním textem. Vzhled textu se může lišit od původního textu. Údaje o původním písmu jsou však uloženy v souboru PNG, takže je možné použít původní písmo v systému, kde je nainstalováno.

Poznámka:

Fireworks neumí exportovat text ve formátu Photoshop 6 a 7. Pokud upravujete dokument obsahující text aplikace Photoshop 6 nebo 7 a pak ho exportujete zpět do programu Photoshop, exportuje se soubor ve formátu Photoshop 5.5. Pokud ale text nezměníte, bude soubor exportován ve formátu Photoshop 6.

Import/export přechodů aplikace Photoshop

Kvalita přechodu po importu a exportu závisí na typu přechodu. Přechody mohou doznat mírného posunu barvy a krytí.

Přechod

Kvalita importu

Lineární

Téměř dokonalá.

Kruhový

Téměř dokonalá.

Zrcadlený

Téměř dokonalá.

Křížový

Přibližně odpovídající (mapováno na obdélníkový)

Úhel

Přibližně odpovídající (mapováno na kuželový)

   

Přechod

Kvalita exportu

Lineární

Téměř dokonalá.

Kruhový

Téměř dokonalá.

Pruhy

Téměř dokonalá.

Obdélníkový

Přibližně odpovídající (mapováno na kosočtverec)

Kuželový

Přibližně odpovídající (mapováno na úhel)

Elipsa

Přibližně odpovídající (mapováno na kruhový)

Zvlnění

Přibližně odpovídající (mapováno na kruhový)

Ohňostroj

Nedokonalá shoda (mapováno na tvarový výbuch)

Profil, satén, vlny

Nedokonalá shoda (mapováno na lineární)

Zachování vzhledu vrstvy Nastavení po importu

Když importujete soubor PSD obsahující vrstvu nastavení, vzhled jednotlivých vrstev se po importu zachová.

  1. V dialogu Předvolby vyberte Importovat/otevřít Photoshop.

  2. Vyberte Zachovat vzhled upravených vrstev.

Zachování vzhledu upravených vrstev

Když importujete soubor PSD obsahující vrstvu nastavení, vzhled jednotlivých vrstev se po importu zachová. Zkontrolujte, zda jste v dialogu vybrali Vlastní preferencí z předvoleb.

Používání filtrů a zásuvných modulů aplikace Photoshop

Můžete použít mnoho filtrů a zásuvných modulů aplikace Photoshop a jiných výrobců, a to buď v okně Živé filtry nebo v nabídce Filtry.

Poznámka:

Zásuvné moduly a filtry pro Photoshop 5.5 a starší verze jsou podporované. Zásuvné moduly a filtry aplikace Photoshop verze 6 nebo novější nejsou kompatibilní s Fireworks.

Povolení zásuvných modulů aplikace Photoshop v dialogovém okně Předvolby

  1. Zvolte možnosti Úpravy > Předvolby (Windows) nebo > Předvolby (Mac OS).

  2. Klepněte na kategorii Zásuvné moduly.

  3. Vyberte zásuvné moduly Photoshop.

    Otevře se dialogové okno Vybrat složku (Windows) nebo Zvolit složku (Mac OS).

    Poznámka:

    Pokud se dialogové okno neotevře, klepněte na tlačítko Procházet.

  4. Přejděte do složky, do které jste nainstalovali filtry a zásuvné moduly aplikace Photoshop nebo jiné filtry a zásuvné moduly, a klepněte na možnost Vybrat (Windows) nebo Zvolit (Mac OS).

  5. Klepnutím na OK zavřete dialogové okno Předvolby.

  6. Restartujte Fireworks.

Povolení zásuvných modulů aplikace Photoshop v okně Živé filtry

  1. Vyberte libovolný vektorový objekt., bitmapový objekt nebo textový blok na kreslicím plátnu a v inspektoru Vlastnosti klepněte na ikonu Plus (+) vedle nápisu Filtry.

  2. V rozbalovací nabídce vyberte možnosti Volby > Vyhledat zásuvné moduly.

  3. Přejděte do složky, do které jste nainstalovali filtry a zásuvné moduly aplikace Photoshop nebo jiné filtry a zásuvné moduly, a klepněte na možnosti Vybrat (Windows) nebo Zvolit (Mac OS). Pokud se zobrazí zpráva s dotazem, zda chcete restartovat Fireworks, klepněte na OK.

  4. Restartujte Fireworks, aby se filtry a zásuvné moduly načetly.

    Poznámka:

    Zásuvné moduly můžete také nainstalovat přímo do složky Zásuvné moduly Fireworks.

Umístění grafiky Fireworks do aplikace Photoshop

Fireworks poskytuje rozsáhlou podporu pro export souborů ve formátu aplikace Photoshop (PSD). Obraz Fireworks exportovaný do aplikace Photoshop si zachová stejnou upravitelnost, když ho znovu otevřete ve Fireworks, jako ostatní grafiky aplikace Photoshop. Uživatelé aplikace Photoshop mohou se svojí grafikou pracovat ve Fireworks a pak pokračovat v úpravách v aplikaci Photoshop.

Poznámka:

Pro rychlý export stránek a stavů ve svých dokumentech aplikace Fireworks do samostatných souborů PSD můžete použít rozšíření PSD Save. Toto rozšíření je k dispozici na adrese http://www.adobe.com/go/learn_fw_psdsave_cz

Export souboru ve formátu aplikace Photoshop

  1. Vyberte Soubor > Uložit jako.

  2. Zadejte název souboru a v nabídce Uložit jako vyberte možnost Photoshop PSD.

  3. Pokud chcete zadat nastavení předvoleb exportu pro objekty, efekty a text, klepněte na tlačítko Volby. Potom vyberte v nabídce Nastavení některé z níže uvedených předvoleb.

    Zachovat upravitelnost před vzhledem

    Převede objekty na vrstvy, zachová upravitelnost efektů a převede text na upravitelné textové vrstvy aplikace Photoshop. Tuto volbu vyberte, pokud chcete provádět rozsáhlé úpravy obrazu v aplikaci Photoshop a nepotřebujete zachovat přesný vzhled obrazu Fireworks.

    Zachovat vzhled Fireworks

    Převádí každý objekt do samostatné vrstvy aplikace Photoshop a efekty a text již nelze upravit. Vyberte tuto volbu, pokud chcete zachovat kontrolu nad objekty Fireworks v aplikaci Photoshop, ale chcete také zachovat původní vzhled obrazu Fireworks.

    Menší soubor aplikace Photoshop

    Sloučí každou vrstvu do plně vykresleného obrazu. Vyberte tuto volbu, pokud exportujete soubor, který obsahuje velký počet objektů Fireworks.

    Jiný

    Dovoluje zvolit specifické nastavení pro objekty, efekty a text.

  4. Klepnutím na Uložit exportujte soubor aplikace Photoshop.

    Poznámka:

    V programu Photoshop 5.5 a starších verzích nelze otevírat soubory s více než 100 vrstvami. Pokud exportovaný dokument Fireworks obsahuje více než 100 objektů, musíte objekty odstranit nebo sloučit.

Přizpůsobení nastavení exportu do aplikace Photoshop

  1. V dialogovém okně Uložit jako vyberte jako typ souboru Photoshop PSD a klepněte na tlačítko Volby.

  2. V rozbalovací nabídce Nastavení vyberte možnost Vlastní.

  3. V rozbalovací nabídce Objekty zvolte jednu z následujících voleb:

    Převést na vrstvy aplikace Photoshop

    Převádí jednotlivé objekty Fireworks na vrstvy aplikace Photoshop a masky aplikace Fireworks na masky vrstev aplikace Photoshop.

    Sloučit všechny vrstvy Fireworks

    Sloučí všechny objekty v každé jednotlivé vrstvě aplikace Fireworks a každá vrstva Fireworks se stane vrstvou v aplikaci Photoshop. Vyberete-li tuto volbu, ztratíte schopnost upravovat objekty Fireworks v aplikaci Photoshop. Ztratíte také funkce, které jsou přidruženy k objektům Fireworks, například režimy prolnutí.

  4. V rozbalovací nabídce Efekty zvolte jednu z následujících voleb:

    Zachovat upravitelnost

    Převádí živé filtry Fireworks na jejich ekvivalenty v aplikaci Photoshop. Efekty, které v programu Photoshop neexistují, budou vypuštěné.

    Vykreslit efekty

    Sloučí efekty do jejich objektů. Pokud zvolíte tuto volbu, zachováte vzhled efektů, ale nebude možné je upravovat v aplikaci Photoshop.

  5. V rozbalovací nabídce Text zvolte jednu z následujících voleb:

    Zachovat upravitelnost

    Převádí text na upravitelnou vrstvu aplikace Photoshop. Formátování textu, které Photoshop nepodporuje, se ztratí.

    Vykreslit text

    Změní text na obrazový objekt. Pokud zvolíte tuto volbu, zachováte vzhled textu, ale nebude možné jej upravovat.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online