Přečtěte si, jak přidávat, nastavit a upravit vrstvy v aplikaci Adobe Muse.

Poznámka:

Do aplikace Adobe Muse již nejsou přidávány žádné další funkce a 26. března 2020 bude její podpora ukončena. Podrobnější informace a možnosti asistence naleznete na stránce Ukončení životnosti aplikace Adobe Muse.

Práce s panelem Vrstvy v aplikaci Muse

Aplikace Muse obsahuje panel Vrstvy, který můžete používat ke strukturování prvků na stránce a uspořádání návrhů webů. V tomto článku se seznámíte s panelem Vrstvy a objevíte strategie, jak své projekty snadněji aktualizovat.

Principy vrstev

Ve výchozím nastavení obsahuje každá stránka webu aplikace Muse minimálně jednu pojmenovanou vrstvu. Pomocí více vrstev můžete vytvořit a upravit konkrétní oblasti obsahu na stránce bez ovlivnění jiných oblastí nebo náhodné změny jiného obsahu. Vrstvy můžete například použít k zobrazení obsahu hlavní stránky a informací na postranním panelu ve stejném návrhu webu. Nebo můžete umístit obsah, který není často aktualizován, do jedné vrstvy a obsah, který aktualizujete často, do jiné vrstvy na stejné stránce.

Představte si vrstvy jako průhledné fólie, které jsou navrstveny jedna na druhou. Pokud ve vrstvě nejsou žádné objekty, můžete přes ni vidět všechny objekty, které existují ve vrstvách pod ní.

Prohlédněte si panel Vrstvy a zamyslete se na chvíli, jak funguje pořadí vrstvení.

Panel Vrstvy v aplikaci Adobe Muse
Panel Vrstvy v aplikaci Adobe Muse.

V předchozím příkladu má Vrstva 1 textové pole obsahující položku 1, Vrstva 2 textové pole s položkou 2 a Vrstva 3 textové pole s položkou 3.

Všechny prvky umístěné do Vrstvy 3 (horní vrstvy) se zobrazí nad prvky ve Vrstvě 2 a Vrstvě 1. Toto chování je podobné pořadí vrstvení, ke kterému dojde, když vyberete objekt a kliknete na položky Uspořádat > Zcela dopředu. Kromě případů, kdy umístíte prvky na specifické vrstvy, jsou uspořádány způsobem umožňujícím řídit pořadí vrstvení skupin prvků.

Chcete-li změnit pořadí vrstvení, můžete vybrat vrstvu a přetáhnout ji, a změnit tak její pozici v pořadí na panelu Vrstvy. V tomto příkladu byla Vrstva 1 přetažena do horní části panelu Vrstvy a Vrstva 3 byla přemístěna do dolní části sloupce.

Změna pořadí vrstev v aplikaci Adobe Muse
Změnou pořadí vrstev změníte, který prvek bude nahoře.

Každá vrstva může obsahovat více prvků a pořadí vrstvení v jednotlivých vrstvách také určuje, které položky se zobrazí nad nebo pod jinými položkami na stránce.

Vrstvy poskytují přímou kontrolu nad uspořádáním prvků stránky ve webových projektech aplikace Muse.

Používání vrstev ve webech aplikace Muse

I když jste již dříve pracovali s panely vrstev v jiných nástrojích, například v editorech obrázků, je důležité porozumět tomu, jak vrstvy fungují v aplikaci Muse:

Rozbalení a sbalení vrstev. Každá vrstva má vlevo od názvu vrstvy zobrazen trojúhelník. Pokud je sbalená, můžete klinutím na tento trojúhelník rozbalit obsah vrstvy a zobrazit seznam objektů a jejich pořadí vrstvení v této vrstvě pro aktivní stránku. Skupiny, widgety a některé části widgetů mají také trojúhelníky, na něž můžete kliknout a rozbalit sadu s objekty, které obsahuje. Můžete měnit pořadí těchto objektů, zamykat je a odemykat a přidávat nebo odebírat je ze skupin. Vrstvy neobsahující žádné objekty na aktuální stránce trojúhelník nezobrazí, protože jsou již rozbaleny.

Objekty na vzorových stránkách se zobrazí v dolní části jednotlivých vrstev. Vzorové položky se mohou zobrazit před objekty na stránce dokumentu, pokud jsou objekty na vzorové stránce umístěny ve vyšší vrstvě, ale ve výchozím nastavení jsou umístěny dole v pořadí vrstvení.

Vrstvy zahrnují všechny stránky webu včetně vzorových. Pokud například skryjete Vrstvu 1 při úpravách domovské stránky dokumentu, bude obsah na Vrstvě 1 skryt, dokud se nerozhodnete jej znovu zobrazit.

Kontrola panelu Vrstvy

Panel Vrstvy je velmi výkonný a obsahuje mnoho užitečných funkcí, které vám pomohou pracovat efektivněji. Vyhraďte si chvíli na seznámení s hlavními funkcemi:

  • Vytvoření nových vrstev
  • Nastavení voleb vrstvy
  • Přidávání objektů do vrstev
  • Výběr, přemístění a kopírování objektů ve vrstvách
  • Vkládání objektů do různých vrstev
  • Duplikování vrstvy
  • Změna pořadí vrstev
  • Zobrazení nebo skrytí vrstev a objektů
  • Zamknutí nebo odemknutí vrstev
  • Odstranění vrstev
  • Sloučení vrstev v dokumentu

Tyto funkce jsou podrobněji popsány v následujících částech. Klíčové prvky panelu Vrstvy jsou zvýrazněny níže.

Jednotlivé funkce na panelu Vrstvy.
Jednotlivé funkce na panelu Vrstvy.

A. Cílová vrstva B. Odstranit vrstvu C. Nová vrstva D. Hledání E. Nápověda pro vrstvy F. Zamknutá vrstva G. Skrytá vrstva H. Viditelná vrstva 

Vytvoření nových vrstev

Vrstvy můžete přidat kdykoli kliknutím na tlačítko Nová vrstva v dolní části panelu Vrstvy. Počet vrstev, které dokument může mít, je omezen pouze velikostí paměti RAM, kterou má aplikaci Muse k dispozici. Nové vrstvy, které vytvoříte, se vždy zobrazí v horní části panelu Vrstvy, ale můžete je přetažením přemístit.

Pomocí těchto kroků vytvoříte novou vrstvu:

  1. Kliknutím na kartu Vrstvy aktivujte panel Vrstvy nebo kliknutím na Okno > Vrstvy panel Vrstvy otevřete, pokud je zavřený.
  2. Klikněte na tlačítko Nová vrstva v dolní části panelu Vrstvy.

Poznámka: Pokud chcete vytvořit novou vrstvu a také otevřít dialogové okno Volby vrstvy, stiskněte při kliknutí na tlačítko Nová vrstva klávesu Alt.

Nastavení voleb vrstvy

Atributy vrstvy můžete aktualizovat v panelu Vrstvy: změnit barevné rozlišení přidružené k dané vrstvě, zobrazit nebo skrýt vodítka a uzamknout vrstvy, aby je nebylo možné náhodně vybrat a upravit. Pomocí těchto kroků můžete aktualizovat volby vrstvy:

  1. Klikněte pravým tlačítkem nebo dvakrát klikněte na existující vrstvu. (Nebo stiskněte klávesu Alt při kliknutí na tlačítko Nová vrstva).
  2. V zobrazeném dialogovém okně Volby vrstvy zadejte volby vrstvy a pak klikněte na tlačítko OK.
Dialogové okno Volby vrstvy
Aktualizujte nastavení v dialogovém okně Volby vrstvy.

Můžete aktualizovat následující nastavení:

  • Název vrstvy: Zadejte popisný název pro vrstvu pro lepší uspořádání obsahu na stránce.
  • Barva: Přiřaďte barvu pro identifikaci objektů existujících v dané vrstvě. Přiřazení barvy vrstvě usnadňuje rozlišení vrstev různých vybraných objektů. Po výběru na stránce zobrazí každý objekt barvu své vrstvy ve svém ohraničujícím poli, úchyty pro výběr tvaru, textové rámečky a okraje rámečku obrazu. Barva vrstvy se nezobrazí, když objekty nejsou vybrány.
  • Zobrazit vrstvu: Tuto volbu vyberte, pokud chcete vrstvu zviditelnit. Výběrem této volby vyvoláte stejné chování jako kliknutím na ikonu oka, kterou zobrazíte vrstvu v panelu Vrstvy.
  • Zamknout vrstvu: Výběrem této volby zabráníte změnám jakýchkoli objektů na vrstvě.

Přidávání objektů do vrstev

Všechny nové objekty se umisťují na cílovou vrstvu, což je vrstva s tučným popiskem zobrazující trojúhelník v pravém horním rohu vrstvy v panelu Vrstvy. Konkrétní vrstvu označíte jako cílovou tak, že na ni kliknete.

Objekty můžete na cílovou vrstvu přidat provedením některé z následujících akcí:

  • Vytvoření nových objektů pomocí nástroje Text nebo nástrojů Obdélník.
  • Importem, umístěním nebo vložením textu nebo grafiky.
  • Výběrem objektů v jiných vrstvách a pak jejich přesunutím do nové vrstvy.

Na skrytou nebo zamknutou vrstvu nemůžete nakreslit ani umístit nový objekt. Když vyberete nástroj kreslení nebo nástroj Typ, případně umístíte soubor, když je cílová vrstva skrytá nebo uzamčena, zobrazí ukazatel ikonu překřížené tužky, když jej umístíte na stránku v zobrazení návrhu. Buď zobrazte nebo odemkněte cílovou vrstvu nebo nastavte jako cíl viditelnou odemknutou vrstvu.

Pokud vyberete možnosti Úpravy > Vložit, když je cílová vrstva skrytá nebo uzamčena, zobrazí se zpráva s upozorněním umožňující zobrazit nebo odemknout cílovou vrstvu.

Když kliknete na vrstvu v panelu Vrstvy, abyste ji označili jako cíl, zobrazí se trojúhelník v pravém horním rohu vrstvy, na kterou jste klikli, popisek vrstvy se zobrazí tučně a vrstva se zvýrazní, aby bylo vidět, že je cílová.

Výběr, přemístění a kopírování objektů ve vrstvách

Standardně můžete vybrat kterýkoliv objekt v libovolné vrstvě. Na panelu Vrstvy označují barevné čtverečky úplně vpravo vrstvy, které obsahují vybrané objekty. Malý čtvereček označuje, že na této vrstvě je vybrán nejméně jeden objekt, a velký čtvereček označuje, že na této vrstvě jsou aktuálně vybrány všechny objekty. Barva výběru na vrstvě vám pomáhá identifikovat vrstvu objektu. Chcete-li zabránit výběru objektů na konkrétní vrstvě, zamkněte (nebo skryjte) danou vrstvu.

  • Pokud chcete vybrat jednotlivé objekty ve vrstvě, kliknutím na ikonu trojúhelníku vlevo od názvu vrstvy vrstvu vyberte a vyberte cílový prvek v seznamu. Cílový objekt je rovněž možné přetáhnout do jiného umístění, aniž by byl vybrán.
  • Pokud chcete vybrat všechny objekty na konkrétní vrstvě, klikněte na čtvereček vpravo od názvu vrstvy.
  • Pokud chcete objekty přesunout nebo zkopírovat do jiné vrstvy, vyberte pomocí nástroje Výběr jeden nebo více objektů na stránce nebo na vzorové stránce. Na panelu Vrstvy přetáhněte barevný čtvereček vpravo od seznamu vrstev, čímž vybrané objekty přetáhnete do druhé vrstvy.

Vkládání objektů do různých vrstev

Volba Vkládat do stejné vrstvy ovlivňuje, jak objekty vložené z jiných umístění spolupracují s existujícími vrstvami.

Pokud je volba „Vkládat do stejné vrstvy“ zapnuta, zachovají si objekty vyjmuté nebo zkopírované z jiných vrstev po vložení na novou stránku nebo do jiného umístění svoje přiřazení vrstvy. Jestliže vložíte objekt na stránku, která neobsahuje stejné vrstvy jako stránka, ze které byl zkopírován, přidá aplikace Muse název vrstvy objektu do panelu Vrstvy ve druhém dokumentu a vloží objekt na jeho odpovídající vrstvu.

Pokud volba Vkládat do stejné vrstvy není zapnuta, budou objekty vyjmuté nebo zkopírované z jiných vrstev vloženy společně na aktuální cílovou vrstvu.

  1. Zkontrolujte, zda je výběr volby Vkládat do stejné vrstvy zrušen v kontextové nabídce Vrstvy, která se zobrazí po kliknutí pravým tlačítkem myši kdekoli na stránce.
  2. Vyberte objekty a klikněte na položky Úpravy > Kopírovat nebo Úpravy > Vložit.
  3. Na panelu Vrstvy označte kliknutím jinou vrstvu jako cílovou.
  4. Vyberte možnosti Úpravy > Vložit.

Duplikování vrstvy

Když duplikujete vrstvu, kopírujete její obsah a nastavení. Duplikovaná vrstva se pak objeví nad původní vrstvou v panelu Vrstvy.

V panelu Vrstvy proveďte jeden z následujících úkonů:

  • Vyberte název vrstvy a zvolte příkaz Duplikovat vrstvu v kontextové nabídce Vrstvy, která se zobrazí po kliknutí pravým tlačítkem (kontextovém kliknutí) na vrstvu (nebo vybrané vrstvy).
  • Přetáhněte název vrstvy na tlačítko Nová vrstva.

Změna pořadí vrstev

Změnou uspořádání vrstev v panelu Vrstvy změníte pořadí překrývání vrstev v dokumentu. Změna pořadí vrstev změní pořadí vrstev na každé stránce na webu, nikoli pouze na aktuální stránce v pohledu návrhu.

Můžete také změnit pořadí překrývání objektů na vrstvě změnou polohy objektů na vrstvě.

V panelu Vrstvy přetáhněte vrstvu nahoru nebo dolů v seznamu. Můžete také přetáhnout více vybraných vrstev.

Zobrazení nebo skrytí vrstev a objektů

Vrstvu můžete kdykoli skrýt nebo zobrazit a můžete skrýt nebo zobrazit objekty na vrstvě. Skryté vrstvy a objekty nelze upravit a nezobrazí se na obrazovce v pohledu návrhu, náhledu, publikování nebo po exportu webů. Skrytí vrstev může být užitečné, když chcete provést některé z následujících úkonů:

  • Skrýt objekty, když navrhujete weby pomocí responzivního rozvržení. Když navrhujete stránku pro různá zařízení na jediném plátně, můžete případně skrývat některé objekty. Při navrhování webu pro mobilní telefony můžete například skrýt tradiční nabídku a místo ní zobrazit skládačku. Informace o skrývání objektů v responzivním rozvržení naleznete v tématu Zobrazení nebo skrytí objektů v responzivním rozvržení.
  • Skrýt části dokumentu, které nejsou určené k tomu, aby se objevily ve výsledném dokumentu.
  • Skrýt alternativní verze dokumentu.
  • Zjednodušit zobrazení dokumentu, aby se usnadnily úpravy jiných částí dokumentu.
  • Zabránit exportu vrstvy.
  • Urychlit překreslování obrazovky, když vrstva obsahuje grafiky s vysokým rozlišením.

Poznámka: Skryté vrstvy nebo skryté položky na stránce se neexportují. Stránka se však přesto zobrazí v pohledu návrhu, jako kdyby byly položky přítomné. Například skrytý textový rámeček bude stále posunovat položky pod ním dolů na stránku. Tak se zabrání posunutí obsahu na stránce při skrytí/zobrazení vrstev.

Vrstvy zobrazíte nebo skryjete pomocí jedné z následujících voleb:

  • Chcete-li skrýt nebo zobrazit jednu vrstvu, klikněte v panelu Vrstvy na čtvereček zcela vlevo od názvu vrstvy, abyste skryli nebo zobrazili ikonu oka dané vrstvy.
  • Pokud chcete skrýt jednotlivé objekty ve vrstvě, klikněte na dolů otočený trojúhelník vlevo od názvu vrstvy pro zobrazení všech objektů ve vrstvě a pak kliknutím na ikonu oka zobrazte nebo skryjte objekt.

Zamknutí nebo odemknutí vrstev

Zamknutí je užitečné, když chcete zabránit náhodným změnám ve vrstvě. U zamknuté vrstvy se v panelu Vrstvy zobrazuje ikona přeškrtnutého pera. Objekty v zamknutých vrstvách nelze přímo vybrat nebo upravovat; pokud ale objekty v zamknutých vrstvách mají atributy, které lze upravit nepřímo, mohou se změnit. Pokud například upravíte vzorek odstínu, objekty v zamknutých vrstvách, které používají tento vzorek ze Vzorníku, tato změna ovlivní.

Pro zamykání a odemykání objektů ve vrstvě můžete také použít panel Vrstvy. Pokud chcete odemknout a uzamknout vrstvy, proveďte následující kroky:

  • Chcete-li zamknout nebo odemknout jednu vrstvu, klikněte v panelu Vrstvy na čtvereček v druhém sloupci zleva, abyste zobrazili (zamknuli) nebo skryli (odemknuli) vrstvu.

Odstranění vrstev

Nezapomeňte, že každá vrstva zahrnuje celý web – zobrazí se na každé stránce webu. Před odstraněním vrstvy zvažte nejprve skrytí všech ostatních vrstev a pak zkontrolujte jednotlivé stránky webu za účelem ověření, že je bezpečné odstranit zbývající objekty. Když jste si jisti, že chcete vrstvu odstranit, proveďte následující kroky:

  • Pokud chcete odstranit vrstvu, přetáhněte vrstvu z panelu Vrstvy k ikoně Odstranit vpravo dole na panelu vrstvy nebo klikněte pravým tlačítkem myši a zvolte příkaz Odstranit vrstvu z kontextové nabídky.
  • Pokud chcete odstranit více vrstev, vyberte je tak, že podržíte klávesu Control/Command a současně na vrstvy kliknete. Pak přetáhněte vrstvy z panelu Vrstvy k ikoně Odstranit nebo klikněte pravým tlačítkem myši a zvolte příkaz Odstranit vrstvy z kontextové nabídky.
  • Chcete-li odstranit objekt na vrstvě, vyberte objekt v panelu Vrstvy a potom klikněte na ikonu Odstranit.

Sloučení vrstev v dokumentu

Počet vrstev na webu můžete snížit bez odstranění objektů tak, že vrstvy sloučíte. Když sloučíte vrstvy, objekty ze všech vybraných vrstev se přesunou do cílové vrstvy. Ze všech slučovaných vrstev zůstane v dokumentu pouze cílová vrstva, ostatní vybrané vrstvy se odstraní. Web můžete také zploštit sloučením všech vrstev.

Poznámka: Pokud sloučíte vrstvy obsahující kombinaci objektů stránky a objektů vzorové stránky, vzorové položky se přesunou do zadní výsledné sloučené vrstvy.

  1. V panelu Vrstvy vyberte jakoukoli kombinaci vrstev. Vybraná musí být i vrstva, kterou chcete použít jako cílovou vrstvu pro sloučení. Pokud zplošťujete web na jednu vrstvu, vyberte všechny vrstvy v panelu.
  2. Klikněte pravým tlačítkem na panel Vrstvy a pak klikněte na příkaz Sloučit vrstvy v kontextové nabídce.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online