Naučte se organizovat a opakovaně používat widgety, šablony a další prvky návrhu pomocí panelu Knihovna aplikace Adobe Muse CC.

Poznámka:

Do aplikace Adobe Muse již nejsou přidávány žádné další funkce a 26. března 2020 bude její podpora ukončena. Podrobnější informace a možnosti asistence naleznete na stránce Ukončení životnosti aplikace Adobe Muse.

Panel Knihovna aplikace Muse nabízí pohodlný způsob ukládání a správy běžných elementů stránky. Přidáním položek do knihovny získáte k těmto položkám rychlý přístup a následně můžete přidávat obsah do stránek svého webu. Knihovna může obsahovat mnoho druhů elementů, například loga, obrázky webu, políčka barev, vodítka, přizpůsobené widgety, vložené stránky HTML a styly odstavců, znaků a grafiky. Tento článek vám poskytne přehled používání panelu Knihovna ke zjednodušení vašeho procesu návrhu.

Doplňky služby Creative Cloud vám nabízejí široký výběr elementů pro návrhy, pomocí kterých můžete obohatit svůj vlastní návrh. Informace o stažení najdete v části Doplňky služby Creative Cloud pro aplikaci Adobe Muse.

Otevření panelu Knihovna

Panel Knihovna můžete otevřít z pohledu Návrh. Panel můžete aktivovat vybráním nabídky Okno > Knihovna nebo kliknutím na kartu Knihovna v ukotveném panelu.

Otevřete panel Knihovna v aplikaci Adobe Muse.
Otevřete panel Knihovna v aplikaci Adobe Muse.

Poznámka:

Kliknutím na odkaz navštívíte web Adobe Muse Exchange, ve kterém najdete položky knihovny ke stažení a k použití v budoucích projektech webových stránek.

Správa složek v panelu Knihovna

Vytvoření nové složky

Abyste mohli začít panel Knihovna používat, vytvořte novou složku. Postupujte takto:

  1. Klikněte na tlačítko Vytvořit složku (ikona složky) ve spodní části panelu Knihovna.
Kliknutím na tlačítko Vytvořit složku vytvořte novou, prázdnou složku.
Kliknutím na tlačítko Vytvořit složku vytvořte novou, prázdnou složku.

  1. Do pole vedle ikony složky zadejte popisný název.

Složky jsou v panelu Knihovna tříděny abecedně podle názvu, takže používáním podobných názvů můžete udržovat související položky pohromadě v seznamu.

Na složku v knihovně můžete kdykoli dvakrát kliknout a přejmenovat ji.

Do pole zadejte popisný název složky.
Do pole zadejte popisný název složky.

Po vytvoření složky můžete do knihovny přidat položky.

Poznámka:

I když můžete přidat položku knihovny do panelu Knihovna bez toho, abyste nejprve vytvořili složku, je rychlejší vytvořit novou složku, pojmenovat ji, a poté přidat položku než přidat novou položku, a poté přejmenovat jak novou položku, tak její složku. Bez ohledu na použitou metodu doporučujeme vždy pojmenovat jak složky, tak položky v panelu Knihovna popisně.

Pokud plánujete přidávat do knihovny více položek, můžete vytvořit a pojmenovat několik prázdných složek a poté do nich přidat položky.

Přidejte složky za účelem zorganizování různých elementů webů aplikace Adobe Muse a jejich snadného vyhledání.
Přidejte složky za účelem zorganizování různých elementů webů a jejich snadného vyhledání.

Přidávání elementů stránek do složek

Chcete-li do knihovny přidat elementy za účelem jejich rychlého vyhledání a přidání do jiných stránek, vyberte libovolný element na stránce. Vybíráte-li více položek, stiskněte a podržte klávesu Shift nebo vyberte požadované elementy kliknutím a přetažením nástroje Výběr.

Elementy můžete do knihovny přidávat jedním z následujících dvou postupů:

Možnost 1:

  1. Klikněte pravým tlačítkem na vybraný element, vyberte možnost Přidat do knihovny a poté vyberte složku, do které chcete položku knihovny uložit.
V kontextové nabídce aplikace Adobe Muse vyberte možnost Přidat do knihovny.
V kontextové nabídce vyberte možnost Přidat do knihovny.

Vybrané položky jsou přidány do složky a v panelu Knihovna se zobrazí jejich náhled.

  1. Do zobrazeného pole zadejte popisný název elementu.
Zadejte popisný název nového elementu uloženého do složky.
Zadejte popisný název nového elementu uloženého do složky.

Vybrané položky můžete do knihovny přidat také následujícím způsobem:

Možnost 2:

  1. Vyberte elementy a poté klikněte na tlačítko Přidat vybrané položky (ikona obrácení stránky) nacházející se v pravém dolním rohu panelu Knihovna.
Klikněte na tlačítko Přidat vybrané položky.
Klikněte na tlačítko Přidat vybrané položky.

  1. Do zobrazeného pole zadejte název elementu.

Pokud složka obsahuje alespoň jednu položku, můžete kliknutím na šipku dolů, nacházející se vlevo od názvu složky, rozbalit nebo sbalit obsah této složky.

V případě projektů s mnoha soubory můžete sbalit všechny složky panelu Knihovna, zkrátit tak jejich seznam a usnadnit jejich vyhledávání a správu. Chcete-li otevřít nebo zavřít všechny složky na panelu Knihovna, stiskněte klávesu Option a klikněte na šipku (Alt + kliknutí na šipku v systému Windows).

Přejmenování a uspořádání složek

Jak již bylo uvedeno výše, složku můžete kdykoli přejmenovat dvojitým kliknutím na její název. Pokud ukládáte elementy pro určitého klienta nebo pro určitou část webu, je výhodné pojmenovat všechny složky v panelu Knihovna tak, aby byly složky zobrazeny vedle sebe.

Názvy složek v panelu Knihovna aplikace Adobe Muse jsou řazeny abecedně.
Názvy složek v panelu Knihovna, řazené abecedně.

Nejvýhodnější je pojmenovávat složky a položky knihovny popisně - nepoužívejte výchozí názvy nepojmenovaný, které přiřadila aplikace Muse. Popisné názvy vám umožní rychle vyhledávat položky prohlédnutím seznamu složek. Tento postup vám navíc umožňuje vyhledávat specifické položky knihovny tak, jak je popsáno v následující části.

Správa datových zdrojů v panelu Knihovna

Vyhledávání v panelu Knihovna

Pokud přidáte do panelu Knihovna mnoho různých elementů, může být obtížné si zapamatovat, která složka obsahuje položku, kterou chcete použít. Jednotlivé složky můžete kdykoli rozbalit a prohlédnout si jejich obsah, ale při práci s rozsáhlejšími knihovnami může být tento postup časově náročný.

Chcete-li prohledat panel Knihovna, zadejte libovolnou část názvu položky do pole Filtrovat podle názvu.

Všechny odpovídající položky se zobrazí v seznamu v rozbalených složkách knihovny.

Vyhledejte specifickou položku zadáním názvu do pole hledání.
Vyhledejte specifickou položku zadáním jejího názvu do pole hledání.

Po dokončení hledání kliknutím na tlačítko X vymažte toto pole a znovu si zobrazte celý seznam položek na panelu Knihovna.

Importování datových zdrojů

Uživatelské datové zdroje knihovny lze sdílet mezi uživateli a usnadnit si tak spolupráci s dalšími návrháři a standardizovat návrhy webů. Exportované soubory knihovny aplikace Muse se ukládají s koncovkou .mulib.

Chcete-li do aktuálního projektu importovat soubor knihovny aplikace Muse, stačí dvakrát kliknout na soubor .mulib. Spustí se aplikace Muse (pokud již není otevřená) a obsah souboru knihovny se přidá do panelu Knihovna.

Nebo postupujte následovně:

  1. V levém spodním rohu panelu Knihovna klikněte na tlačítko Importovat knihovnu aplikace Muse.
  2. Zobrazí se dialog Položky importu knihovny, ve kterém přejděte k souboru .mulib nacházejícímu se na vaší ploše a klikněte na možnost Otevřít.
Klikněte na tlačítko Importovat knihovnu aplikace Muse a otevřete v aplikaci Adobe Muse soubor .mulib.
Klikněte na tlačítko Importovat knihovnu aplikace Muse a otevřete soubor .mulib.

Importované složky se zobrazí v panelu Knihovna a jsou připraveny k používání v aktuálním souboru.

Pokud byste chtěli importovat položky knihovny, a nepracujete v pohledu Návrh, můžete vybrat možnost nabídky Soubor > Otevřít web a poté v zobrazeném dialogu Otevřít vyhledat a otevřít jeden či více souborů .mulib.

Používání položek knihovny v návrzích

Můžete uchovávat a spravovat různé druhy datových zdrojů, včetně prvků grafiky, vektorových obrazů, formulářů, záhlaví, zápatí, atd. Tyto položky můžete ve svých návrzích používat dvěma způsoby:

Umístěním položek knihovny:

Vyberte položku, kterou chcete použít v návrhu. Přetáhněte položku knihovny do zobrazení Návrh.

Umístěním položek knihovny se zarážkami:

Pokud položka knihovny obsahuje zarážky, můžete ji umístit do rozvržení společně s těmito zarážkami. Chcete-li používat položky knihovny se zarážkami, klikněte na symbol plus vedle položky. Přetáhněte položku do zobrazení Návrh.

Přidání položek knihovny se zarážkami v aplikaci Adobe Muse
Přidání položek knihovny se zarážkami

Zarážky z položky knihovny se přidají do stránky. Tato funkce umožňuje jediným kliknutím přidat sadu zarážek do všech hlavních i podřízených stránek. Zarážky můžete také zachovat v rámci různých projektů Adobe Muse.

Pokud na stránce existují nějaké zarážky a vy přidáte položku knihovny se zarážkami, budou se na stránce vyskytovat všechny tyto zarážky.

Exportování obrázků a dalších datových zdrojů

Po přidání obsahu do panelu Knihovna můžete tento obsah exportovat jako samostatný soubor za účelem sdílení s dalšími návrháři (nebo urychlení vlastního procesu návrhu, pokud pracujete na více počítačích).

Pamatujte si, že obsah propojený s vaším webem (obsah, který v něm není zabudován), jako jsou například soubory Adobe Edge Animate OAM, video klipy a další propojený obsah, nebude při exportu elementů z panelu Knihovna zahrnut do souboru .mulib.

Chcete-li exportovat soubor knihovny aplikace Muse obsahující také obrázky, postupujte následovně:

  1. V pohledu Návrh vytvořte element nebo sadu elementů pro přidání do vaší knihovny. Tato sada elementů může zahrnovat soubory obdélníků, textů a obrázků.
  2. Před přidáním těchto položek do panelu Knihovna otevřete panel Datové zdroje (Okno > Datové zdroje), klikněte pravým tlačítkem na obrázky, které chcete exportovat, a vyberte možnost Vložit odkaz.

Poznámka: Pokud položky knihovny, které chcete exportovat, neobsahují soubory obrázků, můžete krok 2 přeskočit.

  1. Vyberte požadované elementy a přidejte je do své knihovny.
  2. Klikněte na tlačítko Exportovat ve spodní části panelu Knihovna.
Vyberte složky nebo položky, které chcete exportovat a klikněte na tlačítko Exportovat.
Vyberte složky nebo položky, které chcete exportovat a klikněte na tlačítko Exportovat.

Dojde k vytvoření souboru .mulib a k jeho uložení na plochu (nebo do libovolného, vámi určeného umístění). Soubor .mulib můžete předat e-mailem nebo jiným způsobem přenosu souboru jinému návrháři nebo členovi týmu.

Když příjemce otevře soubor .mulib a poté přidá položku knihovny do stránky, zobrazí se obrázky na panelu Datové zdroje jako vložené obrázky.

Vytváření vlastních vzorků barev

Pomocí panelu Knihovna můžete uložit element obsahující všechny barvy použité při návrhu webu. Můžete také vybrat vlastní sadu vodítek a přidat je do panelu Knihovna. Tyto postupy velice pomohou při standardizaci vzhledu vašich projektů webových stránek.

Pomocí následujících kroků můžete importovat specifickou sadu barev do nového souboru .muse a urychlit tak proces návrhu.

  1. Otevřete soubor .muse obsahující barvy, které chcete uložit. Pomocí nástroje Obdélník vytvořte jeden obdélníkový tvar a poté se stisknutou klávesou Option/Alt přetáhněte tento obdélník a několikrát jej zduplikujte. Pomocí nástroje kapátko z nabídky Výplň nastavte výplně jednotlivých obdélníků na hodnoty primárních barev webu.
  2. V panelu Knihovna vytvořte novou složku pro uložení vzorků barev.
  3. Pomocí nástroje Výběr vyberte celou sadu obdélníků. Můžete buď kliknout pravým tlačítkem na vybranou skupinu obdélníků a vybrat možnost Přidat do knihovny nebo kliknout na tlačítko Přidat vybrané položky ve spodní části panelu Knihovna. Označte sadu políček zadáním popisného názvu do pole.
  4. Vyberte složku obsahující políčka a kliknutím na tlačítko Exportovat ve spodní části panelu Knihovna exportujte soubor knihovny aplikace Muse s vybraným obsahem. Odešlete soubor .mulib členovi svého týmu jako přílohu e-mailu nebo soubor přesuňte pomocí jednotky USB.
  5. Příjemce souboru .mulib spustí aplikaci Muse, vytvoří nový web, otevře panel Knihovna a kliknutím na tlačítko Importovat importuje soubor obsahující políčka do své knihovny. (Případně může vybrat možnost nabídky Soubor > Otevřít web a otevřít soubor .mulib.)
  6. Následně přetáhne element obsahující barvy z panelu Knihovna na stránku a přidá tak políčka do panelu Políčko.
  7. Příjemce poté otevře panel Políčka (Okno > Políčka), klikne pravým tlačítkem na panel Políčka a v kontextové nabídce vybere možnost Odstranit všechna nepoužívaná.
Po importu nepoužívané vzorky barev v novém webu Adobe Muse odstraňte.
Po importování vzorků barev do nového webu můžete na panelu Políčka odstranit všechny nepoužívané barvy.

Po odstranění nepoužívaných políček na panelu Políčka můžete odstranit element knihovny ze stránky.

Poznámka:

Stejný trik lze použít při importu stylů odstavců či znaků, když je přiřadíte textu a přidáte textový rámeček jako element do panelu Knihovna.

Vytváření vlastních miniatur

Podokno náhledu v panelu Knihovna představuje vizuální znázornění vybraného obsahu, což usnadňuje vybírání položek z knihovny a jejich přidávání do stránek. Podokno náhledu je ale určeno k zobrazování převážně čtvercových souborů. Pokud do knihovny přidáte delší nebo vyšší element nebo sadu elementů, může dojít k úpravě měřítka výsledného obrazu náhledu.

Vytváření vlastních miniatur v aplikaci Adobe Muse
Vytváření vlastních miniatur v aplikaci Adobe Muse

V případě potřeby můžete vytvořit jiný obraz náhledu, který se bude používat jako náhled položky knihovny. Postupujte takto:

  1. Pomocí programu Mac Finder nebo Windows Explorer vyhledejte ve svém počítači následující adresář:
  • Mac: ~/Library/Preferences/Adobe/AdobeMuseLibrary/
  • Windows: %AppData%/AdobeMuseLibrary/

Poznámka:

V systému Mac OSX můžete do tohoto adresáře přejít pomocí příkazu Přejít > Přejít do složky. V systému Windows zkopírujte výše uvedenou cestu a vložte ji do pole pro adresu URL.

  1. Vyhledejte název složky odpovídající složce Knihovna v aplikaci Muse, kterou chcete aktualizovat. V tomto případě se složka knihovny jmenuje nav - pozadí.
  2. Otevřením složky si zobrazíte její obsah. Obsahuje soubor PNG.
  3. Pomocí programu pro úpravu obrázků, jako je například Photoshop nebo Fireworks, otevřete soubor PNG. Upravte soubor PNG.
  4. Uložte soubor PNG do aktuálního umístění a ukončete program pro úpravu obrázků.
  5. Vraťte se do aplikace Muse a vyberte tuto položku v knihovně. Upravený soubor PNG se zobrazí v podokně náhledu.
Vlastní soubor PNG zobrazí miniaturu, kterou je snadnější identifikovat jedním pohledem.
Vlastní soubor PNG zobrazí miniaturu, kterou je snadnější identifikovat jedním pohledem.

Potřebujete-li další informace o práci s aplikací Adobe Muse, navštivte stránku Nápověda a výukové lekce pro aplikaci Adobe Muse a podívejte se na fórum podpory aplikace Adobe Muse.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online