Zveřejnění aktualizací zabezpečení pro aplikaci Adobe Flash Player

Datum vydání: 13. října 2015

Poslední aktualizace: 7. ledna 2016

Identifikátor chyby zabezpečení: APSB15-25

Priorita: Viz tabulka níže

Číslo CVE: CVE-2015-5569, CVE-2015-7625, CVE-2015-7626, CVE-2015-7627, CVE-2015-7628, CVE-2015-7629, CVE-2015-7630, CVE-2015-7631, CVE-2015-7632, CVE-2015-7633, CVE-2015-7635, CVE-2015-7636, CVE-2015-7637, CVE-2015-7638, CVE-2015-7639, CVE-2015-7640, CVE-2015-7641, CVE-2015-7642, CVE-2015-7643, CVE-2015-7644

Platforma: všechny platformy

Shrnutí

Společnost Adobe vydala aktualizace zabezpečení pro přehrávač Adobe Flash Player.  Tyto aktualizace řeší kritické chyby zabezpečení, které potenciálně mohou útočníkovi umožnit převzetí kontroly nad napadeným systémem.

Postižené verze

Produkt Postižené verze Platforma
Modul runtime Adobe Flash Player pro stolní počítače 19.0.0.185 a starší verze
Windows a Macintosh
Adobe Flash Player Extended Support Release 18.0.0.241 a starší verze Windows a Macintosh
Přehrávač Adobe Flash Player pro prohlížeč Google Chrome 19.0.0.185 a starší verze Windows, Macintosh, Linux a ChromeOS
Přehrávač Adobe Flash Player pro prohlížeče Microsoft Edge a Internet Explorer 11 19.0.0.185 a starší verze Windows 10
Přehrávač Adobe Flash Player pro prohlížeč Internet Explorer 10 a 11 19.0.0.185 a starší verze Systém Windows 8.0 a 8.1
Přehrávač Adobe Flash Player pro systém Linux 11.2.202.521 a starší verze Linux
Běhové prostředí AIR pro stolní počítače 19.0.0.190 a starší verze Windows a Macintosh
Sada AIR SDK 19.0.0.190 a starší verze Windows, Macintosh, Android a iOS
Sada SDK a kompilátor prostředí AIR 19.0.0.190 a starší verze Windows, Macintosh, Android a iOS
  • Chcete-li ověřit verzi aplikace Adobe Flash Player nainstalovanou ve vašem systému, přejděte na stránku O aplikaci Flash Player nebo klikněte pravým tlačítkem myši na obsah přehrávaný v aplikaci Flash Player a vyberte z nabídky možnost „O aplikaci Adobe (nebo Macromedia) Flash Player“. Pokud používáte více prohlížečů, proveďte tuto kontrolu u každého prohlížeče, který jste v systému nainstalovali.  

Řešení

Společnost Adobe označuje tyto aktualizace následujícími hodnoceními priority a doporučuje uživatelům aktualizovat produkt na nejnovější verzi:

Produkt Aktualizované verze Platforma Dostupnost
Modul runtime Adobe Flash Player pro stolní počítače
19.0.0.207 Windows a Macintosh
1 Centrum stahování přehrávače Flash Player  Distribuce přehrávače Flash Player
Adobe Flash Player Extended Support Release 18.0.0.252 Windows a Macintosh
1 Rozšířená podpora
Přehrávač Adobe Flash Player pro prohlížeč Google Chrome 19.0.0.207 Windows, Macintosh, Linux a ChromeOS    1 Verze Google Chrome
Přehrávač Adobe Flash Player pro prohlížeče Microsoft Edge a Internet Explorer 11 19.0.0.207 Windows 10 1 Informační zpravodaje zabezpečení společnosti Microsoft
Přehrávač Adobe Flash Player pro prohlížeč Internet Explorer 10 a 11 19.0.0.207 Systém Windows 8.0 a 8.1
1 Informační zpravodaje zabezpečení společnosti Microsoft
Přehrávač Adobe Flash Player pro systém Linux 11.2.202.535 Linux 3 Centrum stahování přehrávače Flash Player
Běhové prostředí AIR pro stolní počítače 19.0.0.213 Windows a Macintosh 3 Centrum stahování prostředí AIR
Sada AIR SDK 19.0.0.213 Windows, Macintosh, Android a iOS 3 Stažení sady AIR SDK
Sada SDK a kompilátor prostředí AIR 19.0.0.213 Windows, Macintosh, Android a iOS 3 Stažení sady AIR SDK
  • Společnost Adobe doporučuje uživatelům běhového prostředí Adobe Flash Player pro stolní počítače pro systémy Windows a Macintosh přejít na verzi Adobe Flash Player 19.0.0.207, kterou si mohou stáhnout z Centra stahování přehrávače Adobe Flash Player nebo pomocí funkce aktualizace v produktu, když k tomu budou vyzváni [1].
  • Společnost Adobe doporučuje uživatelům přehrávače Adobe Flash Player Extended Support Release přejít na verzi 18.0.0.252, kterou si mohou stáhnout z adresy http://helpx.adobe.com/cz/flash-player/kb/archived-flash-player-versions.html.
  • Společnost Adobe doporučuje uživatelům aplikace Adobe Flash Player pro systém Linux přejít na verzi Adobe Flash Player 11.2.202.535, kterou si mohou stáhnout z Centra stahování přehrávače Adobe Flash Player
  • Aplikace Adobe nainstalovaná s prohlížečem Google Chrome se automaticky aktualizuje na nejnovější verzi prohlížeče Google Chrome, která bude obsahovat aplikaci Adobe Flash Player 19.0.0.207 pro systémy Windows, Macintosh, Linux a Chrome.
  • Přehrávač Adobe Flash Player nainstalovaný s prohlížečem Microsoft Edge pro systém Windows 10 se automaticky aktualizuje na nejnovější verzi, která bude obsahovat přehrávač Adobe Flash Player 19.0.0.207.
  • Přehrávač Adobe Flash Player nainstalovaný s prohlížečem Internet Explorer 10 a 11 pro systém Windows 8.0 a 8.1 se automaticky aktualizuje na nejnovější verzi, která bude obsahovat přehrávač Adobe Flash Player 19.0.0.207.
  • Společnost Adobe doporučuje uživatelům běhového prostředí AIR pro stolní počítače, sady AIR SDK a sady SDK a kompilátoru prostředí AIR, aby provedli aktualizaci na verzi 19.0.0.213 prostřednictvím Centra stahování prostředí AIR nebo Centra pro vývojáře prostředí AIR
  • Pomoc s instalací přehrávače Flash Player najdete na stránce Nápověda k přehrávači Flash Player.
 
[1] Uživatelé aplikace Flash Player 11.2.x nebo novější verze pro Windows nebo uživatelé aplikace Flash Player 11.3.x nebo novější verze pro Macintosh, kteří vybrali možnost Povolit společnosti Adobe instalovat aktualizace, obdrží tuto aktualizaci automaticky. Pokud uživatelé nepovolili instalaci aktualizací od společnosti Adobe, mohou ji nainstalovat prostřednictvím aktualizačního mechanismu příslušného produktu, jakmile k tomu budou vyzváni.

Podrobnosti o chybě zabezpečení

  • Tyto aktualizace řeší chybu zabezpečení, které lze využít k obejití zásad „same-origin-policy“ a které mohou vést k poskytnutí informací (-7628, CVE-2015).
  • Tyto aktualizace obsahují funkci defense-in-depth ve zprostředkovatelském rozhraní API aplikace Flash (CVE-2015-5569).
  • Tyto aktualizace řeší chyby zabezpečení umožňující využití paměti po uvolnění, které mohou vést ke spuštění kódu (CVE-2015-7629, CVE-2015-7631, CVE-2015-7635, CVE-2015-7636, CVE-2015-7637, CVE-2015-7638, CVE-2015-7639, CVE-2015-7640, CVE-2015-7641, CVE-2015-7642, CVE-2015-7643, CVE-2015-7644).
  • Tyto aktualizace řeší chybu zabezpečení spočívající v přetečení vyrovnávací paměti, která může vést ke spuštění kódu (CVE-2015-7632).
  • Tyto aktualizace řeší chyby zabezpečení spočívající v poškození paměti, které mohou vést ke spuštění kódu (CVE-2015-7625, CVE-2015-7626, CVE-2015-7627, CVE-2015-7630, CVE-2015-7633).

Poděkování

Společnost Adobe děkuje za nahlášení těchto potíží a za spolupráci při ochraně našich zákazníků následujícím jednotlivcům a organizacím: 

  • Dave „dwizzzle“ Weston (CVE-2015-5569)
  • bee13oy spolupracující s programem Chromium Vulnerability Rewards Program (CVE-2015-7633)
  • instruder ze střediska Alibaba Security Threat Information Center spolupracující s iniciativou HP Zero Day Initiative (CVE-2015-7629)
  • Anonym spolupracující s iniciativou HP Zero Day Initiative (CVE-2015-7632)
  • Nicolas Joly a Natalie Silvanovich z projektu Google Project Zero (CVE-2015-7644)
  • bilou spolupracující v rámci programu Zero Day Initiative společnosti HP (CVE-2015-7631)
  • bilou spolupracující s iniciativou HP Zero Day Initiative a Yuki Chen z týmu Qihoo 360 Vulcan Team (CVE-2015-7643)
  • instruder ze střediska Alibaba Security Threat Information Center (CVE-2015-7630)
  • Jincheng Liu a Lijun Cheng z týmu Alibaba Security Research Team (CVE-2015-7625, CVE-2015-7626)
  • Kai Kang z laboratoře Xuanwu LAB společnosti Tencent (CVE-2015-7627)
  • Yuki Chen z týmu Qihoo 360 Vulcan Team (CVE-2015-7635, CVE-2015-7636, CVE-2015-7637, CVE-2015-7638, CVE-2015-7639, CVE-2015-7640, CVE-2015-7641, CVE-2015-7642, CVE-2015-7643)
  • Pan Tokuji Akamine (CVE-2015-7628)

Verze

14. října 2015: Byly přidány problémy CVE, které pomáhal řešit Yuki Chen z týmu Qihoo 360 Vulcan Team

5. listopadu 2015: Z bulletinu byl odebrán problém CVE-2015-7634.  Tento problém CVE byl původně klasifikován jako potíže spojené s poškozením paměti, potom však byl překlasifikován na nevyužitelnou chybu přístupu přes nulový ukazatel.

7. ledna 2016: Bylo přidáno poděkování panu Tokuji Akaminovi za zveřejnění informací o problému CVE-2015-7628