Zveřejnění aktualizací zabezpečení pro aplikaci Adobe Flash Player

Datum vydání: 16. června 2016

Identifikátor chyby zabezpečení: APSB16-18

Priorita: Viz tabulka níže

Číslo CVE: CVE-2016-4122, CVE-2016-4123, CVE-2016-4124, CVE-2016-4125, CVE-2016-4127, CVE-2016-4128, CVE-2016-4129, CVE-2016-4130, CVE-2016-4131, CVE-2016-4132, CVE-2016-4133, CVE-2016-4134, CVE-2016-4135, CVE-2016-4136, CVE-2016-4137, CVE-2016-4138, CVE-2016-4139, CVE-2016-4140, CVE-2016-4141, CVE-2016-4142, CVE-2016-4143, CVE-2016-4144, CVE-2016-4145, CVE-2016-4146, CVE-2016-4147, CVE-2016-4148, CVE-2016-4149, CVE-2016-4150, CVE-2016-4151, CVE-2016-4152, CVE-2016-4153, CVE-2016-4154, CVE-2016-4155, CVE-2016-4156, CVE-2016-4166, CVE-2016-4171

Platforma: Windows, Macintosh, Linux a ChromeOS

Shrnutí

Společnost Adobe vydala aktualizace zabezpečení pro aplikaci Adobe Flash Player pro platformy Windows, Macintosh, Linux a ChromeOS.  Tyto aktualizace řeší kritické chyby zabezpečení, které potenciálně mohou útočníkovi umožnit převzetí kontroly nad napadeným systémem.  

Společnost Adobe si je vědoma, že chyba zabezpečení CVE-2016-4171 existuje a je zneužívána k omezenému počtu cílených útoků. Více informací viz APSA16-03.

Postižené verze

Produkt Postižené verze Platforma
Modul runtime Adobe Flash Player pro stolní počítače 21.0.0.242 a starší verze
Windows a Macintosh
Adobe Flash Player Extended Support Release 18.0.0.352 a starší verze Windows a Macintosh
Přehrávač Adobe Flash Player pro prohlížeč Google Chrome 21.0.0.242 a starší verze Windows, Macintosh, Linux a ChromeOS
Přehrávač Adobe Flash Player pro prohlížeče Microsoft Edge a Internet Explorer 11 21.0.0.242 a starší verze Systém Windows 10 a 8.1
Přehrávač Adobe Flash Player pro systém Linux 11.2.202.621 a starší verze Linux
  • Chcete-li ověřit verzi aplikace Adobe Flash Player nainstalovanou ve vašem systému, přejděte na stránku O aplikaci Flash Player nebo klikněte pravým tlačítkem myši na obsah přehrávaný v aplikaci Flash Player a vyberte z nabídky možnost „O aplikaci Adobe (nebo Macromedia) Flash Player“. Pokud používáte více prohlížečů, proveďte tuto kontrolu u každého prohlížeče, který jste v systému nainstalovali.  

Řešení

Společnost Adobe označuje tyto aktualizace následujícími hodnoceními priority a doporučuje uživatelům aktualizovat produkt na nejnovější verzi:

Produkt Aktualizované verze Platforma Hodnocení priority Dostupnost
Modul runtime Adobe Flash Player pro stolní počítače
22.0.0.192 Windows a Macintosh
1

Centrum stahování přehrávače Flash Player

Distribuce přehrávače Flash Player

Adobe Flash Player Extended Support Release 18.0.0.360 Windows a Macintosh
1 Rozšířená podpora
Přehrávač Adobe Flash Player pro prohlížeč Google Chrome 22.0.0.192 Windows, Macintosh, Linux a ChromeOS   1 Verze Google Chrome
Přehrávač Adobe Flash Player pro prohlížeče Microsoft Edge a Internet Explorer 11 22.0.0.192 Systém Windows 10 a 8.1 1 Informační zpravodaje zabezpečení společnosti Microsoft
Přehrávač Adobe Flash Player pro systém Linux 11.2.202.626 Linux 3 Centrum stahování přehrávače Flash Player
  • Společnost Adobe doporučuje uživatelům modulu runtime Adobe Flash Player pro stolní počítače pro systémy Windows a Macintosh provést aktualizaci na verzi 22.0.0.192 pomocí funkce pro aktualizaci v rámci produktu, když k tomu budou vyzváni [1], případně mohou navštívit centrum pro stahování dat aplikace Adobe Flash Player.
  • Společnost Adobe doporučuje uživatelům přehrávače Adobe Flash Player Extended Support Release přejít na verzi 18.0.0.360, kterou si mohou stáhnout z adresy http://helpx.adobe.com/cz/flash-player/kb/archived-flash-player-versions.html.
  • Společnost Adobe doporučuje uživatelům přehrávače Adobe Flash Player pro systém Linux přejít na verzi Adobe Flash Player 11.2.202.626, kterou si mohou stáhnout z centra stahování aplikace Adobe Flash Player.
  • Přehrávač Adobe Flash Player nainstalovaný s prohlížečem Google Chrome se automaticky aktualizuje na nejnovější verzi prohlížeče Google Chrome, která bude obsahovat aplikaci Adobe Flash Player 22.0.0.192 pro systémy Windows, Macintosh, Linux a Chrome OS.
  • Přehrávač Adobe Flash Player nainstalovaný s prohlížeči Microsoft Edge a Internet Explorer pro systém Windows 10 a 8.1 se automaticky aktualizuje na nejnovější verzi, která bude obsahovat přehrávač Adobe Flash Player 22.0.0.192. 
  • Pomoc s instalací přehrávače Flash Player najdete na stránce Nápověda k přehrávači Flash Player.

[1] Uživatelé aplikace Flash Player 11.2.x nebo novější verze pro Windows nebo uživatelé aplikace Flash Player 11.3.x nebo novější verze pro Macintosh, kteří vybrali možnost Povolit společnosti Adobe instalovat aktualizace, obdrží tuto aktualizaci automaticky. Pokud uživatelé nepovolili instalaci aktualizací od společnosti Adobe, mohou ji nainstalovat prostřednictvím aktualizačního mechanismu příslušného produktu, jakmile k tomu budou vyzváni.

Podrobnosti o chybě zabezpečení

  • Tyto aktualizace řeší chyby zabezpečení způsobující záměnu typů, které by mohly vést ke spuštění kódu (CVE--2016-4144, CVE-2016-4149).
  • Tyto aktualizace řeší chyby zabezpečení umožňující využití paměti po uvolnění, které mohou vést ke spuštění kódu (CVE-2016-4142, CVE-2016-4143, CVE-2016-4145, CVE-2016-4146, CVE-2016-4147, CVE-2016-4148).
  • Tyto aktualizace řeší chyby zabezpečení spojené s přetečením vyrovnávací paměti na haldě, které mohou vést ke spuštění kódu (CVE-2016-4135, CVE-2016-4136, CVE-2016-4138).
  • Tyto aktualizace odstraňují chyby zabezpečení spojené s poškozením paměti, které mohou vést ke spuštění kódu (CVE-2016-4122, CVE-2016-4123, CVE-2016-4124, CVE-2016-4125, CVE-2016-4127, CVE-2016-4128, CVE-2016-4129, CVE-2016-4130, CVE-2016-4131, CVE-2016-4132, CVE-2016-4133, CVE-2016-4134, CVE-2016-4137, CVE-2016-4141, CVE-2016-4150, CVE-2016-4151, CVE-2016-4152, CVE-2016-4153, CVE-2016-4154, CVE-2016-4155, CVE-2016-4156, CVE-2016-4166, CVE-2016-4171).
  • Tyto aktualizace řeší chyby zabezpečení spočívající v cestě hledání adresářů používané k vyhledání zdrojů, které mohou vést ke spuštění kódu (CVE-2016-4140).
  • Tyto aktualizace řeší chybu zabezpečení, které lze využít k obejití zásad „same-origin-policy“ a které mohou vést k poskytnutí informací (-4139, CVE-2016). 

Poděkování

  • Aleksandar Nikolic ze společnosti Cisco Talos (CVE-2016-4132)
  • Mateusz Jurczyk a Natalie Silvanovich z projektu Google Project Zero (CVE-2016-4135, CVE-2016-4136, CVE-2016-4137, CVE-2016-4138)
  • willJ ze společnosti Tencent PC Manager (CVE-2016-4122, CVE-2016-4123, CVE-2016-4124, CVE-2016-4125, CVE-2016-4127, CVE-2016-4128, CVE-2016-4129, CVE-2016-4130, CVE-2016-4131, CVE-2016-4134, CVE-2016-4166)
  • Nicolas Joly ze společnosti Microsoft Vulnerability Research (CVE-2016-4142, CVE-2016-4143, CVE-2016-4144, CVE-2016-4145, CVE-2016-4146, CVE-2016-4147, CVE-2016-4148)
  • Wen Guanxing ze společnosti Pangu LAB (CVE-2016-4150, CVE-2016-4152, CVE-2016-4153, CVE-2016-4154, CVE-2016-4155, CVE-2016-4156)
  • LMX ze společnosti Qihoo 360 Codesafe Team (CVE-2016-4141)
  • Dan Caselden ze společnosti FireEye (CVE-2016-4140)
  • Wen Guanxing ze společnosti Pangu LAB. (CVE-2016-4151)
  • Genwei Jiang ze společnosti FireEye (CVE-2016-4149)
  • Sebastian Lekies ze společnosti Google (CVE-2016-4139)
  • kelvinwang ze společnosti Tencent PC Manager (CVE-2016-4133)
  • Anton Ivanov ze společnosti Kaspersky (CVE-2016-4171)