Festlegen von Eigenschaften für Widgets mit Adobe Captivate

Erfahren Sie, wie Sie Widgets verwenden und ändern sowie spannende E-Learning-Projekte erstellen.

Zusätzlich zu den vom Widget-Entwickler definierten Parametern können Sie mit Adobe Captivate Eigenschaften für Widgets einstellen. Sie können die Eigenschaften eines Widgets mithilfe des Eigenschafteninspektors („Fenster“ > „Eigenschaften“) ändern.

Widgets

Name

Geben Sie einen eindeutigen Namen für das Objekt ein. Diesen Namen können Sie beim Definieren der Sichtbarkeitsbedingungen für das Objekt verwenden.

Sichtbar

Deaktivieren Sie diese Option, wenn das Objekt auf der Folie standardmäßig nicht sichtbar sein soll. Mit der Aktion „PieChart.fla“ können Sie das Widget sichtbar machen. Weitere Informationen finden Sie unter Steuern der Sichtbarkeit von Objekten.

Name und die Sichtbarkeit
Name und die Sichtbarkeit

Animation

Objektname

Name des Animationsobjekts.

Linkage

Stellt den Link zur zugeordneten SWF-Datei bereit.

Aktualisieren

Klicken Sie auf diese Option, um die Änderungen an der Quelldatei zu übernehmen (falls diese extern bearbeitet wurde).

Quelle

Verknüpfung mit der FLA-Quelldatei der SWF-Animationsdatei.

Bearbeiten

Klicken Sie auf diese Option, um die FLA-Datei in Adobe Animate mit Adobe Captivate zu bearbeiten.

Alpha

Die Transparenz des Widgets. Bei 0 % Transparenz ist das Widget undurchsichtig, bei 100 % Transparenz hingegen unsichtbar.

Widget-Eigenschaften

Klicken Sie auf diese Option, um das Dialogfeld „Widget-Eigenschaften“ anzuzeigen, in dem die Parameter aufgeführt sind, mit denen Sie das Widget anpassen können. Diese Parameter sind nur verfügbar, wenn der Entwickler beim Erstellen des Widgets Vorkehrungen zum Anpassen des Widgets getroffen hat. In diesem Dialogfeld wird unter Umständen auch ein Snapshot des Widgets angezeigt.

Timing

Anzeigen für [Dauer]

Gibt an, wie lange das Widget auf der Folie angezeigt wird

Erscheint nach [#] Sekunden

Gibt an, wie viele Sekunden zwischen der ersten Anzeige der Folie und der ersten Anzeige des Widgets liegen

Widget-Timing
Widget-Timing

Übergang

Effekt

Übergangseffekt für das Widget. Sie können Einblend- oder Ausblendeffekte einsetzen und die Zeit für diese Effekte festlegen.

Widget-Übergang
Widget-Übergang

Aktion

Bei Erfolg

Die verfügbaren Optionen, wenn der Benutzer die im Widget angegebenen Kriterien erfolgreich erfüllt. Weitere Informationen finden Sie unter Projektnavigation mithilfe von interaktiven Objekten.

Versuche

Definieren Sie die Anzahl der Versuche.

Unbegrenzt

Der Benutzer hat eine unbegrenzte Anzahl von Versuchen zur Verfügung.

Nach dem letzten Versuch

Verfügbare Optionen, wenn Benutzer die im Widget angegebenen Kriterien nach einer definierten Zahl von Versuchen nicht erfüllen. Weitere Informationen finden Sie unter Projektnavigation mithilfe von interaktiven Objekten.

Optionen

Wählen Sie aus folgenden Optionen die entsprechenden Optionen:

Erfolg

Die angezeigte Beschriftung, wenn der Benutzer die vom Widget zugewiesene Aufgabe erfolgreich abschließt.

Fehler

Die angezeigte Beschriftung, wenn der Benutzer die vom Widget angeforderte Eingabe nicht bereitstellt.

Tipp

Die Beschriftung mit einem Tipp für den Benutzer. Der Tipp wird angezeigt, wenn Benutzer die Maus über das Widget bewegen.

Für Erfolgs- und Fehlerbeschriftungen anhalten

Das Projekt wird so lange angehalten, bis alle Erfolgs- und Fehlerbeschriftungen angezeigt werden.

Transformieren

Wenn Sie die genaue Größe oder Position des Widgets in Pixel festlegen oder das Widget drehen möchten, klicken Sie auf die Registerkarte „Transformieren“. Die folgenden Optionen stehen zur Verfügung:

X

Die Position der X-Koordinate des Objekts.

Y

Die Position der Y-Koordinate des Objekts.

B

Die Breite des Objekts.

H

Die Höhe des Objekts.

Proportionen beschränken

Behält das Seitenverhältnis des Objekts bei, wenn seine Größe anpasst wird.

Winkel

Winkel der Drehung des Widgets.

Transformierungseigenschaften
Transformierungseigenschaften

Weitergabe

Wenn Sie eine Punktzahl für das Widget speichern oder die Punktzahl mit einem Learning Management-System koordinieren möchten, klicken Sie auf die Registerkarte „Weitergabe“.

In Quiz einbeziehen

Die dem Widget zugeordneten Punkte werden dem Resultat des aktuellen Quiz hinzugefügt.

Punkte

Einer korrekten Antwort zugeordnete Punktzahl. Die Höchstpunktzahl beträgt 100, die Mindestpunktzahl 0 Punkte.

Zur Gesamtsumme hinzufügen

Die Bewertung der Schaltfläche wird der Quizgesamtsumme hinzugefügt.

Antworten weitergeben

Sendet das Quizergebnis an das Learning Management-System (LMS).

Interaktions-ID

Sendet Tracking-Informationen an das Learning Management-System, die auf der vom Learning Management-System angegebenen Interaktions-ID basieren

Festlegen des Audios für Widgets

Sie können nicht interaktiven Objekten Audiodateien hinzufügen. Die Audiodatei wird abgespielt, wenn das Objekt auf der Folie angezeigt wird.

  1. Um Audio hinzuzufügen, wechseln Sie im Eigenschafteninspektor in den Bereich „Audio“ und klicken Sie dann auf „Audio hinzufügen“.

    Das Dialogfeld „Objektaudio“ wird angezeigt.

  2. Verwenden Sie auf der Registerkarte „Hinzufügen/ersetzen“ die folgenden Optionen:

    Audio aufzeichnen 

    Das Dialogfeld „Audio aufzeichnen“ wird geöffnet. (Für die Audioaufzeichnung sind bestimmte Geräte erforderlich.)

    Stoppen 

    Hält das Abspielen der Audiodatei an.

    Abspielen 

    Spielt die Audiodatei ab.

  3. Auf der Registerkarte „Bearbeiten“ können Sie die Audiodatei auf verschiedene Weisen bearbeiten, beispielsweise durch Einfügen von Stilleperioden oder durch Regulieren der Lautstärke.

  4. Klicken Sie auf „Einstellungen“, um das Dialogfeld „Audioeinstellungen“ zu öffnen. Sie können Audioeinstellungen, wie z. B. die Eingangsquelle, Audioqualität und Kalibrierung, festlegen. Klicken Sie auf die Schaltfläche „Einstellungen“ und nehmen Sie die gewünschten Einstellungen vor.

  5. Klicken Sie auf „Importieren“, um das Dialogfeld „Audio importieren“ anzuzeigen. In diesem Dialogfeld können Sie nach einer Audiodatei suchen und sie importieren.

  6. Klicken Sie auf „Bibliothek“, um die Bibliothek zu öffnen. In der Bibliothek sind alle Audiodateien aufgeführt, die bereits im aktuellen Adobe Captivate-Projekt verwendet werden.

Verwenden und Bearbeiten von Widgets

Im Folgenden wird beschrieben, wie Sie die folgenden Widgets erstellen können. Klicken Sie auf die Links, um weitere Anleitungen zu erhalten.

Beispiel 01 - Verwendung des Lesezeichen-Widget

  1. Um das Lesezeichen-Widget in Ihrer Folie zu benutzen, klicken Sie auf Einfügen > Widget und wählen Sie Lesezeichen, oder klicken Sie auf Interaktionen > Lerninteraktionen und wählen Sie Lesezeichen aus der Liste aus.

    Lesezeichen-Widget
    Lesezeichen-Widget

  2. Ändern Sie die Eigenschaften des Widgets. Wenn Sie Fragenfolien in einem Projekt bearbeiten möchten und alle Fragenfolien mit einem Lesezeichen versehen möchten, wählen Sie die Option  Kontrollkästchen  Nur Fragenfolien mit Lesezeichen versehen.

    Passen Sie das Lesezeichensymbol an und weisen Sie außerdem Designfarben dem Lesezeichen hinzu. Auf einer Fragenfolie wird ein Lesezeichen-Widget unten angezeigt:

    Widget auf einer Fragenfolie
    Widget auf einer Fragenfolie

  3. Machen Sie das Quiz SCORM kompatibel und aktivieren Sie die Berichterstellung für das Quiz in einem LMS.

    Klicken Sie auf Bearbeiten > Quiz > Weitergabe und aktivieren Sie das Kontrollkästchen  Weitergabe für dieses Projekt aktivieren.

    Nun veröffentlichen Sie das Projekt als ZIP-Datei an einem beliebigen Ort auf Ihrem Computer.

    Veröffentlichen als ZIP-Datei
    Veröffentlichen als ZIP-Datei

  4. Importieren Sie die ZIP-Datei in einem beliebigen LMS- oder in SCORM Cloud und starten Sie den Kurs. Klicken Sie auf das Lesezeichen auf einer beliebigen Folie und schließen Sie den Kurs.

  5. Starten Sie den Kurs erneut.  Sie  setzen den Vorgang auf der Folie fort, auf der Sie auf das Lesezeichen geklickt haben. Das Lesezeichen ist grün, wie nachfolgend gezeigt:

    Lesezeichen aktiviert
    Lesezeichen aktiviert

    Klicken Sie erneut auf das Lesezeichen und setzen Sie den Kurs fort.

    Lesezeichen deaktiviert
    Lesezeichen deaktiviert

Beispiel 02 - Verwendung des Dropdown-Widgets

  1. Um das Dropdown-Widget in Ihrer Folie zu benutzen, klicken Sie auf Einfügen > Widget und wählen Sie Dropdown, oder klicken Sie auf Interaktionen > Lerninteraktionen und wählen Sie Dropdown aus der Liste aus.

    Dropdown-Widget
    Dropdown-Widget

    Name

    Beschreibung

    1

    Listeneinträge. Die Einträge sind durch Kommas getrennt.

    2

    Mit der Schaltfläche Updates können Sie eine Vorschau der Dropdown-Liste nach der Formatierung sehen.

    3

    Formatierungsbedienfeld zur Auswahl einer Schriftart, eines Schriftschnitts und eines Attributs.

    4

    Variable zur Validierung der Elemente in der Liste. Erstellen Sie die Variable im Dialogfeld Variable. Weitere Informationen zum Erstellen einer Variablen finden Sie unter Erstellen von Variablen in Captivate.

  2. Wenn Sie beispielsweise auf eine beliebige Sprache klicken, können Sie einen entsprechenden übersetzten Text anzeigen.

    Fügen Sie eine Schaltfläche OK  auf der Folie neben dem Widget ein. Weisen Sie der Schaltfläche eine erweiterte Aktion zu, die, wenn darauf geklickt wird, eine entsprechende Meldung anzeigt.

    Dropdown - erweiterte Aktion
    Dropdown - erweiterte Aktion

  3. Ähnlich wie für englische und deutsche Texte, werden die entsprechenden Smartformen ein- bzw. ausgeblendet.

  4. Veröffentlichen Sie das Projekt oder zeigen Sie es in der Vorschau an. Je nach der in der Dropdownliste ausgewählten Option und nach dem Klicken auf OK, können Sie die entsprechende Übersetzung sehen.

Beispiel 03 - Verwendung des Glossar-Widgets

  1. Um das Glossar-Widget auf Ihrer Folie zu nutzen, klicken Sie auf Einfügen > Widget und wählen Sie 08_Glossary.wdgt, oder klicken Sie auf Interaktionen > Lerninteraktionen und wählen Sie Glossar aus der Liste aus.

    Glossar-Widget
    Glossar-Widget

    Name

    Beschreibung

    1

    Geben Sie dem Glossar einen Namen und eine Beschreibung.

    2

    Wählen Sie richtiges Design für das Glossar.

    3

    Zeigen Sie einen Glossarbegriff und eine Beschreibung in der Vorschau an.

    4

    Fügen Sie einen Glossarbegriff hinzu oder entfernen Sie ihn.

    5

    Importieren Sie Glossarbegriffe aus einer XML-Datei.

    6

    Zeigen Sie eine XML-Beispieldatei an.

  2. Wenn Sie einen Begriff in das Glossar hinzuzufügen, klicken Sie auf +.

    Glossarbegriff hinzufügen
    Glossarbegriff hinzufügen

    Um einen Begriff zu entfernen, wählen Sie den Begriff aus und klicken Sie auf -.

  3. Um eine XML für Glossarbegriffe zu importieren, klicken Sie auf IMPORTIEREN. Wählen Sie die XML-Datei aus und importieren Sie die Datei in das Widget. Alle Begriffe, die in der XML enthalten sind, sind im Widget inbegriffen.

    Der folgende Text ist eine Beispiel-XML:

    <XMLBit>    <term>      <label>Asynchrones Lernen</label>      <def>Wenn Lernende zu unterschiedlichen Zeiten an einem Online-Lernkurs teilnehmen, wird dies als asynchrones Lernen bezeichnet.</def>   </term>   <term>      <label>Gemischtes Lernen</label>      <def>Gemischtes Lernen ist ein Unterrichtsansatz, der eine Kombination aus Online- und persönlichen Lernaktivitäten umfasst.</def>   </term> <term>      <label>Courseware</label>      <def>Courseware bezieht sich auf jede Lehrsoftware, die auf einem Computer bereitgestellt wird.</def>   </term> <term>      <label>E-Learning</label>      <def>eLearning (kurz für elektronisches Lernen) ist ein Oberbegriff, der sich auf alle Arten von Schulung, Ausbildung und Unterricht bezieht, die auf einem digitalen Medium wie Computer oder Mobiltelefon stattfinden.</def>   </term> <term>      <label>Webinar</label>      <def>Ein Webinar ist ein Seminar oder Workshop, in dem der Kursleiter und die Teilnehmer gleichzeitig denselben Bildschirm anzeigen.   </def>   </term> </XMLBit>
  4. Wenn Sie die XML importieren, und wenn das XML-Objekt korrekt formatiert ist, wird die folgende Meldung angezeigt:

    Import der XML-Datei erfolgreich
    Import der XML-Datei erfolgreich

    Die Begriffe, die Sie in der XML-Datei definiert haben, werden im Glossar-Widget wie folgt angezeigt:

    Glossarbegriffe hinzugefügt
    Glossarbegriffe hinzugefügt

  5. Veröffentlichen Sie das Projekt oder zeigen Sie es in der Vorschau an.

Beispiel 04 - Verwendung des Listbox-Widgets

  1. Um das Listbox-Widget auf Ihrer Folie zu nutzen, klicken Sie auf Einfügen > Widget und wählen Sie Listbox-Widget, oder klicken Sie auf Interaktionen > Lerninteraktionen und wählen Sie Liste aus der Liste aus.

    Listbox-Widget
    Listbox-Widget

    Name

    Beschreibung

    1

    Fügen Sie durch Kommas getrennte Listenelemente hinzu.

    2

    Aktualisieren Sie die Listenvorschau.

    3

    Zeigen Sie die Liste in der Vorschau an.

    4

    Ändern Sie den Schriftschnitt, die Größe und Farbe.

    5

    Ändern Sie die Statuseigenschaften der Schaltfläche.

    6

    Weisen Sie den Listenelementen eine Variable zu.

  2. Erstellen Sie beispielsweise eine Quizfrage, bei der, wenn Sie die richtige Antwort aus der Liste wählen, ein Popup-Fenster angezeigt wird, das eine entsprechende Meldung enthält.

    Erstellen Sie zwei Smartformen, die Richtig oder Falsch anzeigen.

    Erstellen Sie eine erweiterte Aktion, die überprüft, ob die Variable v_city die richtige Antwort speichert. Weisen Sie der Schaltfläche die Aktion zu.

    Wenn Sie auf die Schaltfläche klicken, können Sie je nach Bedingung die richtige Antwort sehen.

    In der folgenden Abbildung wird die erweiterte Aktion gezeigt.

    Listbox - Erweiterte Aktion
    Listbox - Erweiterte Aktion

  3. Im ELSE-Abschnitt zeigen Sie die Smartform mit der Beschriftung „Falsch“ an und blenden Sie die Smartform mit der Beschriftung „Richtig“ aus.

  4. Veröffentlichen Sie das Projekt oder zeigen Sie es in der Vorschau an.

Herunterladen

Beispiel 05 - Verwendung des Hinweis-Widgets

  1. Um das Hinweis-Widget auf Ihrer Folie zu nutzen, klicken Sie auf Einfügen > Widget und wählen Sie Hinweise, oder klicken Sie auf Interaktionen > Lerninteraktionen und wählen Sie Hinweise aus der Liste aus.

    Hinweis-Widget
    Hinweis-Widget

    Name

    Beschreibung

    1

    Legen Sie ein benutzerdefiniertes oder Captivate-Standardsymbol für den Hinweis fest.

    2

    Fügen Sie einen Hinweis für jede Folie oder für das Projekt ein.

    3

    Legen Sie den Hinweis-Bezeichner fest.

    Weitere Informationen finden Sie unter: Teilnehmerhinweis-Widget.

  2. Um die Änderungen zu speichern, klicken Sie auf „OK„. Das Hinweis-Widget wird in der Folie angezeigt.

Adobe Captivate: Hinweis-Interaktions-Widget

Textanimation erstellen

Animierter Text ist Text, dem Spezialeffekte hinzugefügt werden. Adobe Captivate bietet zahlreiche Textanimationseffekte, mit denen Sie nach Belieben experimentieren können. Einen überzeugenden Starteffekt erzielen Sie zum Beispiel, wenn in der ersten Folie Ihres Projekts Text allmählich eingeblendet wird.

  1. Um eine Textanimation auf der Folie einzufügen, wählen Sie Text > Textanimation.

    Textanimationseigenschaften
    Textanimationseigenschaften

    Ändern der Texteigenschaften entsprechend Ihrer Anforderungen.

  2. Um dem Text einen Effekt hinzuzufügen, wählen Sie einen Effekt aus der Effekte-Dropdownliste.

    Textanimationseffekte
    Textanimationseffekte

  3. Um die Änderungen zu speichern, klicken Sie auf OK und verwenden Sie Text in Ihrem Projekt.

    Weitere Informationen finden Sie unter Animierter Text.

Beispielprojekte herunterladen

Um mehr über Captivate zu erfahren und wie Sie ansprechende Lerninhalte erstellen können, laden Sie folgende Projekte herunter:

Adobe-Logo

Bei Ihrem Konto anmelden